Help Index

Imagine - просмотр картинок и анимации для Windows

1. Введение

a. Возможности

b. Требования к системе

c. Лицензия

d. Параметры командной строки

2. Благодарности

a. Переводы

b. Особые благодарности

3. Обратная связь

a. Интернет

b. Ответы на типичные вопросы

(c) 2003-2012 Chun Sejin


Features

Возможности

- Очень быстрый просмотр и сохранение картинок и анимации

- Поддержка множества форматов рисунков и анимации:

PNG, JPG, GIF, BMP, PCX, TGA, TIFF, ICO, CUR, LBM, ANI, FLI, WMF, EMF и других.

- Извлечение одного или всех кадров из анимированных картинок

- Показ подробных сведений о файлах рисунков и анимации

- Показ информации EXIF и IPTC

- Показ прозрачности по желанию

- Показ необработанных снимков цифровых камер в форматах:

3FR, ARW, CR2, CRW, DNG, ERF, KDC, MRW, NEF, ORF, RAF, RAW, SRW, SR2 и других.

- Просмотр файлов в архивах:

ZIP, RAR, 7Z, ALZ, HV3, CBZ, CBR, CB7, ARJ, LZH, EGG, TAR, ISO, CAB и других.

- Показ изображений с широким динамическим диапазоном (high dynamic range) в форматах:

HDR, EXR, SXR, MXR и других.

- Есть 64-битная версия

- Есть Unicode-версия

- Переводы на многие языки: английский, немецкий, испанский, русский, датский, корейский, китайский и многие другие...

- Обзор эскизов

- Пакетное конвертирование

- Показ слайдов

- Пакетное переименование

- Захват экрана

- Просмотр "черепицей" (проверка бесшовной стыковки текстур, очень полезно для разработчиков игр и моддеров)

- Создание анимации

- Создание многостраничных рисунков

- Обработка и редактирование рисунков:

- отражение по вертикали и по горизонтали

- повороты влево, вправо и произвольный

- преобразование в оттенки серого

- обращение в негатив

- изменение глубины цвета (1, 4, 8, 16, 24 и 32 бита)

- обмен цветовых каналов

- изменение размеров попиксельно или в стандартные форматы

- несколько фильтров пересчета размера

- фильтры эффектов с предварительным просмотром

- импорт, экспорт и редактирование палитр

- установка и снятие прозрачности

- Настраиваемое управление клавиатурой и мышкой

- Поддержка ключей командной строки

- Поддержка расширения оболочки

- Поддержка дополнительных модулей

- Модуль просмотра и архивации для Total Commander

- Не пишет лишнего в системный реестр (настройки в ini-файле)

- Полностью оптимизированный код (компактный, чистый, быстрый, аккуратный)


Требования к системе

- Процессор: совместимый с Pentium

- ОЗУ: не менее 32MБ

- ОС: Microsoft Windows 95/98/ME/NT 4.0/2000/XP/2003/Vista/7

- Экран: не менее 256 цветов


License

Лицензия

* на русском

Эта программа бесплатна (приветствуются пожертвования).

Это значит, что ее можно использовать бесплатно без каких-либо ограничений.

Но Вы можете пожертвовать мне любую сумму, и ваше пожертвование очень поможет мне продолжать работу над ней.

Больше того, если Вы пожертвуете, то получите от меня техническую поддержку, а ваши предложения будут рассматриваться первыми.

Если эта программа Вам понравится, пожертвуйте пожалуйста!

Адрес для пожертвований:

Спасибо!

Пожертвовав, Вы получите собственный лицензионный код.

И этот лицензионный код гарантирует, что данный экземпляр Imagine - Ваш собственный.

Сумма пожертвования остается на Ваше усмотрение.

Но для получения собственного лицензионного кода нужно пожертвовать не менее $10.00(США).

Если хотите узнать больше о принципе donationware, пройдите по ссылке:

http://ru.wikipedia.org/wiki/Donationware

* ЗС±№ѕо

АМ ЗБ·О±Ч·ҐАє №«·б јТЗБЖ®їюѕо(±вєО јТЗБЖ®їюѕо)АФґПґЩ.

АМґВ ѕЖ№«·± Б¦ЗС ѕшАМ АЪАЇ·У°Ф АМ ЗБ·О±Ч·ҐА» »зїлЗТ јц АЦАЅА» АЗ№МЗХґПґЩ.

±Ч·ЇіЄ, АъїЎ°Ф µ·А» ±вєОЗПЅЗ јц АЦАёёз ґзЅЕАЗ ±вєОґВ Б¦°Ў АМ ЗБ·О±Ч·Ґ °і№ЯА» БцјУЗПґВµҐ АЦѕо Е« µµїтАМ µЛґПґЩ.

»Уёё ѕЖґП¶у, ±вєОЗПЅГёй Аъ·ОєОЕН ±вјъАы БцїшА» №ЮАёЅЗ јц АЦАёёз Б¦ѕИ »зЗЧїЎ ґлЗШј їмј±АыАё·О °н·БЗП°Ф µЛґПґЩ.

ёёѕа АМ ЗБ·О±Ч·ҐАМ АЇїлЗПґЩ°н »э°ўµЗЅГёй ±вєОё¦ єОЕ№µеёіґПґЩ!

ґЩАЅ АєЗа°иБВ·О АФ±ЭЗШБЦЅЗ јц АЦЅАґПґЩ:

ЅЕЗСАєЗа: 110-104-513208 (ГµјјБш)

їмё®АєЗа: 605-702400-18-568 (ГµјјБш)

KB±№№ОАєЗа: 627702-01-286350 (ГµјјБш)

±вѕчАєЗа: 478-038421-01-015 (ГµјјБш)

ЗПіЄАєЗа: 582-910008-57907 (ГµјјБш)

ѕѕЖјАєЗа: 895-03381-264-01 (ГµјјБш)

°Ё»зЗХґПґЩ!

±вєО ИДїЎ є»АОёёАЗ ¶уАМјѕЅє ДЪµеё¦ №ЮАёЅЗ јц АЦЅАґПґЩ.

(АФ±Э ИД nyam@nyam.pe.kr·О АФ±ЭЗПЅЕ єРАЗ јєЗФА» e-mail·О ѕЛ·ББЦЅГёй јєЗФїЎ ЗШґзЗПґВ ¶уАМјѕЅє ДЪµеё¦ e-mail·О ИёЅЕЗПї© µеёіґПґЩ.)

АМ ¶уАМјѕЅє ДЪµеґВ ImagineАМ ґзЅЕАЗ °нАЇЗС №цАьАМ¶уґВ °НА» БхёнЗШБЩ °НАФґПґЩ.

±вєО ±ЭѕЧАє АьАыАё·О »зїлАЪАЗ АЪАЇ АЗ»зїЎ µыёЈ°ЪЅАґПґЩ.

±Ч·ЇіЄ є»АОёёАЗ ¶уАМјѕЅє ДЪµеё¦ №ЮАёЅГ±в А§ЗШјґВ ГЦјТ 1ёёїш АМ»уАЗ ±ЭѕЧА» ЗКїд·О ЗХґПґЩ.

ёёѕа ±вєО јТЗБЖ®їюѕоїЎ ґлЗШј АЪјјИч ѕЛ°н ЅНАёЅГёй ґЩАЅ ёµЕ©ё¦ ВьБ¶ЗПЅЗ јц АЦЅАґПґЩ:

http://en.wikipedia.org/wiki/Donationware


Command line parameters

Параметры командной строки

Синтаксис:

Imagine.exe [параметр...] "имя файла"...

Параметры: (в любом регистре)

/about О программе

/anim[:имя файла] Редактор анимации

/assocext Связать с расширением файла

/browse[:папка] Обзор

/capture Снимок экрана

/copy Скопировать

/depth[:глубина цвета] Изменить глубину цвета

/dissocext Разорвать связь с расширением файла

/filter[:имя фильтра] Фильтр

/flip Перевернуть вертикально

/fullscreen Во весь экран

/grayscale В оттенках серого

/help Перечислить параметры командной строки

/jpegtran[:список имён файлов] Преобразовать JPEG без искажений

/mirror Отразить горизонтально

/multipage[:имя результирующего файла] Создать многостраничное изображение

/negative Преобразовать в негатив

/p Распечатать

/palimp[:имя файла] Импортировать палитру

/paste Вставить

/pref Предпочтения

/print Распечатать

/register Зарегистрировать

/regcontextmenu Внести в контекстное меню

/resize[:(ширина,высота)["%"]] Изменить размеры

/rotate[:градусы|"Left"|"Right"] Повернуть

/save[:имя или расширение файла] Сохранить

/slide[:список имён файлов] Показ слайдов

/swapcol[:"BGR"|"RBG"|"GRB"|"BRG"|"GBR"] Поменять местами цветовые каналы

/top Поверх всех других окон

/uninstall Удалить программу

/unregcontextmenu Исключить из контекстного меню

/viewer Запуск в режиме просмотра

/wallpaper[:"Centered"|"Tiled"|"Stretched"] Сделать фоном рабочего стола

Дополнительные параметры: (в любом регистре, но сразу за основным параметром)

[/slide]

--full[:"no"] Во весь экран

--auto[:"no"|секунд] Автосмена слайдов

--loop[:"no"] Повторять бесконечно

--randomize[:"no"] В случайном порядке

--effect[:название эффекта] С эффектом рамки

[/jpegtran]

--tran[:"none"|"mirror"|"flip"|"90"|"180"|"270"] Вид преобразования

--extra[:"keepall"|"keepcomment"|"removeall"] Задать "дополнительный маркер"

--keeptime[:"no"] Сохранить исходную датировку

--optimize[:"no"] Оптимизировать таблицу Хаффмана

--trim[:"no"] Обрезать непрозрачные блоки на краях

[/save]

--progressive[:"no"] Сделать "прогрессивным" (формат JPEG)

--quality[:1~100] Задать качество (формат JPEG)

--compression[:"none"|"lzw"|"packbits"|"jpeg"|"zip"|"adobe zip"|"huffman rle"|"ccitt fax 3"|"ccitt fax 4"] Задать вид сжатия (формат TIFF)

* Эти дополнительные параметры к "/save" - лишь часть, а не все. Можно использовать любую строку-параметр (на английском) из окна 'File->Save as->Options'.

Примеры:

Imagine /save:"001.gif" "001.jpg"

: Открыть файл "001.jpg" и сохранить его в формате GIF под именем "001.gif".

Imagine /save "001.jpg"

: Открыть файл "001.jpg" и запросить, как его сохранить.

Imagine /save:tif --compression:packbits *.jpg

: Все файлы jpg из текущей папки сохранить в формате tif со сжатием packbits.

Imagine /save:jpg --quality:90 *.bmp

: Все файлы bmp из текущей папки сохранить в формате jpg с качеством 90%.

Imagine /neg /filter:"emboss" /gray /save:*.gif *.jpg

: Все файлы jpg из текущей папки преобразовать в негативы в оттенках серого, применить фильтр "emboss" и сохранить их в формате gif.

(пакетное преобразование)

Imagine /resize:(320,240) /save:png *.jpg

: У всех файлов jpg из текущей папки сделать ширину = 320, а высоту = 240 пикселей и сохранить их в формате png.

Imagine /resize:(,100) /save:png *.jpg

: У всех файлов jpg из текущей папки сделать высоту = 100 пикселей и сохранить их в формате png.

(ширина будет рассчитана пропорционально.)

Imagine /flip /p "001.jpg"

: Перевернуть вертикально и распечатать файл "001.jpg".

Imagine /multipage:output.tif "001.jpg" "002.jpg" "003.jpg"

: Создать многостраничное изображение из файлов "001.jpg", "002.jpg", "003.jpg" и сохранить его как "output.tif".

Imagine /multipage *.jpg

: Создать многостраничное изображение из всех файлов jpg в текущей папке и запросить, как его сохранить.

Imagine /slide "001.jpg" "002.jpg" "003.jpg"

: Показать слайды файлов "001.jpg", "002.jpg", "003.jpg".

Imagine /slide *.jpg

: Показать слайды всех файлов jpg из текущей папки.

Imagine /slide --full --auto:5 --loop --randomize --effect:"overlap" *.jpg

: Показать слайды всех файлов jpg из текущей папки с указанными параметрами.

Imagine /jpegtran --tran:mirror --extra:removeall --keeptime --optimize --trim *.jpg

: Все файлы jpg из текущей папки преобразовать без искажений как указано.


Translation

Переводы

на белорусский

- Микола Шиплюк

на болгарский

- SSTANEV

на хорватский

- Elvis Gambiraza

на чешский

- Vaclav Panenka

- z_o_o_m

- Motycka Petr

на датский

- Peter H. S. Madsen

на английский

- Chun Sejin (я сам)

- deus-ex

- Kurt Lettmaier

на эстонский

- Grunt

на французский

- Paul Vansumsen

на немецкий

- deus-ex

- Kurt Lettmaier

на венгерский

- Bodnar Gabor Kalman (Panthera)

на итальянский

- Angeleri Paolo

на японский

- Nardog

на корейский

- Chun Sejin (я сам)

на польский

- Dariusz J. Kawecki

на румынский

- Lorant Szakacs

на русский

- Ираклий Чантурия

- Дмитрий Ерохин

- Александр IMPOMEZIA

- Константин Власов

- справка - Игорь Федоренко

на упрощенный китайский

- Shanny

- Kend Tung

- Leo Dou

на испанский

- Jose Manuel Breto

на шведский

- Leif Larsson

на традиционный китайский

- BOSS Wang

- James Cai

на турецкий

- Tahsin Kocaman

- Adem HURTURK

на украинский

- Роман Новоставский


Special thanks to

Мои особые благодарности:

Thomas G. Lane (за библиотеку JPEG IJG)

Guy Eric Schalnat, Group 42, Inc. (за libpng)

Sam Leffler, Silicon Graphics, Inc. (за libtiff)

Jean-loup Gailly and Mark Adler (за zlib)

Guido U. Draheim (за zziplib)

Markus Oberhumer, Laszlo Molnar & John Reiser (за UPX)

Xiaolin Wu (за Color Quantizer)

Jose Manuel Breto (за испанский язык, оформление панели инструментов и испанский сайт)

deus-ex (за английский языковый шаблон и интерфейс пользователя)

2CANA Universal IT Solutions (за пожертвование)

Mark James (за шёлковые значки)

Chun Seyoung

Lee Hoyoung

Jeon Sungjoo

Hwang Jonghwan

Kim Panki

Kim Changnam

Kim Seungtae

Park Heejoong

Chae Jonghwan

Lee Sunggon

Cho Hyungil

Lee Hyungjoon

Kim Sangil

Kim Hyunsik

Jeon Dongsu

Shin Sungchul

Cha Jaeho

Thomas Knoop

Kim Hongkil

Kim Jinhyuk

Kim Kiuk


Internet

Интернет

сайт

- http://www.nyam.pe.kr

e-mail

- nyam@nyam.pe.kr


Frequently asked questions (FAQ)

Ответы на типичные вопросы (FAQ)

1. Что за файлы Imagine.wlx и Imagine.wcx?

Imagine можно использовать с Total Commander (известным файловым менеджером).

Файл Imagine.wlx можно использовать как модуль просмотра для Total Commander, а Imagine.wcx - как модуль архивации для Total Commander.

Но если вы не пользуетесь Total Commander, можете удалить эти файлы.

В этом случае минимальный комплект состоит из Imagine.exe и Imagine.dll.

2. Как пользоваться файлом Imagine.wcx?

Они касаются только пользователей Total Commander, о чем я говорил выше.

Файл Imagine.wcx нужен для просмотра файлов рисунков и анимации.

Свяжите его с расширением 'Imagine'. После этого можно будет просматривать в нем рисунки всех форматов, поддерживаемых Imagine.

Еще можно извлекать нужные кадры из анимированных рисунков. (например, из анимированных GIF)

И еще можно конвертировать форматы рисунков. Формат, в который преобразуется рисунок, задается расширением файла.

Включив 'Отдельные архивы для каждого выбранного файла и каталога', его можно использовать для пакетного преобразования.

3. Я не могу удалить Imagine, файл Imagine.dll не удаляется.

Наверное, вы используете его как расширение оболочки.

Если он зарегистрирован как расширение оболочки, процесс Imagine не выгружается до закрытия Проводника, поэтому файл и не получается удалить.

Сначала отключите интеграцию в оболочку ОС (на закладке "Расширение оболочки ОС" в меню настроек).

Затем завершите сеанс или перезагрузите Windows, после этого вы сможете удалить Imagine.dll.

4. Я хочу сделать модуль для Imagine. С чего мне начать?

Есть инструментарий (SDK) для модулей Imagine. Его последнюю версию можно скачать на сайте Imagine.

Но вам может не хватить документации или описания. Тогда найдите меня на WWW или по E-mail.

5. Часть функций не работает.

Функция сглаживания и некоторые стили панели инструментов могут потребовать обновления системных библиотек общих органов управления.

Их можно обновить, установив последнюю версию Internet Explorer.

6. Я не вижу рисунков WMF.

Наверное, вы используете Imagine как модуль просмотра Total Commander.

Рисунки WMF отключены в просмотре и эскизах из соображений безопасности (прорехи в безопасности Windows).

Их можно включить в wincmd.ini, раздел [Configuration], параметр WmfAllowed=3

7. Можно ли использовать переменные среды?

Переменные среды можно использовать, заключив в '%'.

Например, '%TEMP%' означает переменную среды, указывающую каталог для временных файлов.