autodata intro

Autodata Technical Topics

The Technical Topics section consists of informative technical material covering a range of subjects.

© Copyright & database rights Autodata Limited 2010


Index

Air Conditioning - Index

Principles of air conditioning Component descriptions Safety precautions General test procedure Frequently asked questions System pressure testing and diagnosis


Principles of air conditioning (AC)

Function of vehicle air conditioning systems

  • Vehicle air conditioning systems are designed to perform two basic functions, to cool the passenger compartment air to a lower temperature than the ambient (outside) air and to de-humidify the passenger compartment air to a comfortable level.
  • In order to carry out these functions successfully the system must be able to counter the effects of unwanted heat and relative air humidity in the vehicle interior.

Unwanted heat

  • Unwanted heat may enter the vehicle by radiation, e.g.
    • Heat radiated by the sun is conducted through the roof, windows and body panels.
    • Heat which radiates upwards from the road is conducted through the floor panel.
    • Occupants' body heat which radiates into the interior.
    • Or alternatively by conduction e.g.
    • Engine heat conducted through the bulkhead panel.
    • Exhaust heat conducted through the floor panel.

    Relative air humidity

    • Relative air humidity is very important for driver and passenger comfort. A level of around 60% is desirable as the air can easily absorb the moisture given off by the human body. The role of the air conditioning system is therefore to maintain a comfortable level of humidity at all times.

    Evaporation

    • Evaporation is the process whereby the state of a liquid is changed to a vapour. If for example water is boiled it evaporates and changes its state to steam, as the evaporation takes place the vapour produced absorbs heat. If more heat is applied the temperature of the water will not increase, but the rate at which it evaporates will.

    Condensation

    • Condensation is the process whereby a vapour when cooled, changes its state to a liquid. If for example the vapour given off by boiling water is allowed to cool it will return to a liquid state.

    Refrigerant evaporation and condensation

    • Water is not a suitable refrigerant for air conditioning as its boiling point is too high. Even at low pressures no usable cooling effect could be achieved when it evaporates. For that reason special refrigerants are used that evaporate at very low temperatures (R134a boils at approximately -27°C at normal atmospheric pressure). The temperature at which refrigerant evaporation takes place varies according to pressure.

    Refrigerant circuit

    • The heat from the car interior, that is absorbed during evaporation, must be dispelled into the atmosphere and the refrigerant vapour condensed back to a liquid. Therefore the refrigerant in an automotive air conditioning system needs to be circulated continuously.

    Expansion valve system

    When the AC system is in operation the refrigerant is circulated continuously, passing through the following stages:

    1. Relatively cold, low pressure refrigerant vapour is drawn into the compressor and is compressed. During its compression the temperature of the vapour is greatly increased.
    2. Hot high pressure refrigerant vapour from the compressor enters the top of the condenser and passes down through the cooling tubes. The heat created during compression and that absorbed by the refrigerant during the previous cooling cycle is extracted. The refrigerant temperature lowers and it condenses before it exits the bottom of the condenser as high pressure liquid refrigerant.
    3. Cool air is forced through the condenser fins, either by the speed of the vehicle, or by the condenser blower. This ensures the condenser can function under all operating conditions.
    4. Liquid refrigerant from the condenser is collected in the receiver/drier where it is filtered and dried. The refrigerant vapour rises to the top of the receiver/drier and the liquid refrigerant collects at the bottom. The liquid refrigerant leaves through the central tube.
    5. High pressure liquid refrigerant from the receiver/drier enters the expansion valve and a metered quantity is injected into the evaporator. The expansion valve senses the temperature of the vapour leaving the evaporator and the quantity is varied to maintain complete evaporation of the refrigerant.
    6. As the pressure drops, the liquid refrigerant evaporates and absorbs heat from the evaporator.
    7. Warm air from the car's interior is forced through the evaporator fins by the heater blower and is cooled as its heat is absorbed by the evaporating refrigerant. The cooled, de-humidified air is blown into the car's interior. The moisture in the warm air condenses on the surface of the evaporator and is allowed to drain away from the evaporator housing. Relatively cold low pressure refrigerant vapour leaves the evaporator and is then recycled.
    8. High pressure refrigerant temperatures are monitored by switches or sensors located in the system.
    1. High pressure refrigerant vapour
    2. High pressure refrigerant liquid
    3. Low pressure refrigerant liquid/vapour
    4. Low pressure refrigerant vapour

    Fixed orifice tube system

    When the AC system is in operation the refrigerant is circulated continuously, passing through the following stages:

    1. The compressor draws in relatively cold, low pressure refrigerant vapour and compresses it, causing a significant temperature increase.
    2. Hot high pressure refrigerant vapour from the compressor enters at the top of the condenser and passes down through the cooling tubes. The heat created during compression and that absorbed by the refrigerant during the previous cooling cycle is extracted. The refrigerant temperature lowers and it condenses before it exits the bottom of the condenser as high pressure liquid refrigerant.
    3. Cool air is forced through the condenser fins, either by the speed of the vehicle, or by the condenser blower. This ensures the condenser can function under all operating conditions.
    4. High pressure liquid refrigerant from the condenser enters the orifice tube which allows only a metered quantity to be injected into the evaporator.
    5. As the pressure drops, the liquid refrigerant evaporates and absorbs heat from the evaporator.
    6. Warm air from the car's interior is forced through the evaporator fins by the heater blower and is cooled as its heat is absorbed by the evaporating refrigerant. This cooled, de-humidified air is then blown back into the car. The moisture in the warm air condenses on the surface of the evaporator and is allowed to drain away from the evaporator housing. Relatively cold low pressure refrigerant vapour (and possibly liquid) leaves the evaporator and is then recycled.
    7. Because the orifice tube is of a fixed size it cannot ensure that the refrigerant leaving the evaporator is completely evaporated. Therefore it is passed through the accumulator/drier where it is filtered and dried and is allowed to completely evaporate (liquid refrigerant would damage the compressor). It leaves the accumulator/drier and is then recycled.
    8. Low pressure refrigerant temperatures are monitored by switches or sensors located in the accumulator/drier.
    9. High pressure refrigerant temperatures are monitored by switches or sensors located in the line before the fixed orifice tube.
    1. High pressure refrigerant vapour
    2. High pressure refrigerant liquid
    3. Low pressure refrigerant liquid/vapour
    4. Low pressure refrigerant vapour

    Fixed orifice tube system with refrigerant heating - cooling mode

    This system is used in some diesel powered vehicles during the engine warm up period to aid the heating of the passenger compartment in cold weather. When the AC system is in operation refrigerant is circulated continuously, passing through the following stages:

    NOTE: In this mode the AC refrigerant control valve [A] is open.

    1. The compressor draws in relatively cold, low pressure refrigerant vapour and compresses it, causing a significant increase in temperature.
    2. Hot high pressure refrigerant vapour from the compressor enters at the top of the condenser and passes down through the cooling tubes. The heat created during compression and that absorbed by the refrigerant during the previous cooling cycle is extracted.
    3. The refrigerant enters an integral receiver drier (also called a modulator) where it is filtered and dried before it exits the bottom of the condenser as high pressure liquid refrigerant.
    4. Cool air is forced through the condenser fins, either by the speed of the vehicle, or by the condenser blower. This ensures the condenser can function under all operating conditions.
    5. High pressure liquid refrigerant from the condenser enters the orifice tube which allows only a metered quantity to be injected into the evaporator via the AC refrigerant control valve.
    6. As the pressure drops, the liquid refrigerant evaporates and absorbs heat from the evaporator.
    7. Warm air from the car's interior is forced through the evaporator fins by the heater blower and is cooled as its heat is absorbed by the evaporating refrigerant. This cooled, de-humidified air is then blown back into the car. The moisture in the warm air condenses on the surface of the evaporator and is allowed to drain away from the evaporator housing. Relatively cold low pressure refrigerant vapour (and possibly liquid) leaves the evaporator and is then recycled.
    8. Because the orifice tube is of a fixed size it cannot ensure that the refrigerant leaving the evaporator is completely evaporated. Therefore it is passed through the AC refrigerant hot gas tank where it is allowed to completely evaporate (liquid refrigerant would damage the compressor). The refrigerant vapour leaves the AC refrigerant hot gas tank and is then recycled.
    9. Refrigerant pressure is monitored by a refrigerant pressure sensor located in the high pressure line.
    1. High pressure refrigerant vapour
    2. High pressure refrigerant liquid
    3. Low pressure refrigerant liquid/vapour
    4. Low pressure refrigerant vapour

    Fixed orifice tube system with refrigerant heating - heating mode

    This system is used in some diesel powered vehicles during the engine warm up period to aid the heating of the passenger compartment in cold weather. When the refrigerant heating system is in operation refrigerant is circulated continuously, passing through the following stages:

    NOTE: In this mode the AC refrigerant control valve [A] is closed.

    1. The compressor draws in low pressure refrigerant vapour and compresses it. This results in a significantly increased refrigerant temperature.
    2. Hot high pressure refrigerant vapour from the compressor bypasses the condenser via the AC refrigerant control valve and passes directly to the evaporator.
    3. Cold air from the car's interior is forced through the evaporator fins by the heater blower and is heated by the hot refrigerant vapour. Relatively cold low pressure refrigerant vapour (and possibly liquid) leaves the evaporator.
    4. Relatively cold low pressure refrigerant vapour enters the AC refrigerant hot gas tank where any liquid can completely evaporate. Some models use an electrical AC refrigerant heater around the AC refrigerant hot gas tank to raise the temperature of the refrigerant before it returns to the compressor to be recycled.
    5. Refrigerant pressure is monitored by a refrigerant pressure sensor located in the high pressure line.
    6. The AC refrigerant heater is controlled by a thermal switch.
    1. Low pressure refrigerant liquid/vapour
    2. Low pressure refrigerant vapour


AC component descriptions

Compressor

Function

  • The compressor is a mechanical pump that compresses and circulates refrigerant around the AC system.

Operation

  • The compressor draws in low pressure refrigerant vapour and delivers high pressure refrigerant vapour.
  • During compression the temperature of the refrigerant vapour rises considerably. The compressor can only compress vapour as liquid would destroy the compressor.
  • The compressor is normally driven by a belt directly from the engine crankshaft or alternatively via the alternator or power steering pump.

Swash plate type

Fig 1

  • The swash plate [1] is rigidly connected to the compressor shaft [2] at an oblique angle. A number of pistons [3] are located around the circumference of the swash plate at even intervals (the number of pistons and at which angle they are set is dependent on the capacity of the compressor).
  • The swash plate converts the rotary movement of the compressor shaft into the reciprocating movement of the pistons. Reed type suction and discharge valves [4] are mounted in valve plates between the cylinder assembly and the cylinder head.
  • Swash plate compressors can be of either fixed or variable capacity.
  • Variable capacity control greatly reduces the conventional ON/OFF operation of the magnetic clutch and the mechanical shocks that this causes.
  • Variable capacity compressors are fitted with a pressure control valve [5] that senses the pressure of the suction side, this varies the delivery capacity by allowing the swash plate to change its angle.
  • Late models can be fitted with an electrically operated pressure control valve. This is controlled by the AC control module or engine control module (ECM) and reduces the power required to operate the system, improves fuel consumption and reduces exhaust emissions.

Vane type

Fig 2

  • The vanes [3] are set at even intervals within a rotor [1] which is mounted on the compressor shaft. When the rotor turns, centrifugal force pushes the vanes outwards against the inner wall of the compressor [4]. The eccentric arrangement of the rotor and the vane movements generate pressure changes in the compressor housing [2] which create suction for refrigerant intake, subsequently compression and finally the discharge of the refrigerant.

Scroll (Helix) type

Fig 3

  • The scroll compressor consists of two helices which are located in a cylindrical housing [3]. One helix lies within the other, one being fixed [2], the other [5] oscillates on a drive shaft and being guided by bearing balls [6] and a thrust plate [1]. The drive shaft [7] incorporates a counterweight and runs in a bearing in the housing cover [8]. Sealing strips [4] provide a gas tight seal for the cavity between the helices which creates two crescent-shaped compression chambers. These expand and contract through the movement of the oscillating helix.
  • Scroll compressors can be of either fixed or variable capacity.
  • Variable capacity control greatly reduces the conventional ON/OFF operation of the magnetic clutch and the mechanical shocks that this causes.
  • Variable capacity compressors are fitted with a control valve. To reduce delivery, the control valve passes partially compressed refrigerant vapour back into the low pressure chamber. The amount of refrigerant vapour fed back is determined by the position of the piston in relation to the bypass in the control valve.

Magnetic clutch

Fig 4

  • A magnetic clutch is used to connect or disconnect the drive to the compressor.
  • When voltage is applied to the clutch field coil [5], the clutch plate [1] (which is connected to the compressor shaft) is drawn into contact with the pulley [4] and the compressor rotates.
  • When voltage is disconnected from the clutch field coil [5], the clutch plate [1] is released and the compressor ceases to rotate.
  • The compressor clutch clearance on some models may be adjusted with shims [2].
  • The clutch field coil [5] is normally held in position with a snap ring [3].
  • Compressors are lubricated by oil held in the compressor and mixed with the refrigerant.

Condenser

Function

Fig 5

  • As the refrigerant vapour is compressed its temperature increases and it therefore needs to be cooled before it is passed to the evaporator.
  • The function of the condenser is to cool the hot refrigerant vapour ensuring it condenses into a liquid, and it is normally located in front of the engine coolant radiator.

Operation

Fig 6

  • The condenser receives vapour from the compressor under high pressure.
  • The vapour enters the top of the condenser and flows down through the condenser tubes.
  • As cool air passes over the condenser fins the refrigerant is cooled and it condenses before leaving the bottom of the condenser as liquid.
  • When the vehicle is stationary a mechanical or electrically operated fan is used to force air through the condenser fins.
  • On late models the condenser is divided into three separate chambers. The top section [1] cools the hot vapour ensuring it condenses into liquid. It is then passed to an integral receiver/drier [2] (also called a modulator in this arrangement), where it is dried and separated from any remaining vapour before entering the lower section [3], a sub cooler that ensures that only liquid is passed to the expansion valve.

Receiver/drier

Function

  • The receiver/drier is used in an expansion valve system and is located in the high pressure side of the system. On older systems it is connected by pipes and located between the condenser and the expansion valve, on late models it can be integral to the condenser.
  • Its primary function is to ensure that only liquid refrigerant is passed on to the expansion valve. It also filters any impurities from the system and absorbs any moisture that may have entered the system.
  • In the event of compressor damage or when the refrigerant circuit has been left open to the atmosphere, it must be serviced (integral types only), or renewed.

Operation

Fig 7

  • The high pressure liquid passes from the condenser through the inlet line [1] into the receiver/drier, and a drying element [4] absorbs moisture from the refrigerant and filters foreign matter.
  • The liquid refrigerant [5] then passes along a riser [6] to the outlet line [3] and on to the expansion valve.
  • In some systems a sight glass [2] is incorporated in the outlet line.

Integral receiver/drier

Fig 8

  • Integral types have a desiccant cartridge [1] and filter [2] that can be accessed after refrigerant discharging by removing the plug [3].

    NOTE: nbsp;The filter is integral to the plug on some models.

Accumulator/drier

Function

  • The accumulator/drier is used in a fixed orifice tube system and is located in the refrigerant circuit between the evaporator and the compressor.
  • Its primary function is to prevent liquid refrigerant from entering and damaging the compressor.
  • To achieve this it acts as a reservoir for liquid refrigerant which failed to vaporise while passing through the evaporator, and allows only refrigerant vapour to be drawn off by the compressor.
  • The accumulator/drier also acts as a filter ensuring that the refrigerant circuit is clean, and absorbs moisture that may have entered the refrigerant.
  • In the event of compressor damage or when the refrigerant circuit has been left open to the atmosphere, it must be renewed.

Operation

Fig 9

  • Refrigerant vapour passes from the evaporator through the inlet line [3] into the accumulator/drier and flows around the cap [4] creating a vortex. The drying element [8] collects any moisture absorbed by the refrigerant.
  • Refrigerant vapour collects under the cap where it is extracted through the opening of the U-shaped tube into the outlet line [2].
  • The heavier liquid tends to flow towards the bottom of the accumulator/drier, where it has a second opportunity to vaporise.
  • Behind the filter screen [6] there is a small hole in the U-shaped tube [5]. Oil collected in the accumulator/drier [7] is extracted through this opening and mixed with the outgoing refrigerant vapour.
  • A connection at the top of the accumulator/drier [1] accommodates the low pressure switch.

Expansion valve

Function

Fig 10

  • Located in the high pressure line between the receiver/drier and the evaporator the expansion valve separates the refrigerant circuit high and low pressure sides.
  • By controlling the flow of refrigerant into the evaporator, it ensures complete evaporation of the liquid refrigerant so that only refrigerant vapour can return to the compressor.
  • Expansion valves are not adjustable and are changed as a complete service unit.

Operation - block valve type

Fig 11

  • This type of expansion valve consists of the diaphragm head [5] and the valve body. The refrigerant from the receiver/drier [1] flows through the lower bore and is injected in precisely metered quantities. The metering is carried out by a sensor [4] and diaphragm chamber [6] filled with a small amount of refrigerant.
  • The sensor [4] monitors the temperature of the refrigerant vapour returning from the evaporator [7]. When the temperature rises, the sensor heats the liquid refrigerant enclosed by the diaphragm. The refrigerant expands and the diaphragm pushes on a valve slide [2] that forces the ball [9] downwards away from the valve seat against spring pressure [10]. This increases the flow of the refrigerant to the evaporator [8]. The ball valve closes again as soon as the temperature in the evaporator falls and the refrigerant in the diaphragm head cools. Refrigerant vapour returns to the compressor via the connection [3].

Operation - thermostatic valve type

Fig 12

  • The thermostatic expansion valve (TXV) with thermal bulb [2] is located directly in the evaporator inlet. High pressure liquid refrigerant from the receiver/drier enters the valve at [4] and acts against the spring loaded valve [6] to be injected into the evaporator [5].
  • A thermal sensing bulb [2] is placed on the low pressure line. When the temperature rises, the sensor heats the liquid refrigerant enclosed by the diaphragm. The refrigerant expands and the diaphragm pushes the valve downwards away from its seat. This increases the flow of the refrigerant to the evaporator [5]. The valve closes again as soon as the temperature in the evaporator falls and the refrigerant in the diaphragm cools.
  • A pressure equalisation line [1] is used to compensate for varying outlet pressures. Some are fitted externally to the suction line as shown, while others types use an internal drilling.

Fixed orifice tube

Function

  • The orifice tube is located in the high pressure line between the condenser and the evaporator.
  • The exact location may be visible from the outside by a shoulder in the refrigerant line. This is a restriction which stops the orifice tube from being pushed into the evaporator.
  • The orifice tube separates the refrigerant circuit high pressure side from the low pressure side and meters the flow of refrigerant into the evaporator.
  • The orifice tube cannot ensure complete evaporation of the liquid refrigerant within the evaporator so an accumulator is used to ensure that only refrigerant vapour can return to the compressor.

Operation

Fig 13

  • The liquid refrigerant [1] flows from the condenser at high pressure to the inlet side of the orifice tube [3]. Two O rings [4] prevent refrigerant from bypassing the orifice tube. A screen filter at the inlet [2] ensures that the orifice does not become blocked. The screen on the outlet side [5] finely atomises the refrigerant before it is delivered to the evaporator [6].
  • The inside diameter of the fixed orifice tube varies between vehicle types. Each fixed orifice tube is colour coded to show the calibration of the tube. It is important to install the correctly calibrated fixed orifice tube as cooling performance can otherwise be significantly affected.
  • If the compressor has suffered internal damage, the fixed orifice tube and/or filter can become blocked with metal particles and should be renewed.

Variable orifice tube

Function

  • The variable orifice tube is located in the high pressure line between the condenser and the evaporator.
  • The exact location may be visible from the outside by a shoulder in the refrigerant line. This is a restriction which stops the orifice tube from being pushed into the evaporator.
  • The orifice tube separates the refrigerant circuit high pressure side from the low pressure side and meters the flow of refrigerant into the evaporator via two orifices, one fixed and one variable.
  • The variable orifice tube cannot ensure complete evaporation of the liquid refrigerant within the evaporator so an accumulator is used to ensure that only refrigerant vapour can return to the compressor.

Operation

Fig 14

  • The liquid refrigerant [1] flows from the condenser at high pressure to the inlet side of the variable orifice tube [2]. Two O rings [3] prevent refrigerant from bypassing the variable orifice tube. A screen filter at the inlet [4] ensures that the orifices do not become blocked. Refrigerant flow is metered via the fixed orifice [5] and the variable orifice [6]. The quantity of refrigerant is metered depending on the refrigerant temperature. As the temperature rises the bi-metal spring [7] rotates operating a restrictor [8] to meter the flow of refrigerant through the variable orifice [6]. The screen on the outlet side [9] finely atomises the refrigerant before it is delivered to the evaporator [10].
  • The inside diameter of each orifice may vary between vehicle types. Each orifice tube is colour coded to show the calibration of the tube. It is important to install the correctly calibrated orifice tube as cooling performance can otherwise be significantly affected.
  • If the compressor has suffered internal damage, the orifice tube and/or filter can become blocked with metal particles and should be renewed.

Evaporator

Function

  • The evaporator is normally located in the heater air intake.
  • The evaporator receives cold refrigerant vapour and cools the air in the passenger compartment, it also de-humidifies (removes moisture from) the passenger compartment air.
  • Some vehicles are fitted with more than one evaporator, for example, one in the front of the vehicle and one in the rear passenger compartment.

Operation

Fig 15

  • The evaporator receives a mixture of cold refrigerant liquid and vapour from the expansion valve or orifice tube (depending on system type) [1].
  • Air (normally re-circulated) [A], is drawn over the evaporator fins [3] by an electric fan [4].
  • As the air passes over the evaporator fins, it is cooled and blown into the passenger compartment [B], before being recirculated through the evaporator.
  • The heat from the intake air ensures that the refrigerant liquid is vapourised before it leaves the evaporator [2], and is drawn back into the compressor for recirculation.
  • Water vapour in the air that passes through the evaporator condenses on the fins, with the result that the air is de-humidified, the water that is collected in the process runs away through drainage channels.

Service connectors

Function

  • The service connectors are normally located in the engine bay. The low pressure service connector may be on the AC compressor, or on the low pressure refrigerant line. The high pressure service connector may be on the AC compressor, the high pressure refrigerant line, or the receiver/drier. Some vehicles may be fitted with only a high pressure service connector.
  • Service connectors allow the connection of a manifold gauge set to the refrigerant circuit for service and testing.

    NOTE: Compressors may have service connectors identified by SUC (suction) for the low pressure connection and DIS (discharge) for the high pressure connection.

Operation - R12 service connectors

Fig 16

Fig 17

  • The protective caps prevent the valves becoming contaminated with dirt and provide an additional seal when the system is in operation. They must be reinstalled after servicing or repairs.
  • The service connectors are internally and externally threaded couplings and they both use screw-on connectors. The high pressure Fig 16 [A] and low pressure Fig 16 [B] service connectors normally have 3/8 inch external threads.
  • The high and low pressure service connectors are not identified except where they are fitted to the compressor.
  • Some vehicles use one 3/8 inch (high pressure) and one 7/16 inch (low pressure) externally threaded coupling.
  • The service connectors contain Schrader type valves. An integral valve core Fig 17 [4] is screwed into the connector body Fig 17 [1].
  • The valves work like a tyre valve, depressing pin [2] against the seating spring Fig 17 [3] opens the valve.

Operation - R134a service connectors

Fig 17

Fig 18

  • The service connectors are internally threaded couplings and both use push-on connectors. The high pressure Fig 18 [A] and low pressure Fig 18 [B] service connectors have different size couplings.
  • The high pressure service connector has a large diameter while the low pressure service connector is of a smaller diameter. The service connectors contain Schrader type valves as in R12 connectors .

    NOTE: Do not use ordinary tyre valves for servicing an air conditioning system. Tyre valve seal material deteriorates rapidly when it comes in contact with refrigerant.

Refrigerant pressure switches

Function

  • Refrigerant pressure switches may be located in the low pressure and/or high pressure lines of the refrigerant circuit depending upon the type of system.
  • The contacts of the switch are opened or closed according to the circuit pressure and switches that have more than one set of contacts are called dual, triple or quadruple pressure switches.
  • The operating pressures of the switches and their function will vary according to the type of system, for example:
  • A low or triple pressure switch is used to ensure that the compressor will not operate if the refrigerant pressure is too low.
  • A high or triple pressure switch is used to ensure that the compressor will not operate if the refrigerant pressure is too high.
  • A low pressure switch is used to control (cycle) the compressor operation on orifice tube systems.
  • A high pressure switch may be used to operate the condenser or engine coolant blower motors.

Operation - refrigerant dual pressure switch

Fig 19

  • Refrigerant enters the dual pressure switch (sometimes referred to as a binary switch) through the drilling [1] and pressure is sensed by the membrane [2] to operate the actuator [3] against the spring [4].
  • If the refrigerant pressure falls below approximately 2 bar the low pressure switch contacts [5] open and the compressor clutch circuit is broken.
  • When the refrigerant pressure rises above approximately 3 bar the low pressure switch contacts close and the compressor clutch circuit is closed.
  • If the refrigerant pressure rises above approximately 27 bar the high pressure switch contacts [6] open and the compressor clutch circuit is broken.
  • When the refrigerant pressure returns to approximately 23 bar the high pressure switch contacts close and the compressor clutch circuit is closed.

Operation - refrigerant triple/quadruple pressure switch

Fig 19

  • The refrigerant triple pressure switch (sometimes referred to as a trinary switch or pressostat) operates in the same way as the dual pressure switch to control the compressor operation.
  • It has additional contacts to control the condenser or engine coolant blower motors.
  • If the refrigerant rises above approximately 15-19 bar the switch contacts [7] close and the condenser or engine coolant blower motor circuit is operated.
  • The quadruple pressure switch has an additional set of contacts to enable the condenser or engine coolant blower motor(s) to be operated in stages dependent on the refrigerant pressure.

Operation - refrigerant high pressure switch

Fig 19

  • The refrigerant high pressure switch operates in a similar way to the dual pressure switch, but has only high pressure contacts [6] to control the operation of the compressor.

Operation - refrigerant low pressure switch

Fig 20

  • The refrigerant low pressure switch (sometimes referred to as a cycling switch in fixed orifice tube systems) operates in a similar way to the dual pressure switch, but has only low pressure contacts [1] to control the operation of the compressor.

Refrigerant pressure sensor

Function

  • A refrigerant pressure sensor may be used to control the operation of both the compressor and condenser or engine coolant blower motors via either the AC control module or engine control module (ECM).

Operation - analogue type

Fig 21

  • Analogue pressure sensors operate in a similar way to the dual pressure switch but the contacts are replaced by a variable resistance or pressure sensitive crystal.
  • The pressure sensor is supplied with a reference voltage to its connections [1] from the AC control module or engine control module (ECM).
  • The control voltage emitted from its connection [2] varies in proportion to the refrigerant pressure.

Operation - digital type

Fig 22

Fig 23

  • Digital pressure sensors operate in a similar way to the analogue type but use a pressure sensitive crystal Fig 22 [1] and a microprocessor Fig 22 [2] to produce a digital signal.
  • The pressure sensor is supplied with a voltage to its connections Fig 22 [3] from the AC control module or engine control module (ECM) and returns a signal through connection Fig 22 [4].
  • The crystal is supplied with a reference voltage from the microprocessor Fig 22 [5].
  • The crystal distorts as the refrigerant pressure varies resulting in a change to its electrical resistance. This change varies the voltage emitted to the microprocessor Fig 22 [6] where a digital signal is generated.
  • The digital signal reflects the refrigerant pressure by a varying pulse width (duty cycle).

Temperature switches and temperature sensors

Function

  • Both temperature switches and sensors may be used to control the operation of the AC system for example:
  • the engine coolant temperature may be monitored to ensure that the engine does not overheat due to the additional heat generated when the AC system is operating.
  • the temperature of the evaporator may be monitored to ensure that if its temperature falls to a point that may allow freezing, the compressor operation is interrupted.
  • both in-car and ambient air temperature may be monitored to control the operation of the AC system.

Operation - engine coolant temperature (ECT) sensor

Fig 24

  • The engine coolant temperature (ECT) sensor is located in the cooling system either in the radiator or on the engine and is connected to the AC control module or cooling fan control module.
  • In most cases the sensor incorporates a negative temperature coefficient (NTC) resistor, which decreases in resistance as the coolant temperature rises.

Operation - air temperature sensor

Fig 25

  • Air temperature sensors may be fitted at various locations both inside and outside the vehicle and are connected to the AC control module.
  • In most cases the sensor incorporates a negative temperature coefficient (NTC) resistor, which decreases in resistance as the air temperature rises.

Operation - evaporator temperature sensor

Fig 26

  • The evaporator temperature sensor is located in the evaporator housing and is connected to an electronic control module.
  • The temperature sensor probe [1] is placed into the evaporator cooling fins and changes its resistance in proportion to temperature changes. If the temperature falls to a point where freezing may occur, the sensor signal is used to switch the compressor off until the temperature rises again.
  • In most cases the sensor incorporates a negative temperature coefficient (NTC) resistor, which decreases in resistance as the evaporator temperature rises.
  • The sensor may incorporate a transistor within the assembly [2] to act as a switch.

Operation - engine coolant temperature (ECT) switch

Fig 27

  • The engine coolant temperature (ECT) switch is located in the cooling system either in the radiator or on the engine. It incorporates a bimetallic switch that either opens or closes as the coolant temperature rises.
  • The engine coolant temperature (ECT) switch may be used to operate cooling fans or interrupt the compressor operation.

Operation - evaporator temperature switch

Fig 28

  • The evaporator temperature switch is located in or near the evaporator housing while the sensor capillary tube [1] is positioned in the evaporator cooling fins.
  • Temperature changes within the evaporator cause proportional pressure changes in the capillary tube, the pressure in the sensor capillary tube decreases as the temperature decreases.
  • This pressure decrease acts on a membrane [2] which is connected to the switch contacts [3]. When the contacts open the compressor clutch circuit is interrupted.
  • Typically the switch contacts open at approximately 1°C and close at approximately 4°C.

Electronic control modules

Function

  • Automatic and semi-automatic systems may be controlled by an AC control module.
  • The AC control module is commonly integrated into the AC/heater control panel but in some systems may be a separate unit installed either under the bonnet or inside the vehicle. The engine control module (ECM) may also control certain AC components.
  • The AC and engine control modules are normally linked and may have a common data link connector (DLC) for access to fault diagnosis data.

Operation - AC control module

Fig 29

  • Electrical signals from the heating and AC system controls and sensors are received and processed by the electronic circuits in the AC control module.
  • The AC control module automatically maintains the in-car temperature selected at the control panel.
  • The AC control module receives inputs from:
    • AC evaporator temperature sensor.
    • AC refrigerant pressure sensor.
    • AC/heater controls.
    • Automatic transmission.
    • Engine speed (RPM) sensor.
    • Heater output temperature sensor.
    • In-car temperature sensor.
    • Outside air temperature sensor.
    • Vehicle speed sensor (VSS).
  • Outputs from the AC control module control the following:
    • AC compressor clutch.
    • AC/heater blower motor
    • AC/heater flap solenoid or motors.
    • Condenser blower motor(s).
    • Engine coolant blower motor(s).
    • Engine coolant heater regulator valve.

NOTE: The AC control module may be equipped with a self-diagnosis system.

  • Faults recorded by the AC control module need to be rectified before any further diagnosis of the AC system.

Operation - engine control module (ECM)

Fig 30

Fig 31

  • Electrical signals from the fuel and ignition system sensors are received and processed by the electronic circuits in the ECM.
  • The ECM controls the fuel, ignition and exhaust emission systems.
  • Additionally it may be used to control certain functions of the AC system.
  • ECM inputs that may affect the AC function:
    • AC ON signal.
    • Automatic transmission.
    • Engine coolant temperature.
    • Engine load.
    • Engine speed (RPM).
    • Throttle position.
    • Vehicle speed.
  • Outputs from the ECM that control the AC function:
    • AC compressor clutch operation.
    • Engine coolant blower motor(s).
    • Condenser blower motor(s).

NOTE: The ECM may be equipped with a self-diagnosis system.

  • Faults may be indicated by an LED on the ECM or a malfunction indicator lamp (MIL) or check engine warning light on the instrument panel .
  • Faults recorded by the ECM may affect the operation of the AC system and need to be rectified before the diagnosis of AC faults.
  • For details of ECM fault diagnosis - refer to the relevant Autodata Engine Management Manual.


Safety precautions

Introduction

  • When working with any type of air conditioning system the safety procedures listed below must be observed to prevent component damage and personal injury. The advice given in this chapter is supplementary to any instructions supplied with equipment or materials. Always follow safety and service procedures given by the manufacturer or distributor of the equipment being used.
  • Additional health and safety information may be obtained from equipment, refrigerant and lubrication manufacturers and distributors.

Airbags (Supplementary Restraint System - SRS

Many of the models covered by this product are fitted with airbags as standard equipment. When working on a vehicle fitted with such a system, extreme caution must be taken to avoid accidental deployment of the airbag, which could result in personal injury.

Unauthorised repairs to the system could render it inoperative, or cause it to inflate accidentally.

NOTE: All related wiring may be encased in a yellow outer covering.

When the engine is started the AIRBAG warning lamp should go out after approximately 5-10 seconds, if not this indicates a fault in the system. The fault should be corrected before any other work is carried out.

  • NEVER attempt to test the system using a multi-meter.
  • NEVER tamper with or disconnect the airbag wiring harness.
  • NEVER make extra connections to any part of the system wiring harness or terminals.
  • ALWAYS ensure that the airbag wiring harness has not been trapped or damaged in any way when working on adjacent components or systems.

Electrical

  • ALWAYS ensure that the battery is properly connected before attempting to start the engine.
  • DO NOT attempt to start the engine using a source in excess of 12 volts, such as a fast charger (16 volts) or by connecting two batteries in series (24 volts). ALWAYS disconnect the battery before charging it.
  • DO NOT disconnect the battery while the engine is running.
  • DO NOT connect the battery with reverse polarity.
  • DO NOT disconnect or touch the HT leads when the engine is being cranked or when it is running.
  • DO NOT connect or disconnect the engine control module (ECM), AC control module or any other control module while the ignition is switched ON.
  • DO NOT disconnect any control module multi-plugs within 30 seconds of switching ignition OFF.
  • DO NOT flash a wire or circuit to earth to check that continuity exists.
  • DO NOT attempt to rotate electrical fans for the radiator/condenser by hand with the battery connected. Some can start to operate automatically at any time, even with the ignition switched OFF.
  • ALWAYS ensure that any replacement AC system parts are correct for the application in question. Many units share common external features, but differ internally.

Refrigerant circuit

  • ALWAYS wear appropriate protective clothing, including gloves made of fluoroelastomer (leather or fabric gloves are not suitable when servicing any part of a refrigerant system).
  • ALWAYS wear eye protection, a leak of refrigerant can result in serious blistering (frostbite) of any unprotected skin and especially the eyes.
  • DO NOT service or repair AC refrigerant circuits whilst smoking or near an open flame or hot surface. Although under normal conditions refrigerants are non-poisonous, a discharge near an open flame or hot surfaces can produce toxic gases (fluorine, phosgene).
  • DO NOT service or repair AC refrigerant circuits whilst in enclosed areas, near the ground or in service pits. Although refrigerant is not toxic, it is heavier than air and will displace the air surrounding the area where the refrigerant is released, resulting in suffocation.
  • ALWAYS maintain good ventilation surrounding the work area when handling refrigerant
  • DO NOT deliberately discharge refrigerant to the atmosphere. It is illegal and will damage the environment.
  • ALWAYS discharge the refrigerant from the air conditioning system into an approved recovery system.
  • ALWAYS wear protective goggles, to prevent eyesight damage, when using an ultraviolet (UV) light source for leak detection.
  • DO NOT carry out leak-testing of the refrigerant circuit with compressed air. Refrigerant oil in the system can combust under certain conditions.
  • DO NOT handle refrigerant oil without wearing appropriate gloves. It may contain acids and PAG oil can be absorbed through the skin.
  • DO NOT use non-approved refrigerants. Any other substance in the system can react chemically with the refrigerant or the system components, causing problems. The use of butane gas can result in explosion and personal injury.
  • NEVER weld, use a blow torch or use any excessive amount of heat on or close to the refrigerant circuit, whether filled with refrigerant or not.

Safe handling of refrigerant containers/filling bottles

The following procedures should always be observed:
  • Keep out of reach of children.
  • Store in a cool place, but protect against frost.
  • Do not expose to heat (incl. warm water), sunlight or temperatures above 50°C.
  • Do not handle damp containers with bare hands during charging.
  • Transport upright.
  • Do not drop.
  • Do not overfill pressurised containers - leave space for expansion.
  • Always make sure they are properly closed.
  • Always observe specific local/national regulations.


General test procedures

Introduction

This section deals only with service and repair of the air conditioning (AC) system. For information regarding the function and operation of AC components refer to the appropriate section.

CAUTION: Many of the models covered by this product are fitted with airbags as standard equipment. When working on a vehicle fitted with such a system, extreme caution must be taken to avoid accidental deployment of the airbag, which could result in personal injury. Unauthorised repairs to the system could render it inoperative, or cause it to inflate accidentally.

Refrigerant circuit

NOTE: This section covers general procedures and applies only to standard components.

  • Most refrigerant circuit components of an air conditioning system are not serviceable.
The following components should be renewed if diagnosis has shown that they are faulty:
  • Accumulator/drier.
  • Receiver/drier.
  • Expansion valve.
  • Orifice tube.
  • Compressor.
  • The condenser, evaporator and refrigerant lines may be flushed to remove debris, but the components listed above must be bypassed and an appropriate flushing fluid used.

NOTE: If an appropriate flushing fluid is not available, ONLY USE liquid refrigerant (of the type used in the system).

Refrigerant circuit components

Service connectors

Fig 1

  • The service connectors contain Schrader type valves with integral valve cores which are screwed into the connector body.
  • The valves in service connectors must seal completely to prevent refrigerant leaks. To check for leaks, apply a few drops of refrigerant oil into the valve.
  • If bubbles are formed, the valve is leaking and the valve core will need to be renewed.
  • Normally the refrigerant in the system will need to be recovered and the system recharged. However, there are tools available which allow the valve to be changed while the system is charged with refrigerant (provided there is sufficient access space).
  • The valve core replacer shuts off the service port, enabling the faulty valve to be extracted and the new valve to be installed. The replacer can then be removed from the system.

NOTE: Do not use ordinary tyre valves for servicing an air conditioning system. Tyre valve seal material deteriorates rapidly when it comes in contact with refrigerant.

Fixed orifice tube

  • The orifice tube separates the refrigerant circuit high pressure side from the low pressure side. It can become restricted or blocked by metallic particles or dirt.
  • The orifice tube cannot be serviced, cleaning is not advised.
  • The fixed orifice tube must be renewed if one of the following conditions is present:
    • The orifice tube screen is restricted or blocked.
    • The orifice tube body is broken.
    • The compressor has been renewed due to lack of performance or because of internal damage.

Removing

Fig 2

Fig 3

  • Recover the refrigerant and disconnect the high pressure refrigerant line.
  • Removing the orifice tube may require the use of a special tool Fig 2. Lubricate the evaporator inlet tube (or refrigerant line) and orifice tube O rings with refrigerant oil to ease removal.
  • Follow special tool manufacturer's instructions.

NOTE: DO NOT twist or rotate the orifice tube while it is in the evaporator inlet tube, it may break off inside the tube.

  • If the orifice tube has broken off, it can be removed with another extractor Fig 3.
  • Follow special tool manufacturer's instructions.

Refitting

Fig 4

NOTE: It is extremely important that the correct size of orifice tube is installed to obtain the optimum cooling performance.

  • Orifice tubes are colour coded according to calibration. Refer to manufacturer's specifications.
  • Lubricate the O rings on the orifice tube with clean refrigerant oil.
  • Follow special tool manufacturer's instructions.

Receiver/drier, accumulator/drier

The receiver/drier or accumulator/drier should be renewed when any of the following occur:
  • The compressor is replaced because of internal damage.
  • The expansion valve is replaced.
  • The condenser is replaced.
  • The evaporator valve is replaced.
  • The fixed orifice tube is replaced.
  • The receiver/drier or accumulator/drier has been perforated.
  • The refrigerant circuit has been opened to the atmosphere for a period longer than is required to undertake a minor repair.
  • There is evidence of moisture or water in the refrigerant circuit.
  • The refrigerant is contaminated.

Expansion valve

  • The expansion valve can be checked using either a service station or a pressure gauge manifold set.
  • If, with the air conditioning system in operation, the pressure difference between the high pressure side and the low pressure side is very large, the expansion valve is permanently closed and requires renewal.
  • With the air conditioning system in operation, using freezing spray, spray the diaphragm head while observing the pressure gauges.
  • NORMAL operation:
    • High pressure gauge reading - rises slightly
    • Low pressure gauge reading - lowers slightly
  • ABNORMAL operation:
    • High pressure gauge reading - does not change
    • Low pressure gauge reading - does not change

NOTE: Moisture or water in the refrigerant circuit can freeze, which will affect the performance of the expansion valve.

  • Only use a suitable cleaning fluid if the expansion valve requires cleaning. Do not use compressed air as it may become contaminated with water.
The expansion valve should be renewed when the following occurs:
  • The compressor is replaced because of internal damage.
  • The refrigerant circuit has become contaminated with foreign matter.

Compressor

  • Major compressor repairs are usually best left to specialists as special tools and equipment will be required, however the magnetic clutch and pulley can be replaced and the clearance adjusted.

Removing and refitting the magnetic clutch

Fig 5

NOTE: These instructions are general and will not apply to all makes and models.

Removing

  1. Remove the friction plate retaining nut [1].
  2. Using a suitable puller, remove the friction plate [2].
  3. Remove the shims (if applicable) [3] and the circlip [4].
  4. Using a suitable puller, remove the drive pulley [5].
  5. Remove the circlip [6] (some makes use screws), and the field coil[7].

Refitting

  1. Refit the components in reverse order of removal.
  2. Check the clearance and adjust if necessary.

Checking and adjusting the clearance

Fig 6

  • The compressor magnetic clutch clearance should be checked during regular maintenance procedures.
  • It should also be checked when clutch components are refitted.
  • An incorrectly adjusted clearance can cause:
    • Rough running or intermittent operation.
    • Unusual noise when the clutch is engaged.
    • Clattering when the clutch is not engaged.
    • Partial engagement and slip resulting in poor AC performance.
    • Premature clutch wear.
  • Using a feeler gauge check the clearance between the compressor drive pulley and the friction plate, at several points around the pulley Fig 6.
  • If the clearance is adjusted with shims, remove the friction plate Fig 5 [2], add or remove shims Fig 5 [3] as necessary and refit the friction plate.
  • If the clearance cannot be adjusted with shims, special tools may be required to reposition the friction plate.

NOTE: For clearance specifications refer to 'Technical data' in the model-specific chapter.

System oil level inspection

  • When the AC system is new the compressor is filled with oil equal to the total system quantity.
  • As the system operates the oil mixes with the refrigerant and is distributed around the refrigerant circuit.
  • To check the refrigerant oil level the refrigerant must be recovered.

NOTE: The oil level MUST be checked whenever any of the following occur:

  • A refrigerant circuit component is replaced.
  • The refrigerant circuit is discharged and charged.
  • The refrigerant circuit leaks.

Component replacement

  • When replacing a refrigerant circuit component, the quantity of oil drained from the displaced component must be added to the new component.
  • Some manufacturers specify the amount of oil to be added for each component - refer to 'Technical data' in the model-specific chapter.
  • If no oil is drained from a component and no data is available, the table below can be used as a guide to the quantity to be added:
    • Condenser - 30 ml
    • Evaporator - 30 ml
    • Receiver/ drier - 12 ml
    • Accumulator/drier - 12 ml
    • Refrigerant lines (total) - 30 ml

Refrigerant circuit discharging and charging

  • When the refrigerant system is discharged, some oil will be removed (that mixed with the refrigerant).
  • Some refrigerant recovery equipment separates the oil from the refrigerant. This quantity (of new oil) must be added when charging the system.
  • If the equipment in use does not separate the oil from the refrigerant, then add the quantity specified by the manufacturer - refer to 'Technical data' in the model-specific chapter. li>If the manufacturer does not specify the quantity to be added, add approximately 30 ml of oil when charging the system.

Refrigerant circuit leaks

  • If there has been a refrigerant leak it must be assumed that some of the oil has also been lost.
  • To check the quantity of oil in the system, the compressor must be removed and drained or (if applicable) a dipstick can be used.
  • Compressors with the facility to measure the oil level by using a dipstick should be checked as follows:
  • Recover the refrigerant and remove the access plug.
  • Use special graduated dipsticks to check the oil level.
  • Where there is no dipstick facility, the compressor will have to be removed, the oil drained and refilled.

NOTE: Ensure that the correct type and grade of oil is used, refer to 'Technical data' in the model-specific chapter.

Spring lock couplings

Fig 7

Fig 8

  • Spring lock couplings Fig 7 are used as an alternative to threaded connections.
  • A special tool (different sizes dependent on which refrigerant line is being serviced) is required to separate and disconnect the refrigerant lines Fig 8. li>When refitting, renew the O rings and lubricate with clean refrigerant oil.

Condenser

  • The condenser cannot be serviced and must be replaced if faulty.
  • The condenser should be regularly inspected for signs of dirt and dead insects which build up in the fins.
  • The exterior of condenser should be regularly cleaned, taking care not to damage to the fins.

NOTE: A restriction of air flow through the condenser can result in engine overheating (the air flow through the radiator will also be restricted).

Evaporator

  • The evaporator cannot be serviced and must be replaced if faulty.
  • During normal operation, the exterior of the evaporator and its housing are subjected to damp (the humidity removed from the cooled air).
  • The damp atmosphere allows bacteria to grow in the evaporator housing which may result in a bad odour in the passenger compartment.
  • If odours occur, the evaporator and housing can be treated with a chemical disinfectant with a deodorising action.
  • These chemicals are widely available and are sprayed into the evaporator housing either directly (by gaining access through the housing) or through the heater air intake (the pollen filter should be removed where applicable).

Pollen filter

Fig 9

  • Many models covered by this product are fitted with a pollen filter.
  • The pollen filter cannot be cleaned and should be changed regularly at the intervals as recommended by the manufacturer (refer to model-specific chapter).
  • If the filter is not changed regularly it will become blocked and effect the performance of the heating and ventilation system.

Electrical system

General recommendations

  • Electronic control modules such as the engine control module (ECM) or AC control module need special care during fault diagnosis. They are easily damaged by excess voltage or reversed polarity. Whenever possible disconnect them before testing wiring continuity.
  • Some ECMs have an adaptive memory which may have to be re-learned (during driving) if the power supply is interrupted.
  • Electrical wiring can be repaired where practicable but ensure that all repairs are properly insulated and protected by a fuse of the correct amperage.
  • DO NOT operate the AC system with the high pressure switch circuit bridged without a manifold gauge set connected.

NOTE: Many electronic control modules have self-diagnosis and may erase recorded fault codes if the power supply is interrupted.

Using multimeters

  • The majority of electrical tests described in this product require the use of an ohmmeter or voltmeter. Normally these will be combined in a multimeter.
  • Many suitable instruments are available, with a wide range of specifications.

Voltage checking

Fig 10

  • Set the meter to VOLTAGE.
  • If applicable, set the meter to the correct scale (most modern meters are self-ranging).
  • Connect the black test lead to the negative terminal being tested.
  • Observe the conditions of the test, eg. Ignition ON etc.
  • Connect the red test lead to the positive terminal being tested.
  • Read and record the value displayed.

Resistance and continuity checking

Fig 11

Fig 12

  • Set the meter to RESISTANCE.
  • If applicable, set the meter to the correct scale (most modern meters are self-ranging).
  • Connect the black test lead to the red test lead and check that the meter displays ZERO W.

NOTE: If ZERO W is not displayed, refer to the meter operating instructions.

  • Disconnect the component from any wiring.
  • Connect the black test lead to one terminal being tested.
  • Connect the red test lead to the other terminal being tested.
  • Read and record the value displayed.
  • If the meter displays ZERO W, Fig 11 this indicates continuity.
  • If the meter displays ¥ (infinity) Fig 12, this indicates NO continuity.

Diode checking

Fig 13

Fig 14

  • Set the meter to RESISTANCE or DIODE.
  • Connect the red test lead to positive terminal of the diode.
  • Connect the black test lead to the negative terminal of the diode.
  • The meter should display continuity Fig 13.
  • Reverse the test leads, the meter should display NO continuity Fig 14.

NOTE: If the meter displays continuity in both tests the diode is faulty.

Component checking

Electronic control modules
  • No testing of control modules is possible, except by self-diagnosis (if applicable).
  • However it is possible to check:
    • The signal inputs.
    • The signal outputs.
    • The wiring.

NOTE: For information regarding AC control module self-diagnosis refer to model-pecific chapter. For information regarding engine control module (ECM) self-diagnosis refer to the relevant Autodata publication.

Magnetic clutch

NOTE: The compressor will not operate if the refrigerant level is low.

  • The clutch can be connected in many configurations depending on make and model.

NOTE: If the clutch does not engage when the engine is running and the air conditioning is switched on, check the wiring diagram to confirm its mode of operation BEFORE system testing.

  • The following system diagrams show examples of different compressor circuits and how each type should be tested - refer to model-pecific circuit diagrams before commencing tests.
  • Check condition of ALL fuses in the system prior to circuit testing.
  • Carry out tests in numerical order starting at multimeter [image].

Preparatory conditions

  • Voltage tests should be carried out with all components connected and the ignition and AC switched ON.
  • Voltage tests should be carried out with the engine running where the circuit diagram is similar to Fig 16 [B] or Fig 17 [C].
  • All resistance tests should be carried out with the component disconnected.

Expansion valve system - A

  • The compressor clutch will operate without the engine running.

Fig 15

NOTE: Carry out tests in numerical order starting at multimeter [image].

Expansion valve system - B

  • The compressor clutch may only operate with the engine running.

Fig 16

NOTE: Carry out tests in numerical order starting at multimeter [image].

Expansion valve system - C

  • The compressor clutch may only operate with the engine running.

Fig 17

NOTE: Carry out tests in numerical order starting at multimeter [image].

Fixed orifice tube system - D

  • The compressor clutch will operate without the engine running.

Fig 18

NOTE: Carry out tests in numerical order starting at multimeter

Circuit diagram key

Code | Component description
A35 | Engine control module (ECM)
A63 | AC control module
B24 | Engine coolant temperature (ECT) sensor
B53 | AC evaporator temperature sensor
K143 | AC compressor clutch relay
S149 | AC master switch
S152 | AC refrigerant high pressure switch
S153 | AC refrigerant low pressure switch
S341 | AC refrigerant triple pressure switch
V35 | AC compressor clutch diode
Y11 | AC compressor clutch
15 | Ignition switch - ignition ON
30 | Battery +
31 | Battery -

NOTE:
1. All voltage tests should result in battery voltage.
2. All resistance tests should result in continuity.

  • The clutch resistance should be as specified in the model-specific chapter (where given). If no data is available the following may be assumed for most (but not all) vehicles using a 12 Volt electrical system - 3-4 ? approx.

Refrigerant pressure switches

Fig 19

  • All AC refrigerant circuits are fitted with either one or more pressure switches or a pressure sensor.
  • They cannot be serviced and must be replaced if faulty.
  • To enable any testing they must be fitted in the refrigerant circuit, and a set of manifold pressure gauges must be connected.
  • A Schrader type valve is often fitted under the switch Fig 19, allowing the switch to be replaced without discharging the system.

CAUTION: Ensure that eye protection, suitable protective clothing and gloves are worn.

  • Discharge the system before removing the switch, if in any doubt that a valve is fitted.

Checking

Fig 20

NOTE: These instructions are general and will not apply to all makes and models.

Low pressure contacts

  • Ensure ignition switched OFF.
  • Connect a set of manifold gauges to the refrigerant high and low pressure service connectors.
  • Check and record the reading of the low pressure gauge.
  • Disconnect the pressure switch multi-plug.
  • Using an ohmmeter:
  • Check the resistance [A] of the pressure switch low pressure contacts [1] and high pressure contacts [2].
Technical Data
Pressure | Resistance
3,5 bar approx. | Zero
2 bar approx. | inf

NOTE: If the low pressure gauge reads less than approximately 4 bar the refrigerant level is low.

Condenser blower motor pressure contacts:

CAUTION: If the compressor does NOT SWITCH OFF when the pressure reaches 30 bar, switch the AC OFF immediately and allow the pressure to decrease. Suspect a high pressure switch fault.

  • Ensure ignition switched OFF.
  • Connect a set of manifold gauges to the refrigerant high and low pressure service connectors.
  • Start engine.
  • Switch AC ON.
  • Set AC/heater blower motor switch to maximum speed.
  • Set AC/heater recirculation flap to fresh air position.
  • Set AC/heater temperature control(s) to maximum cold position.
  • Fully open all ventilation outlets.
  • Check condenser blower motor(s) contacts [3] close, and the blower motor(s) operate at the specified pressure.
Technical Data
Pressure | Condenser blower motor
Over 15-19 bar approx. | ON
Under 15-19 bar approx. | OFF

High pressure contacts

CAUTION: If the compressor does NOT SWITCH OFF when the pressure reaches 30 bar, switch the AC OFF immediately and allow the pressure to decrease. Suspect a high pressure switch fault.

  • Ensure ignition switched OFF.
  • Connect a set of manifold gauges to the refrigerant high and low pressure service connectors.
  • Start engine.
  • Switch AC ON.
  • Set AC/heater blower motor switch to maximum speed.
  • Set AC/heater recirculation flap to fresh air position.
  • Set AC/heater temperature control(s) to maximum cold position.
  • Fully open all ventilation outlets.
  • Check and record the reading of the high pressure gauge.
  • Check that the compressor switches OFF when the pressure rises to its maximum limit.

NOTE: The pressure may not reach its maximum limit at low ambient temperatures or if the system is operating correctly.
Technical Data
Pressure | Compressor
Over 28 bar approx. | Switches OFF
Under 23 bar approx. | Switches ON


Frequently asked questions

Q | Can I put R134a in an R12 system?
A | NO, R134a has a different molecular structure to R12 which necessitates the use of different flexible hoses and seals. The compressor may not be suitable (materials within it may not be compatible with R134a or its lubricant), and the service connectors are of a different design.
Q | Can I use mineral oil in R134a systems?
A | NO, mineral oil as used in R12 systems will not mix with R134a and will lead to compressor seizure due to lack of lubrication. Most R134a systems use Polyalkylene glycol (PAG) oil, but some may use the alternative Ester oil.
Q | Can I use PAG oil in R12 systems?
A | NO, if PAG oil is used in an R12 system it will cause corrosion and long-term damage.
Q | Can I re-use a receiver/drier or an accumulator/drier?
A | Yes, providing the system has NOT been open to the atmosphere, had a major component failure or been subject to contamination, it will probably be serviceable. However if any major repairs or replacements are carried out to the refrigerant circuit, it is advisable to change the unit.
Q | Why do manufacturers advise the use of the air conditioning system all year round?
A | If the system is not used for a prolonged period of time, the seals in the compressor will become dry and leak. The AC system also de-humidifies the air, when used in conjunction with the heater's defrosting function it will extract excess moisture from the passenger compartment air resulting in more efficient demisting.
Q | Can I charge an air conditioning system with R12?
A | NO, from January 2001 the use of R12 has been prohibited. A proprietary 'replacement refrigerant' may be used or the system will need to be modified to allow the use of R134a. Many replacement refrigerants are available but they may have different pressure/temperature relationships and may make fault diagnosis difficult. Some replacement refrigerants may contain a percentage of liquid petroleum gas (LPG) and could be considered dangerous in an automotive application. The use of alternative refrigerants may affect the system performance and the manufacturer's warranty.
Q | Do I need to have qualifications to work on air conditioning systems?
A | NO, but it is strongly recommended that only properly trained and equipped personnel service and repair AC systems.
Q | Are there any special precautions to be observed when working on a vehicle with air conditioning?
A | Yes, the AC system is always under relatively high pressure and when operating, its components can be either very hot or very cold. Ensure that NO dismantling of the refrigerant circuit is undertaken unless it has been evacuated with special equipment. Never allow liquid refrigerant to touch skin as it will cause severe blistering (frostbite). Never drain refrigerant in areas with poor ventilation (such as inspection pits) as it will sink to the floor and spread out, with the risk of asphyxiation. Never smoke or use a naked flame in an area containing refrigerant gas, as high temperatures cause the gas to change into toxic substances.
Q | Can welding repairs be carried out in the vicinity of AC components?
A | Yes, but ensure that all components are shielded from excessive heat or direct flames.
Q | Can I evacuate the system by depressing the Schrader valve or loosening a fitting and releasing refrigerant to the atmosphere?
A | NO, although R134a, unlike R12, does not deplete ozone, all refrigerants damage the environment by adding to global warming. In most countries it is also an offence to 'deliberately discharge environmentally damaging refrigerant to the atmosphere'.


System pressure testing and diagnosis

System temperature checks

A simple but effective initial test is to check the temperature of the refrigerant system components and lines by touching them while the system is operating.

With the engine at operating temperature and the air conditioning system switched ON, the touch test should reveal the following:

  • A hot compressor.
  • A hot high pressure refrigerant line from the compressor outlet to the condenser.
  • A hot condenser on the inlet side.
  • A warm condenser on the outlet side.
  • A warm liquid line from the condenser to the evaporator (before the expansion valve or fixed orifice tube).
  • A cold evaporator outlet line.
  • A cold low pressure refrigerant line to compressor inlet.
If the results from the touch test deviate from the above list, suspect a restriction in the line or the component whose temperature is abnormal.

Confirm this by carrying out a pressure test.

System pressure testing

Measuring the pressures in the high and low pressure circuits is the best way to test an air conditioning system.
  • ALWAYS wear appropriate protective clothing, including gloves made of fluoroelastomer (leather or fabric gloves are not suitable when servicing any part of a refrigerant system).
  • ALWAYS wear eye protection, a leak of refrigerant can result in serious blistering (frostbite) of any unprotected skin and especially the eyes.
  • Identify which type of refrigerant is in the system.

NOTE: DO NOT presume that it has been charged with the correct refrigerant. The pressure-temperature relationship of other gasses will be different and may result in incorrect diagnosis. Refer to the chart at the end of this section.

  • Connect a manifold gauge set to the low and high pressure service connectors.
  • Carry out a pressure test without the engine running.

NOTE: The shaded area on the gauges denotes normal system pressures at an ambient air temperatures of 20-25°C.

  • Refer to the vehicle chapter for model specific data (where available).

Compressor clutch cycling time

To control the temperature of the evaporator the compressor clutch switches ON and OFF (cycles).

The rate of the cycle and the time that the compressor is operating is dependent on the pressure in the low pressure refrigerant line between the evaporator and the accumulator/drier.

As the evaporator temperature falls, the refrigerant starts to freeze and the flow through the evaporator is restricted.

This restriction results in a decrease in pressure at the evaporator outlet and the low pressure refrigerant (cycling) switch breaks the compressor circuit.

When the restriction thaws, the pressure increases and the cycling switch reconnects the compressor circuit.

The charts below show typical compressor clutch cycling times.

Compressor clutch cycling rate

Compressor clutch ON time

Compressor clutch OFF time

Refrigerant pressure-temperature relationship

The following chart shows the relationship between pressure and temperature for both R12 and R134a.

This information can be used to identify which refrigerant is in the system.

Pressure-temperature relationship
Temperature | R12 | R134a
-9°C | 1,27 bar | 1,06 bar
0°C | 2,07 bar | 1,88 bar
10°C | 3,22 bar | 3,1 bar
21°C | 4,84 bar | 4,87 bar
30°C | 6,33 bar | 6,55 bar
40°C | 8,59 bar | 9,17 bar

  • Connect a manifold gauge set to the low and high pressure service connectors.
  • Carry out the pressure test without the engine running.
  • Ensure that the high and low pressure gauges have equalised.
  • Insert an accurate thermometer into the lower fins of the condenser.
  • Check the temperature and low pressure gauge readings.
  • Compare the results with the chart.

Refrigerant circuit leak testing

Introduction

Many leaks are caused simply by vibration which causes refrigerant line connections to come loose, but refrigerant gas can also escape through the walls of the rubber hoses or at the drive shaft oil seal of the compressor.

NOTE: A leakage rate of between 50 and 100g of refrigerant per annum is normal.

In systems using R12 refrigerant, leaks can appear as an oily residue at the leakage point. The oily residue soon picks up dust and dirt particles from the surrounding air and appears greasy. Through time, this will build up and appear to be a heavy dirty grease deposit.

In systems using R134a refrigerant, the leaks can be more difficult to pinpoint as the synthetic refrigerant oil does not appear as an oily residue at the leakage point.

If an air conditioning system requires frequent charging, a leak test should be carried out. If the source of the refrigerant leak cannot be found through visual inspection, there are various other methods available.

Preparation for leak testing

The refrigerant circuit must be under pressure when performing a leak test.

If the air conditioning system is still operational there should be sufficient pressure in the circuit (at least 3,5 bar), to carry out an effective leak test. If the system charge is too low, the refrigerant will need to be recovered.

NOTE: If the system is empty, DO NOT charge it with refrigerant, carry out leak testing with oxygen free nitrogen (OFN).

Areas to check

  • All connections and pipes.
  • Compressor drive shaft.
  • Compressor service valves and sealing gaskets.
  • Condenser and evaporator matrix tube ends.
  • Receiver/drier or accumulator/drier connections.
  • Pressure switches.
  • Spring lock coupling connections.
  • Hoses.
Leak testing using oxygen free nitrogen (OFN)

Nitrogen has a molecular structure which makes it suitable to find most leaks, and in addition it is reasonably priced.

IMPORTANT:

  • DO NOT exceed the recommended pressures (use a pressure regulator).
  • DO NOT operate the air conditioning system with oxygen free nitrogen (OFN) in the refrigerant circuit.

Testing

  • If the air conditioning system is still operational, recover the refrigerant.
  • Connect the cylinder of OFN to a service connector, component or line, using a suitable adapter.
  • Open the cylinder valve to pressurise the circuit to approx. 10 to 15 bar (sufficient for leak testing purposes), and close the valve.
  • Using a commercially available bubble dye solution, spray the suspect areas to locate the leak.
  • Release the OFN from the circuit before attempting any repairs.

Leak testing using an electronic tester

Electronic leak detectors can be particularly useful in finding very small leaks. Different types of detectors are available for air conditioning, and most leak detectors can be used for both R12 and R134a.

Electronic leak testing can be difficult in drafty conditions. It may be necessary therefore to shelter the suspected leak area in order to prevent any draft blowing the refrigerant gas away.

If the surrounding air is contaminated with refrigerant gas, the leak tester will indicate gas all the time. It may therefore be necessary to ventilate an area to be leak tested.

  • Ensure that the air conditioning system is charged, a partial charge, approximately 225g is sufficient.
  • Pass the probe under the suspected leak area starting at the highest point in the circuit (refrigerant gas is heavier than air).
  • When a refrigerant leak is detected, the tester will emit an acoustic signal. The signal and intensity will change as the concentration of refrigerant gas increases or decreases.
  • If the leak cannot be detected with the air conditioning system switched off, start the engine and operate the system to build up system pressure.

NOTE: With a partially charged system it is advisable to run the air conditioning system for only a short period and not to exceed engine idle speed, as there may be insufficient oil to sustain lubrication of the compressor.

Leak testing with bubble dye solution

For basic leak detection, for instance in the area of connections, a bottle of commercially available bubble dye solution can be used. The bubble test method is a cheap form of leak testing and can assist in finding a variety of leaks, but it is not as reliable as other leak testing methods.

  • Ensure the refrigerant circuit is fully charged.
  • Swab the suspected area with the solution.
  • Check for bubbles which would indicate a leak.
  • If the leak cannot be detected with the air conditioning system switched off, start the engine and operate the system to build up system pressure.

NOTE: With a partially charged system it is advisable to run the air conditioning system for only a short period and not to exceed engine idle speed, as there may be insufficient oil to sustain lubrication of the compressor.

Leak testing with an ultraviolet lamp

To make leaking refrigerant visible under ultraviolet light, the refrigerant gas is mixed with a special dye which is added to the refrigerant. The highlighting effect produced by exposure to the light of an ultraviolet lamp makes it easy to locate refrigerant system leaks.

NOTE: Leak testing dye may have already been added to the system by the vehicle manufacturer.

The dye can be added to the refrigerant system during repair, or during the evacuation process, depending on the equipment available. Using an injector, dye can also be added to the low pressure (suction) side when the system is being charged.

The dye attaches itself to the refrigerant oil and even if the refrigerant is removed and the system is re-charged, the dye will still remain in the system.

  • Following the manufacturer's instructions add the amount of dye stated to the refrigerant system.
  • Start the engine and operate the air conditioning system.
  • Shine the ultraviolet lamp around the suspected areas.
  • The leak will be visible when the dye is exposed to the ultraviolet lamp.

CAUTION: Excessive ultraviolet light can damage eyesight. When using ultraviolet light always wear suitable safety goggles that screen out ultraviolet light.


Diesel Engine Management Systems Index

Diesel Engine management component descriptions Bosch Common rail Bosch in-line with EDC Bosch VE with EDC Bosch VP & VR Lucas DPC-N & DPI-N Lucas EPIC Toyota ECD - Denso Lucas Unit injector Safety precautions Tools & equipment Oscilloscope testing


Diesel Engine management component descriptions

Engine control module (ECM)

Electrical signals from engine and vehicle sensors are received and processed by the electronic circuits in the ECM.

Functions

Input signals are received from some or all of the following:

  • Accelerator position (APP) sensor.
  • Fuel lever position sensor.
  • Injector needle lift sensor.
  • Fuel temperature sensor.
  • Engine coolant temperature (ECT) sensor.
  • Intake air temperature (IAT) sensor.
  • Throttle position (TP) sensor.
  • Load sensor - mass air flow (MAF) sensor or manifold absolute pressure (MAP) sensor.
  • Vehicle speed (VSS) sensor.
  • Crankshaft position (CKP) sensor.
  • Engine speed (RPM) sensor.
  • Barometric pressure (BARO) sensor.
  • Immobilizer control module.

Outputs from the ECM control some or all of the following:

  • Injectors (electrical type only) - by controlling the length of time each injector remains open.
  • Fuel pump relay.
  • Fuel injection timing solenoid.
  • Fuel quantity adjuster.
  • Fuel pressure control solenoid.
  • Idle speed control system.
  • Exhaust gas recirculation system.
  • Turbocharger (TC) wastegate regulating valve.
  • Intake manifold air control solenoid.
  • Glow plug relay.
  • Glow plug warning lamp.
  • Self-diagnosis of faults, indicated by a malfunction indicator lamp (MIL) or check engine warning light on the instrument panel Fig. 1.
  • Emergency 'limp-home' programme, which substitutes an average value for certain sensors enabling the vehicle to be driven to a workshop for correction.

Fig. 1

Fuel supply system

Fuel pressure regulator - Common rail

Maintains an even supply pressure to the injectors.

Located in the high-pressure pump or the fuel rail.

Fig. 2

  1. Solenoid
  2. Spring
  3. Magnetic core
  4. Pressurised fuel inlet
  5. Ball valve
  6. Fuel outlet to common rail
  7. Fuel return
  8. Electrical connector

Operation

  • A ball-type valve separates the high-pressure fuel supply from the fuel return circuit. The valve remains closed under pressure from the high-pressure supply pump. When the solenoid is energised the magnetic core pushes the ball valve off its seat and allows the excess fuel to flow back to the tank.
  • The regulator is continually switched on and off (cycled) by the engine control module (ECM) and the delivery pressure is dependent on the duty cycle.

Fuel pressure regulator - unit injector

Located in the fuel supply housing on the cylinder head.

Fig. 3

  1. Pre-set regulator
  2. Circlip
  3. 'O' ring
  4. 'O' ring
  5. Regulator housing

Operation

  • The pressure regulator consists of a spring-loaded regulator that acts on a valve in the regulator housing.
  • When the fuel supply pressure exceeds the preset regulator pressure the valve opens and allows the excess fuel to flow back to the tank.

Injectors - mechanical type

Operation

  • Fuel is delivered to the high-pressure connection at the commencement of injection. The pressure acts against the injector spring pressure and lifts the needle from its seat. Atomized fuel is sprayed from the nozzle into the engine swirl or combustion chamber.

Fig. 4

  1. Fuel return connection
  2. Compression spring
  3. Body
  4. Cap nut/nozzle holder
  5. Nozzle needle
  6. Pintle
  7. Shim

Injectors - mechanical type, with needle lift sensor

Operation

  • This injector operates in the same way as in Fig. 4, but has an integral inductive sensor. At the commencement of injection the magnetic setting pin moves upwards and induces an alternating current into the sensor windings. This information, together with signals from the crankshaft position (CKP) sensor, is used by the engine control module (ECM) to measure the injection timing.

Fig. 5

  1. Setting pin
  2. Sensor winding
  3. Pressure pin
  4. Electrical connector

Injectors - electrical type

Operation

  • Electronically controlled injectors are supplied with a constant supply of fuel at high pressure. A solenoid operated ball-type valve separates the control chamber from the return circuit and ensures that the needle is held on its seat by the injector spring.
  • At the commencement of injection the solenoid is energised and the ball valve opens allowing the pressure in the control chamber to fall. The pressure in the pressure chamber acts against the injector spring and lifts the needle from its seat. Atomized fuel is sprayed from the nozzle into the engine combustion chamber.
  • To reduce the high current required to operate the injector, the engine control module (ECM) rapidly switches the solenoid during the opening duration.

Fig. 6

  1. Solenoid
  2. Fuel inlet
  3. Fuel return
  4. Electrical connector
  5. Control chamber
  6. Pressure chamber
  7. Injector needle
  8. Injector spring
  9. Control piston
  10. Ball valve
  11. 1Return nozzle

Unit injector

Operation

Fuel is supplied at a regulated pressure to the injector by an electrical fuel lift pump.

The solenoid is energised by the engine control module (ECM) and the spill port is closed. As the engine rotates, the engine camshaft pressurises the fuel in the unit injector. The pressure acts against the injector spring pressure and lifts the needle from its seat. Atomized fuel is sprayed from the nozzle into the engine combustion chamber. When the correct quantity of fuel has been injected the solenoid is de-energised, the spill port opens and allows excess fuel to return to the fuel tank.

The unit injectors use low resistance solenoids. To reduce the current being switched by the ECM, the voltage is rapidly switched during the injection period.

Fig. 7

  1. Fuel inlet
  2. Fuel return
  3. Injector
  4. Injector spring
  5. Pump plunger
  6. Pushrod
  7. Pushrod return spring
  8. Solenoid
  9. Solenoid valve

Load sensing

Mass air flow (MAF) sensor - hot-wire type

The MAF sensor has no moving parts and provides very little restriction to the air flow. It is fitted between the air filter and intake manifold.

Operation

  • The MAF sensor consists of a venturi with a resistance wire exposed to the incoming air.
  • An air temperature sensor or compensating wire is also exposed to the air flow.
  • The engine control module (ECM) senses changes in temperature caused by variations in air mass passing through the sensor body and increases or decreases the current flowing through the measuring wire.
  • An internal electronic circuit maintains the approximate temperature of the measuring wire at a constant 120°C above the intake air temperature.
  • As the mass of air passing the wire increases, so the current required to maintain the temperature also increases.
  • This increase in current is sensed by the ECM.

Fig. 8

  1. Protective mesh
  2. Resistance wire
  3. Intake air
  4. Compensating wire

Mass air flow (MAF) sensor - hot-film type

Similar to the hot-wire type, but with the measuring element incorporated in a ceramic plate.

Manifold absolute pressure (MAP) sensor

  • Fitted to the intake manifold or located in the engine bay and connected by vacuum hose.

Operation

  • The sensor consists of a diaphragm and piezo-electric circuit which varies the resistance in proportion to the pressure in the manifold.
  • The sensor has a 5 volt supply and sends a signal voltage to the ECM which is proportional to the manifold pressure.
  • The ECM uses the voltage signals from the MAP sensor to monitor turbocharger (TC) boost pressure and adjust fuel injection quantity and timing.

Fig. 9

  1. Full load
  2. Idling
  1. Vacuum connector
  2. Piezo-electric crystal
  3. Electrical connections

Idle speed control

Idle speed control (ISC) actuator

The ISC actuator is used in conjunction with mechanical fuel injection pumps and allows the idle speed to be controlled to suit all operating conditions.

Fig. 10

  1. Idle speed control (ISC) actuator
  2. Operating cable

Operation

  • The device consists of a reversible electric motor-driven geartrain, acting on an operating cable attached to the idle lever of the injection pump. The ECM monitors the engine speed and if necessary the motor is energised to either extend or shorten the cable.
  • The actuator also incorporates a switch to confirm its fully retracted position.

Sensors

Accelerator position (APP) sensor

The APP sensor can comprise of a potentiometer, idle and/or full load switch, or an electronic circuit.

The APP sensor can be mounted on the accelerator pedal bracket and operated directly, or operated by a cable and located in the engine bay.

Signals from the APP sensor are used by the ECM to determine the exact accelerator position.

Fig. 11

  1. Potentiometer and idle/full load switch
  2. Spring
  3. Shaft

Engine coolant/intake air temperature sensor

The engine coolant (ECT) sensor probe is immersed in coolant and changes its resistance in proportion to engine coolant temperature changes.

The intake air temperature (IAT) sensor probe is either incorporated in the mass air flow (MAF) sensor or is mounted in the air stream of the intake system. Its resistance changes in proportion to intake air temperature changes.

Fig. 12

  1. Electrical connections
  2. Housing
  3. NTC resistor

Operation

  • In most cases the sensor incorporates a negative temperature coefficient (NTC) resistor, which decreases in resistance as the temperature rises.

Engine speed and position sensors

Engine speed (RPM), crankshaft position (CKP) and camshaft position (CMP) sensors are of two basic types, inductive or Hall effect. CMP sensors may be mounted on the camshaft housing or cylinder head, CKP sensors may be mounted on the crankcase or bell housing.

Inductive type

These sensors contain a permanent magnet partly enclosed in a soft iron core and partly in a field winding.

The tip of the sensor is positioned close to the flywheel ring gear, a separate toothed trigger wheel, or a toothed wheel attached to the crankshaft pulley.

In certain applications the sensor(s) are incorporated in the fuel injection pump.

Fig. 13

  1. Soft iron core
  2. Field winding
  3. Permanent magnet
  4. Flywheel ring gear
  5. TDC pin

Operation

  • As the teeth or pins of the trigger wheel pass the sensor the magnetic field changes, inducing a voltage signal which is sent to the engine control module (ECM).

Hall-effect type

The Hall effect sensor consists of a semi-conductor material, through which a current flows, enclosed by a magnetic field at right angles to the current flow.

Fig. 14

  1. Sensor
  2. Electrical connector

Operation

  • The trigger wheel Fig. 15 [1] rotates allowing a magnetic field to pass between the sensor's magnet poles when aligned Fig. 15 [2].
  • This magnetic field is used to control the flow of current through a semiconductor which then operates an integral control circuit.
  • The sensor is supplied with a control current from the ECM which is switched to earth as the sensor operates generating a square wave signal.

Fig. 15

Throttle position (TP) sensor

The throttle position sensor is a variable resistance (potentiometer) connected to the throttle valve shaft.

Fig. 16

  1. Throttle butterfly shaft
  2. Wiper arm
  3. Resistance tracks

Operation

  • It is supplied with a reference voltage and the output signal voltage is used by the ECM to interpret the exact throttle position.

Valves

Exhaust gas recirculation (EGR) valve

To reduce the oxides of nitrogen emitted by the exhaust, a proportion of the exhaust gas can be returned to the inlet manifold when operating conditions allow.

Operation

  • The exhaust gas recirculation valve is operated by a vacuum-controlled solenoid-operated modulator valve. The duty cycle is varied according to the operating conditions to control the flow of exhaust gas into the inlet manifold.

Fig. 17

Turbocharger (TC) wastegate regulating valve

The turbocharger boost pressure can be controlled by the engine control module (ECM) with a solenoid-operated modulator valve. Signals from the manifold absolute pressure (MAP) sensor are monitored and the maximum boost pressure controlled.

Fig. 18

Operation

  • The turbocharger wastegate actuator is operated by a vacuum-controlled solenoid-operated modulator valve (turbocharger wastegate regulating valve). The duty cycle is varied according to the operating conditions to control the maximum boost pressure.

Cold starting equipment

Glow plugs

To enable the engine to be started in low temperatures glow plugs are used to raise the temperature in the combustion chambers (pre-heating). The glow plugs can also be used during cold running to reduce harmful exhaust emissions, blue smoke and knocking (post-heating).

Although the pre-heating and post-heating can be controlled by a dedicated glow plug control unit, it is more common on modern systems to be controlled by the engine control module (ECM).

Fig. 19

  1. Terminal
  2. Insulator
  3. Casing
  4. Element seal
  5. Heater and control coils
  6. Glow tube
  7. Powder

Operation

  • The glow plug comprises heater and control coils embedded in magnesium-oxide powder. When voltage is applied to the terminal current flows through the heating elements and the temperature rapidly rises. Current also flows through the control coils and this produces heat but at a slower rate. The resistance rises as the temperature increases at the tip to approximately 1200°C.
  • The glow plugs can remain energised after starting (post-heating), when cold until the engine coolant temperature reaches a predetermined point, or for a maximum time in the region of 180 seconds.


Bosch Common rail

Fuel injection system components

Fig. 1

  1. 3rd piston cut-off solenoid
  2. Accelerator position (APP) sensor
  3. Battery
  4. Crankshaft position (CKP) sensor
  5. Engine control module (ECM)
  6. Engine coolant temperature (ECT) sensor
  7. Exhaust gas recirculation (EGR) solenoid
  8. Fuel cooler
  9. Fuel filter
  10. Fuel heater
  11. Fuel injector
  12. Fuel lift pump (electrical)
  13. Fuel lift pump (mechanical)
  14. Fuel lift pump relay
  15. Fuel pressure control solenoid
  16. Fuel pressure sensor
  17. Fuel rail
  18. Fuel shut-off solenoid
  19. Fuel tank
  20. Fuel temperature sensor
  21. Glow plug relay
  22. Glow plug
  23. Glow plug warning lamp
  24. High-pressure fuel pump
  25. Ignition switch
  26. Intake air temperature (IAT) sensor
  27. Malfunction indicator lamp (MIL)
  28. Manifold absolute pressure (MAP) sensor
  29. Mass air flow (MAF) sensor
  30. Turbocharger (TC) wastegate regulating valve
  31. Vehicle speed sensor (VSS)

System operation

The Bosch Common rail system uses the latest diesel injection technology.

The fuel injection quantity and timing together with control of exhaust emissions are electronically controlled.

Signals from the accelerator pedal position (APP) sensor [2] together with information from other engine and vehicle sensors are transmitted to the engine control module (ECM) [5].

An electrical fuel pump [12] or an engine driven mechanical pump [13] or both supply fuel at low pressure to the high-pressure pump.

The high-pressure fuel supply is provided by an engine-driven mechanical high-pressure pump [24]. The pump comprises three pumping elements driven by an eccentric shaft.

The pressure is controlled by a fuel pressure control solenoid [15] mounted on the rear of the pump.

On some applications a 3rd piston cut-off solenoid [1] is used to enable the pump to operate only two pumping elements, resulting in less engine power being absorbed at low engine loads.

High-pressure fuel from the high-pressure fuel pump is delivered to the fuel rail [17] where it is distributed to the injectors [11]. Operating conditions in the fuel rail are monitored by the fuel temperature sensor [20] and fuel pressure sensor [16].

The fuel injectors are electrically operated by the ECM [5] and use low-resistance solenoids. To reduce the current being switched by the ECM, the voltage is rapidly switched during the injection period.

The fuel is injected in two stages (or three where exhaust emission standards are higher), firstly the PILOT injection to precondition the combustion chamber, followed very shortly afterwards by the MAIN injection. Some applications where higher exhaust emission standards are required use a third period of injection called POST injection, where fuel is injected into the exhaust stroke and reburnt via the exhaust gas recirculation (EGR) system.


Bosch in-line with EDC

Fuel injection system components

Fig. 1

  1. Accelerator position (APP) sensor
  2. Battery
  3. Crankshaft position (CKP) sensor
  4. Engine control module (ECM)
  5. Engine coolant temperature (ECT) sensor
  6. Exhaust gas recirculation (EGR) solenoid
  7. Fuel filter
  8. Fuel injection pump
  9. Fuel injector
  10. Fuel tank
  11. Glow plug relay
  12. Glow plug
  13. Glow plug warning lamp
  14. Ignition switch
  15. Intake air temperature (IAT) sensor
  16. Malfunction indicator lamp (MIL)
  17. Manifold absolute pressure (MAP) sensor
  18. Turbocharger (TC) wastegate regulating valve
  19. Vehicle speed sensor (VSS)

Injection pump operation

Fig. 2

  1. Low-pressure plunger-type pump
  2. High-pressure pump plunger
  3. Delivery valve holder
  4. Fuel quantity adjuster
  5. Control rod
  6. Fuel shut-off solenoid

The Bosch in-line fuel injection pump has been used by many vehicle manufacturers in cars and commercial vehicles for many years.

The pump is driven at engine camshaft speed via gears or chain.

Fuel is supplied to the injection pump by an integral low-pressure plunger-type pump [1].

Excess fuel is allowed to drain from the injection pump via the overflow restriction in the pump return connection.

Fuel is pressurised by the high-pressure pump plunger [2] and delivered to the injectors at high pressure via the delivery valve holder [3].

Unlike the earlier version, the Electronic Diesel Control (EDC) in-line pump uses computer technology to control fuel injection quantity.

The fuel injection quantity is controlled by an electrical actuator (fuel quantity adjuster) [4] acting on the control rod [5], and its position is monitored by an integral quantity adjuster position sensor. A crankshaft position (CKP) sensor is used to monitor engine speed which allows closed-loop control.

The fuel injection timing is controlled by a mechanical unit integral to the fuel injection pump drive gear or sprocket.

Signals from the accelerator pedal position (APP) sensor together with information from other engine and vehicle sensors are used by the engine control module (ECM) to calculate the fuel injection quantity.

When the ignition is in the OFF position (or if the vehicle immobilizer is not deactivated), the fuel quantity adjuster will return to the position of zero fuel quantity and the engine will stop.

To ensure that the engine can be stopped in the event of a fault in the control system or actuator, a fuel shut-off solenoid [6] is retained.


Bosch Common rail

Bosch VE with EDC

Fuel injection system components

Fig. 1

  1. Accelerator position (APP) sensor
  2. Battery
  3. Crankshaft position (CKP) sensor
  4. Engine control module (ECM)
  5. Engine coolant temperature (ECT) sensor
  6. Exhaust gas recirculation (EGR) solenoid
  7. Fuel filter
  8. Fuel injection pump
  9. Fuel injector (with needle lift sensor)
  10. Fuel tank
  11. Glow plug relay
  12. Glow plug
  13. Glow plug warning lamp
  14. Ignition switch
  15. Malfunction indicator lamp (MIL)
  16. Mass air flow (MAF) sensor
  17. Vehicle speed sensor (VSS)

Injection pump operation

Fig. 2

  1. Vane-type low-pressure pump
  2. Return connection
  3. Distributor plunger
  4. Distributor head
  5. Fuel quantity adjuster
  6. Control collar
  7. Fuel quantity adjuster position sensor
  8. Fuel injection timing solenoid
  9. Timing actuator
  10. Roller ring
  11. Fuel shut-off solenoid
  12. Fuel temperature sensor

The Bosch VE rotary fuel injection pump has been used by many vehicle manufacturers in cars and light commercial vehicles for many years.

The pump is driven at engine camshaft speed either via gears, chain or toothed belt.

Fuel is drawn into the injection pump by a vane-type low-pressure pump [1] and the pump internal pressure is regulated by a pressure control valve.

Excess fuel is allowed to drain from the injection pump via the overflow restriction in the return connection [2].

Fuel is pressurised by the distributor plunger [3] and delivered to the injectors at high pressure via the distributor head [4].

Unlike the earlier version, the Electronic Diesel Control (EDC) VE pump uses computer technology to control fuel injection quantity and timing.

The fuel injection quantity is controlled by an electrical actuator (fuel quantity adjuster) [5] acting on the control collar [6], and its position is monitored by the quantity adjuster position sensor [7] which allows closed-loop control.

The fuel injection timing is controlled by the fuel injection timing solenoid [8], which regulates the control pressure acting on the timing actuator [9]. The timing actuator varies the position of the roller ring [10]. A crankshaft position (CKP) sensor and an injector needle lift sensor are used to monitor the actual injection timing which allows closed-loop control.

Signals from the accelerator pedal position (APP) sensor together with information from other engine and vehicle sensors are used by the engine control module (ECM) to calculate the fuel quantity and injection timing.

When the ignition is in the OFF position (or if the vehicle immobilizer is not deactivated), the fuel quantity adjuster will return to the position of zero fuel quantity and the engine will stop.

To ensure that the engine can be stopped in the event of a fault in the control system or actuator, a fuel shut-off solenoid [11] is retained.


Bosch VP & VR

Fuel injection system components

Fig. 1

  1. Accelerator position (APP) sensor
  2. Battery
  3. Crankshaft position (CKP) sensor
  4. Engine control module (ECM)
  5. Engine coolant temperature (ECT) sensor
  6. Exhaust gas recirculation (EGR) solenoid
  7. Fuel filter
  8. Fuel injection pump
  9. Fuel injector (with needle lift sensor)
  10. Fuel lift pump
  11. Fuel lift pump relay
  12. Fuel tank
  13. Glow plug relay
  14. Glow plug
  15. Glow plug warning lamp
  16. Ignition switch
  17. Intake air temperature (IAT) sensor
  18. Malfunction indicator lamp (MIL)
  19. Manifold absolute pressure (MAP) sensor
  20. Mass air flow (MAF) sensor
  21. Turbocharger (TC) wastegate regulating valve
  22. Vehicle speed sensor (VSS)

Injection pump operation

Fig. 2

  1. Vane-type low-pressure pump
  2. High-pressure plungers
  3. Distributor head
  4. Fuel injection pump control module
  5. Fuel quantity adjuster
  6. Fuel injection timing solenoid
  7. Timing actuator
  8. Cam ring
  9. Injection pump position sensor

Fig. 2

  1. Vane-type low-pressure pump
  2. Distributor plunger
  3. Distributor head
  4. Fuel injection pump control module
  5. Fuel quantity adjuster
  6. Fuel injection timing solenoid
  7. Timing actuator
  8. Cam ring
  9. Injection pump position sensor

This Bosch rotary fuel injection pump is available with either radial (VR-type pump) Fig. 2 or axial (VP-type pump) Fig. 3 high-pressure pumping elements.

Both pumps uses computer technology to control fuel injection quantity and timing.

The pump is driven at engine camshaft speed either via gears, chain or toothed belt. NOTE: Damage may occur to the injection pump if it is operated without an adequate fuel supply. Refer to the manufacturers instructions when changing fuel filters or opening the fuel lines.

Fuel is drawn into the injection pump by a vane-type low-pressure pump Fig. 2 [1] & Fig. 3 [1] and the pump internal pressure is regulated by a pressure control valve.

Excess fuel is allowed to drain from the injection pump via the overflow restriction in the return connection.

In the radial-type (VR) pump Fig. 2, fuel is pressurised by the two high pressure plungers Fig. 2 [2] and delivered to the injectors at high pressure via the distributor head Fig. 2 [3].

In the axial-type (VP) pump Fig. 3, fuel is pressurised by the distributor plunger Fig. 3 [2] and delivered to the injectors at high-pressure via the distributor head Fig. 3 [3].

Signals from the accelerator pedal position (APP) sensor together with information from other engine and vehicle sensors are transmitted to the engine control module (ECM). Signals from sensors mounted in the injection pump are transmitted to the fuel injection pump control module Fig. 2 [4] & Fig. 3 [4] mounted on the injection pump. The two control modules communicate by a CAN data bus system enabling the calculation of the fuel quantity and injection timing.

The fuel injection quantity is controlled by a solenoid (fuel quantity adjuster) Fig. 2 [5] & Fig. 3 [5]. The fuel quantity adjuster is energised during the pressure stroke until the calculated quantity of fuel has been injected. The fuel quantity adjuster is then de-energised allowing excess fuel to be diverted to the return circuit.

The fuel injection timing is controlled by the fuel injection timing solenoid Fig. 2 [6] & Fig. 3 [6], which regulates the control pressure acting on the timing actuator Fig. 2 [7] & Fig. 3 [7]. The timing actuator varies the position of the cam ring Fig. 2 [8] & Fig. 3 [8]. An injection pump position sensor Fig. 2 [9] & Fig. 3 [9] mounted in the injection pump together with a crankshaft position (CKP) sensor and an injector needle lift sensor are used to monitor the actual injection timing which allows closed-loop control.

When the ignition is in the OFF position (or if the vehicle immobilizer is not deactivated), the fuel quantity adjuster will remain de-energised (zero fuel quantity) and the engine will stop


Lucas DPC-N & DPI-N

Fuel injection system components

Fig. 1

  1. Battery
  2. Crankshaft position (CKP) sensor
  3. Engine control module (ECM)
  4. Engine coolant temperature (ECT) sensor
  5. Exhaust gas recirculation (EGR) solenoid
  6. Fuel filter
  7. Fuel injection pump
  8. Fuel injector (with needle lift sensor)
  9. Fuel tank
  10. Glow plug relay
  11. Glow plug
  12. Glow plug warning lamp
  13. Ignition switch
  14. Intake air temperature (IAT) sensor
  15. Malfunction indicator lamp (MIL)
  16. Mass air flow (MAF) sensor
  17. Turbocharger (TC) wastegate regulating valve
  18. Vehicle speed sensor (VSS)

Injection pump operation

Fig. 2

  1. Vane-type low-pressure pump
  2. High-pressure plungers
  3. Distributor head
  4. Fuel injection timing solenoid
  5. Timing actuator
  6. Cam ring
  7. Fuel lever position sensor
  8. Fuel shut-off solenoid

The Lucas DPC rotary fuel injection pump has been used by many vehicle manufacturers in cars and light commercial vehicles for many years.

The pump is driven at engine camshaft speed either via gears, chain or toothed belt.

Fuel is drawn into the injection pump by a vane-type low-pressure pump [1] and the pump internal pressure is regulated by a pressure control valve.

Excess fuel is allowed to drain from the injection pump via the overflow restriction in the return connection.

Fuel is pressurised by the two high-pressure plungers [2] and delivered to the injectors at high pressure via the distributor head [3].

The fuel injection quantity is controlled by a mechanical governor.

Unlike the earlier DPC injection pump, the DPC-N and DPI-N (N = Numeric) pumps use computer technology to control fuel injection timing.

The fuel injection timing is controlled by the fuel injection timing solenoid [4], which regulates the control pressure acting on the timing actuator [5]. The timing actuator varies the position of the cam ring [6]. A crankshaft position (CKP) sensor and an injector needle lift sensor are used to monitor the actual injection timing which allows closed-loop control.

Signals from the fuel lever position sensor [7], together with information from other engine and vehicle sensors are used by the engine control module (ECM) to calculate the fuel injection timing.

When the ignition is switched OFF (or if the vehicle immobilizer is not deactivated), the fuel shut-off solenoid [8] will return to the closed position and the engine will stop.


Lucas EPIC

Fuel injection system components

Fig. 1

  1. Accelerator position (APP) sensor
  2. Battery
  3. Crankshaft position (CKP) sensor
  4. Engine control module (ECM)
  5. Engine coolant temperature (ECT) sensor
  6. Exhaust gas recirculation (EGR) solenoid
  7. Fuel filter
  8. Fuel injection pump
  9. Fuel injector (with needle lift sensor)
  10. Fuel tank
  11. Glow plug relay
  12. Glow plug
  13. Glow plug warning lamp
  14. Ignition switch
  15. Intake air temperature (IAT) sensor
  16. Malfunction indicator lamp (MIL)
  17. Manifold absolute pressure (MAP) sensor
  18. Vehicle speed sensor (VSS)

Injection pump operation

Fig. 2

  1. Vane-type low-pressure pump
  2. Pressure control valve
  3. Fuel return connection
  4. Distributor plungers
  5. Distributor head
  6. Fuel quantity adjusters
  7. Rotor cavity
  8. Rotor
  9. Injection pump rotor position sensor
  10. Injection timing solenoid
  11. Timing actuator
  12. Cam ring
  13. Injection pump cam ring position sensor
  14. Injection pump position sensor
  15. Fuel shut-off solenoid

The Lucas EPIC is a fully electronically controlled rotary fuel injection pump. It is used by many vehicle manufacturers in cars and light commercial vehicles.

The pump is driven at engine camshaft speed either via gears, chain or toothed belt.

Fuel is drawn into the injection pump by a vane-type low-pressure pump [1] and the pump internal pressure is regulated by a pressure control valve [2].

Excess fuel is allowed to drain from the injection pump via the fuel return connection [3].

Fuel is pressurised by the distributor plungers [4] and delivered to the injectors at high pressure via the distributor head [5].

The fuel injection quantity is controlled by two solenoids (fuel quantity adjusters) [6]. The solenoids act on valves controlling the flow of fuel into (feed valve) and out of (drain valve) the cavity at the end of the rotor [7]. When the feed valve is opened the rotor [8] is forced against spring pressure and moves towards the front of the pump (minimum fuel position). When the drain valve is opened the spring forces the rotor towards the rear of the pump (maximum fuel position). The solenoids are continually switched to control fuel injection quantity.

Closed-loop control of the rotor position is maintained with the use of a rotor position sensor mounted at the rear of the pump [9].

The fuel injection timing is controlled by the fuel injection timing solenoid [10]. The solenoid acts on a valve controlling the flow of fuel to the timing actuator [11]. The timing actuator varies the position of the cam ring [12].

Closed-loop control of the cam ring position is maintained with the use of an injection pump cam ring position sensor mounted on the side of the pump [13].

A crankshaft position (CKP) sensor, and either an injector needle lift sensor or an injection pump position sensor [14] are used to monitor the actual injection timing.

Signals from the accelerator pedal position (APP) sensor together with information from other engine and vehicle sensors are used by the engine control module (ECM) to calculate the fuel quantity and injection timing.

When the ignition is in the OFF position (or if the vehicle immobilizer is not deactivated), the fuel shut-off solenoid [15] will be de-energised and the engine will stop.


Toyota ECD - Denso

Fuel injection system components

Fig. 1

  1. Accelerator position (APP) sensor
  2. Battery
  3. Crankshaft position (CKP) sensor
  4. Engine control module (ECM)
  5. Engine coolant temperature (ECT) sensor
  6. Exhaust gas recirculation (EGR) solenoid
  7. Fuel filter
  8. Fuel injection pump
  9. Fuel injector
  10. Fuel tank
  11. Glow plug relay
  12. Glow plug
  13. Glow plug warning lamp
  14. Ignition switch
  15. Intake air temperature (IAT) sensor
  16. Malfunction indicator lamp (MIL)
  17. Manifold absolute pressure (MAP) sensor
  18. Turbocharger (TC) wastegate regulating valve
  19. Vehicle speed sensor (VSS)

Injection pump operation

Fig. 2

  1. Inlet connection
  2. Pressure control valve
  3. Return overflow valve
  4. Distributor head
  5. Fuel quantity adjuster
  6. Fuel injection timing solenoid
  7. Timing actuator
  8. Injection pump position sensor
  9. Module coding plug
  10. Fuel temperature sensor

The Denso rotary fuel injection pump is of the axial type and has been used by many Asian vehicle manufacturers in cars and light commercial vehicles for many years.

The pump is driven at engine camshaft speed either via gears, chain or toothed belt.

Fuel is drawn into the injection pump by a vane-type low-pressure pump at the inlet connection [1], and the pump internal pressure is regulated by a pressure control valve [2].

Excess fuel is allowed to drain from the injection pump via the return overflow valve in the return connection [3].

Fuel is pressurised by the distributor plunger and delivered to the injectors at high pressure via the distributor head [4].

Unlike the earlier version, the electronic control diesel (ECD) pump uses computer technology to control fuel injection quantity and timing.

The fuel injection quantity is controlled by an electrical solenoid (fuel quantity adjuster) [5] which is continually switched by the engine control module (ECM).

The fuel injection timing is controlled by the fuel injection timing solenoid [6], which regulates the control pressure acting on the timing actuator [7]. The timing actuator varies the position of the roller ring. An injection pump position sensor [8], (which also gives pump speed information), together with a crankshaft position (CKP) sensor are used to monitor the actual injection timing which allows closed-loop control.

A module coding plug [9] is used to correct manufacturing variations between injection pumps.

Signals from the accelerator pedal position (APP) sensor together with information from other engine and vehicle sensors are used by the ECM to calculate the fuel quantity and injection timing.

When the ignition is in the OFF position (or if the vehicle immobilizer is not deactivated), the fuel quantity adjuster will return to the position of zero fuel quantity and the engine will stop.


Bosch VP & VR

Lucas Unit injector

Fuel injection system components

Fig. 1

  1. Accelerator position (APP) sensor
  2. Battery
  3. Crankshaft position (CKP) sensor
  4. Engine control module (ECM)
  5. Engine control relay
  6. Engine coolant temperature (ECT) sensor
  7. Exhaust gas recirculation (EGR) solenoid
  8. Fuel cooler
  9. Fuel filter
  10. Unit injector
  11. Fuel lift pump
  12. Fuel lift pump relay
  13. Fuel pressure regulator
  14. Fuel tank
  15. Fuel temperature sensor
  16. Glow plug relay
  17. Glow plug
  18. Glow plug warning lamp
  19. Ignition switch
  20. Intake air temperature (IAT) sensor
  21. Malfunction indicator lamp (MIL)
  22. Manifold absolute pressure (MAP) sensor
  23. Mass air flow (MAF) sensor
  24. Turbocharger (TC) wastegate regulating valve
  25. Vehicle speed sensor (VSS)

System operation

Fig. 2

  1. Fuel inlet
  2. Fuel return
  3. Injector
  4. Injector spring
  5. Pump plunger
  6. Pushrod
  7. Pushrod return spring
  8. Solenoid
  9. Solenoid valve

The unit injector system has been used on diesel engines for many years. The injectors are mechanically operated and until recently the system has been used mainly for large commercial vehicles, marine applications and stationary engines.

The latest systems, now being used for smaller engines, use computer technology to control the injectors Fig. 2 .

Signals from the accelerator pedal position (APP) sensor Fig. 1 [1] together with information from other engine and vehicle sensors are transmitted to the engine control module (ECM) Fig. 1 [4].

A two-stage electrical fuel lift pump Fig. 1 [11] supplies fuel via a fuel filter Fig. 1 [9] to the fuel pressure regulator Fig. 1 [13]. Fuel at a regulated pressure (approximately 4 bar) is supplied to the unit injector and the excess is allowed to return to the fuel tank after its temperature is lowered by the fuel cooler Fig. 1 [8].

As the engine rotates, the engine camshaft pressurises the fuel in the unit injector to approximately 1500 bar.

The unit injectors Fig. 2 are electrically operated by the engine ECM Fig. 1 [4] and use low resistance solenoids. To reduce the current being switched by the ECM, the voltage is rapidly switched during the injection period.

The pump plunger is depressed by the camshaft, and at a point determined by the ECM the solenoid valve is energised closing the spill port. Pressure rises until the injector needle is forced from its seat and injection takes place.

After the injection period the solenoid valve is de-energised and the rotation of the camshaft releases the pump plunger allowing cool fuel to replenish the injector in readiness for the next cycle.


Safety precautions

Airbags (Supplementary Restraint System - SRS)

Many of the models covered by this manual are fitted with airbags as standard equipment. When working on a vehicle fitted with such a system, extreme caution must be taken to avoid accidental firing of the airbag, which could result in personal injury.

Unauthorised repairs to the system could render it inoperative, or cause it to inflate accidentally.

NOTE: All related wiring may be encased in a yellow outer covering.

When the engine is started the AIRBAG warning lamp should go out after approximately 5-10 seconds. If not this indicates a fault in the system. Refer to the Autodata manual Airbags & seat belt pretentioners.

  • NEVER attempt to test the system using a multi-meter.
  • NEVER tamper with or disconnect the airbag wiring harness.
  • NEVER make extra connections to any part of the system wiring harness or terminals.
  • ALWAYS ensure that the airbag wiring harness has not been trapped or damaged in any way when working on adjacent components or systems.

Electrical

  • ALWAYS ensure that the battery is properly connected before attempting to start the engine.
  • DO NOT attempt to start the engine using a source in excess of 12 volts, such as a fast charger (16 volts) or by connecting two batteries in series (24 volts). ALWAYS disconnect the battery before charging it.
  • DO NOT disconnect the battery while the engine is running.
  • DO NOT connect the battery with reverse polarity.
  • DO NOT connect or disconnect the engine control module (ECM), or any other component of the diesel injection system while the ignition is switched ON.
  • DO NOT disconnect ECM multi-plug within 30 seconds of switching ignition OFF.
  • DO NOT connect or disconnect multi-meters, voltmeters, ammeters or ohmmeters with the ignition switched ON.
  • DO NOT reverse the polarity of the fuel pump.
  • ALWAYS ensure that all electrical connections are in good condition and making good contact, PARTICULARLY the ECM connector.
  • ALWAYS disconnect the ECM, fuel pump relay/fuse before carrying out a compression test.
  • DO NOT flash a wire or circuit to ground to check that continuity exists.
  • ALWAYS ensure that any replacement electrical parts are correct for the application in question. Many units share common external features, but differ internally.

Mechanical

CAUTION: Do not connect pressure testing equipment to the fuel rail or other high pressure fuel system components of a common rail diesel injection system.

  • DO NOT attempt to slacken any high pressure fuel pipe connections with the ignition on or the engine running.
  • AVOID the risk of fire - NEVER work on the diesel injection system when SMOKING or close to a NAKED FLAME.
  • ALWAYS keep a fire extinguisher close at hand when working on the diesel injection system.
  • ALWAYS ensure that any replacement fuel system parts are correct for the application in question. Many units share common external features, but differ internally.


Tools & equipment

General recommendations

The majority of electrical tests described in this manual require the use of a digital multi-meter.

Many suitable instruments are available, with a wide range of prices and specifications, as described below.

Certain other tools, such as a breakout box or a digital oscilloscope (see separate section), will be necessary, or desirable to make best use of this manual.

Breakout box

  • Whenever possible a breakout box should be used for testing pinout signals.
  • A breakout box [1] is a means of connecting test equipment to the ECM pins, without the need to probe into the back of the harness multi-plug. It is connected by an adaptor lead [2], between the ECM [3] and the car's wiring harness [4].
  • The pin connections are laid out in rows in numerical order and have large connecting sockets, enabling test leads to be securely plugged into a circuit, and avoiding the possibility of connecting to the incorrect pin, due to miscounting.
  • The possibility of damaging components or wiring, due to shorting live pins to ground or to other components, is also much reduced.
  • The limiting factor is the range of adaptor leads. Several equipment manufacturers produce breakout boxes, but none are able to supply a complete range of leads to cover all the models included in this manual.

Fig 1 - Breakout Box

ECM harness multi-plug testing

  • If a breakout box and suitable adaptor leads are not available, testing must be carried out at the wire side of the ECM harness multi-plug Fig. 2.
  • To access the terminals the protective cover must be removed from the plug. Many different types of plug are used for engine management wiring harnesses and two examples are shown in Fig. 3 and Fig. 4.
  • Use the appropriate ECM harness multi-plug - wire side diagram and identify the pin(s) to be tested.
  • Use only very fine test probes to access the connections and measure the signal between the pin and earth Fig. 2 [1] , or between two ECM pins Fig. 2 [2], where a second pin number is given in brackets after the first number.

Fig 2 - ECM harness multi-plug testing

Fig 3 - ECM harness multi-plug testing

Fig 4 - ECM harness multi-plug testing

Multi-meters

  • A high impedance (10 K W/volt minimum) multi-meter that includes a 0-20 V voltage scale and a low (0-200W) and high (0-20 KW) range ohm scale is recommended for measuring the voltage and resistance of the system components.
  • Analogue Fig. 5 and digital Fig. 6 electrical multi-test meters are available in a wide range of prices and specifications. In view of the fact that the instrument will be used in the harsh environment of the workshop, the extra expense of a shock-proof digital type will be a good investment.
  • In addition to the usual volts, ohms and milliamp scales, features such as the facility to read frequency (Hz) and duty cycle (%), will also be useful.

Fig 5 - Analogue

Fig 6 - Digital

Using multi-meters

Voltage checking

  • Connect negative test lead to a good earth, or direct to the negative battery terminal.
  • Observe conditions for test, e.g. ignition OFF, ignition ON etc.
  • If the meter does not automatically select the appropriate voltage range, ensure correct meter scale selected, e.g. 0-12 volts.
  • Connect positive test lead to ECM pin being tested.

Continuity checking

  • Ensure that battery supply voltage is not present at test terminals.
  • Select appropriate resistance scale.
  • Connect meter leads together and check zero reading (analogue meters only).

    NOTE: If unable to zero meter, this usually indicates that the internal battery requires replacement.

  • Connect ohmmeter leads to each end of component or wire to be tested.
  • Read off resistance.

NOTE: If meter indicates zero Fig. 7 this indicates continuity between the two test points. If the meter indicates infinity Fig. 8, this indicates an open circuit (broken wire, burnt out component etc.) between the two test points.

Fig 7 - Continuity indicated

Fig 8 - Open circuit indicated

Diode checking

  • To check a diode connect the meter negative lead to the positive side of the diode and the positive lead to the negative side of the diode. The meter should indicate continuity Fig. 9.
  • When the meter connections are reversed the meter should indicate an open circuit Fig. 10.
  • If continuity is indicated in each direction, the diode is faulty.

Fig 9 - Continuity indicated

Fig 10 - Open circuit indicated

Vacuum pump

A hand operated vacuum pump, with gauge, will be necessary for testing certain components, such as manifold absolute pressure (MAP) sensors.

Several types are available and are usually supplied with a connecting hose and a selection of adaptors Fig. 11.

Fig 11 - Vacuum Pump

Memory savers

With the increasing number of electronic devices incorporating a memory, whenever the battery is disconnected inconvenience is caused by the loss of such information as radio security codes and station settings, clock settings and ECM memories.

This situation can be avoided by the use of an alternative power source such as the memory savers marketed by several of the leading test equipment manufacturers.


Oscilloscope testing

Why use an oscilloscope?

  • Digital multi-meters are entirely satisfactory for checking circuits in a static condition and for instances where any change in reading is a gradual one, but for dynamic checking (with the engine running) and the diagnosis of intermittent faults, the oscilloscope is a very powerful workshop tool.
  • Unlike older analogue oscilloscopes dedicated to HT ignition testing, a modern digital oscilloscope has a variable voltage scale, enabling low voltages (typically 0-5 V or 0-12 V) to be displayed and also an adjustable time scale, enabling any wave form to be displayed in the ideal manner.
  • Most oscilloscopes designed for automotive use can be hand-held and are therefore ideal for use in the workshop. They can also be used inside the car, while the vehicle is driven, to capture dynamic data.
  • Usually it is possible to store wave forms and associated data in an internal memory and then print it out or download it onto a PC, enabling the scope patterns to be studied in detail.
  • The oscilloscope display can show the amplitude, frequency, pulse width, shape and pattern of the signal received, by effectively drawing a graph of voltage (vertically) and time (horizontally).
  • It is easy to connect (normally just two leads) and the speed of sampling can be far in excess of even the best of digital multi-meters.
  • This fast response time enables diagnosis of intermittent problems and also enables the effect of disturbing parts of the system to be observed. When necessary, the response time can be slow enough to display signals such as the accelerator position (APP)sensor.
  • Once the cause of a problem has been diagnosed and rectified, the repair can be verified by retesting with the oscilloscope.
  • Currently available oscilloscopes are easy to connect and use, enabling a trace to be displayed on the screen without any specialist knowledge or experience. The interpretation of this trace can be greatly assisted by reference to the typical wave forms illustrated in this topic.

Oscilloscope scales

  • To enable testing of the circuit's operating voltage and frequency, each oscilloscope wave form reference in the Pin Data tables has been assigned a voltage and time scale.
  • When testing the circuit, set the oscilloscope to given voltage and time scale.
  • Ensure that the oscilloscope is set to either DC (direct current) or AC (alternating current) as appropriate, and that the trigger level is within the voltage range quoted.

    NOTE: Some circuits may require very fine adjustment of the oscilloscope to enable the pattern to be viewed.

  • Refer to the wave form number [image] and overlay the voltage and time scale given.
  • For the example:

    Typical value
    2 V 50 ms per division

    Fig. 1 - Voltage and time scale

  • In this example the circuit is operating at approximately 4 volts, switching at approximately 50 ms intervals.
  • Voltage scales used for the patterns in this publication range from 5 mV (mv = millivolt, 1/1000 V) to 20 V per division.
  • Time scale units used for the patterns in this publication are s = seconds, ms = milliseconds (one thousandth of a second) or µs = microsecond (one millionth of a second).

Wave forms

  • Each oscilloscope wave form has one or more of the following parameters:
  • Amplitude - voltage (V)
    • The signal voltage at a certain moment in time
  • Frequency - cycles per second (Hz)
    • The time between points of the signal
  • Pulse width - duty cycle (%)
    • The period during which the signal is ON - expressed as a percentage (%) of the total
  • Shape - spike, curve, saw-tooth etc.
    • The overall 'picture' of the signal

    Fig. 2 - Wave form parameters

  • Pattern - repeated shapes
    • The pattern of repetition of the overall shape of the signal
  • The oscilloscope will show all these parameters in one display and by comparing the scope traces from the vehicle under test with those illustrated, a judgement can be made about the condition of each circuit and its components.
  • The scope trace for a faulty circuit or component will usually appear very different to that for a satisfactory one, thus simplifying fault identification.
  • The five parameters listed above can be categorised as follows:

Direct current (DC) voltage signals - amplitude only

  • Analogue signal voltages from components such as:

    Fig. 3 - Engine coolant temperature (ECT) sensor

    Fig. 4 - Intake air temperature (IAT) sensor

    Fig. 5 - Accelerator position (APP)sensor

    Fig. 6 - Mass air flow (MAF) sensor

Alternating current (AC) voltage signals - amplitude, frequency and shape

  • AC voltage signals are generated by components such as:

    Fig. 7 - Injector needle lift sensor

    Fig. 8 - Engine speed (RPM) sensor - inductive type

Frequency modulated signals - amplitude, frequency, shape and pulse width

  • Frequency modulated signals are generated by components such as:

    Fig. 9 - Crankshaft position (CKP) sensor - inductive type

    Fig. 10 - Camshaft position (CMP) sensor - inductive type

    Fig. 11 - Vehicle speed (VSS) sensor - inductive type

    Fig. 12 - Hall-effect speed and position sensors

Pulse width modulated signals - amplitude, frequency, shape, pulse width

  • Pulse width modulated signals from components such as:

    Fig. 13 - Injectors

    Fig. 14 - Fuel injection timing solenoid

    Fig. 15 - Fuel quantity adjuster

    Fig. 16 - Exhaust gas recirculation (EGR) valves

Interpreting wave forms

Typical wave forms

  • Oscilloscope wave form patterns can vary greatly and are dependent on many factors. Therefore prior to making a diagnosis or changing components the following points should be considered when the wave form obtained does not appear to be correct when compared with the 'typical' wave form in the pin data table being used.

Voltage

  • Typical wave forms indicate the approximate position of the wave form in relationship to the 'zero grid', but this may vary Fig. 17 [1], dependent on the system being tested and may be positioned anywhere within the approximate 'zero range' Fig. 17 [2] & Fig. 18 [1].
  • The amplitude or overall height of the pattern (the voltage) Fig. 17 [3] & Fig. 18 [2], will depend on the circuit's operating voltage.
  • For direct current (DC) circuits this will depend on the voltage being switched, for example, the fuel injection timing solenoid voltage will be constant and will not vary with engine speed.
  • For alternating current (AC) circuits this will depend on the speed of the signal generator, for example, an inductive crankshaft position (CKP) sensor's output voltage will increase with engine speed.
  • Therefore if the oscilloscope pattern is too high (or the upper part is missing) increase the voltage scale to obtain the view required. If the pattern is too low decrease the voltage scale.
  • Some circuits operating solenoid components, for example the fuel injection timing solenoid, may display voltage spikes Fig. 17 [4], when the circuit is switched off. This voltage is generated by the component and can normally be ignored.
  • Some circuits that have a square wave type of typical wave form may display the voltage decaying at the end of the switching period Fig. 17 [5]. This is a characteristic of some systems and can normally be ignored, as it does not by itself indicate a fault.

Frequency

  • The overall width of the pattern (the frequency), will depend on the circuit's operating speed.
  • The typical wave forms illustrated show the wave form viewed with the oscilloscope's time scale set to enable detailed observation.
  • In direct current (DC) circuits the time scale will be dependent on the speed at which the circuit is switched Fig. 17 [6], for example, the frequency of a fuel quantity adjuster will vary with engine load.
  • In alternating current (AC) circuits the time scale will depend on the speed of the signal generator Fig. 18 [3], for example, an inductive crankshaft position (CKP) sensor's frequency will increase with engine speed.
  • If the oscilloscope pattern is too compressed, decrease the time scale to obtain the view required. If the pattern is too expanded, increase the time scale.
  • If the pattern is reversed Fig. 18 [4], this indicates that the system being tested has its component connected in the opposite polarity to the typical wave form shown and can normally be ignored as it does not by itself indicate a fault.

    Fig. 17 - Digital wave form

    Fig. 18 - Analogue wave form

Component testing

  • Wave forms for a variety of components can be displayed. A few of the more common examples are described below.
  • Most modern oscilloscopes have just two test leads, used with a variety of interchangeable test probes. The red lead is the positive and is normally connected to the ECM pin. The black lead is the negative and is normally connected to a good earth.
  • If the leads are inadvertently connected with the wrong polarity, usually the only consequence is that the wave form will be displayed upside down.
  • All common rail and electronically controlled unit injector systems operate by varying the opening time of the injectors to match the quantity of fuel supplied with the engine operating conditions.
  • The duration of the electrical impulses from the control unit is measured in milliseconds (ms) and typically ranges from 1 to 2 at idle speed. The oscilloscope on most engine testers can be used to display the injector pulse, enabling the duration to be measured.
  • A typical oscilloscope trace is shown in Fig. 19.
  • Most modern Diesel engines inject fuel in stages called pilot, main and post injection.
  • The first injection (pilot) Fig. 19 [A], occurs as the piston is rising on its compression stroke and is used to pre-condition the combustion chamber.
  • The second injection (main) Fig. 19 [B], occurs at or near top dead centre (TDC) and provides most of the combustion.
  • The third injection (post), used where exhaust emission standards dictate, occurs in the exhaust stroke and is used in conjunction with the exhaust gas recirculation (EGR) system to reduce exhaust emissions.
  • The injectors operate at very high fuel pressures and have to react rapidly necessitating the use of high current solenoids. To reduce the current switched by the ECM, the injector solenoid is rapidly modulated during its open period Fig. 19 [C].
  • As the injector is energised the voltage at the signal pin falls to, or near zero, and as it is de-energised the returning armature of the solenoid generates a pulse (spike) of high voltage.
  • It is therefore possible to check that the control unit is operating correctly by observing the changes in injector opening times during various engine operating conditions.
  • Injector opening during cranking may be higher than at idle speed, and will increase as the engine load rises.

    Fig. 19 - Injectors

Injector pulse

  • Using a thin probe, connect the oscilloscope test probe to the ECM injector terminal and the second test probe to earth.
  • Start engine and observe the wave form at idle speed.
  • Depress the accelerator pedal rapidly to increase engine speed to around 3000 rpm.
  • The measured pulse duration should increase during acceleration and then stabilise at a reading equal to or slightly below the idle speed value.
  • Release the accelerator pedal rapidly and the trace should become a straight line with no pulse indicating that injection has been cut-off.
Technical Data
Injection | Duration
Pilot | 1-2 ms
Main | 1-2 ms

Inductive sensors

  • The general procedure is as follows:
  • Select sensor pin from pin data list with wave form reference.
  • Connect oscilloscope probe to ECM pin and second probe to earth.
  • Start engine and observe test conditions.
  • Compare scope trace with wave form reference.
  • Raise the engine speed and watch for the voltage (amplitude) display to increase.

    Fig. 20 - Inductive sensor wave form

Fuel injection timing solenoid/fuel quantity adjuster

  • Fuel injection timing solenoids and fuel quantity adjusters come in many different types, each with a different wave form.
  • In each case the duty cycle (or ON time) of the solenoid should increase when additional engine load is applied.
  • If the wave form shows a straight line around the zero mark, or the line is constant at the 5 V or 12 V level, this indicates a fault in the control circuit or ECM signal output.

    Fig. 21 - Fuel injection timing solenoid/fuel quantity adjuster wave form

Injector needle lift sensor

  • Connect oscilloscope test probes between injector needle lift sensor ECM pin and earth.
  • Compare scope trace with wave form reference Fig. 22.
  • If the trace shows no wave form but instead is a straight line, this usually indicates a wiring fault or a defective sensor.

    NOTE: This sensor only produces a small amount of voltage which may be difficult to detect if the oscilloscope is incorrectly adjusted.

    Fig. 22 - Injector needle lift sensor wave form


Index

Petrol Engine Management - Index

Engine management component descriptions General test procedures


Engine management component descriptions

Engine control module (ECM)

  • Electrical signals from the fuel and ignition system sensors are received and processed by the electronic circuits in the ECM.

Functions

  • Outputs from the ECM control the following:
  • Injectors - by controlling the length of time each injector valve remains open.
  • Fuel pump relay.
  • Idle speed control system.
  • Evaporative emissions system.
  • Exhaust gas recirculation.
  • Ignition timing and knock sensing.
  • Self-diagnosis of faults, indicated by an LED on the ECM Fig 1 or a MIL or check engine warning light on the instrument panel Fig 2 (some models).
  • Emergency `limp-home' programme, which substitutes an average value for any failed sensor enabling the vehicle to be driven to a workshop for correction.

Fig 1

Fig 2

Fuel supply system

Fuel pressure regulator - Fig 3

  • Maintains an even supply pressure to the injectors.
  • Single point systems - incorporated in the throttle body.
  • Multi-point systems - fitted downstream of the injectors.

Fig 3

  1. Diaphragm
  2. Spring
  3. Vacuum connection
  4. Pressurised fuel inlet
  5. Fuel return

Operation

  • The regulator body is divided into two chambers by a diaphragm.
  • The upper (spring) chamber is connected, by vacuum hose, to the inlet manifold downstream of the throttle valve.
  • The lower chamber receives pressurised fuel.
  • When the fuel supply pressure exceeds the pre-set regulator pressure the diaphragm valve opens and allows the excess fuel to flow back to the tank.
  • The vacuum exerted on the upper chamber modifies the spring pressure and ensures that the pressure difference between the fuel chamber and the inlet manifold is constant.

Injector

  • Single point systems - the injector sprays fuel into the throttle body.
  • Multi-point systems - the injectors spray fuel into the inlet manifold.

Operation

  • Electronically controlled injectors are opened by an integral solenoid - single point Fig 4, multi-point Fig 5, which responds to signals from the ECM.
  • The fuel is injected in a fine spray, in order to ensure thorough mixing with the intake air.
  • External resistors may be provided for each injector.
  • Injectors for mechanical systems (KE-Jetronic and derivatives) have a spring loaded valve operated by fuel pressure Fig 6.

Fig 4

  1. Solenoid
  2. Fuel inlet
  3. Fuel return
  4. Needle valve

Fig 5

  1. Solenoid
  2. Fuel inlet
  3. Needle valve

Fig 6

  1. Fuel inlet
  2. Filter gauze
  3. Needle valve - open
  4. Needle valve - closed

Air flow measurement

Volume air flow (VAF) sensor - Fig 7

  • The VAF sensor is fitted between the air filter and throttle body. It measures the amount of air drawn into the engine by the deflection of a flap inside the sensor.

Fig 7

  1. Sensor flap
  2. Damper flap
  3. Potentiometer
  4. Intake air temperature sensor

Operation

  • The flap is connected to a potentiometer which sends a signal voltage to the ECM.
  • This is the primary signal which, in conjunction with those from the other system sensors, is used to determine the fuelling requirements of the engine.
  • In many applications the intake air temperature sensor is incorporated in this type of air flow sensor

Mass air flow (MAF) sensor - hot-wire type - Fig 8

  • The MAF sensor has no moving parts and provides very little restriction to the air flow. It is fitted between the air filter and throttle body.

Operation

  • The MAF sensor consists of a venturi with a resistance wire exposed to the incoming air.
  • An air temperature sensor or compensating wire is also exposed to the air flow.
  • The ECM senses changes in temperature caused by variations in air mass passing through the sensor body and increases or decreases the current flowing through the measuring wire.
  • An internal electronic circuit maintains the approximate temperature of the measuring wire at a constant 120°C, above the intake air temperature.
  • As the mass of air passing the wire increases, so the current required to maintain the temperature also increases.
  • This increase in current is sensed by the ECM.
  • This is the primary signal, used in conjunction with signals from the other system sensors, for determining the correct amount of fuel to be supplied to the engine.
  • A `burn-off' facility operates when the system is switched off, to remove dirt from the filament.

Fig 8

  1. Protective mesh
  2. Resistance wire
  3. Intake air
  4. Compensating wire

Mass air flow (MAF) sensor - hot-film type

  • Similar to the hot-wire type, but with the measuring element incorporated in a ceramic plate. This arrangement obviates the need for a `burn-off' facility.

Manifold absolute pressure (MAP) sensor - Fig 9

  • Connected by vacuum hose to the engine inlet manifold. Usually located in the engine bay, or built into the ECM casing.

Operation

  • The sensor consists of a diaphragm and piezo-electric circuit which varies the resistance in proportion to the pressure in the manifold.
  • The sensor has a 5 volt supply and sends a signal voltage to the ECM which is proportional to the manifold pressure.
  • The ECM uses the voltage signals from the MAP sensor to adjust the signals to the injectors.

Fig 9

  1. Full load
  2. Idling
  1. Vacuum connector
  2. Piezo-electric crystal
  3. Electrical connections

Idle speed control

  • Idle speed control devices are all fitted into a throttle by-pass system, allowing extra air to enter the engine. This extra air complements the mixture enrichment during a cold start and the subsequent warm-up period.

Idle air control (IAC) valve - Fig 10

  • The auxiliary air valve allows air to by-pass the throttle valve when the engine is cold, to increase idle speed during the warm-up period.

Fig 10

  1. Bi-metal strip
  2. Heating element
  3. Valve plate
  4. By-pass air

Operation

  • The valve is mounted on the engine in a position where it is in direct contact with engine temperature.
  • The valve incorporates an electrically heated bi-metal strip which determines the cut-off point as the engine reaches normal operating temperature.

Idle air control (IAC) valve - solenoid type - Fig 11

  • The solenoid idle air control actuator allows air to by-pass the throttle valve to govern the idle speed, under all conditions.

Fig 11

  1. Solenoid
  2. Air valve
  3. Air outlet
  4. Air inlet

Operation

  • It is controlled directly by the ECM, which interprets signals from sensors such as RPM and coolant temperature to maintain the idle speed at a pre-determined level.
  • The solenoid acts against a spring, either with a rotary or linear action.

Idle air control (IAC) valve - rotary type - Fig 12

  • The rotary idle air control actuator allows air to by-pass the throttle valve to govern the idle speed, under all conditions.

Fig 12

  1. Rotary valve
  2. Air inlet
  3. Air outlet
  4. Motor

Operation

  • The device consists of a rotary valve, in the by-pass air way, mounted on the shaft of a special electric motor.
  • The motor has two sets of armature windings and is limited to an angular movement of 90°.
  • The ECM supplies an alternating voltage to the two windings, depending on signals from sensors such as engine RPM and coolant temperature.
  • The alternating voltages exert opposing forces on the armature resulting in the valve taking up a position corresponding to the voltage ratio.

Idle air control (IAC) valve - stepper motor type - Fig 13

  • The idle air control stepper motor positions an air by-pass valve mounted in the throttle body and is used mainly with single point injection systems.

Operation

  • The stepper motor has four control windings, enabling it to be precisely positioned in either direction.
  • It is controlled by the ECM and changes idle speed irrespective of throttle valve position.
  • As an additional function the stepper motor may open the throttle valve mechanically to increase idle speed.

Fig 13

Sensors

Heated oxygen sensor (HO2S) - Fig 14

  • Sometimes referred to as a Lambda sensor.
  • Fitted in the exhaust system upstream of the catalytic converter, where it can measure the exhaust gases evenly from all cylinders.
  • Where necessary (e.g. on a V-engine with a dual exhaust system) two sensors may be fitted.

Fig 14

  1. Protective cap with slots
  2. Heating element
  3. Sensor element
  4. Electrical connections

Operation

  • The sensor reacts to the oxygen content of the exhaust gasses and uses the voltage generated (200-800 mV) to signal the ECM to modify the mixture (air/fuel) ratio.
  • If the oxygen content is at the ideal value (Lambda = 1), the sensor signal voltage will be 500 mV.
  • If the mixture is too weak the voltage will be 200-450 mV (Lambda 1,10).
  • If it is too rich the voltage will be 550-800 mV (Lambda 0,96).
  • In practice the oxygen sensor continually signals the ECM to alter the fuelling by a small amount, to maintain the mixture strength as near as possible (± 1%) to the theoretical ideal (stoichiometric) ratio of 14.7 parts air to 1 part fuel, which is the optimum for the catalytic converter to work efficiently.
  • The sensor will not begin to operate until it has reached 482-572°C, but most now incorporate a heater element, which enables the closed loop system to come into operation soon after a cold start.

Engine coolant temperature (ECT) sensor - Fig 15

  • The ECT sensor probe is immersed in the engine coolant and changes its resistance in proportion to temperature changes.

Fig 15

  1. Electrical connections
  2. Housing
  3. NTC resistor

Operation

  • In most cases the sensor incorporates a negative temperature coefficient (NTC) resistor, which decreases in resistance as the coolant temperature rises.

Engine speed and position sensors

  • Engine speed (RPM), crankshaft position (CKP) and camshaft position (CMP) sensors are of two basic types, inductive or Hall effect. Inductive sensors may be mounted on the camshaft housing, crankcase or in the distributor, but Hall effect sensors are usually mounted in the distributor.

Inductive type - Fig 16

  • These sensors contain a permanent magnet partly enclosed in a soft iron core and partly in a field winding.
  • The tip of the sensor is positioned close to the flywheel ring gear, a separate toothed trigger wheel, or a toothed wheel attached to the crankshaft pulley.
  • In certain applications the sensor(s) are incorporated in the ignition distributor or in a separate unit driven by the camshaft.

Fig 16

  1. Soft iron core
  2. Field winding
  3. Permanent magnet
  4. Flywheel ring gear
  5. TDC pin

Operation

  • As the teeth or pins of the trigger wheel pass the sensor the magnetic field changes, inducing a voltage signal which is sent to the ECM.

Hall effect - Fig 17

  • The Hall effect generator consists of a semi-conductor material, through which a current flows, enclosed by a magnetic field at right angles to the current flow.

Fig 17

  1. Trigger vane
  2. Hall generator
  3. Distributor shaft

Operation

  • When the ignition is switched on, a small voltage is generated across the semi-conductor (the `Hall' voltage).
  • A soft iron trigger vane attached to the distributor shaft is positioned to pass between the poles of the magnet.
  • This diverts the magnetic field and has the effect of reducing the Hall voltage to practically zero Fig 18.
  • As the vane passes the sensor, the Hall trigger is switched `on' when it is opposite a gap [1] and [2] and `off' when there is no gap [3] and [4].

Fig 18

Throttle position (TP) switch - Fig 19

  • The throttle position switch assembly is mounted on the throttle body and attached to the throttle valve shaft. It incorporates an idle switch and a wide open throttle switch.

Fig 19

  1. Full throttle switch
  2. Throttle butterfly shaft
  3. Idle switch

Operation

  • The idle switch governs fuel shut-off on the overrun and the wide open throttle switch signals the ECM to provide full load enrichment.

Throttle position (TP) sensor - Fig 20

  • Used as an alternative to a throttle switch assembly, the throttle position sensor is a variable resistance (potentiometer) connected to the throttle valve shaft.
  • In the case of single point injection systems, load sensing may be by means of this sensor, avoiding the need for a MAP sensor.

Fig 20

  1. Throttle butterfly shaft
  2. Wiper arm
  3. Resistance tracks

Operation

  • It is supplied with a reference voltage and the output signal voltage is used by the ECM to interpret the exact throttle position.

Valves

Evaporative emission (EVAP) canister purge valve - Fig 21

  • A reduction in pollution of the atmosphere can be achieved by fitting an evaporative control system.
  • Fuel vapour from the tank is stored in a carbon filter when the engine is stopped.

Fig 21

  1. Vapour inlet
  2. Non-return valve
  3. Solenoid
  4. Vapour outlet

Operation

  • When the engine approaches normal operating temperature, the solenoid valve on the carbon filter opens, allowing the fuel vapour to be drawn out of the carbon filter into the inlet manifold.

Exhaust gas recirculation (EGR) valve - Fig 22

  • To reduce the oxides of nitrogen emitted by the exhaust, a proportion of the exhaust gas can be returned to the inlet manifold when the engine is on full load.

Operation

  • The exhaust gas recirculation valve is operated mechanically or by vacuum to control the flow of exhaust gas into the inlet manifold.

Fig 22


General test procedures

Injector checking and cleaning

General procedures

  • Apart from the basic test of checking the electrical resistance of the solenoid coil, injectors should ideally be removed from the engine and checked and cleaned using dedicated injector test and cleaning equipment.
  • The most satisfactory method of restoring the efficiency of fouled injectors is to have them ultrasonically cleaned.
  • Several machines are available for this operation. These are capable of cleaning the interior of a set of injectors, using ultrasonics, in just a few minutes, followed by simultaneous spray testing of the complete set for comparative purposes.
  • At the same time the filter baskets and pintle caps should be changed.

Fig 1

Oscilloscope testing

  • All electronically controlled intermittent injection systems operate by varying the opening time of the injections to match the quantity of fuel supplied with the engine operating conditions.
  • The duration of the electrical impulses from the control unit is measured in milli-seconds (ms) and typically ranges from 1 to 14. The oscilloscope on most engine testers can be used to display the injector pulse, enabling the duration to be measured.
  • Typical oscilloscope traces are shown in Fig 2 and Fig 3.

Fig 2

Fig 3

  • It is therefore possible to check that the control unit is operating correctly by observing the changes in injector opening times during various engine operating conditions.
  • Pulse duration during cranking and at idle speed will be higher than at low engine speeds, but will increase as the engine speed rises, up to a maximum at full throttle.
  • This effect will be particularly evident if the throttle is 'blipped'.
  • The other variable is the pulse period.
  • The pulse period is the time between a particular injector opening and the next opening of the same injector. Normally the pulse period will be once per crankshaft revolution. 50% of the fuel required for one firing stroke of the engine is injected at each injector valve opening.
  • The relationship between pulse period and pulse duration, for an engine with a speed range from 600-6000 rpm, is diagrammatically shown in Fig 4 and Fig 5.

Fig 4

Fig 5

  • When the engine is idling at 600 rpm this is equivalent to 10 revs per second, therefore the crankshaft rotates once every tenth of a second, equivalent to 100 milli-seconds - this is the pulse period.
  • At 6000 rpm, equivalent to 100 revs per second, the crankshaft rotates 10 times per 100 milli-seconds and therefore the injectors open ten times during this period.
  • This means that if the injector dwell period reaches 10 ms, the injector valves are open continuously.
  • The dwell meter may also be used to indicate changes in the opening period of the injectors. Injection dwell provides a precise means of checking the operation of the ECM and its associated sensors.
  • The reading indicates the percentage time that the injector remains open and delivers fuel. Some dwell meters and oscilloscopes have a scale calibrated in degrees, the reading may be converted to % dwell using the following formula:
      D% = | D° x C | x 100
 | 360 |
    Where
      D% = Dwell period %
      C = No. of cylinders
      D° = Dwell angle in degrees

Test procedure - injector pulse (dwell)

  • Using a thin probe, connect scope test lead to one terminal of injector and second test lead to earth.
  • Crank the engine and check either scope for trace or dwell meter for reading.
  • If reading is obtained start engine and observe trace at idle speed. Open throttle rapidly to increase engine speed to around 3000 rpm.
  • The measured pulse duration should increase during acceleration and then stabilise at a reading equal to or slightly below the idle speed value.
  • Close the throttle rapidly and the trace should become a straight line with no pulse indicating that injection has been cut-off (for systems fitted with overrun injection cut-off).
  • When the engine is started from cold the quantity of fuel required is increased and therefore the pulse duration or dwell will be greater.
  • During warm-up the injection period should progressively decrease until the engine reaches normal operating temperature.
  • Some systems, without a cold start injector, give additional injector pulses during the cold start, which may be seen as long and short pulses on the scope.
  • Additional information may also be displayed, such as the TDC or reference sensor signal and a series of smaller pulses, which hold the injector open after the initial negative pulse.
  • A sharp positive voltage spike will be displayed as the injector closes.

Test values - typical

Injection period - warm engine
Idle speed | 2,2-2,4 ms
2000-3000 rpm | 1,5-2,2 ms
Full throttle | 8,2-8,4 ms

Volume air flow sensor

  • The oscilloscope may also be used to check the air flow sensor voltage.
  • Connect the low voltage test lead of the oscilloscope to the potentiometer terminal (No.7 on Bosch LE-Jetronic) and make the earth connection to the engine. Manually operate the sensor flap and observe the oscilloscope trace, checking for hash or irregular voltage readings as the flap is moved Fig 6.
  • Some systems are fitted with a stepper motor which operates an idle air control valve. This enables small adjustments to be made to the idle speed in reaction to variations of operating temperature and load.
  • The stepper motor responds to an oscillating voltage signal from the ECM.
  • This voltage can be checked by connecting the low voltage test lead to each of the four stepper motor leads in turn.
  • By turning the ignition on and off an oscillating voltage trace between 0 and 12 volts should be observed Fig 7.
  • If no signal is obtained, repeat the test at the relevant terminals of the ECM multi-plug.

Fig 6

Fig 7

HT Circuit tests

NOTE: The following checks cover all the HT components of a `conventional' ignition system.

  • Distributorless systems have HT leads for each plug, but no cap or rotor arm.
  • Direct ignition systems dispense with the HT leads as well, but have individual coils for each plug, which may be tested for insulation breakdown.
  • Use a high-voltage capacity tester of approximately 500V to test insulation of HT components.
  • Ohmmeter can be used for testing component insulation, but will not be as effective.
  • Components should be observed for signs of `tracking' during testing.

Checking HT lead resistance

  • Connect ohmmeter between ends of HT leads.
  • Measure resistance of each HT lead.
  • Check resistance is 25000-30000 W, unless otherwise specified.
  • If leads show excessive resistance, or are mechanically damaged in any way, install replacement set.

Fig 8

Checking distributor cap insulation

  • Connect a high-voltage capacity tester between each HT terminal in turn and cap casing.
  • Tester should indicate open circuit.
  • If there is any sign of insulation breaking down, install replacement distributor cap.

Fig 9

Checking rotor arm insulation

  • Connect a high-voltage capacity tester between rotor arm HT terminal and rotor arm case.
  • Tester should indicate open circuit.
  • Alternatively, remove distributor cap and hold coil HT lead, using insulated pliers, approximately 1 4 in. above rotor arm contact.
  • Crank engine with starter.
  • If rotor arm insulation is faulty spark will jump across gap between HT lead and rotor arm and ground on distributor shaft.
  • If there is any sign of insulation breaking down, install replacement rotor arm.

Fig 10

Checking ignition coil insulation

  • Connect a high-voltage capacity tester between coil tower HT terminal and coil casing.
  • Measure resistance of the insulation.
  • Tester should indicate open circuit.
  • If there is any sign of insulation breaking down, install a replacement ignition coil.

Fig 11

Fig 12


Diagnostic trouble codes

Diagnostic Trouble Codes - Index

Terminology General test conditions Safety precautions Tools and equipment Oscilloscope testing System description Trouble code format EOBD codes


Terminology

DTC - Terminology

Throughout this application the following standard descriptions and terminology have been used, together with J1930 component descriptions.

  • Left-hand (LH) and right-hand (RH) - As seen from the driver's seat facing forward
  • Bank 1 - Cylinder bank or group including No.1 cylinder (e.g. cylinders 1, 2 & 3 of a six cylinder engine)
  • Bank 2 - Cylinder bank or group not including No.1 cylinder (e.g. cylinders 4, 5 & 6 of a six cylinder engine)
  • HO2S 1 - Heated oxygen sensor (HO2S) single or nearest to engine (in front of catalytic converter)
  • HO2S 2 - Heated oxygen sensor (HO2S) after catalytic converter
  • KS 1 - Knock sensor (KS) single or nearest No.1 cylinder

Typical sensor locations and descriptions:

Fig 1.
  1. Heated oxygen sensor (HO2S) 1
  2. Heated oxygen sensor (HO2S) 2
  3. Knock sensor (KS) 1
  4. Knock sensor (KS) 2
  5. Catalytic converter
4 cylinder in-line
Fig 2.
  1. Heated oxygen sensor (HO2S) 1, bank 2
  2. Heated oxygen sensor (HO2S) 1, bank 1
  3. Heated oxygen sensor (HO2S) 2, bank 2
  4. Heated oxygen sensor (HO2S) 2, bank 1
  5. Heated oxygen sensor (HO2S) 2
    (if only single heated oxygen sensor (HO2S) after cat)
  6. Catalytic converter
6 cylinder in-line
Fig 3.
  1. Heated oxygen sensor (HO2S) 1, bank 1
  2. Heated oxygen sensor (HO2S) 2, bank 1
  3. Heated oxygen sensor (HO2S) 1, bank 2
  4. Heated oxygen sensor (HO2S) 2, bank 2
  5. Knock sensor (KS) 1
  6. Knock sensor (KS) 2
  7. Catalytic converter
V6
Fig 4.
  1. Heated oxygen sensor (HO2S) 1, bank 2
  2. Heated oxygen sensor (HO2S) 1, bank 1
  3. Heated oxygen sensor (HO2S) 2
  4. Knock sensor (KS) 1, bank 2
  5. Knock sensor (KS) 2, bank 2
  6. Knock sensor (KS) 1, bank 1
  7. Knock sensor (KS) 2, bank 1
  8. Catalytic converter
V8


General test conditions

DTC - General test conditions

Find the model related chapter from vehicle manufacturer, model name, engine code, year of manufacture and system.

Observe the following relevant test conditions:

  • All auxiliary equipment, including air conditioning, switched OFF.
  • Ensure battery voltage above 11 volts.
  • Ensure earth wires in good condition.
  • If vehicle fitted with engine malfunction indicator lamp (MIL):
  • Check MIL operation - if MIL does not flash or illuminate, replace bulb or repair circuit.

  • NOTE: If MIL remains illuminated or flashes, this indicates a fault, but if it goes out there could still be trouble codes logged in the ECM. Scan tool may not respond if MIL is not working.

  • Engine at normal operating temperature.
  • Carry out road test.
  • Ensure overrun cut-off function operates several times.
  • Operate accelerator pedal several times over complete travel range.
  • Allow engine to idle.
  • If engine does not start: Briefly crank engine and leave ignition switched ON.
  • Observe any model specific information.
  • Find the location of the data link connector (DLC).
  • Bridge DLC terminals, connect an LED tester or scan tool, as appropriate and observe any special conditions. If a scan tool is used, follow the manufacturer's operating instructions.
  • Follow procedure for accessing trouble codes and note any codes displayed.

  • NOTE: The trouble code may not identify the exact cause of any problem, but serves as a guide to the component or system to be investigated.

  • Refer to probable causes and carry out systematic check of components and circuits until cause of problem is identified and rectified.
  • NOTE: Where the probable cause is a non-specific engine fault, fuel system or ignition system fault, refer to General Trouble Shooter section.
  • Check for further trouble codes.
  • Follow procedure for erasing trouble codes.

  • NOTE: If the battery is disconnected to erase trouble codes, data stored, such as radio security codes and ECM adaptive memory may be lost.

  • Road test vehicle and recheck for any logged trouble codes.
  • If a trouble code is output, but not listed in the appropriate code table, suspect a control module fault.

  • NOTE: In the case of signal or component malfunction, the ECM will substitute a fixed value from its internal limited operating strategy (LOS) software. This enables the vehicle to be driven in limp-home mode until the fault can be rectified. Depending on the component or circuit in question, it may not be obvious to the driver that the engine management system is operating in limp-home mode.

Fault location

Fuel trim

  • Fig 1.
  • Short and long term fuel trim refers to the strategy used to reduce exhaust emissions after the basic computation of injection period, using engine load as the major parameter.
  • Both front and rear oxygen sensor signals are used to fine tune the fuel/air mixture by increasing or decreasing the injection period +/-25% above or below the basic level.
  • Any fault requiring a correction beyond this level will result in a trouble code being logged.
  • When the engine is new and running satisfactorily a level of fuel trim will be established - represented by 100%.
  • The fuel trim will oscillate the injection period +/-5% above and below the mean level Fig 1 - [A].
  • Manufacturing and in-service tolerances of load sensors (MAP, MAF or VAF) and injectors in particular and faults such as intake air leaks will affect the fuel/air mixture and cause the fuel trim to quickly compensate.
  • An intake air leak for instance would result in the injection period increasing, for example to 115-125%. This level will also oscillate +/-5% as before Fig 1- [B].
  • This new short term fuel trim (STFT) level will be stored in the ECM if it is established as a new basic mixture level. It will then become a long term fuel trim (LTFT) correction and results in the correct mixture level immediately after starting, even when the HO2S has had insufficient time to heat up.
  • Long term fuel trim (LTFT) values can be erased by disconnecting the ECM power supply for a suitable length of time.
  • If the memory is not erased after repairs the ECM will eventually learn the new LTFT values, but this will take some time and probably cause high emissions and some driveability problems.
  • For example if an intake air leak causes the engine to run lean this will be compensated by a change in the LTFT value, which will be stored in the ECM memory.
  • After the leak has been repaired this memorised LTFT value will still be used to compute the injection period, resulting in excessively rich running, until new LTFT values have been learned.

Probable causes

Wiring

  • Wiring - refers not only to the wiring harness, but also to any associated component multi-plugs, relay plates, welded, crimped or soldered joints and bulkhead connectors.
  • Short to earth - refers to wiring that has a 'leak' to earth somewhere along its length e.g. if the insulation has chaffed through and the wiring is in contact with the body or engine.
  • Short to positive - refers to wiring that would normally not be carrying 12 volts, but is shorted to the 12 volt supply e.g. a sensor wire that would normally be fed with approx. 5 volts from the ECM, shorted to a 12 volt battery positive supply.
  • Open circuit - refers to wiring that is either disconnected or broken, but is not shorted to either earth or a positive supply.
  • Poor connection - refers to a loose, intermittent or high resistance connection.

General faults

Despite the sophistication of modern electronic management systems, basic mechanical faults can still cause unsatisfactory starting, running and driveability.
Before assuming that a problem is an electronic one, it should be established that the engine/transmission/immobilizer is in good mechanical condition and that the basic fuel and electrical circuits are OK.

Check the following:

Engine

Mechanical

  • Compression pressure
  • Manifold vacuum
  • Valve clearances
  • Valve timing
  • Oil filler cap sealing
  • Not burning excess oil
  • No excessive crankcase fumes

Electrical

  • Battery fully charged and 11-14 volts available
  • Plug leads connected correctly
  • Ignition coil(s)
  • Ignition timing
  • HT leads (where applicable)
  • Spark at plugs
  • Engine ground connections
  • Engine control module (ECM) ground connections

Fuel system

  • Air filter for blockage
  • Fuel filter for blockage
  • Fuel delivery rate
  • Fuel system pressure
  • Fuel regulated pressure
  • Fuel injector spray pattern
  • Vacuum hoses not split or collapsed
  • Catalytic converter and exhaust for blockage

Transmission

  • Fluid level correct
  • Fluid in good condition
  • No foreign matter in transmission fluid
  • No restricted fluid passages in valve block
  • Vacuum hoses not disconnected, split, blocked or collapsed
  • No engine related faults
  • Selector lever cable/linkage adjusted correctly
  • Multi-plugs connected securely
  • Wiring undamaged

Immobilizer (engine won't start)

  • Correct key is being used
  • Key is not damaged
  • Does the key need reprogramming
  • No spurious signals from external source
  • No engine related faults
  • Gear selector in P or N


Safety precautions

DTC - Safety precautions

Airbags (Supplementary Restraint System - SRS)

Many of the models covered by this application are fitted with airbags as standard equipment. When working on a vehicle fitted with such a system, extreme caution must be taken to avoid accidental firing of the airbag, which could result in personal injury. Unauthorised repairs to the system could render it inoperative, or cause it to inflate accidentally.

NOTE: Usually, all related wiring is encased in a yellow outer covering.

When the engine is started the AIRBAG warning lamp should go out after approximately 5-10 seconds, if not this indicates a fault in the system. The system should be checked and the fault corrected by a competent technician before any other work is undertaken.

  • NEVER attempt to test the system using a multi-meter.
  • NEVER tamper with or disconnect the airbag wiring harness.
  • NEVER make extra connections to any part of the system wiring harness or terminals.
  • ALWAYS ensure that the airbag wiring harness has not been trapped or damaged in any way when working on adjacent components or systems.

Electrical

  • CAUTION: To prevent the engine starting and to avoid damaging the catalytic converter(s), disconnect the fuel injector valve multi-plug(s) before cranking tests.
  • ALWAYS ensure that the battery is properly connected before attempting to start the engine.
  • DO NOT attempt to start the engine using a source in excess of 12 volts, such as a fast charger (16 volts) or by connecting two batteries in series (24 volts). - ALWAYS disconnect the battery before charging it.
  • DO NOT disconnect the battery while the engine is running.
  • DO NOT connect the battery with reverse polarity.
  • DO NOT disconnect or touch the HT leads when the engine is being cranked or when it is running.
  • DO NOT connect or disconnect the electronic control module (ECM), or any other component of the fuel injection system while the ignition is switched ON.
  • DO NOT disconnect ECM multi-plug within 30 seconds of switching ignition OFF.
  • DO NOT connect or disconnect multi-meters, voltmeters, ammeters or ohmmeters with the ignition switched ON.
  • DO NOT reverse the polarity of the fuel pump.
  • ALWAYS ensure that all electrical connections are in good condition and making good contact, PARTICULARLY the ECM connector.
  • ALWAYS disconnect the ignition coil, ECM, fuel pump relay/fuse before carrying out a compression test.
  • DO NOT flash a wire or circuit to ground to check that continuity exists.
  • Modern ignition systems operate at very high voltages and these high voltages can severely damage transistorised components such as a wrist-watch if electrical contact is made. Wearers of heart pacemaker devices, therefore, should not at any time carry out work involving ignition systems. In addition to the danger from electric shock, further hazards can arise through sudden uncontrolled body movement causing involuntary contact with moving parts of the engine, i.e. fan blades, pulleys and drive belts.
  • ALWAYS ensure that any replacement fuel or ignition system parts are correct for the application in question. Many units share common external features, but differ internally.

Mechanical

  • CAUTION: To minimise fire risk, fuel system must be depressurised before disconnecting any fuel lines or fuel system components.
  • ALWAYS disconnect the distributor before carrying out a fuel pump pressure or delivery check.
  • AVOID the risk of fire - ALWAYS disconnect the ignition coil supply and ground the coil HT lead, so that NO HT spark can be emitted, before checking the fuel injector valves, or any other component of the fuel injection system likely to result in the presence of fuel in or around the engine bay.
  • AVOID the risk of fire - NEVER work on the fuel injection system when SMOKING or close to a NAKED FLAME.
  • ALWAYS keep a fire extinguisher close at hand when working on the fuel injection system.
  • ALWAYS ensure that test equipment, leads, tools and especially items of clothing, are clear of moving parts and are not liable to fall into the engine bay, due to vibration, when the engine is running.


Tools and equipment

DTC - Tools and equipment

Code readers and scan tools

  • The method of fault code output varies considerably from manufacturer to manufacturer. The simplest to access are flash type codes displayed with the malfunction indicator lamp (MIL) on the instrument panel Fig 1 or an LED display on the control module Fig 2 - these do not require any special equipment.
  • Systems requiring special tools or equipment may output fault memory data as numerical codes or as plain text messages.
  • Many different types of diagnostic equipment are available for reading self-diagnosis fault memories.
  • These vary from simple LED based testers, for reading flash type codes, to software based scan tools fully compatible with EOBD requirements and incorporating many additional features, including the facility to be connected to a PC and printer.
  • Some flash type codes are very complex, with up to ten flashes per group and four or five groups of digits, so that reading them accurately with an LED tester is difficult and the possibility of miscounting is quite likely.
  • Some code readers can only display numerical codes, which means that they are unsuitable for use on certain makes and models (such as Renault, Rover, Fiat etc.). These require equipment capable of displaying fault descriptions in plain text.
  • Most scanner tools will enable fault codes to be erased without disconnecting the battery, therefore avoiding the loss of radio codes and control module learnt values.
  • Any software based equipment will need to be updated periodically by replacement 'pods' or CDs provided by the equipment manufacturers.
  • Additional features accessible with the more sophisticated testers include:
    • Activation and functional testing of specific actuators and sensors.
    • Multi-meter ranges.
    • Recording and displaying oscilloscope patterns.
    • Links to menu based fault diagnosis procedures, with wiring diagrams, technical data and fault finding flow charts.
Fig 1 | Fig 2
Instrument panel malfunction indicator lamp (MIL) | Control module with LED indicator

Fault diagnosis and testing methods

General recommendations

  • Electronic control modules such as the engine control module (ECM), transmission control module (TCM) and immobilizer control module need special care during fault diagnosis. They are easily damaged by excess voltage or reversed polarity. Whenever possible disconnect them before testing wiring continuity.
  • Some ECMs have an adaptive memory which may have re-learn its basic dynamic values (during driving) if the power supply is interrupted, for instance to erase fault codes.
  • Electrical wiring can be repaired where practicable but ensure that all repairs are properly insulated, preferably with heat shrink tubing and protected by a fuse of the correct amperage.

    • NOTE: Many electronic control modules have fault memories which may be erased if the power supply is interrupted.

  • Check condition of ALL fuses in the system prior to circuit testing.

Test equipment

Multi-meter types

  • The majority of electrical faults identified in this application can be successfully diagnosed using an ohmmeter or voltmeter. Normally these functions will be combined in a multi-meter.
  • A high impedance (10 K ohms/volt minimum) multi-meter that includes a 0-20 V voltage scale and a low (0-200) and high (0-20 K) range ohm scale is recommended for measuring the voltage and resistance of the system components.
  • Analogue meters (with a needle sweeping across a numerical scale), due to their continuous readout are useful for certain applications, such as counting needle deflections to identify fault codes on certain models and the identification of intermittent faults, but for general workshop use a digital meter is easier to use and is more resistant to rough handling and less likely to be damaged by incorrect use.
  • Digital meters (with an LED or LCD display), are available in many different types. In addition to the basic, general purpose meters with voltage (DC/AC), resistance and amperage scales additional features such as temperature, duty cycle and engine RPM etc. are often incorporated in dedicated test meters for automobile applications.

Using multi-meters

Voltage checking - Fig 3, Fig 4, Fig 5 & Fig 6

  • Set the meter to VOLTAGE.
  • If applicable, set the meter to the correct scale e.g. AC/DC, V/mV etc. (most modern meters are self-ranging).
  • Connect the black test lead to the negative terminal being tested.
  • Observe the conditions of the test, e.g. ignition ON etc.
  • Connect the red test lead to the positive terminal being tested.
  • Read and record the value displayed.
    • Measurement of voltage drop through cables and components can be a useful diagnostic tool, as any abnormal condition will have an effect on the operation of the circuit(s) and components involved.
    • The multi-meter should be set to measure milli-volts and the circuit should be in its normal operating mode e.g. all multi-plugs connected and current flowing.
    • Maximum voltage drop should not exceed the following values:
      • Control module harness wire - 200 mV
      • Switch - 300 mV
      • Earth connection - 100 mV
      • Sensor connection - 50 mV
    Fig 3
             Fig 4
    Checking voltage with multi-meter
    Checking supply voltage - harness multi-plug disconnected
    Fig 5
             Fig 6
    Checking signal voltage between wires - harness multi-plug connected
    Checking signal voltage between wire and earth - component multi-plug connected

    Resistance and continuity checking - Fig 7, Fig 8, Fig 9 & Fig 10

    • High resistance in earth connections can cause unusual (and apparently illogical) symptoms that are seemingly unconnected with the components involved.
    • Earth connections should be thoroughly cleaned and treated with a proprietary contact cleaner before assembly.
    • Connections in the vicinity of the battery are particularly vulnerable to corrosion.
    • Earth wires should be checked along their whole length for chafing, corrosion and mechanical damage. A typical earth wire may have 20-30 strands and although there will still be a connection if only a few of these are intact, the resulting high resistance will cause problems.
    • Suspect multi-plugs should be 'dismantled' (if possible) and the terminals thoroughly inspected and cleaned.
    • Set the meter to RESISTANCE.
    • If applicable, set the meter to the correct scale (most modern meters are self-ranging).
    • Connect the black test lead to the red test lead and check that the meter displays ZERO Ω.

    • NOTE: If ZERO Ω is not displayed, refer to the meter operating instructions.

    • Disconnect the component from any wiring.
    • Connect the black test lead to one terminal being tested.
    • Connect the red test lead to the other terminal being tested.
    • Read and record the value displayed.
    • If the meter displays ZERO, Fig 7 this indicates continuity.
    • If the meter displays ¥ (infinity) Fig 8, this indicates NO continuity (open circuit).
    Fig 7
            Fig 8
    Circuit continuity
    Open circuit
    Fig 9
            Fig 10
    Checking component resistance
    Checking earth connection at harness multi-plug

    Diode checking - Fig 11 & Fig 12

    • Set the meter to RESISTANCE or DIODE.
    • Connect the red test lead to positive terminal of the diode.
    • Connect the black test lead to the negative terminal of the diode.
    • The meter should display continuity Fig 11.
    • Reverse the test leads, the meter should display NO continuity Fig 12.

    • NOTE: If the meter displays continuity in both tests the diode is faulty.

    Fig 11
            Fig 12
    Continuity through diode
    No continuity through diode

    Signal checking with LED tester - Fig 13

    • CAUTION:
      Circuit testers incorporating a bulb should not be used on electronic circuits as the high current involved could damage sensitive components.

    • LED testers can be used safely on electronic circuits as their low current consumption cannot damage electronic components.
    • They are particularly useful where a pulse or intermittent signal is being checked.
    • Most LED testers are in the form of a probe attached to the tester body, with a test lead and clip for the other terminal. The more sophisticated testers have different coloured LEDs to indicate polarity.
    Fig 13
    Checking sensor signal with LED tester - multi-plug connected

    Breakout box - Fig 14

    • Whenever possible a breakout box should be used for circuit testing at the control module multi-plug and when checking pin data.
    • A breakout box [1] is a means of connecting test equipment to the control module harness without the need to probe into the back of the harness multi-plug. For checking pin data it is connected by an adaptor lead [2] between the ECM [3] and the car's wiring harness [4].
    • For circuit testing the harness multi-plug is disconnected from the control module and connected to the breakout box.
    • The pin connections are laid out in rows in numerical order and have large connecting sockets, enabling test leads to be securely plugged into a circuit, and avoiding the possibility of connecting to the incorrect pin, due to miscounting.
    • The possibility of damaging components or wiring, due to shorting live pins to ground or to other components, is also much reduced.
    • The limiting factor is the range of adaptor leads. Several equipment manufacturers produce breakout boxes, but none are able to supply a complete range of leads to cover all the models included in this application.
    Fig 14
    Breakout box connections

    ECM harness multi-plug testing - Fig 15, Fig 16 & fig 17

    • If a breakout box and suitable adaptor leads are not available, testing must be carried out at the wire side of the ECM harness multi-plug Fig 15.
    • To access the terminals the protective cover must be removed from the plug. Many different types of plug are used for engine management wiring harnesses and two examples are shown in Fig 16 and Fig 17.
    • Use the appropriate ECM harness multi-plug - wire side diagram and identify the pin(s) to be tested - refer to Autodata CD2 or Pin Data manual.
    • Use only very fine test probes to access the connections and measure the signal between the pin and earth Fig 15 [1], or between two ECM pins Fig 15 [2].
    Fig 15
    Testing at wire side of harness multi-plug
    Fig 16
            Fig 17
    Testing at harness multi-plug
    Testing at harness multi-plug


Oscilloscope testing

DTC - Oscilloscope testing

Oscilloscopes

  • Digital multi-meters are entirely satisfactory for checking circuits in a static condition and for instances where any change in reading is a gradual one, but for dynamic checking and the diagnosis of intermittent faults, the oscilloscope is a very powerful workshop tool.
  • Unlike older analogue oscilloscopes dedicated to HT ignition testing, a modern digital oscilloscope has a variable voltage scale, enabling low voltages (typically 0-5 V or 0-12 V) to be displayed and also an adjustable time scale, enabling any wave form to be displayed in the ideal manner.
  • Most oscilloscopes designed for automotive use can be hand-held and are therefore ideal for use in the workshop. They can also be used inside the car, while the vehicle is driven, to capture dynamic data.
  • Usually it is possible to store wave forms and associated data in an internal memory and then print out or download the information onto a PC, enabling the scope patterns to be studied in detail.
  • The oscilloscope display can show the amplitude, frequency, pulse width, shape and pattern of the signal received, by effectively drawing a graph of voltage (vertically) and time (horizontally).
  • It is easy to connect (normally just two leads) and the speed of sampling can be far in excess of even the best of digital multi-meters.
  • This fast response time enables diagnosis of intermittent problems and also enables the effect of disturbing parts of the system to be observed. When necessary, the response time can be slow enough to display signals such as the throttle position sensor.
  • Once the cause of a problem has been diagnosed and rectified, the repair can be verified by retesting with the oscilloscope.
  • The oscilloscope can also be used to check the overall condition of an engine management system equipped with a catalytic converter, by monitoring the activity of the oxygen sensor.
  • The complex electronic engine management systems fitted to catalyst equipped vehicles are designed to maintain the mixture level between quite close tolerances so that the oxygen sensor is able react to small changes in the exhaust oxygen level and feed this information back to the ECM in the form of a voltage signal. By watching the oxygen sensor signal with an oscilloscope any irregularity in the overall system performance can be detected. If the wave form displayed is satisfactory this is a reliable indication that the whole system is operating correctly.
  • Currently available oscilloscopes are easy to connect and use, enabling a trace to be displayed on the screen without any specialist knowledge or experience. The interpretation of this trace can be greatly assisted by reference to the typical wave forms illustrated in this chapter.

Wave forms - Fig 1

  • Each oscilloscope wave form has one or more of the following parameters:
  • Amplitude - voltage (V)
    • The signal voltage at a certain moment in time
  • Frequency - cycles per second (Hz)
    • The time between points of the signal
  • Pulse width - duty cycle (%)
    • The period during which the signal is ON - expressed as a percentage (%) of the total
  • Shape - spike, curve, saw-tooth etc.
    • The overall 'picture' of the signal
  • Pattern - repeated shapes
    • The pattern of repetition of the overall shape of the signal
  • The oscilloscope will show all these parameters in one display and by comparing the scope traces from the vehicle under test with those illustrated, a judgement can be made about the condition of each circuit and its components.
  • The scope trace for a faulty circuit or component will usually appear very different to that for a satisfactory one, thus simplifying fault identification.
  • The five parameters listed above can be categorised as follows:
Fig 1
Wave form parameters

Direct current (DC) voltage signals - amplitude only

  • Analogue signal voltages from components such as:
Fig 2 | Fig 3
Engine coolant temperature (ECT) sensor | Intake air temperature (IAT) sensor
Fig 4 | Fig 5
Throttle position (TP) sensor | Heated oxygen sensor (HO2S)
Fig 6 | Fig 7
Volume air flow (VAF) sensor | Mass air flow (MAF) sensor

Alternating current (AC) voltage signals - amplitude, frequency and shape

  • AC voltage signals are generated by components such as:
Fig 8 | Fig 9
Knock sensor (KS) | Engine speed (RPM) sensor - inductive type

Frequency modulated signals - amplitude, frequency, shape and pulse width

  • Frequency modulated signals are generated by components such as:
Fig 10 | Fig 11
Crankshaft position (CKP) sensor - inductive type | Camshaft position (CMP) sensor - inductive type
Fig 12 | Fig 13
Vehicle speed (VSS) sensor - inductive type | Hall effect speed and position sensors
Fig 14 | Fig 15
Optical speed and position sensors | Mass air flow (MAF) and manifold absolute pressure (MAP) sensors - digital type

Pulse width modulated signals - amplitude, frequency, shape, pulse width

  • Pulse width modulated signals from components such as:
Fig 16 | Fig 17
Injectors | Idle air control (IAC) devices
Fig 18 | Fig 19
Ignition coil primary circuits | Evaporative emission (EVAP) canister purge valve
Fig 20
Exhaust gas recirculation (EGR) valves

Serial data - amplitude, frequency, shape, pulse width and pattern

  • Serial data signals will be generated by the engine control module (ECM), if it has a self-diagnosis facility - Fig 21.
  • By noting the pulse width, pattern and frequency, the short pulses can be counted in groups and interpreted as a trouble code, in this case 1223.
  • The amplitude and shape remain constant and the pattern will be repeated until the trouble code has been erased.
Fig 21
Trouble code wave form

Interpreting wave forms

Typical wave forms - Fig 22 & Fig 23

  • Oscilloscope wave form patterns can vary greatly and are dependent on many factors. Therefore prior to making a diagnosis or changing components the following points should be considered when the wave form obtained does not appear to be correct when compared with the 'typical' wave form.
Fig 22 | Fig 23
Digital wave form | Analogue wave form

Voltage

  • Typical wave forms indicate the approximate position of the wave form in relationship to the 'zero grid', but this may vary fig 22 [1], dependent on the system being tested and may be positioned anywhere within the approximate 'zero range' Fig 22 [2] & Fig 23 [1].
  • The amplitude or overall height of the pattern (the voltage) Fig 22 [3] & Fig 23 [2], will depend on the circuit's operating voltage.
  • For direct current (DC) circuits this will depend on the voltage being switched, for example, idle speed control device voltage will be constant and will not vary with engine speed.
  • For alternating current (AC) circuits this will depend on the speed of the signal generator, for example, an inductive crankshaft position (CKP) sensor's output voltage will increase with engine speed.
  • Therefore if the oscilloscope pattern is too high (or the upper part is missing) increase the voltage scale to obtain the view required. If the pattern is too low decrease the voltage scale.
  • Some circuits operating solenoid components, for example idle speed control devices, may display voltage spikes Fig 22 [4], when the circuit is switched off. This voltage is generated by the component and can normally be ignored.
  • Some circuits that have a square wave type of typical wave form may display the voltage decaying at the end of the switching period Fig 22 [5]. This is a characteristic of some systems and can normally be ignored, as it does not by itself indicate a fault.

Frequency

  • The overall width of the pattern (the frequency), will depend on the circuit's operating speed.
  • The typical wave forms illustrated show the wave form viewed with the oscilloscope's time scale set to enable detailed observation.
  • In direct current (DC) circuits the time scale will be dependant on the speed at which the circuit is switched Fig 22 [6], for example, the frequency of an idle speed control device will vary with engine load.
  • In alternating current (AC) circuits the time scale will depend on the speed of the signal generator Fig 23 [3], for example, an inductive crankshaft position (CKP) sensor's frequency will increase with engine speed.
  • If the oscilloscope pattern is too compressed, decrease the time scale to obtain the view required. If the pattern is too expanded, increase the time scale.
  • If the pattern is reversed Fig 23 [4], this indicates that the system being tested has its component connected in the opposite polarity to the typical wave form shown and can normally be ignored as it does not by itself indicate a fault.

Component testing

  • Wave forms for a variety of components can be displayed. A few of the more common examples are described below.
  • Most modern oscilloscopes have just two test leads, used with a variety of interchangeable test probes. The red lead is the positive and is normally connected to the ECM pin. The black lead is the negative and is normally connected to a good earth.
  • If the leads are inadvertently connected with the wrong polarity, usually the only consequence is that the wave form will be displayed upside down.

Injectors

  • All electronically controlled intermittent injection systems operate by varying the opening time of the injectors to match the quantity of fuel supplied with the engine operating conditions.
  • The duration of the electrical impulses from the control module is measured in milliseconds (ms) and typically ranges from 1 to 14. The oscilloscope on most engine testers can be used to display the injector pulse, enabling the duration to be measured.
  • A typical oscilloscope trace is shown in Fig 24.
  • A series of smaller pulses, which hold the injector open after the initial negative pulse and a sharp positive voltage spike may be displayed as the injector closes.
  • It is therefore possible to check that the control module is operating correctly by observing the changes in injector opening times during various engine operating conditions.
  • Pulse duration during cranking and at idle speed will be higher than at low engine speeds, but will increase as the engine speed rises, up to a maximum at full throttle.
  • This effect will be particularly evident if the throttle is 'blipped'.
Fig 24
Injector wave form

Injector pulse

  • Using a thin probe, connect the oscilloscope test probe to the ECM injector terminal and the second test probe to earth.
  • Crank the engine and check the wave form.
  • Start engine and observe the wave form at idle speed.
  • Open the throttle rapidly to increase engine speed to around 3000 rpm.
  • The measured pulse duration should increase during acceleration and then stabilise at a reading equal to or slightly below the idle speed value.
  • Close the throttle rapidly and the trace should become a straight line with no pulse indicating that injection has been cut-off (for systems fitted with overrun injection cut-off).
  • When the engine is started from cold the quantity of fuel required is increased and therefore the pulse duration or dwell will be greater.
  • During warm-up the injection period should progressively decrease until the engine reaches normal operating temperature.
  • Systems without a cold start injector usually give additional injector pulses during the cold start, which may be seen as long and short pulses on the scope.

Typical injector duration periods

Condition | Duration
Idle speed | 1,5-5 ms
2000-3000 rpm | 1,1-3,5 ms
Full throttle | 8,2-8,4 ms

Inductive sensors

  • The general procedure is as follows:
  • Select sensor pin from pin data list with wave form reference.
  • Connect oscilloscope probe to ECM pin and second probe to earth.
  • Start engine and observe test conditions.
  • Compare scope trace with wave form reference.
  • Raise the engine speed and watch for the voltage (amplitude) display to increase.
Fig 25
Inductive sensor wave form

Idle air control (IAC) valve

  • Idle air control (IAC) valves come in many different types, each with a different wave form.
  • In each case the duty cycle (or ON time) of the valve should increase when any additional engine load starts to reduce the idle speed.
  • If the duty cycle varies but the idle speed is not maintained under load, this indicates a faulty valve.
  • If the wave form shows a straight line around the zero mark, or the line is constant at the 5 V or 12 V level, this indicates a fault in the IAC valve circuit or ECM signal output.
  • The commonly used 4 pin stepper motor type is described below. Two and three pin IAC valves can be tested in a similar way, but will of course generate very different wave forms.
  • The stepper motor responds to an oscillating signal from the ECM, enabling small adjustments to be made to the engine idle speed, in reaction to variations of operating temperature and load.
  • This voltage signal can be checked by connecting the oscilloscope test probe to each of the four stepper motor ECM pins in turn.
  • Ensure engine is at normal operating temperature.
  • Start the engine and allow idle speed to stabilise.
  • Increase the load on the engine by switching on the headlights, air conditioning or by turning the steering (power steering only).
  • The idle speed should momentarily drop, but then be stabilised by the action of the IAC valve.
  • Compare scope trace with wave form reference Fig 26.
Fig 26
Idle air control (IAC) valve wave form

Oxygen sensor (O2S)

  • NOTE: The following voltage figures refer to the almost universally used Zirconium type O2S, without a 0,5 V control reference. A few recent models are fitted with a Titanium sensor which has an operating range of 0-5 volts and shows a high voltage signal with a weak mixture and a low voltage signal with a rich mixture.

  • Connect oscilloscope test probes between oxygen sensor ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Compare scope trace with wave form reference Fig 27.
  • If the wave form is satisfactory at idle, open the throttle briefly several times in succession.
  • The wave form should show the signal voltage 'cycling' between approximately 0-1 Volt.
  • The increasing voltage corresponds to the engine speed rising and the decreasing voltage corresponds to the engine speed falling.
Fig 27
Oxygen sensor (O2S) wave form

Knock sensor (KS)

  • Connect oscilloscope test probes between knock sensor ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Briefly snap throttle open.
  • Wave form should display an AC signal showing a considerable increase in amplitude Fig 28.
  • If this signal is not distinctly displayed, tap the cylinder block lightly in the region of the sensor.
  • If the signal is still not satisfactory this indicates a faulty sensor or associated circuit.
Fig 28
Knock sensor (KS) wave form

Ignition amplifier

  • Connect oscilloscope test probes between ignition amplifier ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Start the engine and allow to idle.
  • The signal should show a digital DC voltage pulse.
  • Compare scope trace with wave form reference Fig 29.
  • If the signal is satisfactory the amplitude, frequency and shape of each pulse should be closely matched.
  • Increase the engine speed and check that the signal frequency increases in proportion to the engine rpm.
Fig 29
Ignition amplifier wave form

Ignition coil - primary

  • Connect oscilloscope test probes between ignition coil ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Start the engine and allow to idle.
  • Compare scope trace with wave form reference Fig 30.
  • Positive voltage spikes should be of even amplitude.

  • NOTE : Major differences of amplitude could indicate either a high resistance in the secondary circuit or a faulty spark plug or HT lead (where applicable).
Fig 30
Ignition coil wave form

Electronic control modules

  • Without specialist equipment and data no testing of control modules is possible, except by self-diagnosis (if applicable) or substitution.
  • Several companies operate a repair or exchange service for control modules and some offer a diagnosis service via a modem link to an appointed agent.
  • However it is possible to check:
    • The signal inputs.
    • The signal outputs.
    • The wiring.

NOTE : Refer to Autodata application for engine management system signal values.

NOTE : For information regarding control module self-diagnosis refer to model-specific chapter in this application.


System description

Introduction

All the systems covered by this application are controlled by a module which incorporates a self-diagnosis function. These control modules are capable of detecting certain faulty signals and storing them for access later. In many cases the detection of a faulty signal will cause the control module to invoke the limp-home mode, which adopts a mean signal value (programmed into the control module memory), to enable the vehicle to be driven until the fault can be diagnosed and rectified. In many early models faults are signalled by numerical trouble codes comprising two, three or four digits, which can be interpreted by reference to the code tables in this application. Later models have EOBD codes which are mandatory on new vehicles produced after January 2000. Trouble codes on early models may be displayed by an LED on the control module, or on the fascia mounted malfunction indicator lamp (MIL). If this is not possible then an LED tester can sometimes be used at the data link connector (DLC). If access to trouble codes is possible in this manner it is described along with the relevant code table. Many later models and those that comply with EOBD regulations may require a scan tool to enable the trouble code information to be displayed. Self-diagnosis for fuel injection, mapped ignition and integrated engine management systems has been used for many years, but with the more recently introduced electronically controlled transmissions and immobilizer systems, the scope for trouble code based fault diagnosis has expanded considerably and the adoption European On-Board Diagnostics (EOBD) has brought a degree of standardisation.

Engine management

  • The engine control module (ECM) processes the load and temperature signals received from the system sensors and controls the fuel/air ratio, idle speed, ignition timing and other functions through outputs to the actuators, such as injectors, idle speed control (ISC) valve, evaporative emission (EVAP) canister purge valve etc.
  • As emission regulations have become more stringent, more systems, such as throttle control, cruise control, transmissions and immobilizers have been linked to the ECM.
  • The ECM self-diagnosis fault memory will log trouble codes if certain inputs or outputs are outside the programmed parameters and may invoke 'limp home' substitute values for any out-of range signals, to enable the vehicle to continue to be driven until repairs can be carried out.
    • Fig 1
    Typical engine management system

Electronically controlled transmissions

  • Most electronically controlled transmission systems have sensors monitoring load, selector lever position, gear change strategy program, transmission output shaft speed, engine crankshaft speed, and speed of brake and throttle operation. Signals from these are sent to a combined engine and transmission (powertrain) control module or a separate transmission control module (TCM).
  • These inputs are processed by the transmission control module (TCM) and appropriate control outputs are sent to the transmission.
  • Where a separate engine control module (ECM) and transmission control module (TCM) are used, these are linked and data is shared between the two.
  • The self-diagnosis fault memory will log trouble codes when certain control module inputs or outputs are outside the programmed parameters and may invoke 'limp home' substitute values for any out-of range signals.
  • There are several types of transmission that can have electronic control with self-diagnosis trouble code output:
    • Automatic
    • Semi-automatic
    • 4 wheel drive
  • Automatic transmission: usually comprise a torque converter driven by the engine crankshaft and an epicyclic gearbox with four or five forward ratios.
  • The mechanical operation of the transmission is actuated hydraulically, but with electronic controls, enabling several different change patterns to be selected by the driver (e.g. sport, economy etc.). Smoother gear changes (using torque reduction by retarding the ignition timing) and better matching of gear ratios to available torque, are also advantages.
  • Lower powered (and often front-wheel drive) cars may be fitted with a continuously variable transmission. This may be driven via a torque converter, multi-plate clutch or magnetic coupling.
  • In this form of transmission a steel band is driven by a variable diameter drum and the output is from a similarly variable diameter drum. fixed ratios and finds its own 'ideal' ratio from the inputs of speed and load sensors.
  • Semi-automatic transmission: these are a comparatively recent innovation and use a conventional gearbox (helical spur gears) with hydraulically operated clutch. Electronics are used to ensure smooth gear changes, prevent excessive engine speeds and to 'blip' the throttle during down changes.
  • 4 wheel drive: vehicles with a Haldex coupling between the front and rear wheels have electronic control of the centre differential. Sensor inputs from the wheel speed sensors, stop lamp switch and other control modules (via a CAN data bus) are used to govern the power distribution between the front and rear wheels.
  • The transmission systems covered by this application have associated trouble codes which will be logged under certain fault conditions.
  • These codes may be part of the engine management trouble code output (in the case of powertrain control modules) or they may be accessed separately - refer to model-specific chapters.

    • Fig 2

    1. Selector lever
    2. Selector position switch
    3. Mode selection switch
    4. Kickdown switch
    5. Throttle position (TP) sensor
    6. Engine torque signal
    7. Engine speed (RPM) signal
    8. Output shaft speed (OSS) sensor
    9. Solenoid valves
    10. Transmission control module (TCM)
    11. Engine control module (ECM)
    12. Data link connector (DLC)
    13. Torque converter
    14. Ignition coils
    15. Epicyclic gearbox
    Typical electronically controlled automatic transmission components

Immobilizers

  • The immobilizer may be self-contained or integrated with the alarm system and remote control central locking, all activated from the key. The central locking will be operated separately by either an infrared or radio frequency signal and requires a self-contained battery supply.
  • The immobilizer may also be controlled by the infrared/radio frequency signal or separately by a transponder.
  • The transponder Fig 3 [1] is embedded in the ignition key Fig 3 [2], and is activated by a read coil Fig 3 [3] in the ignition switch Fig 3 [4]. The read coil is connected to the immobilizer control module Fig 3 [5] which is linked to the engine control module (ECM) Fig 3 [6].
  • The transponder uses induced power from the read solenoid and therefore does not require a battery supply.
  • When the ignition is switched on, the read solenoid induces a response from the transponder, which then transmits its unique security code to the immobilizer control module.
  • The key code is compared with the stored code in the immobilizer control module and then matched with the 'rolling' code in the ECM.
  • If all the criteria match, the engine will run normally.
  • If the immobilizer control module does not recognise the key code the engine will either not start or only run for a few seconds.
  • The immobilizer is automatically reset when the key is withdrawn from the ignition switch.
  • Many immobilizer systems feature fault memories which can be accessed in various ways e.g. by counting the immobilizer warning lamp flashes, bridging data link connector (DLC) terminals with a voltmeter or LED tester, or using suitable diagnostic equipment - refer to model-specific chapters.

    • Fig 3

    1. Transponder
    2. Key
    3. Read coil
    4. Ignition switch
    5. Immobilizer control module
    6. Engine control module (ECM)
    7. Data link connector (DLC)
    Typical electronically controlled automatic transmission components


Trouble code format

  • Prior to 2000 there was no uniformity in the display, format or method of retrieval of diagnostic trouble codes, each vehicle manufacturer developing a dedicated system with special diagnostic equipment and varying amounts of data logging. Some systems having just a few one or two digit codes while others had more comprehensive three and four digit coding systems.
  • In many cases the codes for these early systems could be displayed by connecting an LED tester between the appropriate terminals of the data link connector (DLC) and counting the flashes or groups of flashes.
  • For example Fig 1 shows a diagrammatic representation of three LED (or MIL) flashes. The vertical scale represents voltage and the horizontal scale represents time, therefore the shaded areas represent the 'on' time and the gaps in between represent the 'off' time.
  • The three short flashes, with a short pause separating each flash, display trouble code 3. If more than one code has been logged, a long pause would be used to separate each code.
  • If the trouble code is greater than 9, long flashes are used for the tens and short flashes for the units. For example Fig 2 shows one long flash, and two short flashes separated by a short pause, indicating trouble code 12.
  • In 1988 the California Air Resources Board (CARB) introduced legislation covering all new cars sold in California. These new laws governed on-board diagnostic requirements for emissions related faults and began the process of standardization in the US and eventually Europe.
  • These regulations were known as onboard diagnostic systems - phase I (OBD-I) and were subsequently adopted by the vehicle manufacturers, for states other than California.
  • The basic requirements of OBD-I were as follows:
  • A malfunction indicator lamp (MIL), to provide a visible warning that an emissions related fault had been logged by the engine control module (ECM).
  • Provision for the logging and storage, for subsequent retrieval, of diagnostic trouble codes (DTC)/flash codes for emissions related faults.
  • The location of the diagnostic socket, the method of access to the trouble codes and the configuration and scope of the self-diagnosis was left to individual vehicle manufacturers.
  • This resulted in an almost complete lack of standardization, requiring the technician to adopt different procedures and to use different equipment for each vehicle.
  • In 1995 the California Air Resources Board (CARB), after consultation with the Society of Automotive Engineers (SAE), introduced further legislation covering all new cars sold in California.
  • These regulations are known as OBD-II and have been adopted for all states. They closely define trouble code logging and retrieval. More significantly they require monitoring of the operation of the system and components, in addition to detecting component failures.
  • OBD-II also covers systems other than engine management.
  • Basically the US OBD-II regulations have been adopted for European vehicles and are known as EOBD - European On Board Diagnostics.
  • These EOBD regulations became mandatory for most new petrol engined vehicles produced after January 1st 2000 (diesel and LPG engined cars were not required to comply until 2003). Most petrol engined vehicles already in production before January 1st 2000 were granted exemption until January 1st 2001.
Fig 1
 Fig 2


EOBD codes

Basic requirements

  • Malfunction indicator lamp (MIL) located on the instrument panel, which either flashes or illuminates continuously, when a fault is detected. If no fault is present the MIL should illuminate when the ignition is switched on and extinguish when the engine starts.
  • Standard configuration of 16 pin data link connector (DLC).
  • The 16 terminals of the DLC are arranged in two parallel rows, with certain terminals defined by the EOBD regulations and the remainder allocated by the vehicle manufacturer.
          •
  • The terminals are assigned as follows:

  • NOTE: If ISO/SAE regulations are not used to provide on-board diagnosis (OBD) information, the assignment of the terminals 2, 6, 7, 10, 14 & 15 is left to the vehicle manufacturer.

    Terminal
    Assignment
    1
             Defined by vehicle manufacturer
    2
             Data bus (+) - SAE J1850
    3
             Defined by vehicle manufacturer
    4
             Chassis earth
    5
             Signal earth
    6
             CAN data bus, High - ISO 15765-4
    7
             K-line - ISO 9141-2/ISO 14230-4
    8
             Defined by vehicle manufacturer
    9
             Defined by vehicle manufacturer
    10
             Data bus (-) - SAE J1850
    11
             Defined by vehicle manufacturer
    12
             Defined by vehicle manufacturer
    13
             Defined by vehicle manufacturer
    14
             CAN data bus, Low - ISO 15765-4
    15
             L-line - ISO 9141-2/ISO 14230-4
    16
             Battery voltage

Standard location for the DLC

  • The standard location for the DLC is defined as being between the driver's end of the instrument panel and 300 mm beyond the vehicle centre line, accessible from the driver's seat.
  • The recommended location is between the steering column and the vehicle centre line.

Format of EOBD codes

5 character alpha-numeric trouble codes are made up as follows:

First character defines system group

  • B
             Body
    C
             Chassis
    P
             Powertrain
    U
             Network communications

Second character defines code type

  • Body / chassis
    0
             SAE defined (EOBD)
    1
             Manufacturer defined
    2
             Manufacturer defined
    3
             For future allocation
    Powertrain
    0
             SAE defined (EOBD)
    1
             Manufacturer defined
    2
             SAE defined (EOBD)
    3
             P3000-P3399 - Manufacturer defined,
    P3400-P3999 - SAE defined (EOBD)
    Network communications
    0
             SAE defined (EOBD)
    1
             Manufacturer defined
    2
             Manufacturer defined
    3
             SAE defined (EOBD)

Third character defines system area

  • Powertrain - P0/P1 code
    0
             Fuel, air or emission control
    1
             Fuel or air
    2
             Fuel or air
    3
             Ignition system or misfire
    4
             Emission control
    5
             Vehicle speed, idle speed control or auxiliary inputs
    6
             Computer or auxiliary outputs
    7
             Transmission
    8
             Transmission
    9
             Transmission
    A
             Hybrid propulsion
    B
             Hybrid propulsion
    C
             Hybrid propulsion
    D
             For future allocation
    E
             For future allocation
    F
             For future allocation
    Powertrain - P2 code
    0
             Fuel, air or emission control
    1
             Fuel, air or emission control
    2
             Fuel, air or emission control
    3
             Ignition system or misfire
    4
             Emission control
    5
             Auxiliary inputs
    6
             Computer or auxiliary outputs
    7
             Transmission
    8
             For future allocation
    A
             Fuel, air or emission control
    B
             Fuel, air or emission control
    C
             For future allocation
    D
             For future allocation
    E
             For future allocation
    F
             For future allocation
    Powertrain - P3 code
    0
             Fuel, air or emission control
    1
             Fuel, air or emission control
    2
             Fuel, air or emission control
    3
             Ignition system or misfire
    4
             Cylinder deactivation
    5
             For future allocation
    6
             For future allocation
    7
             For future allocation
    8
             For future allocation
    9
             For future allocation
    A
             For future allocation
    B
             For future allocation
    C
             For future allocation
    D
             For future allocation
    E
             For future allocation
    F
             For future allocation
    Network communications
    0
             Network electrical
    1
             Network communications
    2
             Network communications
    3
             Network software
    4
             Network data
    5
             Network data
    6
             For future allocation
    7
             For future allocation
    8
             For future allocation
    9
             For future allocation
    A
             For future allocation
    B
             For future allocation
    C
             For future allocation
    D
             For future allocation
    E
             For future allocation
    F
             For future allocation

The fourth and fifth characters define the specific fault.

  • These characters define general malfunction, range or performance of component or system, low or high input.

  • NOTE: Emissions related problems have a ISO defined list of codes and definitions starting with P0001.

Example code P0108

  • This code is logged when a high input is detected in the circuit of the manifold absolute pressure (MAP) sensor or barometric pressure (BARO) sensor.
  • P
             System -Powertrain
    0
             Code type - EOBD
    1
             System identification (fuel and air)
    08
             MAP/BARO sensor - circuit, high input

Hexadecimal codes

  • The trouble code is a hexadecimal number and therefore the third, fourth and fifth characters can be either a number (0-9), or a letter (A-F).
  • Unlike the decimal system that uses a base of 10, the hexadecimal system uses a base of 16. Using the characters 0-9 and A to F the number can be from 0-15.
  • Character
    0
    1
    2
    3
    4
    5
    6
    7
    8
    9
    A
    B
    C
    D
    E
    F
    Value
    0
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
  • By using the hexadecimal system 2 characters can equate to a maximum number of 255, in the decimal system the maximum number with 2 characters is 99.
  • For example:
  • Hex
    Decimal equation
    Decimal
    C8
             (12 x 16) + (8 x 1)
    200
    FF
             (15 x 16) + (15 x 1)
    255
    100
             (1 x 16 x 16) + (0 x 16) + (0 x 1)
    256

Standard areas monitored

The following areas are monitored continuously:

  • Misfire detection
  • Fuel system performance
  • Component performance

The following areas are monitored continuously:

  • NOTE: The definition of a 'trip' varies, but is basically - key ON, vehicle driven, key OFF.

  • Catalytic converter
  • Evaporative emission system
  • Secondary air (AIR) system
  • Air conditioning system
  • Heated oxygen sensor (HO2S)
  • Oxygen sensor (O2S) heater
  • Exhaust gas recirculation (EGR) system
  • In cases where flash codes and EOBD codes are listed for the same model range, only one flash code will be generated for a particular component, but there may be a list of many EOBD codes related to this component. Alternatively there may be some EOBD codes with no equivalent flash code(s).
  • These EOBD codes will provide more specific details about the fault location, wiring, voltage signals and other information relative to the circuit or system.

Fault logging and drive cycles with EOBD

  • Fault logging is based on inputs received during each 'trip' which may comprise a number of 'drive cycles'.
  • Each 'drive cycle' is initiated when the engine is started and is terminated when the engine is switched off.
  • For a complete 'trip' to be completed the following, complex, conditions need to be met (and may take several 'drive cycles' to complete):
    • Before starting the engine, coolant temperature should be below 50°C and +/-6°C of ambient temperature.
      • This ensures that the ECM logs a cold start.
    • Allow engine to idle for 2-3 minutes with an electrical load switched on (such as headlamps or heated rear window).
      • This will ensure that the misfire monitoring and fuel trim monitoring programmes run.
    • Drive vehicle up to at least 50 mph and maintain this speed for at least 3 minutes.
      • Misfire and fuel trim monitoring will run.
    • Allow the speed to reduce to around 20 mph without changing gear, using the brakes or the clutch.
      • Fuel trim monitoring will run.
    • Accelerate to at least 50 mph and maintain for at least 5 minutes.
      • Misfire and fuel trim monitoring will run.
    • Allow the speed to reduce to around 20 mph without changing gear, using the brakes or the clutch.
      • Fuel trim monitoring will run.
  • Each 'trip' starts when the engine is started and continues through a number of 'drive cycles' until all the EOBD monitors have completed a self-test.
  • The EOBD monitoring programme provides operating tolerance checks on all emissions related sensors and actuators. Some components/circuits are continuously monitored and some are only activated under predetermined operating conditions.
  • Misfire monitoring detects irregularities in the crankshaft position (CKP) sensor signal pattern and identifies which cylinder misfired and if the misfire is frequent enough to cause catalytic converter damage due to excess internal temperatures. If this is the case the MIL will flash.
  • If the misfire is likely to increase emissions above the EOBD limits and occurs on each of two consecutive 'trips' the MIL will flash. If the misfire is absent during the next three 'trips' the MIL will be extinguished.
  • When a trouble code is logged a number of data parameters are stored with it, to assist in accurate fault diagnosis. These are:
    • Vehicle speed
    • Engine coolant temperature
    • Engine rpm
    • Engine load
    • Oxygen sensor system status - open/closed loop
    • Distance since fault first logged
    • Long term fuel trim (LTFT) level
  • Most EOBD scan tools are capable of capturing this 'snapshot' of data and displaying (or printing) it for analysis to aid the fault diagnosis process.

After rectification

  • EOBD monitoring is very sensitive and replacement components may still be identified as faulty if their specifications do not exactly match the originals.
  • The trouble code memory must be completely erased and a 'trip' completed.
  • The trouble code memory should be accessed to establish that no further codes have been logged.


Index

Pin Data - Index

Safety precautions Test procedures Oscilloscope testing Tools & Equipment


Safety precautions

Airbags (Supplementary Restraint System - SRS)

Many of the models covered by this product are fitted with airbags as standard equipment. When working on a vehicle fitted with such a system, extreme caution must be taken to avoid accidental firing of the airbag, which could result in personal injury.
Unauthorised repairs to the system could render it inoperative, or cause it to inflate accidentally.

NOTE: All related wiring is encased in a yellow outer covering.

When the engine is started the AIRBAG warning lamp should go out after approximately 5-10 seconds, if not this indicates a fault in the system. The system should be checked and the fault corrected by a competent technician before any other work is undertaken.

  • NEVER attempt to test the system using a multi-meter.
  • NEVER tamper with or disconnect the airbag wiring harness.
  • NEVER make extra connections to any part of the system wiring harness or terminals.
  • ALWAYS ensure that the airbag wiring harness has not been trapped or damaged in any way when working on adjacent components or systems.

Electrical

CAUTION: To prevent the engine starting and to avoid damaging the catalytic converter(s), disconnect the fuel injector valve multi-plug(s) before cranking tests.

  • ALWAYS ensure that the battery is properly connected before attempting to start the engine.
  • DO NOT attempt to start the engine using a source in excess of 12 volts, such as a fast charger (16 volts) or by connecting two batteries in series (24 volts). ALWAYS disconnect the battery before charging it.
  • DO NOT disconnect the battery while the engine is running.
  • DO NOT connect the battery with reverse polarity.
  • DO NOT disconnect or touch the HT leads when the engine is being cranked or when it is running.
  • DO NOT connect or disconnect the electronic control module (ECM), or any other component of the fuel injection system while the ignition is switched ON.
  • DO NOT disconnect ECM Multi-plug within 30 seconds of switching ignition OFF.
  • DO NOT connect or disconnect multi-meters, voltmeters, ammeters or ohmmeters with the ignition switched ON.
  • DO NOT reverse the polarity of the fuel pump.
  • ALWAYS ensure that all electrical connections are in good condition and making good contact, PARTICULARLY the ECM connector.
  • ALWAYS disconnect the ignition coil, ECM, fuel pump relay/fuse before carrying out a compression test.
  • DO NOT flash a wire or circuit to earth to check that continuity exists.
  • Modern ignition systems operate at very high voltages and these high voltages can severely damage transistorised components such as a wrist-watch if electrical contact is made. Wearers of heart pacemaker devices, therefore, should not at any time carry out work involving ignition systems. In addition to the danger from electric shock, further hazards can arise through sudden uncontrolled body movement causing involuntary contact with moving parts of the engine, i.e. fan blades, pulleys and drive belts.
  • ALWAYS ensure that any replacement fuel or ignition system parts are correct for the application in question. Many units share common external features, but differ internally.

Mechanical

CAUTION: To minimise fire risk, fuel system must be depressurised before disconnecting any fuel lines or fuel system components.

  • ALWAYS disconnect the distributor before carrying out a fuel pump pressure or delivery check.
  • AVOID the risk of fire ALWAYS disconnect the ignition coil supply and earth the coil HT lead, so that NO HT spark can be emitted, before checking the fuel injector valves, or any other component of the fuel injection system likely to result in the presence of fuel in or around the engine bay.
  • AVOID the risk of fire NEVER work on the fuel injection system when SMOKING or close to a NAKED FLAME.
  • ALWAYS keep a fire extinguisher close at hand when working on the fuel injection system.
  • ALWAYS ensure that test equipment, leads, tools and especially items of clothing, are clear of moving parts and are not liable to fall into the engine bay, due to vibration, when the engine is running.


Test procedures

General notes

  • All pin data in this database refers to a closed circuit with all components connected.
  • Typical values are an approximate guide only and should not be regarded as specific.
  • Typical values should be measured with the engine at normal operating temperature, unless otherwise stated.
  • All test voltages are measured by connecting the positive meter probe to the engine control module (ECM) pin and the negative probe to earth or a second ECM pin.
  • Only ECM pins connected to a circuit are listed in pin data tables. Pins not listed may have a wire connected and even a measurable voltage output, but are not used.
  • If available, connect a breakout box between harness multi-plug and ECM.
  • Refer to Safety Precautions section of this product before proceeding with any tests.

Test procedure - without breakout box

  • Find the model related chapter from vehicle manufacturer, model name, year of manufacture, engine code and fuel system type.
  • If required locate ECM position within vehicle by referring to ECM locations section.
  • Turn to appropriate pin data table.
  • Ensure ignition switched OFF.
  • Connect fine test probes to multi-meter.
  • Pull out ECM for easy access to multi-plug(s).
  • Access wire side of harness multi-plug(s) by removing cover or dust boot.
  • Ensure ECM multi-plug(s) are securely connected.
  • Identify location of pin(s) to be tested from multi-plug diagram at beginning of appropriate pin data table.
  • Connect test probe between ECM terminal and a good earth or second ECM terminal (shown in brackets), from the wire side of the harness plug.
  • CAUTION: Avoid shorting a live connector terminal to earth with the test probe as this could damage the ECM, wiring and sensor.
  • NOTE conditions (e.g. Ignition ON, engine cranking, 3000 rpm etc.).
  • Measure signals at selected pins and compare results with data provided.
  • If the test involves a wave form pattern, refer to the Oscilloscope testing section of this product.
  • Verify any repairs by rechecking pin data.

Test procedure - with breakout box

  • Find the model related chapter from vehicle manufacturer, model name, year of manufacture, engine code and fuel system type.
  • If required locate ECM position within vehicle by referring to ECM locations section.
  • Turn to appropriate pin data table.
  • Ensure ignition switched OFF.
  • If required, pull out ECM for easy access to multi-plug(s).
  • Disconnect ECM harness multi-plug(s).
  • Connect T-harness between ECM, breakout box and vehicle harness.
  • Fit appropriate overlay card to breakout box (refer to equipment manufacturer's instructions).
  • Connect suitable test probes to multi-meter.
  • Ensure ECM and breakout box multi-plugs are securely connected.
  • Connect test probe between breakout box terminal and a good earth or second breakout box terminal.
  • CAUTION: Avoid shorting a live breakout box terminal to earth with the test probe as this could damage the ECM, wiring and sensor.
  • NOTE conditions (e.g. Ignition ON, engine cranking, 3000 rpm etc.).
  • Measure signals at selected pins and compare results with data provided.
  • If the test involves a wave form pattern, refer to the Oscilloscope testing section of this product.
  • Verify any repairs by rechecking pin data.


Oscilloscope testing

Oscilloscopes

  • Digital multi-meters are entirely satisfactory for checking circuits in a static condition and for instances where any change in reading is a gradual one, but for dynamic checking and the diagnosis of intermittent faults, the oscilloscope is a very powerful workshop tool.
  • Unlike older analogue oscilloscopes dedicated to HT ignition testing, a modern digital oscilloscope has a variable voltage scale, enabling low voltages (typically 0-5 V or 0-12 V) to be displayed and also an adjustable time scale, enabling any wave form to be displayed in the ideal manner.
  • Most oscilloscopes designed for automotive use can be hand-held and are therefore ideal for use in the workshop. They can also be used inside the car, while the vehicle is driven, to capture dynamic data.
  • Usually it is possible to store wave forms and associated data in an internal memory and then print out or download the information onto a PC, enabling the scope patterns to be studied in detail.
  • The oscilloscope display can show the amplitude, frequency, pulse width, shape and pattern of the signal received, by effectively drawing a graph of voltage (vertically) and time (horizontally).
  • It is easy to connect (normally just two leads) and the speed of sampling can be far in excess of even the best of digital multi-meters.
  • This fast response time enables diagnosis of intermittent problems and also enables the effect of disturbing parts of the system to be observed. When necessary, the response time can be slow enough to display signals such as the throttle position sensor.
  • Once the cause of a problem has been diagnosed and rectified, the repair can be verified by retesting with the oscilloscope.
  • The oscilloscope can also be used to check the overall condition of an engine management system equipped with a catalytic converter, by monitoring the activity of the oxygen sensor.
  • The complex electronic engine management systems fitted to catalyst equipped vehicles are designed to maintain the mixture level between quite close tolerances so that the oxygen sensor is able react to small changes in the exhaust oxygen level and feed this information back to the ECM in the form of a voltage signal. By watching the oxygen sensor signal with an oscilloscope any irregularity in the overall system performance can be detected. If the wave form displayed is satisfactory this is a reliable indication that the whole system is operating correctly.
  • Currently available oscilloscopes are easy to connect and use, enabling a trace to be displayed on the screen without any specialist knowledge or experience. The interpretation of this trace can be greatly assisted by reference to the typical wave forms illustrated in this chapter.

Wave forms

  • Each oscilloscope wave form has one or more of the following parameters:
  • Amplitude - voltage (V)
    The signal voltage at a certain moment in time
  • Frequency - cycles per second (Hz)
    The time between points of the signal
  • Pulse width - duty cycle (%)
    The period during which the signal is ON - expressed as a percentage (%) of the total
  • Shape - spike, curve, saw-tooth etc.
    The overall 'picture' of the signal
  • Pattern - repeated shapes
    The pattern of repetition of the overall shape of the signal
  • The oscilloscope will show all these parameters in one display and by comparing the scope traces from the vehicle under test with those illustrated, a judgement can be made about the condition of each circuit and its components.
  • The scope trace for a faulty circuit or component will usually appear very different to that for a satisfactory one, thus simplifying fault identification.
  • The five parameters listed above can be categorised as follows:

    Fig 1 - Wave form parameters

Direct current (DC) voltage signals - amplitude only

  • Analogue signal voltages from components such as:

    Fig 2 - Engine coolant temperature (ECT) sensor

    Fig 3 - Intake air temperature (IAT) sensor

    Fig 4 - Throttle position (TP) sensor

    Fig 5 - Heated oxygen sensor (HO2S)

    Fig 6 - Volume air flow (VAF) sensor

    Fig 7 - Mass air flow (MAF) sensor

Alternating current (ac) voltage signals - amplitude, frequency and shape

  • AC voltage signals are generated by components such as:

    Fig 8 - Knock sensor (KS)

    Fig 9 - Engine speed (RPM) sensor - inductive type

Frequency modulated signals - amplitude, frequency, shape and pulse width

  • Frequency modulated signals are generated by components such as:

    Fig 10 - Crankshaft position (CKP) sensor - inductive type

    Fig 11 - Camshaft position (CMP) sensor - inductive type

    Fig 12 - Vehicle speed (VSS) sensor - inductive type

    Fig 13 - Hall effect speed and position sensors

    Fig 14 - Optical speed and position sensors

    Fig 15 - Mass air flow (MAF) and manifold absolute pressure (MAP) sensors - digital type

Pulse width modulated signals - amplitude, frequency, shape, pulse width

  • Pulse width modulated signals from components such as:

    Fig 16 - Injectors

    Fig 17 - Idle air control (IAC) devices

    Fig 18 - Ignition coil primary circuits

    Fig 19 - Evaporative emission (EVAP) canister purge valve

    Fig 20 - Exhaust gas recirculation (EGR) valves

Serial data - amplitude, frequency, shape, pulse width and pattern

  • Serial data signals will be generated by the engine control module (ECM), if it has a self-diagnosis facility - Fig 21.
  • By noting the pulse width, pattern and frequency, the short pulses can be counted in groups and interpreted as a trouble code, in this case 1223.
  • The amplitude and shape remain constant and the pattern will be repeated until the trouble code has been erased.

    Fig 21 - Trouble code wave form

Interpreting wave forms

Typical wave forms

  • Oscilloscope wave form patterns can vary greatly and are dependent on many factors. Therefore prior to making a diagnosis or changing components the following points should be considered when the wave form obtained does not appear to be correct when compared with the 'typical' wave form.

    Fig 22 - Digital wave form

    Fig 23 - Analogue wave form

Voltage

  • Typical wave forms indicate the approximate position of the wave form in relationship to the 'zero grid', but this may vary Fig 22 [1], dependent on the system being tested and may be positioned anywhere within the approximate 'zero range' Fig 22 [2] & Fig 23 [1].
  • The amplitude or overall height of the pattern (the voltage) Fig 22 [3] & Fig 23 [1][2], will depend on the circuit's operating voltage.
  • For direct current (DC) circuits this will depend on the voltage being switched, for example, idle speed control device voltage will be constant and will not vary with engine speed.
  • For alternating current (ac) circuits this will depend on the speed of the signal generator, for example, an inductive crankshaft position (CKP) sensor's output voltage will increase with engine speed.
  • Therefore if the oscilloscope pattern is too high (or the upper part is missing) increase the voltage scale to obtain the view required. If the pattern is too low decrease the voltage scale.
  • Some circuits operating solenoid components, for example idle speed control devices, may display voltage spikes Fig 22 [4], when the circuit is switched off. This voltage is generated by the component and can normally be ignored.
  • Some circuits that have a square wave type of typical wave form may display the voltage decaying at the end of the switching period Fig 22 [5]. This is a characteristic of some systems and can normally be ignored, as it does not by itself indicate a fault.

Frequency

  • The overall width of the pattern (the frequency), will depend on the circuit's operating speed.
  • The typical wave forms illustrated show the wave form viewed with the oscilloscope's time scale set to enable detailed observation.
  • In direct current (DC) circuits the time scale will be dependant on the speed at which the circuit is switched Fig 22 [6], for example, the frequency of an idle speed control device will vary with engine load.
  • In alternating current (ac) circuits the time scale will depend on the speed of the signal generator Fig 23 [3], for example, an inductive crankshaft position (CKP) sensor's frequency will increase with engine speed.
  • If the oscilloscope pattern is too compressed, decrease the time scale to obtain the view required. If the pattern is too expanded, increase the time scale.
  • If the pattern is reversed Fig 23 [4], this indicates that the system being tested has its component connected in the opposite polarity to the typical wave form shown and can normally be ignored as it does not by itself indicate a fault.

Component testing

  • Wave forms for a variety of components can be displayed. A few of the more common examples are described below.
  • Most modern oscilloscopes have just two test leads, used with a variety of interchangeable test probes. The red lead is the positive and is normally connected to the ECM pin. The black lead is the negative and is normally connected to a good earth.
  • If the leads are inadvertently connected with the wrong polarity, usually the only consequence is that the wave form will be displayed upside down.

Injectors

  • All electronically controlled intermittent injection systems operate by varying the opening time of the injectors to match the quantity of fuel supplied with the engine operating conditions.
  • The duration of the electrical impulses from the control unit is measured in milliseconds (ms) and typically ranges from 1 to 14. The oscilloscope on most engine testers can be used to display the injector pulse, enabling the duration to be measured.
  • A typical oscilloscope trace is shown in Fig 24.
  • A series of smaller pulses, which hold the injector open after the initial negative pulse and a sharp positive voltage spike may be displayed as the injector closes.
  • It is therefore possible to check that the control unit is operating correctly by observing the changes in injector opening times during various engine operating conditions.
  • Pulse duration during cranking and at cold idle will be higher than at hot idle, and will increase as engine load increases.
  • This effect will be particularly evident if the throttle is 'blipped'.

    Fig 24 - Injector wave form

Injector pulse

  • Using a thin probe, connect the oscilloscope test probe to the ECM injector terminal and the second test probe to earth.
  • Crank the engine and check the wave form.
  • Start engine and observe the wave form at idle speed.
  • Open the throttle rapidly to increase engine speed to around 3000 rpm.
  • The measured pulse duration should increase during acceleration and then stabilise at a reading equal to or slightly below the idle speed value.
  • Close the throttle rapidly and the trace should become a straight line with no pulse indicating that injection has been cut-off (for systems fitted with overrun injection cut-off).
  • When the engine is started from cold the quantity of fuel required is increased and therefore the pulse duration or dwell will be greater.
  • During warm-up the injection period should progressively decrease until the engine reaches normal operating temperature.
  • Systems without a cold start injector usually give additional injector pulses during the cold start, which may be seen as long and short pulses on the scope.

Typical injector duration periods

Condition | Duration
Idle speed | 1-6 ms
2000-3000 rpm | 1-6 ms
Full throttle | 6-35 ms

Inductive sensors

  • The general procedure is as follows:
  • Select sensor pin from pin data list with wave form reference.
  • Connect oscilloscope probe to ECM pin and second probe to earth.
  • Start engine and observe test conditions.
  • Compare scope trace with wave form reference.
  • Raise the engine speed and watch for the voltage (amplitude) display to increase.

    Fig 25 - Inductive sensor wave form

Idle air control (IAC) valve

  • Idle air control (IAC) valves come in many different types, each with a different wave form.
  • In each case the duty cycle (or ON time) of the valve should increase when any additional engine load starts to reduce the idle speed.
  • If the duty cycle varies but the idle speed is not maintained under load, this indicates a faulty valve.
  • If the wave form shows a straight line around the zero mark, or the line is constant at the 5 V or 12 V level, this indicates a fault in the IAC valve circuit or ECM signal output.
  • The commonly used 4 pin stepper motor type is described below. Two and three pin IAC valves can be tested in a similar way, but will of course generate very different wave forms.
  • The stepper motor responds to an oscillating signal from the ECM, enabling small adjustments to be made to the engine idle speed, in reaction to variations of operating temperature and load.
  • This voltage signal can be checked by connecting the oscilloscope test probe to each of the four stepper motor ECM pins in turn.
  • Ensure engine is at normal operating temperature.
  • Start the engine and allow idle speed to stabilise.
  • Increase the load on the engine by switching on the headlights, air conditioning or by turning the steering (power steering only).
  • The idle speed should momentarily drop, but then be stabilised by the action of the IAC valve.
  • Compare scope trace with wave form reference Fig 26.

    Fig 26 - Idle air control (IAC) valve wave form

Oxygen sensor (O2S)

NOTE: The following voltage figures refer to the almost universally used Zirconium type O2S, without a 0,5 V control reference. A few recent models are fitted with a Titanium sensor which has an operating range of 0-5 volts and shows a high voltage signal with a weak mixture and a low voltage signal with a rich mixture.

  • Connect oscilloscope test probes between oxygen sensor ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Compare scope trace with wave form reference Fig 27.
  • If the trace shows no wave form but instead is a straight line, this usually indicates a weak mixture if the voltage is approximately 0-0,15, or a rich mixture if the voltage is approximately 0,6-1 - refer to the Autodata product for possible causes of this condition.
  • If the wave form is satisfactory at idle, open the throttle briefly several times in succession.
  • The wave form should show the signal voltage 'cycling' between approximately 0-1 Volt.
  • The increasing voltage corresponds to the engine speed rising and the decreasing voltage corresponds to the engine speed falling.

    Fig 27 - Oxygen sensor (O2S) wave form

Knock sensor (KS)

  • Connect oscilloscope test probes between knock sensor ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Briefly snap throttle open.
  • Wave form should display an ac signal showing a considerable increase in amplitude Fig 28.
  • If this signal is not distinctly displayed, tap the cylinder block lightly in the region of the sensor.
  • If the signal is still not satisfactory this indicates a faulty sensor or associated circuit.

    Fig 28 - Knock sensor (KS) wave form

Ignition amplifier

  • Connect oscilloscope test probes between ignition amplifier ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Start the engine and allow to idle.
  • The signal should show a digital DC voltage pulse.
  • Compare scope trace with wave form reference Fig 29.
  • If the signal is satisfactory the amplitude, frequency and shape of each pulse should be closely matched.
  • Increase the engine speed and check that the signal frequency increases in proportion to the engine rpm.

    Fig 29 - Ignition amplifier wave form

Ignition coil - primary

  • Connect oscilloscope test probes between ignition coil ECM pin and earth.
  • Ensure engine is at normal operating temperature.
  • Start the engine and allow to idle.
  • Compare scope trace with wave form reference Fig 30.
  • Positive voltage spikes should be of even amplitude.
  • Major differences of amplitude could indicate either a high resistance in the secondary circuit or a faulty spark plug or HT lead (where applicable).

    Fig 30 - Ignition coil wave form

Electronic control modules

  • Without specialist equipment and data no testing of control modules is possible, except by self-diagnosis (if applicable) or substitution.
  • Several companies operate a repair or exchange service for control modules and some offer a diagnosis service via a modem link to an appointed agent.


Tools & equipment

General recommendations

  • Electronic control modules such as the engine control module (ECM) need special care during engine management system fault diagnosis. They are easily damaged by excess voltage or reversed polarity. Whenever possible disconnect them before testing wiring continuity.
  • Some ECMs have an adaptive memory which may have to be re-learned (during driving) if the power supply is interrupted, for instance to erase fault codes.
  • Electrical wiring can be repaired where practicable but ensure that all repairs are properly insulated, preferably with heat shrink tubing and protected by a fuse of the correct amperage.

    NOTE: Many other electronic control modules fitted to the vehicle could have fault memories which may be erased if the power supply is interrupted.

  • Check condition of ALL fuses in the system prior to circuit testing.

Test equipment

Multi-meter types

  • The majority of electrical tests described on this product require the use of a digital multi-meter. Many suitable instruments are available, with a wide range of prices and specifications, as described below.
  • Certain other tools, such as a breakout box, digital oscilloscope (see separate section), vacuum pump, and memory saver will be necessary, or desirable to make best use of this product.
  • A high impedance (10 K ohms/volt minimum) multi-meter that includes a 0-20 V voltage scale and a low (0-200) and high (0-20 K) range ohm scale is recommended for measuring the voltage and resistance of the system components.
  • Analogue meters (with a needle sweeping across a numerical scale), due to their continuous readout are useful for certain applications, such as counting needle deflections to identify fault codes on certain models and the identification of intermittent faults, but for general workshop use a digital meter is easier to use and is more resistant to rough handling and less likely to be damaged by incorrect use.
  • Digital meters (with an LED or LCD display), are available in many different types. In addition to the basic, general purpose meters with voltage, resistance and amperage scales additional features such as temperature, duty cycle and engine RPM etc. are often incorporated in dedicated test meters for automobile applications.

Using multi-meters

Voltage checking

  • Set the meter to VOLTAGE.
  • If applicable, set the meter to the correct scale e.g. ac/DC, V/mV etc. (most modern meters are self-ranging).
  • Connect the black test lead to a good earth or the negative battery terminal.
  • Observe the conditions of the test, e.g. ignition OFF, ignition ON etc.
  • Connect the red test lead to the positive terminal being tested.
  • If the meter does not automatically select the appropriate voltage range, ensure correct meter scale selected, e.g. 0-12 volts.
  • Read and record the value displayed.
    • Measurement of voltage drop through cables and components can be a useful diagnostic tool, as any abnormal condition will have an effect on the operation of the circuit(s) and components involved.
    • The multi-meter should be set to measure milli-volts and the circuit should be in its normal operating mode e.g. all multi-plugs connected and current flowing.
    • Maximum voltage drop should not exceed the following values:
      • Control module harness wire - 200 mV
      • Switch - 300 mV
      • Earth connection - 100 mV
      • Sensor connection - 50 mV

Fig 1 - Checking voltage with multi-meter

Fig 2 - Checking supply voltage - harness multi-plug disconnected

Fig 3 - Checking signal voltage between wires - harness multi-plug connected

Fig 4 - Checking signal voltage between wire and earth - component multi-plug connected

Resistance and continuity checking

  • High resistance in earth connections can cause unusual (and apparently illogical) symptoms that are seemingly unconnected with the components involved.
  • Earth connections should be thoroughly cleaned and treated with a proprietary contact cleaner before assembly.
  • Connections in the vicinity of the battery are particularly vulnerable to corrosion.
  • Earth wires should be checked along their whole length for chafing, corrosion and mechanical damage. A typical earth wire may have 20-30 strands and although there will still be a connection if only a few of these are intact, the resulting high resistance will cause problems.
  • Suspect multi-plugs should be 'dismantled' (if possible) and the terminals thoroughly inspected and cleaned.
  • Set the meter to RESISTANCE.
  • If applicable, set the meter to the correct scale (most modern meters are self-ranging).
  • Connect the black test lead to the red test lead and check that the meter displays ZERO W.

    NOTE: If ZERO W is not displayed, refer to the meter operating instructions.

  • Disconnect the component from any wiring.
  • Connect the black test lead to one terminal being tested.
  • Connect the red test lead to the other terminal being tested.
  • Read and record the value displayed.
  • If the meter displays ZERO, Fig 5 this indicates continuity.
  • If the meter displays INF (infinity) Fig 6, this indicates NO continuity (open circuit).

Fig 5 - Circuit continuity

Fig 6 - Open circuit

Fig 7 - Checking component resistance

Fig 8 - Checking earth connection at harness multi-plug

Diode checking

  • Set the meter to RESISTANCE or DIODE.
  • Connect the red test lead to positive terminal of the diode.
  • Connect the black test lead to the negative terminal of the diode.
  • The meter should display continuity Fig 9.
  • Reverse the test leads, the meter should display NO continuity Fig 10.

    NOTE: If the meter displays continuity in both tests the diode is faulty.

Fig 9 - Continuity through diode

Fig 10 - No continuity through diode

Signal checking with LED tester

CAUTION: Circuit testers incorporating a bulb should not be used on electronic circuits as the high current involved could damage sensitive components.

  • LED testers can be used safely on electronic circuits as their low current consumption cannot damage electronic components.
  • They are particularly useful where a pulse or intermittent signal is being checked.
  • Most LED testers are in the form of a probe attached to the tester body, with a test lead and clip for the other terminal. The more sophisticated testers have different coloured LEDs to indicate polarity.

Fig 11 - Checking sensor signal with LED tester - multi-plug connected

Breakout box

  • Whenever possible a breakout box should be used for circuit testing at the control module multi-plug and when checking pin data.
  • A breakout box [1] is a means of connecting test equipment to the control module harness without the need to probe into the back of the harness multi-plug. For checking pin data it is connected by an adaptor lead [2] between the ECM [3] and the car's wiring harness [4].
  • For circuit testing the harness multi-plug is disconnected from the control module and connected to the breakout box.
  • The pin connections are laid out in rows in numerical order and have large connecting sockets, enabling test leads to be securely plugged into a circuit, and avoiding the possibility of connecting to the incorrect pin, due to miscounting.
  • The possibility of damaging components or wiring, due to shorting live pins to ground or to other components, is also much reduced.
  • The limiting factor is the range of adaptor leads. Several equipment manufacturers produce breakout boxes, but none are able to supply a complete range of leads to cover all the models included in this product.

Fig 12 - Breakout box connections

ECM harness multi-plug testing

  • If a breakout box and suitable adaptor leads are not available, testing must be carried out at the wire side of the ECM harness multi-plug Fig 13.
  • To access the terminals the protective cover must be removed from the plug. Many different types of plug are used for engine management wiring harnesses and two examples are shown in Fig 14 and Fig 15.
  • Use the appropriate ECM harness multi-plug - wire side diagram and identify the pin(s) to be tested - refer to the Autodata product.
  • Use only very fine test probes to access the connections and measure the signal between the pin and earth Fig 13 [1], or between two ECM pins Fig 13 [2].

Fig 13 - Testing at wire side of harness multi-plug

Fig 14 - Testing at harness multi-plug

Fig 15 - Testing at harness multi-plug

Other tools

Vacuum pump

  • A hand operated vacuum pump, with gauge, will be necessary for testing certain components, such as manifold absolute pressure (MAP) sensors.
  • Several types are available and are usually supplied with a connecting hose and a selection of adaptors.

Fig 16 - Typical vacuum pump

Memory savers

  • With the increasing number of electronic devices incorporating a memory, whenever the battery is disconnected inconvenience is caused by the loss of such information as radio security codes and station settings, clock settings and ECM memories.
  • This situation can be avoided by the use of an alternative power source such as the memory savers marketed by several of the leading test equipment manufacturers.


Index

Airbags - Index

Supplementary restraint systems Safety and general procedures Storage and handling Frequently asked questions


Supplementary restraint systems

Introduction

During the mid 80's driver's airbags were introduced as a cost option on low volume top-of-the-range luxury cars. By the early 90's they were being fitted as standard on volume production models.

Since then airbags have become available for front passengers and also as side and head protection for drivers and passengers. Alongside airbags, seat belt pretensioners have been developed. These are either mechanical (by springs) or pyrotechnic (by explosive charge).

The use of airbags as a supplementary restraint system (SRS) results in a reduction in injuries from glass splinters, impact with interior fittings and reduced chance of head, neck and shoulder injuries.

The large energy-absorbing area of the airbags spreads the impact and controlled deflation results in gradual dissipation of energy.

Airbags provide a certain amount of protection to occupants not wearing seat belts, however those fitted to European specification vehicles are designed to be effective in conjunction with a seat belt and are therefore generally smaller than those fitted to US specification models, where the wearing of seat belts is not mandatory.

Mechanical airbags

  • Mechanical airbags can be fitted to the driver's side (on the steering wheel) and on the passenger's side (behind the fascia trim).
  • They are entirely self-contained units, requiring no external electrical circuitry or power supply.
  • The airbag assembly incorporates a tightly folded airbag, inflator (gas generator), inertia deceleration sensor and a mechanical triggering device.
  • An automatic safety device is usually incorporated which disarms the unit when it is removed from its mounting.
  • In the event of a collision the steel ball in the inertia device moves forward releasing the spring-loaded trigger pin.
  • The trigger pin activates a detonator which causes the gas generator pellets to produce, almost instantly, enough gas to inflate the airbag.
  1. Airbag trim cover
  2. Folded airbag
  3. Inflator (gas generator)
  4. Inertia deceleration sensor
  5. Trigger device
  6. Mounting ring with deactivation device
  7. Gas generator pellets

Electronically controlled SRS systems

The main components of an SRS system are:
  • Driver's airbag - middle of steering wheel
  • Passenger's airbag - behind passenger's fascia
  • Side airbags - incorporated in outer side of seat backrests
  • Door airbags - behind door trim panels, often with separate crash sensors also in the doors
  • Head airbags - behind roof trims
  • Side curtains - behind roof trims
  • Seat belt pretensioners - normally fitted to front and sometimes rear seat belts
  • Control module - either behind the driver's airbag or in the car (often under centre console)
  • Crash sensor - either underbonnet, behind fascia, under seats or incorporated in control module
  • Passenger's seat pressure sensor - under seat cushion
  • Safing sensor - usually incorporated in SRS control module
  • Capacitor - usually incorporated in SRS control module
  • Deactivation switch - on fascia panel
  • Slip ring or spiral cable - behind steering wheel

Schematic layout of electronic SRS system

  1. SRS control module
  2. Ignition switch
  3. Battery
  4. Front crash sensors
  5. Spiral cable
  6. Igniter/gas generator
  7. Driver's airbag
  8. Passenger's airbag deactivation switch
  9. Passenger's seat pressure sensor
  10. Passenger's airbag
  11. Seat belt pretensioners
  12. Side impact crash sensors
  13. Side airbags
  14. Data link connector (DLC)
  15. SRS warning lamp

Airbag operation

  • The driver's and passenger's airbags are controlled by sensors which will only react to a frontal impact above 10 mph and within an arc of approximately 60° around the front of the vehicle Fig 2.
  • The driver's and passenger's airbags will not be triggered by a side or rear impact or if the car turns over.

Fig 2

  • The deployment of an airbag is effectively instantaneous. Only approximately 100-150 milliseconds elapse between the initial impact and the time the airbag deflates.
  • During this time a signal from the SRS control module has triggered the solid propellant, which has ignited to produce sufficient gas to fully inflate the airbag Fig 4 & Fig 5. The driver's head has contacted the airbag Fig 6 and returned to the upright position Fig 7 and the airbag has completely deflated.
  • If the vehicle is fitted with seat belt pretensioners, these will have deployed, taking up any slack between the seat belt and the wearer.

Fig 3

Fig 4

Fig 5

Fig 6

Fig 7

Airbag construction

  • The airbag is made from a woven fabric with a silicone coating to protect it from hot gases. It is tightly folded behind the cover and has discharge holes which enable the gas to escape quickly after full inflation.
  • Most airbags are concealed by cover panels with predetermined split lines, which enable the bags to burst through on deployment, without detaching loose areas of trim.
  • In some cases the cover may be attached by a length of webbing which restrains its movement when the airbag is deployed, avoiding the danger of flying debris.
  • The covers form the outer surface of the steering wheel and passenger's side fascia and are usually identified by 'airbag' or 'SRS' moulded into the cover.

Inflator and igniter

  • The inflator is a steel casing filled with a propellant charge and connected to an igniter. When the propellant is ignited it produces enough gas (mostly Nitrogen), which passes through a filter, to fill the airbag.
  • The igniter is usually electrically triggered by a signal from the control module, but a few vehicles are fitted with mechanically triggered units.

Fig 8

  1. Igniter
  2. Inflator

Front airbags

  • The driver's airbag is securely fitted to the centre of the steering wheel Fig 9. The passenger's airbag is incorporated in the fascia panel Fig 10.
  • Airbags are designed to be triggered by moderate to severe frontal impacts.
  • Once the vehicle sensor(s) detect a sudden deceleration and this is confirmed by the safing sensor a signal is sent to the igniter and the gas generator is ignited.
  • A mixture of Nitrogen and Carbon Dioxide is produced, rapidly inflating the airbag. The increasing pressure splits open the trim cover and the airbag deploys in front of the driver or passenger. The airbag rapidly deflates by venting the gas through openings in the airbag.
  • The gas passes through a filter and cools as it fills the airbag.
  • After inflation there may be a residue of harmless powder which is used to lubricate the airbag as it deploys.
  • Passenger's airbags are approximately 2-3 times larger in capacity than the driver's airbags, as the distance between the fascia and the passenger is much greater than that between the driver and the steering wheel.

Fig 9

  1. Airbag cover trim
  2. Gas generator
  3. Igniter

Fig 10

  1. Connecting harness
  2. Igniter/inflator
  3. Airbag
  4. Cover (fascia panel)

Side and door airbags

  • These are mounted in the sides of the seat backrests Fig 11 and behind the door trim panels Fig 12. Due to the very limited space between the occupants and the structure of the vehicle these airbags have an extremely rapid inflation time (typically 10 milliseconds).

Fig 11

  1. Seat frame
  2. Airbag housing
  3. Airbag
  4. Igniter/inflator

Fig 12

  1. Connecting harness
  2. Inner door skin
  3. Airbag assembly

Head airbags and side curtains

  • These normally extend from the windscreen pillar to the rear quarter panel Fig 13. In the case of the side curtain these drop down to cover the glass area and B post Fig 14.
  • They are triggered by separate side impact sensors.
  • Head airbags and side curtains remain inflated longer than other airbags, to provide protection in the event of the vehicle rolling over.

Fig 13

Fig 14

Control module

  • The control module responds to inputs from the crash sensors and activates the airbags and pretensioners. It may also be linked to the central locking system, to ensure that the doors are unlocked in the event of an accident.
  • If there are no separate sensors, the safing and crash sensors will be incorporated in the module.
  • If the system incorporates self-diagnosis, faults in the SRS system will be logged by the module, causing the SRS warning lamp to stay on. In certain cases the control module may disable the system until repairs are carried out.
  • Modules that incorporate crash sensors are direction-sensitive and will only work satisfactorily when correctly orientated.

Fig 15

  1. Mounting direction arrow
  2. Special fixing screws
  3. Harness multi-plug security clip
  4. SRS harness multi-plug

Slip ring or spiral cable ('clock spring')

  • The slip ring or spiral cable provides the electrical connection between the steering wheel and the driver's airbag assembly. It also connects any other steering wheel mounted controls, such as horn, cruise control etc. The slip ring has unlimited rotational movement, but the spiral cable has only limited movement, due to the coiled ribbon connection enclosed within the inner and outer casings.

Fig 16

  1. Fixed housing
  2. Movable housing
  3. Harness connectors

Crash sensors

  • Electronic crash sensors are either incorporated in the control module or mounted separately. They are connected in series with a safing sensor, to prevent unintentional triggering of the system.
  • They are sensitive to a combination of G force and duration. This avoids accidental triggering by, for instance, a direct blow to the sensor or control module, or light impacts from parking bumps etc.
  • Some models have separate sensors for the airbags and the pretensioners.
  • Crash sensors are direction sensitive and will only work satisfactorily when correctly orientated.

Fig 17

  1. Gold plated ball
  2. Permanent magnet
  3. Gold plated contacts
  4. Guide sleeve

Safing sensor(s)

  • The safing sensor, which may be a mercury or reed switch, is connected in series with the crash sensor(s) as a back-up to ensure that the SRS system is not deployed unless absolutely necessary.
  • Unless both the crash and safing sensors detect a deceleration in excess of a predetermined limit the airbag(s) will not be deployed.

Warning lamp

  • The warning lamp warns the driver of any SRS system malfunction and in some cases will display a self-diagnosis trouble code.
  • If the warning lamp does not illuminate, is permanently illuminated or flashing this indicates a system fault, and in the event of a crash the airbag(s) and pretensioner(s) may not work correctly (or at all).

Fig 18

Wiring harness

  • The SRS wiring harness is specially designed to ensure that the possibility of disconnection, shorting and picking up spurious signals is almost eliminated.
  • The SRS wiring is often colour coded or covered in colour coded sheathing (often yellow) and may have special multi-plugs which incorporate a shorting clip Fig 19. When this type of plug is disconnected the two contacts of the airbag lead are shorted together to prevent accidental triggering.
  • The multi-plugs usually have a positive locking device to safeguard against accidental disconnection.

Fig 19

  1. Contacts to igniter
  2. Shorting contacts

Pretensioners

  • Pretensioners take up any slack in the seat belt and pull the webbing tight against the wearer's body.
  • The pretensioner mechanism may act on the inertia reel, the buckle assembly or the B post mounting.
  • The pretensioners can be activated independently of the airbag system, however if the front airbags have been deployed the pretensioners will also be have been activated.
  • Deployment of passenger's seat belt pretensioners may be inhibited by seat pressure sensors or inertia reel micro switches, which signal to the control module that the seat or seat belt is not in use.

Mechanical

  • Mechanical pretensioners Fig 20 are activated by compressed coil springs which, when deployed, pull the seat belt webbing tight against the wearer's body.
  • This reaction can be achieved by pulling the buckle assembly down.

Fig 20

  1. Seat belt webbing
  2. Pre-loaded spring
  3. Connecting cable

Pyrotechnic

  • Pyrotechnic pretensioners have a gas generator which acts on a piston Fig 21, a column of steel balls Fig 22, a fluid turbine or a 'Wankel engine rotor' Fig 23 connected to the seat belt. In the latter case three gas generators are used which are triggered in succession, depending on the amount of belt slack to be reeled in and therefore the degree of rotation of the rotor.
  • Triggering may be by inertia switch or electrical igniter which reacts to the deceleration of the vehicle on impact.
  • Once the pretensioner has been triggered it must be replaced.

Fig 21

  1. Seat belt webbing
  2. Connecting harness
  3. Triggering device/gas generator

Fig 22

  1. Triggering device/gas generator
  2. Seat belt inertia reel
  3. Gear wheel
  4. Ball reservoir
  5. Seat belt webbing

Fig 23

  1. Triggering device
  2. 'Wankel' rotor
  3. Firing pin
  4. Gas generator
  5. Expanding gas

Seat pressure sensor

  • This sensor is used to identify if a particular seat is occupied. It consists of a pressure-sensitive pad incorporated in the seat cushion.

Fig 24

Deactivation

  • Due to the incompatibility between front child safety seats and airbags some models are fitted with a deactivation switch (usually operated by the ignition key) which enables the owner to deactivate the front passenger's airbag.
  • Alternatively deactivation may only be possible using diagnostic equipment plugged into the data link connector (DLC).
  • A separate warning lamp may be provided, or the SRS warning lamp may stay on for an extra period, to indicate that the airbag has been deactivated.

Fig 25

Back-up power

  • When the battery supply has been cut off by an impact, back-up electrical power for triggering the SRS components is provided by one or more capacitors incorporated in the system (usually in the control module).
  • This means that when the battery is disconnected the system will remain 'live' for a short time. Most manufacturers specify a waiting time (up to 30 minutes) to render the system safe to work on.

Fixing brackets and bolts

  • These are safety-critical parts and should always be carefully inspected for damage after deployment of any of the SRS components.
  • If any damage is evident new parts should be fitted.
  • All specified torque figures should be carefully followed, as overtightening can result in the components becoming inoperative through distortion.


Safety and general procedures

Airbags and pyrotechnic pretensioners are safety devices, but as they contain explosives they are capable of causing injury if mishandled.

Always refer to model-specific information before starting work on an SRS system and observe the following recommendations.

Disarming

NOTE: In the case of an emergency, involving a model not covered in this product, the following guidelines can be followed. However there are certain systems that can only be deactived by using specialist equipment.

  • Ensure that any electronic codes are recorded (i.e. radio code).
  • Switch ignition OFF.
  • Remove ignition key.
  • NEVER connect a battery powered 'memory saver' unit.
  • Disconnect all battery leads, ensure that accidental reconnection is not possible.
  • Wait at least 30 minutes.
  • Mechanically lock pretensioners (where applicable).

Arming

  • Ensure vehicle interior is unoccupied before arming the system.
  • Ensure ignition switched OFF.
  • Reconnect all battery leads.
  • Switch ignition ON.
  • Check SRS warning lamp operation, if lamp fails to illuminate, illuminates and remains on or flashes this indicates a fault in the system.

After deployment

NOTE: The metal parts of the airbag and pretensioner will be very hot after deployment and 20-30 minutes should be allowed before touching any of them.

WARNING: Wear gloves and eye protection when working on deployed airbags as the chemical residues can cause skin irritation. Wipe affected areas of the vehicle with a damp cloth or clean with a vacuum cleaner. Any areas of skin that come into contact with deployed airbags should be washed with soap and water.

Check the following

  • Windscreen for smoke or heat damage.
  • SRS wiring harness and connectors for charred or damaged areas.
  • All SRS mounting brackets.
  • All SRS components including undeployed airbag(s)/pretensioner(s).
  • Fascia/instrument panel.
  • Seat assemblies.
  • Seat belts, including buckles and anchorage points.
  • Steering wheel and column.
  • Surrounding components and trims.
  • SRS control module and bracket.
  • SRS control module fault memory.

Slip ring

  • Some models (usually with only a driver's airbag) have a slip ring connecting the steering wheel to the vehicle harness.
  • The slip ring comprises a fixed circular contact ring and a moving contact (attached to the steering wheel).
  • The slip ring has unlimited rotational movement and therefore does not require centralising when the steering wheel is removed and replaced.

Spiral cable ('clock spring')

  • This component provides a permanent connection between the airbag assembly and the rest of the SRS system.
  • The spiral cable assembly is a two-piece moulding [1] with a flexible, coiled connection between the two parts [2].
  • One part is fixed to the steering wheel and the other part to the outer steering column, with a limited (usually 6-7 turns) rotational movement.
  • The spiral cable assembly must be centralised with the road wheels in the straight-ahead position, otherwise when the steering is turned one way the cable will be strained and eventually break.
  • In cases where the central position has been lost and there are no obvious alignment marks [3], the following procedure can be carried out (with the steering wheel removed):
  • Turn clockwise until resistance is felt.
  • Turn anti-clockwise and count turns, until resistance is felt.
  • Turn clockwise half the number of turns noted in the previous operation.
  • Refit the steering wheel, ensuring that the spiral cable does not move.
  • If in any doubt a new replacement unit should be fitted.

Safety precautions

Carefully inspect all components for damage, such as cracks, dents or evidence of being dropped. Any damaged components should be disposed of safely.

Check for signs of contamination, such as water or oil, before installation. Any contaminated components should be disposed of safely.

  • NEVER carry out resistance checks on SRS components, undeployed airbags or pyrotechnic pretensioners.

    NOTE: If a trouble code is logged and the probable cause is a high or low resistance, trouble shooting should NOT be carried out with an ohmmeter. Any faulty components should be replaced with new items.

  • NEVER attempt to repair SRS wiring.
  • NEVER attempt to repair any SRS component.
  • NEVER connect an external electrical supply to SRS components.
  • NEVER connect earth wiring from other electrical circuits to SRS component mounting screws.
  • NEVER install accessories (e.g. such as car phones, drinks holders, cassette racks etc.) in the area of the passenger's airbag, as they could become detached and blown backwards by the force of deployment.
  • NEVER allow pyrotechnic pretensioners to come close to strong magnets.
  • NEVER store or carry undeployed airbags in the passenger compartment of a car.
  • NEVER leave undeployed airbags or pretensioners unattended.
  • NEVER use universal covers on seats incorporating side airbags.
  • NEVER transfer SRS components from one car to another - ALWAYS use genuine new components.
  • NEVER attempt to dismantle components, especially airbags and seat belt pretensioners.
  • ALWAYS disconnect ALL pyrotechnic devices before attempting to check SRS wiring continuity.
  • ALWAYS use a digital multi-meter for checking wiring continuity and voltage. NEVER use an analogue test meter or test lamp on an active SRS system, as this could cause accidental deployment of airbags and/or pretensioners.
  • ALWAYS ensure all multi-plugs are correctly inserted and securely locked together.
  • ALWAYS ensure all wiring is correctly routed and secured to avoid chaffing, trapping or shorting the harness.
  • ALWAYS install airbags and pyrotechnic pretensioners as soon as possible after removal from their special packaging.
  • ALWAYS use the correct fixing bolts for SRS components.
  • ALWAYS disconnect the battery before any welding operations and connect the earth terminal of the welder as near to the welding area as possible.
  • ALWAYS disconnect or remove the SRS control module when welding in the immediate area.
  • ALWAYS disconnect or remove the side airbag sensor when welding the door.
  • ALWAYS record the date of fitting a replacement airbag or pyrotechnic pretensioner.
  • ALWAYS register the replacement by using the registration card or bar code etc. supplied with the new components.
  • ALWAYS remove pretensioners if the vehicle temperature is likely to be above 110°C.
  • ALWAYS remove airbags if the temperature is likely to be above 85°C.
  • ALWAYS remove the SRS control module if the temperature is likely to be above 100°C.
  • ALWAYS observe torque figures,overtightened or loose components could affect the operation of the airbags and pretensioners.

Temporary storage

NOTE: Incorrect handling and storage can render airbags and pretensioners inoperative.

If airbags or pyrotechnic pretensioners are stored overnight they must be kept in an approved secure steel cabinet (registered with the local council) as they are legally classified as explosive items - refer to Storage and handling.

  • ALWAYS keep components dry.
  • ALWAYS carry and store airbag assemblies with the pad surface uppermost.
  • ENSURE nothing is resting on the airbag assembly.
  • PROVIDE a secure, designated storage area for SRS components, especially airbags and pretensioners.
  • NEVER twist, knot, hang up, crush, squeeze, pinch or squash head airbags.

Rescue and recovery

Towing

  • Recovery of a vehicle with airbags that have not deployed is most unlikely to result in inflation of an airbag, but as a safeguard both battery leads should be disconnected and taped over to prevent reconnection.

Rescue - airbag(s) deployed

  • No harmful substances (either gases or solids) are left as a consequence of airbag deployment. Any white residue is basically talcum powder to aid the sliding properties of the airbag material.
  • The chemicals within the gas generator are sealed within a water-tight container and therefore all types of fire extinguisher are suitable for use on vehicles fitted with deployed airbags.
  • Identification: SRS components are normally identified externally either by a moulded SRS or Airbag logo (in the case of airbag covers), and also by warning labels attached to one or more of the following: sun visor, door shut, glove box lid, side of fascia, side of seat base, B post and individual components.
  • Deployed airbags do not need to be covered, folded or removed. They can just be lifted out of the way.
  • Deployed airbags are harmless to the occupants and rescue services.
  • Slight skin grazing can be caused to occupants in contact with airbags during deployment.

Rescue - airbag(s) not deployed

  • Check if the vehicle has airbag(s) fitted - refer to vehicle-specific chapters for warning label locations.
  • If possible, work outside the area of airbag deployment.
  • If it is necessary to cut electrical wiring or remove components by force, unintentional triggering of SRS components is always possible.
  • Ensure the ignition is switched OFF.
  • Move seats as far back as possible.
  • Disconnect all battery leads (earth lead first) and ensure that accidental reconnection is not possible.
  • If the battery terminals are inaccessible cut through all battery leads (earth lead first).
  • If possible wait to allow capacitor(s) to discharge.
  • Avoid drilling or cutting the airbag assemblies.
  • Avoid excess heat in the area of the airbag assemblies.
  • In the case of a vehicle fire, the heat may eventually trigger deployment, which will occur in the normal way. The gas (mainly Nitrogen) is inert and there is no possibility of an explosion.
  • The chemicals within the gas generator are sealed within a water-tight container and therefore all types of fire extinguisher are suitable for use on vehicles fitted with undeployed airbags.


Storage and handling

More and more vehicles are being fitted with a range of airbags and pretensioners which contain pyrotechnic devices. This means that increasingly garages are being required to handle and store them.

Although these devices are designed to save lives, there is the possibility of physical injury and/or poisoning if they are not handled correctly.

The following requirements are sufficient for storing up to 3 or 4 items at a time.

General requirements

Some pyrotechnic components are classified as explosive devices and therefore the premises in which they are stored need to be registered with the local authority (under the Explosives Act 1875).

Registration can usually be arranged through either the fire brigade, trading standards office, or evironmental health department.

Registration is recommended by the Health and Safety Executive, even if it is not planned to store the devices, as delays in fitting them to the vehicle may mean that they are kept on the premises overnight, or for extended periods.

Airbags and pretensioners may be classified as UN Hazard Class 1 or 2. To store Class 1 components a Mode B Registered Premises licence will be required.

Class 2 components do not require this registration, but nevertheless it is still recommended.

Comprehensive guidance for those handling, storing or transporting larger numbers of these devices is provided in the Health and Safety Executive's publication 'The handling, storage and transport of airbags and seat belt pretensioners' (HSG184 1998 ISBN 0 7176 1598 7) - obtainable directly from HSE Books, PO Box 1999, Sudbury, Suffolk, CO10 6FS, or from good booksellers.

Storage

Cabinets designed for Mode B registered storage are substantially constructed, with no exposed steel surfaces, easy to clean finish and can be closed and locked securely.

The cabinet must be secured to a wall or floor, in a dry position.

The cabinet must be kept clear of:

  • Paint, lubricants and other inflammable substances.
  • Areas of excessive heat, such as brazing or welding.
  • Electrical cables, sockets, junction boxes and fuse boxes etc.

Handling

  • ALWAYS consult model-specific instructions before working on vehicles fitted with airbags, as there will be differences in procedure depending on the model and manufacturer.
  • ALWAYS carry airbags with the trim cover facing away from you.
  • ALWAYS return damaged or suspect components to the supplier, EXCEPT where the damage has resulted in the inflator cartridge being exposed or split, in which case specialist advice should be sought from the supplier or manufacturer.
  • ALWAYS dispose of deployed airbags and pyrotechnic pretensioners in accordance with the recommendations of the manufacturer. Some may recommend disposal with normal waste, while some need to be treated as hazardous waste.
  • ALWAYS return undeployed airbags to the supplier using the packaging that the new component was supplied in. If for any reason this packaging is not available, contact the supplier and ask for fresh packaging.
  • NEVER place your head or body close to the front of an undeployed airbag, especially when fitting or removing it from a vehicle.
  • NEVER place airbag assemblies, or steering wheel assemblies fitted with an airbag, trim side down or with the trim against a hard surface.
  • NEVER attempt to repair or modify airbag or pretensioner components.
  • NEVER work on or test an airbag assembly unless it is securely mounted on a bench or jig which allows for the bag to inflate if it is accidentally triggered.
  • NEVER expose airbag assemblies to excessive heat (over 90°C).
  • NEVER allow airbag assemblies to be subject to impact, electrical current (including static electricity), or radio transmitters.
  • NEVER fit used components - ALWAYS use NEW components.
  • NEVER deploy airbags unless you have had appropriate training and work to the manufacturer's procedures.
  • NEVER dispose of explosive devices, such as undeployed airbags or pyrotechnic pretensioners, as normal waste in domestic or commercial waste bins.


Frequently asked questions

SRS - Frequently asked questions

Q | How can I tell if the vehicle is fitted with airbags?
A | Trim panel covers will have an Airbag or SRS logo prominently displayed, with additional warning labels in easily visible locations.
Q | As explosives are used to deploy airbags and pretensioners, aren't they dangerous?
A | No, the explosive force used to deploy airbags and pretensioners is contained and dissipated within the components and disperses harmlessly after activation. Only mishandling or abuse is likely to lead to injury.
Q | Do the pyrotechnic devices contain a chemical charge that can explode if the vehicle catches fire?
A | No, in the event of a fire the devices may be triggered by the heat, but will then deploy normally.
Q | Do rescue service personnel need to wait up to 30 minutes before approaching a vehicle with deployed airbag(s)?
A | No, any 'smoke' is harmless dust and can be ignored. Rescue operations should start immediately.
Q | Will the interior of a vehicle with deployed airbags be contaminated with toxic residues?
A | No, any powdery residue is non-toxic and consists mainly of talcum powder or starch. It may irritate the skin and eyes, but has no lasting effects. As a precaution protective gloves and clothing should be worn when handling deployed airbags.
Q | If the battery is disconnected, will this cause the airbag(s) to be deployed either immediately or after a short pause?
A | No, the action of disconnecting the battery disarms the system and cannot deploy the airbag(s).
Q | Are all SRS wires and connectors colour coded yellow?
A | No, although a lot of vehicles do have yellow wiring or insulating sleeving for the SRS wiring this is not universal. Don't assume that because some wiring is coloured other than yellow, that it is not connected to the SRS system.
Q | Do I need special facilities and an explosives licence to store undeployed airbags and pretensioners?
A | Yes, there are strict regulations governing the storage of explosive devices and advice should be sought from the fire brigade, trading standards office or environmental health department - refer to the Help Storage and Handling section.
Q | Can the airbag(s) be accidentally deployed by parking 'knocks', jacking-up or other mild jolts or bumps?
A | No, the SRS system is designed to ensure that airbags and pretensioners are only deployed under a carefully controlled set of circumstances, which eliminates the possibility of accidental deployment through parking 'knocks' etc.
Q | Can airbags and pretensioners be deployed by repair work being carried out on the vehicle?
A | Yes, sharp blows, shorting of wiring and other repair operations could potentially deploy the SRS system, but simple safety procedures will eliminate this possibility - refer to Safety Procedures on the Autodata product.
Q | Can welding repairs be carried out in the vicinity of SRS components?
A | Yes, but the system should be deactivated and any adjacent components should be disconnected and removed. All wiring should also be removed or protected from excessive heat.
Q | Are there any special precautions to be observed when cleaning the interior of a vehicle fitted with SRS?
A | Although the SRS components are well protected, water should not be allowed to get into the airbag assemblies.
Q | How can I tell if the airbags have deployed or not?
A | If the trim panels are intact the airbags have not deployed, if they have deployed the deflated bag(s) will be hanging outside the steering wheel and/or fascia panel.


Timing Belt Information Index

Timing belt replacement intervals How to use the illustration page Precautions Toothed timing belts Auxiliary drive belts Troubleshooter Belt tension measurement


Timing belt replacement intervals

The information relating to timing belt replacement intervals is additional to the main purpose of this product, but is included to provide guidance to garages and for customer advice.

Where possible the recommended intervals have been compiled from vehicle manufacturers' information. In a few instances no recommendation has been made by the manufacturer and the decision to replace the belt must be made from the evidence of a thorough examination of the condition of the existing belt.

Apart from the visible condition of the belt, which is explained fully later in this section, there are several other factors which must be considered when checking a timing belt:
  1. Is the belt an original or a replacement.
  2. When was the belt last replaced and was it at the correct mileage.
  3. Is the service history of the vehicle known.
  4. Has the vehicle been operated under arduous conditions which might warrant a shorter replacement interval.
  5. Is the general condition of other components in the camshaft drive, such as the tensioner, pulleys, and other ancillary components driven by the timing belt, typically the water pump, sound enough to ensure that the life of the replacement belt will not be affected.
  6. If the condition of the existing belt appears good, can you be satisfied that the belt will not fail before the next check or service is due.
  7. If the belt does fail, have you considered the consequences. If the engine is an INTERFERENCE type then considerable expensive damage may well be the result.
  8. The cost of replacing a belt as part of a routine service could be as little as 5 to 10% of the repair cost following a belt failure. Make sure your customer is aware of the consequences.
  9. If in doubt about the condition of the belt - RENEW it.
  10. Refer to the Toothed Timing Belts/Service Replacement section for further information relating to arduous or adverse operating conditions, inspection and service replacement.


How to use the illustration page

  1. Illustration identification number
  2. Abbreviated sprocket identification
  3. Tightening torque - Newton metres
  4. Detail of timing marks
  5. Timing belt tension checking point


Precautions

  • Engine damage - where it is stated that engine damage will result from belt failure it is still possible that by chance no damage will have occurred, therefore before removing the cylinder head check the compressions.
  • Before disconnecting the battery earth lead ascertain if the vehicle is fitted with a coded radio. If it is, ensure that the owner has a record of the code or that an auxiliary power supply is connected to the set.
  • Always disconnect the battery earth lead before starting work.
  • Remove spark plugs (petrol engines) or glow plugs (diesel engines), to ease turning the engine.
  • Always turn the engine in normal direction of rotation (clockwise - unless otherwise stated).
  • Do NOT turn the camshaft, crankshaft or diesel injection pump, once the toothed belt has been removed (unless otherwise stated).
  • Do NOT use timing pins to lock the engine when slackening or tightening crankshaft pulley bolt(s).
  • Do NOT turn the crankshaft from the camshaft or other drive sprockets via the drive belt.
  • Do NOT use cleaning fluids on belts, sprockets or rollers.
  • Ensure that the replacement belt has the correct tooth profile. Trapezoidal, curvilinear and modified curvilinear types are NOT interchangeable.
  • Do NOT forcibly twist the belt, turn inside out, or bend through a radius of less than 25 mm.
  • Check the pulley alignment.
  • Check the free running of auxiliary drives, such as water pump, oil pump and balancer shaft.
  • Check the free running of tensioner and guide rollers.
  • Always mark the belt with the direction of running before removal.
  • Always refit a used belt so that its original direction of running is maintained.
  • Do NOT lever or force the belt onto its sprockets.
  • Always check the diesel injection pump timing, after replacing the drive belt.
  • Observe all tightening torques.
  • Check the ignition timing after belt replacement.


Toothed timing belts

Since its introduction about 30 years ago the toothed (or synchronous) belt has been increasingly used for driving camshafts, balancer shafts and diesel injection pumps, instead of the traditional roller chain or gears.

1. Construction

These belts are of complex construction (1), being manufactured from a fibre-glass, Kevlar or steel braided laminated inner core, coated with synthetic rubber, neoprene or highly saturated nitrile (HSN) which is wear and heat resistant.

The teeth, which may be curvilinear (2), modified curvilinear (with a more rounded form between teeth) or trapezoidal (3), are moulded integrally, to close tolerances and have a durable fabric facing for long life.

2. Rounded teeth

3. Trapezoidal teeth

This combination of design and construction results in a belt that will stretch little in use, requires no lubrication, is relatively inexpensive to manufacture, is almost silent in use and has a very high working efficiency.

Service replacement

When a replacement interval is recommended by the vehicle manufacturer, this appears as a mileage or time interval in the Replacement Interval Guide box of each model-related page. These intervals should be strictly observed to avoid the possibility of belt failure and consequential expensive engine damage.

NOTE: Reference to a special, lower, recommended replacement interval for vehicles used under arduous or adverse conditions relates to the following types of use:

  • Taxi operations
  • Permanent door-to-door use.
  • Frequent short trips with a cold engine in low temperatures.
  • Use in hot countries with temperatures often over +30°C.
  • Use in cold countries with temperatures often below -15°C.
  • Use in countries with a dusty atmosphere.
  • Towing a trailer or caravan.
  • Sustained high-speed driving.
  • Using poor quality fuel or oil.
If there is no manufacturer's recommended replacement interval, this does not mean that the belt can be ignored, or that it will last forever.

Belts should be inspected at regular intervals and always replaced if their condition is in any way suspect.

Contamination

In use the belt is protected from oil or water contamination by a cover, but should a seal or hose fail it is possible that damage to the belt could result, and in such cases the belt should be replaced.

The belt should not be allowed to come into contact with petrol, water, or oil and under no circumstances should any solvents be used to clean it.

If any doubt exists about the condition of the belt it should be replaced as the cost is low compared to the cost for repairing engine damage resulting from belt failure.

Inspection

At the recommended service intervals, and whenever the timing belt is removed, it should be carefully inspected for wear or damage, however minor, which could lead to failure - with possibly expensive results.

WARNING: In the majority of cases, failure of the drive belt will result in piston and valve contact with resulting engine damage.

Timing belt damage may be visible as cracking or scuffing on the outer surface (4), possibly caused by deposits on the tensioner roller, which often runs on the back of the belt, or by the tensioner binding at some time. Any such damage should be investigated further, to ascertain possible causes before fitting a new belt.

4. Cracking and scuffing

5. Damaged teeth

The teeth should be checked for signs of cracking or other damage (5), and the sides of the belt also inspected for wear or damage (6) which could indicate that the sprockets on which it runs, may be out of alignment.

Cracking or damage to teeth may indicate that the camshaft or one of the ancillaries, such as the water pump, which may be driven by the belt, has locked up, if only briefly. Therefore these should be checked before replacing the belt.

6. Side wear and damage

The teeth on the sprockets should also be checked for damage, and cleaned only with a soft brush.

A wire brush must not be used, nor any form of metal scraper. If there is a build up of dirt or dust in the corners of the teeth, this may be gently removed with a soft wooden scraper.

Cleaning

Solvents should never be used to clean oil deposits from the surface of the belt, and if in any doubt, the belt should be replaced.

Any cleaning of the belt must be undertaken carefully using a dry soft bristle brush, such as a toothbrush. The belt should be laid on a flat surface and care taken not to twist or crush the belt.

Under no circumstances should the belt be turned inside out for cleaning or inspection. Any maltreatment of the belt could result in premature failure.

Fitting

When fitting a belt, the tensioner must be released, and the belt slid into place.

It may be necessary to stretch the belt slightly over the first sprocket, ensuring that the timing marks remain aligned.

Under no circumstances should any form of lever be applied to the belt to force it into place. Once fitted, the engine should always be turned in the direction of normal rotation (except in special cases, where instructed in the text), never backwards as this could cause the belt to slip and the timing to 'jump'.

At each stage of belt fitting, carefully check the timing marks are aligned correctly.

Some belts have timing marks identified which will relate to marks on the sprockets (7). These may be used in conjunction with other timing marks on the engine castings and sprockets, or may be used solely as the timing reference marks. Again, the specific fitting instructions must be followed.

7. Belt timing marks

Never use the belt to lock the camshaft sprockets when undoing the sprocket retaining bolts, as this will damage the belt teeth.

Use a sprocket holding tool, or the hexagons or flats which are provided on some camshafts for this purpose.

8. Direction arrows

Certain manufacturers specify the direction of use for the belt, this being identified by arrows on the top surface (8), and should be strictly observed. If removing a belt for any reason which may be re-used, the direction of rotation should be marked on it, in chalk, for reference when re-fitting.

Any recommended belt checking or replacement intervals should be followed.

Tension

The tension of the belt is important and can be set in a number of different ways.

Engine manufacturers issue specific instructions for each application, which are described in each section. These should always be followed, as incorrect tension can lead to premature failure.

In many cases the tensioner operates automatically, but the installation procedure must be carefully followed to ensure that the correct tension is achieved.

Manually tensioned belts normally require the use of a gauge to measure the tension and these are listed under special tools, in each section.

In some cases an alternative, such as the Burroughs tension gauge can be used and a comparison table, between this and some other gauges, is included in this product.


Auxiliary drive belts

V-Belts

V-belts used for driving auxiliary components, such as alternator, water pump, air conditioning compressor and cooling fan are normally of 'raw-edged' construction.

In this type of belt, sub-surface fibres are laid perpendicular to the direction of belt rotation (9), providing a high degree of flexibility, but having extreme transverse stiffness and high wear resistance.

9. V-belt construction

10. V-belt & pulley contact

Drive is transmitted from the crankshaft pulley through the side wall contact between the belt and the pulley 'V' groove (10).

Several belts may be used, where the loads are high and there are several auxiliary components to be driven.

Poly V-Belts

Introduced in 1979, Poly V (or Micro-V) belts are now fitted to an increasing number of engines.

These belts are considerably wider and thinner than their V-belt counterpart and usually have between three and six ribs (11).

Additionally the back of the belt can be used to drive components or for tensioning purposes.

Due to its reduced thickness, compared to the traditional V-belt, it can drive smaller diameter pulleys, resulting in the so-called 'serpentine drive' layout (12), in which all the auxiliaries are driven by one long belt.

11. Poly V-belt construction

12. Typical serpentine drive belt layout


Troubleshooter

Symptom | Probable Cause | Remedy
Broken belt | Foreign body in drive | Ensure cover is fitted correctly
 | Excessive tension | Set tension correctly
 | Belt crimped during installation | Avoid mishandling belt
Sheared teeth | Insufficient tension | Set tension correctly
 | Seized drive sprocket | Remedy seizure
 | Sprockets misaligned | Align correctly
Worn teeth | Incorrect tension | Set tension correctly
 | Worn sprockets | Replace sprockets
Hollow teeth | Pre-set tension very low | Set tension correctly
 | Running tension too low | Ensure tensioner is operating correctly
Top surface cracks | Excessive heat | Check cause
 | Tensioner pulley/guide pulley binding | Free tensioner pulley/guide pulley
Land wear | Excessive tension | Set tension correctly
 | Rough sprocket surface | Replace sprockets
Oil contamination | Engine oil leak | Remedy oil leak
Edge wear | Sprocket flange damaged | Replace sprocket
 | Sprockets misaligned | Align correctly
Noisy operation | Excessive tension | Set tension correctly
 | Insufficient tension | Set tension correctly
 | Sprockets misaligned | Align correctly
 | Sprocket flange damaged | Replace sprocket


Belt tension measurement

Vehicle manufacturers specify a wide range of different gauges for checking the tension in timing belts.

It is not possible to directly measure the tension in an installed belt so most tension gauges measure belt deflection for a known load or, in some cases, the load for a known deflection. A few manufacturers specify special tools which are essentially a torque arm to load the belt tensioner by a predetermined amount.

To assist workshops offering all-makes service Autodata has prepared a comparison chart for a range of the gauges specified by different car manufacturers. Using this chart it is possible to convert readings from one gauge to another, enabling one gauge to be used for a variety of makes.

The tests were carried out by comparing known belt tensions with a Burroughs gauge, calibrated in Newtons and other gauges calibrated in arbitrary units.

The restricted ranges on some gauges has reduced the readings available for comparison.

With any tension gauge it is important to take care when using the gauge, following the manufacturer's instructions.

It is often difficult to obtain consistent readings with these gauges and it is good practice to take several readings to establish the correct setting.

Tension gauge comparison

Burroughs (BT33-73F /BT33-86J) | Sykes- Pickavant 316690 | SEEM C.Tronic G2 105.5 | SEEM C.Tronic 87 (Pin S) | Lowener (Ford 21- 113 & Vauxhall 510-2) | Peiseler (VAG 210, Volvo 5197 & SEAT U.10.028) | BMW (11.2.080) & (Volvo 9988500*) | Burroughs/ Rover - (KM 4088AR)
Newtons | Kg | Units | Units | Units | Units | Units | Units
50 |  |  | 13 |  |  |  |
100 |  |  | 22,5 |  |  |  |
150 |  | 33 | 31,5 |  |  | 28 |
200 | 16 | 40 | 38,5 |  | 11,7 | 35 | 1,7
250 | 20 | 47 | 46 | 4 | 12,5 | 41,5 | 2,7
300 | 25 | 53 | 52 | 7,4 | 13,1 | 46,5 | 4
350 | 29 | 61 | 58 | 9,6 | 13,4 | 51 | 5
400 | 35 | 67 | 63 | 11 | 13,6 | 53 | 6
450 | 40 | 72 | 68,5 | 12 |  |  | 7
500 | 46 | 78 | 73,5 |  |  |  | 7,5
550 | 51 |  |  |  |  |  | 8
600 | 58 |  |  |  |  |  | 8,5
650 | 63 |  |  |  |  |  | 9
670 | 65 |  |  |  |  |  |

*NOTE: This gauge is sensitive to belt thickness and should only be used as recommended by the vehicle manufacturer.


Wheel Alignment Terminology

Wheel Toe Toe-Out-On Turns Camber Angle King Pin Inclination (KPI) & Included Angle Castor Angle Lock Angles Rear Wheel Steering Axis of Symmetry & Thrust Axis Deviation Wheel Set-Back Ride Height Tyres Adjustment Procedures


Wheel Toe

  • + = toe-in
    - = toe out
The toe setting is the amount by which the front or rear wheels point inwards or outwards at the front of the wheel in relation to each other. When the wheels point inwards they are said to toe-in. Toe-in figures are given a positive value. Conversely when the wheels point outwards they are said to toe-out and the figures are shown as a negative value.

The purpose of correct toe is to ensure that the wheels run parallel when the vehicle is in motion. An incorrect toe setting may affect the stability and controllability of the vehicle.


Toe-Out-On Turns

Toe-out-on-turns is the difference in angles between each front wheel and the centre line of the vehicle when the steering is turned. The steering linkage is designed to allow the inner wheel to turn through a smaller radius to minimise tyre scrub. There should be no difference in angle (A) when the steering is turned to the left or right, taking into consideration manufacturer's tolerances.


Wheel Alignment Terminology

Camber Angle

If the road wheel leans outwards from the vertical, it is said to have positive camber (B) and when leaning inwards from the vertical negative camber (C), looking from the front or rear of the vehicle.

The effect of camber can be compared with the tendency of a cone to roll towards its small end (A). Therefore, wheels which are both set at a positive camber angle have the tendency to roll away from each other while wheels set at a negative camber angle will roll towards each other.

Camber angle is measured in degrees with the wheels in the straight-ahead position.


King Pin Inclination (KPI) & Included Angle

KPI is the angle of inclination of the king pin towards the centre line of the vehicle from the vertical (A).

On systems which use swivel joints the king pin is effectively the line drawn through the steering axis of the joints, hence the term Steering Axis Inclination (SAI).

The Included Angle is the camber angle plus the king pin angle (B). Lines drawn through the camber angle and the king pin angle will intersect. If the lines intersect below the road surface, the dimension is described as positive scrub radius (C). If the two lines intersect above the road surface the dimension is called negative scrub radius.

A small scrub radius will contribute to steering stability. On vehicles with diagonally split brake circuits negative scrub radius stabilises the steering when the braking forces of the front wheels are unequal.


Castor Angle

The castor angle is the tilting of the kingpin either forwards or backwards from the vertical, as seen from the side of the vehicle. Castor angle influences the directional stability of the steering. To increase the tendency of the steering to self-centre, the steering will normally be designed with positive castor.


Lock Angles

This is the angle of the inner or outer wheels on left and right-hand lock, relative to the straight-ahead position. It will be seen that the inner wheel (B) will turn through a greater angle than the outer wheel (A) to reduce tyre wear.


Rear Wheel Steering

A number of vehicle manufacturers have introduced rear wheel steering systems with various means of operation. A basic system is designed to turn the rear wheels in the same direction as the front wheels over speeds of approximately 20-30 mph (A). A more sophisticated system will turn the wheels in the opposite direction to the front wheels at low speed (B), reverting to the same direction of turn as the front wheels when the speed increases. Increased stability, higher cornering speeds and improved manoeuvrability are amongst some of the claimed advantages of rear wheel steering.

It is essential to consult the vehicle manufacturer's manual before attempting to adjust the rear wheel steering alignment.


Axis of Symmetry & Thrust Axis Deviation

The axis of symmetry is the centre line through the front and rear axles (A). Incorrect toe-setting of the rear wheels or wheel set-back may cause the vehicle to travel in a direction different from the centre line. This is known as the thrust axis deviation (B).


Wheel Set-Back

This is the distance (X) by which one wheel is offset to the front or rear, relative to the opposite wheel on the same axle. Wheel set-back can also be measured as an angle.


Ride Height

Test Load Positioning

If a manufacturer's geometry figures are determined with a specified load applied to the suspension, the position of the load on the vehicle will be indicated. The load may have to be positioned on the front seats (A), rear seats (B), or luggage compartment (C), or a combination of the three, depending on the manufacturer and model.

Suspension Settling

The suspension of vehicles is liable to settle initially with use. To make allowance for settling of the suspension, manufacturers may provide a table of geometry settings to be used in conjunction with suspension height measurements. Where applicable, these values and their respective measuring points will be shown.


Tyres

Tyre Wear

Incorrect wheel alignment will cause abnormal tyre wear. The illustration shows the effect that excessive toe-in or toe-out will have on tyre treads. Excessive toe-out will cause feathering (A) and wear (B) on the inside shoulder of the tyre while excessive toe-in will cause wear and feathering on the outside shoulder of the tyre.

Tyre Pressures

The pressure of the four vehicle tyres should be examined and corrected prior to checking and adjusting the wheel alignment.

Tyre Markings

Before carrying out wheel alignment checks, ensure that all road wheels are fitted with the correct size tyres and that tyres on the same axle are of equal size.


Wheel Alignment Terminology

Adjustment Procedures

Preparatory Conditions

The following items should be checked before measuring the wheel alignment:

  1. Correct tyre sizes and pressures.
  2. Condition of road springs/suspension (Vehicle visibly level).
  3. No excessive free play in steering mechanism and linkage.
  4. Wheel bearings correctly adjusted.
  5. No excessive run-out in road wheels (buckled wheels must be replaced).
  6. Test loads positioned in vehicle (if specified).
  7. Vehicle has been bounced on suspension with handbrake OFF.
  8. Steering centralised by marking the steering wheel and then turning the steering wheel from lock to lock measuring the turns. With the steering centralised, the front wheels should be approximately parallel with the longitudinal centre line of the vehicle. Some vehicles with rack and pinion steering specify the length of one or both track rods as a guide when centralising the steering, others feature an access hole in the housing through which a pin or screw has to be inserted in order to centralise the steering. Vehicles fitted with a steering box may have specific alignment points on the box.

Types of Adjustment

  1. Wheel toe - typically, adjustment of the toe-setting can be made by slackening each track rod lock nut or clamp (Fig. 12) and turning the track rod or adjuster an equal amount on each side of the vehicle to lengthen or shorten the track rods as necessary.
  2. Castor angle - adjustment may be achieved by lengthening or shortening the tie rod (Fig. 13). Alternatively, with wishbone type front suspension, shims between the wishbone mounting and chassis (Fig. 14) may be varied in thickness to alter castor settings.
  3. Camber - the most common types of camber adjustment are:
    1. Altering the position of the top of the MacPherson strut.
    2. Varying the thickness of shims between wishbone mounting and chassis (Fig. 14).
    3. Altering the position of the ball-joint on the wishbone (A,Fig. 15).
    4. Cam adjustment at the bottom of the strut (B,Fig. 15).

All the above adjustments may also apply to rear suspensions.

Fig. 12

  1. Track rod end
  2. Locknut
  3. Adjuster
  4. Clamp
  5. Track rod

Fig. 13

  1. Tie rod
  2. Locknut

Fig. 14

  1. Shims
  2. Wishbone

Fig. 15


Additional Wiring Diagrams

Additional Wiring Diagrams - Index

Terminal designations - DIN 72552 How to use the illustration page Safety precautions Electrical symbols


Additional Wiring Diagrams

Terminal designations - DIN 72552

The terminal markings laid down in this Standard for motor vehicle electrical systems, are to ensure as faultless a connection as possible of electrical apparatus, especially in the event of repair of replacement units.
The development of new equipment necessitates the use of multi-pole connectors for which the terminal markings according to DIN 72552 are no longer adequate. For these, a numerical or alphabetical sequence is used, that has no particular relation to the functions concerned.

Ignition/supplementary systems, battery, motors

1 | Low voltage (ignition coil, distributor)
Distributor with two separate circuits
1a | To contact breaker 1
1b | To contact breaker 2
2 | Short-circuit terminal (magneto ignition)
4 | High voltage (ignition coil, distributor)
Distributor with two separate circuits
4a | From ignition coil 1, terminal 4
4b | From ignition coil 2, terminal 4
7 | Base series resistor to or from ignition distributor (control switch contact)
15 | Switched positive output from battery, ignition switch output
15a | Output at ballast resistor to ignition coil
17 | Glow-plug and starter switch, starting
19 | Glow-plug and starter switch, preheating
30 | Input direct from battery positive
30a | Series-parallel switch Input from battery 2 positive with 12/24 V systems
31 | Return direct to battery, negative or ground
31b | Return to battery negative or ground via switch or relay (switched negative)
Electric motors
32 | Return*
33 | Main terminal connection*
33a | Cycle completion switch off
33b | Shunt field
33f | For second, lower speed
33g | For third, lower speed
33h | For fourth, lower speed
33L | Anti-clockwise rotation
33R | Clockwise rotation
(*Polarity change possible at terminals 32-33)

Generator, regulator, starting, lighting systems

44 | Voltage compensation at generator regulators, with two or more generators operated in parallel
45 | Output at separate starting relay, input at starter motor (main current)
For parallel operation of two starter motors
45a | Starter relay output for engaging current to starter motor 1 Input of starter motors 1 and 2
45b | Starter relay output for engaging current to starter motor 2
Control of starting
48 | Terminal at starter motor and start repeating relay
49 | Indicator (pulse generator), input
49a | Indicator (pulse generator), output
49b | Indicator output, second indicator circuit
49c | Indicator output, third circuit
50 | Starter motor control (direct)
50a | Starter motor control (indirect), battery change-over relay
50b | Starter motor control with parallel operation of two starter motors
50c | Input for starter relay for starter motor 1 for sequence control of its actuating current. For parallel operation of two starter motors
50d | Input for starter relay for starter motor 2 for sequence control of its actuating current. For parallel operation of two starter motors
50e | Start locking relay, input
50f | Start locking relay, output
50g | Start repeating relay, input
50h | Start repeating relay, output
51 | DC voltage at rectifier of AC generator
51e | DC voltage at rectifier of AC generator with choke coil for daytime driving
52 | Tyre pressure drop indicator or other signal transmission for trailer to towing vehicle
53 | Wiper motor, input (+)
53a | Wiper (+), parking
53b | Wiper (shunt winding)
53c | Electric windshield washer pump
53e | Wiper (brake winding)
53i | Wiper motor with permanent magnet and third brush (for higher speed)
54 | Stop lamps
54g | Electro-magnetically operated pneumatic valve for retarder in trailer
55 | Fog lamps
56 | Headlamps
56a | Upper beam and upper beam indicator
56b | Lower beam
56d | Headlamp flasher contact
57 | Sidelamp for motor cycles, (also cars, trucks, etc)
57a | Parking lamps
57L | Parking lamp, left
57R | Parking lamp, right
58 | Sidelamp, tail, number plate and instrument panel lamps
58b | Tail lamp switch-over for two wheel tractors
58c | Trailer plug and socket for single line tail lamp, fused in trailer
58d | Adjustable instrument panel lighting
58L | Tail and side marker lamps, left
58R | Tail and side marker lamps, right, number plate lamp
59 | AC voltage, output rectifier input
59a | Charging armature, output
59b | Tail lamp armature, output
59c | Stop lamp armature, output
61 | Charge indicator
63 | Generator regulator, regulated voltage
63a | Generator regulator, current limitation
64 | Transistor regulator, generator current limitation, control lead
71 | Tone sequence control unit, input
Tone sequence control unit, output
71a | to horns 1 and 2, low
71b | to horns 1 and 2, high
72 | Alarm switch (rotating beacon)
75 | Radio, cigarette lighter
76 | Loudspeaker
77 | Door valve control heading switches

Switches

81 | Input to break contact and to change-over contact
Break contact and change over contact (break-contact side)
81a | Output 1
81b | Output 2
82 | Make contact, input
82a | Make contact, output 1
82b | Make contact, output 2
82z | Make contact, input 1
82y | Make contact, input 2
83 | Multi-position switch, input
Multi-position switches
83a | Output, position 1
83b | Output, position 2
83L | Output, position left
83R | Output, position right

Relays

84 | Current relay input end of winding
84a | Output end of the winding
84b | Output
85 | Electro-magnetic actuator, output (output end of the winding, negative or ground)
86 | Electro-magnetic actuator, input (input end of the winding)
86a | Electro-magnetic actuator, input (input end of the winding, or first winding)
86b | Electro-magnetic actuator, input (winding tap or second winding)
87 | Input to relay break-contact or to relay change over contact
Relay break contactor, relay change-over contact (break-contact side)
87a | Output 1
87b | Output 2
87c | Output 3
Relay break-contact or relay change-over contact
87z | Input 1
87y | Input 2
87x | Input 3
88 | Relay make-contact input
Relay make-contact or relay change-over contact (make contact side)
88a | Output 1
88b | Output 2
88c | Output 3
Relay make-contact or relay change-over contact
88z | Input 1
88y | Input 2
88x | Input 3

Generator, generator regulators

B+ | Battery positive
B- | Battery negative
D+ | Dynamo positive
D- | Dynamo negative
DF | Dynamo field
DF1 | Dynamo field 1
DF2 | Dynamo field 2
Alternator
U.V.W. | Individual phase terminals
Alternator with separate rectifier
J | Exitation winding positive
K | Exitation winding negative
Mp | Mid-point terminal

Direction indicators

C | First indicator lamp
CO | Main terminal for indicator circuits separate from the indicator relay
C2 | Second indicator lamp
C3 | Third indicator lamp (i.e. for two-trailer operation)
L | Indicator lamp, left
R | Indicator lamp, right


Additional Wiring Diagrams

Additional Wiring Diagrams - Component groups

Group | Description | Example
A | Assemblies | lamp assemblies, ECU, control units
B | Transducers | sensors, horns, speakers
C | Capacitors | battery, condensers, suppressors
E | Lamps, miscellaneous | lamps, clocks, distributor
F | Protective devices | fuses, fuse box, circuit breakers
G | Generators | alternator
H | Warning devices | lamps, buzzers, chimes
K | Relays | relays
M | Motors | motors
N | Regulators | voltage regulator
P | Meters and gauges | electrical meters, pressure and vacuum gauges
R | Resistors | resistors, heater elements
S | Switches | switches
T | Transformers | coils
V | Semi-conductors | diodes
W | Spare cables | cables terminating at a connector
X | Connectors | loom and component connectors
Y | Solenoids | electro-mechanical valves, pumps, central locking actuators

NOTE: For further details of all component codes refer to Component key.


Additional Wiring Diagrams

Additional Wiring Diagrams - Safety precautions

When working with electrical systems the safety procedures listed below must be observed to prevent component damage and personal injury. The advice given on this page is supplementary to any instructions supplied with equipment or materials. Always follow safety and service procedures given by the manufacturer or distributor of any equipment being used.
Additional health and safety information may be obtained from equipment manufacturers and distributors.

Airbags (Supplementary Restraint System - SRS)

Many of the models covered by this manual are fitted with airbags as standard equipment. When working on a vehicle fitted with such a system, extreme caution must be taken to avoid accidental deployment of the airbag, which could result in personal injury.
Unauthorised repairs to the system could render it inoperative, or cause it to inflate accidentally.
NOTE: All related wiring may be encased in a yellow outer covering.
When the engine is started the AIRBAG warning lamp should go out after approximately 5-10 seconds, if not this indicates a fault in the system. The fault should be corrected before any other work is carried out.

  • NEVER attempt to test the system using a multi-meter.
  • NEVER tamper with or disconnect the airbag wiring harness.
  • NEVER make extra connections to any part of the system wiring harness or terminals.
  • ALWAYS ensure that the airbag wiring harness has not been trapped or damaged in any way when working on adjacent components or systems.
  • Refer to the Autodata product for further information.

Electrical

  • ALWAYS ensure that the battery is properly connected before attempting to start the engine.
  • DO NOT attempt to start the engine using a source in excess of 12 volts, such as a fast charger (16 volts) or by connecting two batteries in series (24 volts). ALWAYS disconnect the battery before charging it.
  • DO NOT disconnect the battery while the engine is running.
  • DO NOT connect the battery with reverse polarity.
  • DO NOT disconnect or touch the HT leads when the engine is being cranked or when it is running.
  • DO NOT connect or disconnect the engine control module (ECM), AC control module or any other control module while the ignition is switched ON.
  • DO NOT disconnect any control module multi-plugs within 30 seconds of switching ignition OFF.
  • DO NOT flash a wire or circuit to earth to check that continuity exists.
  • DO NOT attempt to rotate electrical fans for the radiator/condenser by hand with the battery connected. Some can start to operate automatically at any time, even with the ignition switched OFF.
  • ALWAYS ensure that any replacement components are correct for the application in question. Many units share common external features, but differ internally.


Additional Wiring Diagrams

Electrical symbols

A - Assemblies

Airbag, driver
Airbag, passenger
Airbag, side
Airbag, head
Seat belt
Spiral cable
Transistor

B - Transducers

Engine speed
Knock sensor
Sensor
Sensor with heater
Vehicle speed

C - Capacitors

Battery/power source

E - Lamps

Bulb
Bulb with double filament

F - Protective devices

Fuse

G - Generators

Generator

K - Relays

Relay with winding and contacts

M - Motors

Motor
Motor with electronic positioning

P - Meters/gauges

Gauge
Meter

R - Resistors

Resistor/heater
Variable resistor

S - Switches

Switch
Switch with synchronised operation

T - Transformers

Ignition coil

V - Semi-conductors

Diode
Light emitting diode
Photo diode

Y - Solenoids

Solenoid


Diesl Adjustment Methods

Introduction to adjustment methods

Adjustment method - overflow

Injection pump position
Spill timing with gravity feed fuel supply

Disconnect fuel inlet pipe from injection pump and connect a small tank of approximately 2 litres capacity and positioned to give a gravity supply.

Disconnect delivery pipe to setting cylinder from pump and connect suitable swan-neck spill pipe.

Turn crankshaft back from TDC position approximately 90° and then slowly forward until fuel flow is reduced to single drops at 10 second intervals.

Check crankshaft position with specified spill timing position.

Spill timing with hand pressure pump

Disconnect fuel inlet pipe and connect hand pressure pump. Disconnect delivery pipe from setting cylinder and connect suitable swan-neck spill pipe.

Remove scavenge valve and replace with plug to make pump pressure-tight.

Use pump to bleed air from injector pump through plug.

Pump drive plate should be disconnected.

Use hand pump to raise pressure in pump high enough to open delivery valve. Fuel should flow through swan-neck.

Turn pump shaft in normal direction of rotation until flow is reduced to single drops at 10 second intervals. Tighten drive plate.

Adjustment method - dial gauge

Injection pump position
In-line pump

Remove plug from No. 1 cylinder.

Turn engine until No. 1 pump piston is at lowest point.

Fit dial gauge with special clamp and lever.

Check piston is still at lowest point. Zero gauge.

Turn engine until specified lift is measured.

Reading on flywheel marking should correspond to injection point angle.

Cummins engine

A dial gauge is used to determine the start of injection by indicating upward movement of the injector pushrod.

Bosch VE

Set the crankshaft position to TDC for setting cylinder. Remove plug from rear of injection pump and position dial gauge with suitable stand.

Set probe of dial gauge in contact with distributor piston and pre-load the gauge.

Rotate the engine against the normal direction of rotation until the dial gauge stops moving.

Zero the dial gauge and rotate the engine forwards until setting cylinder TDC position is obtained. The dial gauge reading should be compared with the data figure to check that the pump setting is correct.

CAV/Roto diesel

Install dial gauge in side of pump body, use special adaptors if required.

Rotate engine in the normal direction of rotation until dial gauge needle changes direction. This indicates the deepest point of the groove or recess in the distributor rotor.

Engine position
Dropped valve or plunger method

Use valve spring compressor to remove collets and valve spring. As a safety precaution fit safety pin or wire into collet recess to prevent valve dropping into cylinder head. Fit dial gauge with suitable clamp and, with valve resting on piston crown, rotate engine in normal direction of rotation until position of TDC is determined. Some engines require the use of a plunger inserted through the glow plug orifice, instead of using the valve.

Adjustment method - pointer

Injection pump position

Check that marks on pump body and mounting flange are aligned. With the crankshaft set to the correct position check that the marks on the pump rotor and the pump body (or pointer) are in line.

Engine position
Marks on flywheel

Rotate the engine slowly in normal direction of rotation until the fixed mark and the flywheel mark are in line to ensure that No. 1 piston is at TDC.

Timing scale - crankshaft pulley

A special timing scale is available for attachment to the engine and is used in conjuntion with the mark on the crankshaft pulley to determine the timing point.

Marks on crankshaft pulley

Rotate the engine slowly in the normal direction of rotation until the pointer and timing marks are in line to ensure that No. 1 piston is at TDC.

Adjustment method - special tool

Injection pump position
Timing pin

The pump is held in its setting position by inserting a timing pin through the pump drive pulley, or through the pump side casing.

Timing sensor
Engine position
Timing pin - crankshaft pulley

The timing point is determined by inserting the timing pin through a hole in the crankshaft pulley. The engine is slowly turned until the pin engages in its location in the crankcase.

Timing pin - flywheel

The timing pin is inserted through the timing hole in the bellhousing and is located in a hole in the flywheel to determine the timing point.

Timing pin - camshaft pulley

The timing point is found by inserting timing pin through the hole in the camshaft drive pulley and locating in hole or recess in the cylinder head.

Timing pin - crankshaft
Timing sensor - crankshaft pulley


Clutches

The following information has been allowed by kind permission of the Schaeffler Automotive Aftermarket GmbH & Co. oHG, Langen/Germany:

  • Failure Diagnosis - LuK’s guide to troubleshooting clutch-system failures and malfunctions
    • LuK tips on avoiding clutch system failures and malfunctions
    • Clutch fails to disengage
    • Clutch slip
    • Clutch judder
    • Clutch makes a noise
    • Clutch pedal is heavy in operation
    • General tips on installing passenger vehicle and light transporter clutches
    • Diagnostic charts

  • Self-Adjusting Clutch (SAC) - Technology Special Tools / User Instructions
    • Self-adjusting clutch (SAC)
    • Clutch course
    • Special tools for SAC installation without applying counteracting forces
    • Centring the clutch disc
    • Mounting the SAC
    • Uninstalling the SAC
    • A short guide to Schaeffler’s product catalogues

  • Dual Mass Flywheel (DMF) - Technology Failure Diagnosis Special Tool/User Instructions
    • History
    • Dual mass flywheel – DMF
    • DMF Components
    • DMF Failure Diagnosis
    • Special Tool / User Instructions
    • DMF Function Tests
    • Rated Values
    • Bolts for dual mass flywheels (DMF) and compact DMF (DFC)