Введение
В данном справочном материале собраны ответы на часто задаваемые вопросы.

Составители руководства:
  • Artem Izmaylov
  • Viachaslau Kastko aka Soolo
  • Taras Trofimchuk aka Tarik
© Artem Izmaylov, 2006-2020
Free Audio Player
www.aimp.ru


Обзор программы

Главное окно программы состоит из двух основных частей - фонотеки (1) и плейлистов (2).

Фонотека
Представляет собой органайзер музыкальных файлов, который позволяет упорядочивать музыку - группировать и фильтровать песни по одному или нескольким критериям, поддерживаются шаблоны. Так же она ведет статистику воспроизведения и позволяет выставлять оценки прослушанным композициям. Зона фонотеки разделена на две визуальные части - дерево группировки (слева) и таблицу (справа).

Дерево группировки представляет собой первичный фильтр для песен на основе шаблонов группировки - как встроенных, так и пользовательских. Оно состоит из трех частей: шаблона группировки (3), алфавитного указателя (4), позволяющего отфильтровать отображаемые в дереве данные, и зоны, где отображаются группы с данными (5).

В таблице справа отображаются песни, удовлетворяющие заданным критериям.
Таблица позволяет:
  • Сортировать песни по одной или нескольким колонкам (кликайте по ним с зажатым Ctrl)
  • Фильтровать песни по значению одной или нескольких колонок (кликните по значку, что отображается справа от названия колонки)

    Чтобы добавить файлы в базу данных фонотеки - нажмите кнопку "+", что располагается внизу части (1) окна.

    Плейлисты
    В этой части окна отображаются загруженные в плеер плейлисты. Плейлисты делятся на два типа - обычные, составленные пользователем вручную, и смарт-плейлисты - плейлисты, составляемые автоматически по какому-либо критерию на основе данных фонотеки и/или папок. Все воспроизведение ведется только из плейлистов - если вы попробуете запустить проигрывание выборки из фонотеки - она автоматически создаст плейлист и плеер начнет его воспроизведение.

    Настройка внешнего вида

    Скин по умолчанию - скин-трансформер. Если вам не по душе монолитный вид, где и фонотека, и плейлисты находятся в пределах одного окна - вы можете отцепить эти элементы от главного окна: просто схватите элемент за свободную зону, например, справа от вкладок:

    и оттащите в сторону. Если таким образом отцепить фонотеку - плеер примет классический вид:

    Стоит отметить, что скин по умолчанию выполнен в двух цветовых схемах - светлой и темной, чтобы переключиться между ними, нажмите кнопку "переключить тему":

    • © Artem Izmaylov, 2006-2020


Знаете ли вы, что...
Знаете ли вы, что...
  • Плеер
  • Плейлист
  • Фонотека
© Artem Izmaylov, 2006-%year%


Знаете ли вы, что...
Общее
  • Запустить вторую копию плеера можно с помощью ключа командной строки /DEBUG.

  • Если понадобилось переустановить ОС, вам достаточно предварительно скопировать папку профиля, чтобы сохранить все оценки, плейлисты и настройки.

  • Можно устанавливать дополнения (скины, плагины или иконки) для AIMP, перетаскивая zip-архивы с дополнением на главное окно. Архив должен содержать только одно дополнение без дополнительных файлов.

Элементы управления
  • Сбросить ползунок (к примеру, регулятор баланса или Preamp) в значение по умолчанию можно, кликнув правой кнопкой мышки по ползунку.

  • Для отмены захвата ползунка в полосе прокрутки трека достаточно нажать Escape.

  • Клик с зажатой клавишей SHIFT по полосе прокрутки длинного плейлиста перемещает бегунок прокрутки в место клика.

  • Клик правой кнопкой мышки по некоторым кнопкам (например, "Стоп" "Повтор" "Эквалайзер" "Плейлист") открывает контекстное меню со специфическими настройками.

Вид плеера
  • Существует альтернативный метод сворачивания на панель задач / в трей кликом правой кнопкой мышки по кнопке "Свернуть".

  • Быстро свернуть плеер (развернуть его из трея) можно двойным кликом на главном окне / окне мини-плеера.

  • Плеер можно прикреплять к границам экрана вместе с главным окном.

Скрытые настройки
  • Отключить стрелочку, которая появляется при наведении указателя мышки к краю экрана в случае, когда плеер прикреплен у края экрана, можно установив значение "0" параметра DockEngineShowFloatArrow в файле настроек AIMP.ini. *

  • Отключить вложенное контекстное меню проводника можно с помощью параметра Cascade=0 в файле AIMP-ContextMenu.ini. *

  • С помощью параметра ShowErrorDialog в файле настроек AIMP.ini можно отключить отображение уведомлений, которые отображается в случае ошибок подключения радио или при попытке воспроизвести несуществующий файл в плейлисте. *

    • * Действия по правке ini-файлов нужно производить при выключенном плеере.

Окно "О программе"
  • Прокрутку информационного списка можно приостановить нажатием клавиши пробел, а если зажать shift - список начнет прокручиваться в обратную сторону


Знаете ли вы, что...
Общее
  • Быстро свернуть/развернуть все категории в плейлисте можно кликом по кнопке сворачивания/разворачивания группы с зажатой клавишей ALT.

  • Если дважды нажать клавишу F3, плеер перейдет к активному треку в этом плейлисте.

  • Если перетащить файлы в другой плейлист с помощью мыши с зажатой клавишей ALT - файлы удалятся из исходного плейлиста.

  • Можно перетаскивать в плейлист не только файлы, но и ссылки на радио потоки или онлайн треки.

  • Инвертировать выделение в плейлисте можно нажатием клавиши Num *.

  • Клик левой кнопкой мышки с зажатой клавишей ALT по любому треку в плейлисте, вызывает окошко QFI с информацией о данном треке.

  • Для отмены захвата ползунка полосы прокрутки плейлиста или фонотеки достаточно отвести указатель мыши в сторону более чем на 150 px и отпустить кнопку мыши.

Закладки
  • Если запустить проигрывание закладки с зажатой клавишей Alt - трек начнет проигрываться с начала, без учета сохраненной позиции.

  • В закладках могут храниться не только ссылки на файлы, но так же ссылки на радиостанции.

Очередь
  • Поставить трек в очередь можно кликом колесика мышки (СКМ), убрать трек из очереди – сочетанием ALT+СКМ.

  • Кликом колесика мышки по заголовку группы можно поставить в очередь сразу всю группу.

Вкладки плейлистов
  • Закрыть плейлист можно кликом колесика мышки по его вкладке.

  • Восстановить случайно закрытый плейлист можно с помощью менеджера плейлистов (клик правой кнопкой мыши по любой вкладке плейлиста >> Управление плейлистами).

  • Прокручивать вкладки плейлистов без их переключения можно колесиком мышки с зажатой клавишей CTRL.

  • Если вы боитесь случайно закрыть нужный плейлист, вы можете его заблокировать в индивидуальных настройках. Но в таком случае добавить и удалить файлы из него также будет невозможно.

  • Если "бросить" (схватить и перетащить) несколько папок в менеджер плейлистов, то для каждой папки будет создан отдельный плейлист.

  • Команда "Предыдущий/Следующий плейлист", вызванная глобальной горячей комбинацией клавиш, переключает не только саму вкладку плейлиста, но и воспроизведение этой вкладки.


Знаете ли вы, что...
  • В фонотеке можно задавать метки (ПКМ -> Метки, или ПКМ в столбце с метками). В дальнейшем их можно использовать для сортировки/группировки файлов.

  • Для ускоренной прокрутки списка треков в фонотеке или плейлисте нужно использовать зажатую клавишу CTRL.

  • Чтобы отключить любую сортировку треков в фонотеке достаточно несколько раз нажать на заголовок столбца до исчезновения стрелочек.

  • Для обновления содержимого таблицы фонотеки можно использоваться клавишу F5.

  • В режиме миниатюр можно менять размер картинок с помощью колеса мыши и зажатой клавиши CTRL.

  • В фонотеке и редакторе тегов сортировать записи можно сразу по нескольким столбцам: для этого нужно кликать по нужным столбцам в нужной последовательности с зажатой клавишей CTRL.

  • В фонотеке доступна "быстрая группировка" по значениям полей с зажатой клавишей Ctrl:

  • В выпадающих списках фонотеки и редактора тегов доступен быстрый поиск с помощью ввода слов с клавиатуры:

  • Для подгонки размера столбца под самое большое значение в его ячейках - кликните два раза по разделителю между этим столбцом и следующим. Для подгонки размеров всех столбцов - нажмите CTRL+"Num+"
    • © Artem Izmaylov, 2006-2020


Часто задаваемые вопросы
Часто задаваемые вопросы
  • AIMP для других платформ
  • Визуализация
  • Воспроизведение
  • Горячие клавиши
  • Дополнения (плагины / обложки / иконки)
  • Интернет радио
  • Командная строка
  • Мини-Плеер
  • Настройки (Резервное копирование / Перенос / Сброс)
  • Обложки к альбомам
  • Плейлист
  • Проблемы / Ошибки
  • Скиндвижок
  • Установщик
  • Фонотека
  • Функциональность
© Artem Izmaylov, 2006-%year%


AIMP для других платформ
AIMP для других платформ
  • Будет ли 64-битная версия AIMP?
  • Будет ли плеер портироваться под другие системы?
  • Существует ли архив версий AIMP?
© Artem Izmaylov, 2006-%year%


Ча.Во.
Вопрос:
    Планируется ли создание 64-битной версии программы?

Ответ:
    В ближайшем будущем нет. Большинство используемых библиотек не имеют x64 версий.


Вопрос:
    Будет ли плеер портироваться под другие системы (Unix-подобные, Linux, Mac OS)?

Ответ:
    AIMP for Android можно скачать в Google Play.
    Портировать AIMP на другие системы не планируется.
    Под Linux'ом и некоторыми другими Unix-подобными ОС AIMP можно запустить через Wine.


Вопрос:
    Существует ли архив версий AIMP?

Ответ:
    Архив релиз-версий вы можете найти здесь на нашем сайте.


Визуализация
Визуализация
  • Не все столбики прыгают
  • Частота обновления визуализации
© Artem Izmaylov, 2006-%year%


Вопрос:
    Почему в спектруме столбики, расположенные справа, никогда не прыгают?

Ответ:
    Cпектроанализатор AIMP отображает весь возможный спектр частот для файла, а не только его активную (слышимую) часть. Теперь по нему можно судить о "качестве" проигрываемого файла.


Вопрос:
    Можно ли изменить частоту обновления спектрума?

Ответ:
    Нет.


Воспроизведение
Воспроизведение
  • WASAPI Exclusive не работает
  • Автоматическая подстройка эквалайзера под жанр
  • Воспроизведение видео в AIMP
  • Воспроизведение ускорилось
  • Громкость 'плавает'
  • Трекерная музыка
  • Не воспроизводит некоторые заявленные форматы файлов
  • Не до конца проигрывает mp3 файлы
  • Нет звука при попытке проиграть MIDI / KAR файл
  • Опция 'Сохранять состояние плеера при навигации'
  • Плеер не начинает воспроизведение
  • Повтор плейлиста - как включить?
  • Подвисает плеер в конце каждой песни при смене трека
  • Проигрывание защищенных файлов
  • Пропал звук везде, кроме AIMP
  • Сведение/затухание - где найти настройки
  • Хрипят колонки при использовании эквалайзера
© Artem Izmaylov, 2006-%year%


Вопрос:
    Выбираю в настройках WASAPI Exclusive, а AIMP не начинает воспроизведение и выскакивает ошибка.

Ответ:
    Убедитесь, что в настройках устройства, у вас разрешен эксклюзивный доступ к устройству, а так же у него стоит приоритет перед общим режимом:


Вопрос:
    Хочу, чтобы эквалайзер сам подстраивался под жанр песни, которая играет в данный момент. Возможно ли такое в AIMP?

Ответ:
    Нужно установить опцию "Автоматическая подстройка эквалайзера под песню" (Главное меню \ Настройки \ Плеер \ Автоматика), либо в настройках самого эквалайзера. При этом в тегах файла должна присутствовать информация о жанре.


Вопрос:
    Почему AIMP не поддерживает видео и будет ли поддерживать в будущем?

Ответ:
    AIMP разрабатывался и разрабатывается как аудио плеер, поэтому поддержка видео не планируется.


Вопрос:
    Воспроизведение ускорилось / замедлилось / появилось эхо / искажения звука.

Ответ:
  • Откройте менеджер эффектов (Главное меню \ Менеджер эффектов) и сбросьте все ползунки в значение по умолчанию (клик правой кнопкой мыши по ползунку).
  • Попробуйте проделать следующее:
    • Кликните на кнопке "Пуск" \ "Выполнить" \ Введите "dxdiag.exe" и нажмите "Enter" \ откройте вкладку "Звук"
    • Проверьте, включено ли полное ускорение.


Вопрос:
    "Плавает" громкость музыки: то увеличивается, то уменьшается.

Ответ:
    На это могут влиять несколько факторов:
    1. Включена нормализация громкости или ReplayGain "на лету".
    Отключите данные опции (см. Главное меню \ Менеджер звуковых эффектов \ Громкость).

    2. Включена опция антиклиппинга и превышен уровень громкости из-за использования эквалайзера.
    Попробуйте уменьшить громкость в плеере либо значение регулятора PreAmp (Главное меню \ Менеджер эффектов \ Эквалайзер).


Вопрос:
    Что означает группа "Трекерная музыка" в параметрах преобразования?

Ответ:
    Трекерная музыка.
    Изменения будут применены только к следующему треку

    Ramping (Off/normal/sensitive) - панорамирование звука. Это делает воспроизведение более мягким и плавным, без резких всплесков. По умолчанию — normal. Выставлять значение Sensitive (повышенное) следует только в том случае, если необходимо избежать щелчков в ритм-секции.

    Surround (Off/Mode1/Mode2) - псевдообъемное звучание. По умолчанию — off. mode 2 рекомендуется включать для монофонической модульной музыки, в этом режиме игнорируется наличие паннинга звуковых каналов.

    Playback Mode - выбор режима для воспроизведения: FastTracker 2 / ProTracker 1.

    Interpolation Mode - улучшает качество звука, но использует больше ресурсов ЦП.


Вопрос:
    Почему AIMP не воспроизводит заявленные форматы музыкальных файлов?

Ответ:
    Возможно, у Вас отключен Input-плагин для соответствующего формата файла, проверьте, подключен ли он (см. Главное меню \ Настройки \ Плагины \ Декодеры).


Вопрос:
    Некоторые mp3-файлы плеер проигрывает не до конца, преждевременно переходит на следующий файл. В чем может быть проблема?

Ответ:
    В большинстве случаев такие файлы являются поврежденными ("битыми"). BASS, который используется в плеере как декодер, не умеет воспроизводить такие файлы. Возможно, в будущем AIMP обзаведется собственным mp3-декодером, который решит эту проблему.


Вопрос:
    Нет звука при попытке проиграть MIDI / KAR файл.

Ответ:
    1) Убедитесь, что у вас установлен и подключен плагин bass_midi.dll (Главное меню \ Настройки \ Плагины \ Декодеры).
    2) Необходимо найти и скачать банк инструментов (файл с расширением *.sf2).
    3) Поместить банк инструментов в папке \AIMP\Plugins\.
    4) Перезапустить программу.

    Скачать компактный банк инструментов от Creative можно отсюда.
    В архиве так же находится лицензионное соглашение от Creative. Только для некоммерческого использования!


Вопрос:
    В чем смысл опции "Сохранять состояние плеера при навигации по плейлисту с помощью кнопок "следующий / предыдущий файл"?

Ответ:
    Если галочка снята, то при нажатии на кнопки "следующий / предыдущий файл" в любом случае начнется воспроизведение трека (даже если до нажатия воспроизведение было остановлено). Если включить эту опцию, то при нажатии на указанные кнопки плеер останется в том режиме, что и был: играл плеер - будет играть новый трек, плеер стоял на паузе / в режиме стоп - воспроизведение не начнется.


Вопрос:
    Плеер не начинает воспроизведение. Установки все в порядке, но при нажатии на кнопку Play плеер вроде начинает играть, но воспроизведение не начинается. В чем проблема?

Ответ:
    Судя по всему, у Вас не выбрано устройство вывода звука.
    1) Зайдите в Главное меню \ Настройки \ Воспроизведение.
    2) Выберите подходящее устройство и метод вывода, нажмите "Применить".


Вопрос:
    Как зациклить воспроизведение плейлиста?

Ответ:
    Способ 1. В Главное меню \ Настройки \ Плеер \ Автоматика измените опцию "По окончании воспроизведения плейлиста" - выберите вариант "Повторить плейлист"

    Способ 2. Нажмите правой кнопкой мыши по кнопке "Повтор файла" и выберите нужный вариант:


Вопрос:
    Подвисает плеер в конце каждой песни при смене трека. Как решить эту проблему?

Ответ:
    Вы ставили в плеер плагины от Winamp? Проблема может быть из-за их несовместимости с AIMP. Попробуйте отключить все сторонние плагины и выявить, из-за которого плеер виснет.


Вопрос:
    Существует ли возможность проигрывания защищенных файлов?

Ответ:
    Нет, такой возможности нет.


Вопрос:
    Если включено воспроизведение в AIMP, пропадает звук во всех других приложениях.

Ответ:
    Скорее всего, вы выбрали в настройках воспроизведения ASIO или WASAPI Exclusive. Эти методы используют монопольный доступ к устройству, поэтому звуки от других приложений не слышны.
    Выберите другой метод вывода звука: WASAPI или DirectSound.


Вопрос:
    Где можно найти настройки сведения/затухания треков?

Ответ:
    Главное меню \ Менеджер звуковых эффектов \ вкладка "Сведение"


Вопрос:
    Хрипят колонки при использовании эквалайзера.

Ответ:
    Попробуйте уменьшить громкость в плеере либо значение регулятора PreAmp (Главное меню \ Менеджер эффектов \ Эквалайзер).


Горячие клавиши
Горячие клавиши
  • Громкость плеера не регулируется мультимедиа клавишами
  • Двойной клик вызывает диалог Открыть папку
  • Плеер не реагирует на нажатия мультимедиа клавиш
© Artem Izmaylov, 2006-%year%


Вопрос:
    Мультимедийные клавиши на моей клавиатуре почему-то не меняют громкость плеера, вместо этого они регулируют системную громкость.

Ответ:
    По умолчанию мультимедиа клавиши для управления громкостью не настроены в AIMP. При необходимости, вам это нужно сделать самостоятельно (см. Главное меню \ Настройки \ Плеер \ Горячие клавиши).


Вопрос:
    При двойном клике на плейлисте вызывается диалоговое окно "Выбор папки".

Ответ:
    Данная проблема наблюдается с некоторыми моделями мышек.
    Попробуйте в настройках удалить горячие клавиши CTRL + INS.


Плеер не реагирует на нажатия мультимедиа клавиш
Вопрос:
    Плеер не реагирует на нажатия мультимедиа клавиш.

Ответ:
  • Убедитесь, что на компьютере не запущено от имени администратора других программ, работающих с мультимедиа клавишами.
    Либо запустите эти программы от имени текущего пользователя, либо запустите AIMP от имени администратора.
    (Внимание! Запуск плеера от имени администратора может вызвать другую проблему: невозможность перетаскивать файлы с помощью Drag-n-Drop).
  • Попробуйте удалить файл aimp_mediakeys.dll, расположенный в папке <AIMP>\System\.
  • Некоторый софт для клавиатуры может мешать работе мультимедиа клавиш. Попробуйте удалить этот софт.


Дополнения (плагины / обложки / иконки)
Дополнения (плагины / обложки / иконки)
  • Как включить скробблинг на Last.fm
  • Как отключить информационную ленту вверху экрана?
  • Как установить обложку?
  • Как установить плагин?
  • Как установить иконки?
  • Поддержка плагинов от Winamp
© Artem Izmaylov, 2006-%year%


Вопрос:
    Не работает скробблинг Last.fm

Ответ:
    Подключите плагин "Last.fm Client" через менеджер плагинов, выполните вход в профиль Last.fm (Главное меню \ Настройки \ Плагины \ Last.fm).


Вопрос:
    Как отключить полоску, которая появляется сверху экрана в начале каждой песни?

Ответ:
    Зайдите в Главное меню \ Настройки \ Плагины \ Информационная лента и снимите галочку "При старте воспроизведения показывать информацию о текущем файле".


Вопрос:
    Как установить скачанную обложку?

Ответ:
    1) Распаковать архив с обложкой.
    2) Открыть Главное меню \ Настройки \ Интерфейс \ Обложки и найти распакованную обложку:

    3) Применить выбранный скин с помощью двойного клика мыши.

    Дополнительно: Можно устанавливать дополнения (скины, плагины или иконки) для AIMP, перетаскивая zip-архивы с дополнением на главное окно. Архив должен содержать только одно дополнение без дополнительных файлов.


Вопрос:
    Как установить плагин?

Ответ:
    Каждый плагин имеет свою персональную рабочую папку. Имя папки должно совпадать с именем основного DLL-файла.
    Примечание: Расширение файлов плагинов визуализаций .svp необходимо сменить на .dll

    Подключение плагинов
    По умолчанию плеер подключает все плагины, которые лежат в его рабочей папке \AIMP\Plugins. Поэтому для установки плагина достаточно распаковать содержимое архива (папку плагина) в папку \AIMP\Plugins и перезапустить плеер.

    Подключить плагин можно и вручную:
    • Копируем плагин (папку плагина) в папку \AIMP\Plugins;
    • Открываем главное меню плеера, подпункт "Плагины" (или Главное меню \ Настройки \ Плагины);
    • В появившемся окне выбираем нужную вкладку в зависимости от типа плагина;
    • Ставим флажок слева от его названия;
    • В случае успешной загрузки плагин будет доступен для дальнейшего использования.

    Отключение плагинов
    • Открываем главное меню плеера, подпункт "Плагины" (или Главное меню \ Настройки \ Плагины);
    • В появившемся окне выбираем нужную вкладку в зависимости от типа плагина;
    • Снимаем флажок слева от его названия (при этом плагин физически не удаляется).

    Настройка плагинов
    Если плагин имеет возможность настройки - рядом с ним справа появляется кнопка, нажатие на которую открывает окно настроек.

    Дополнительно: Можно устанавливать дополнения (скины, плагины или иконки) для AIMP, перетаскивая zip-архивы с дополнением на главное окно. Архив должен содержать только одно дополнение без дополнительных файлов.


Вопрос:
    Как установить дополнительные иконки к файлам?

Ответ:
    1. Распаковываем архив с иконками, копируем файл .dll в папку \AIMP\Icons.
    2. Открываем "Настройки \ Система \ Ассоциация с файлами" и выбираем нужный набор иконок.

    Или: Можно устанавливать дополнения (скины, плагины или иконки) для AIMP, перетаскивая zip-архивы с дополнением на главное окно. Архив должен содержать только одно дополнение без дополнительных файлов.


Вопрос:
    Какие плагины от Winamp подходят к плееру и как их подключить?

Ответ:
    К плееру подходят следующие типы плагинов Winamp’а: General, DSP.

    См. также: Как установить плагин?


Интернет радио
Интернет радио
  • Как записать интернет радио?
  • Не показывается никакой информации об исполнителе
  • Не работает радио / не скачиваются обложки альбомов
© Artem Izmaylov, 2006-%year%


Вопрос:
    Как записать интернет радио?

Ответ:
    AIMP позволяет записывать проигрываемую в данный момент на интернет-радиостанции песню.

    Для захвата данных с интернет-радиостанции:
    1. Добавляем ссылку на аудио поток через пункт "Ссылку" в "Меню добавления файлов"

    2. Двойной клик по только что добавленному пункту в плейлисте - запустится проигрывание интернет-радиостанции

    3. На главном окне найдите кнопку "Захват радио".

    Она активизирует и останавливает запись аудио данных.
    В случае, когда ведется запись данных, кнопка будет мигать.

    Настройки параметров захвата можно найти в Главное меню \ Настройки \ Плеер \ Интернет-радио \ Запись Интернет-радио


Вопрос:
    Почему у меня при проигрывании радио в AIMP не показывается никакой информации об исполнителе? Можно ли сделать, чтобы было видно, кто поет и как называется песня?

Ответ:
    Это все зависит от самой радиостанции, которая посылает эту информацию в потоке. Если ваше любимое радио такую информацию не посылает, то она не будет показываться в плейлисте и в бегущей строке.

    Иногда помогает смена User-Agent (см. Главное меню \ Настройки \ Плеер \ Интернет-радио \ Общие настройки).


Вопрос:
    Не работает радио / не скачиваются обложки альбомов, хотя подключение к интернету есть.

Ответ:
    Что-то блокирует доступ AIMP-у в интернет (фаервол, антивирус). Попробуйте добавить AIMP в исключения.
    Так же, проверьте настройки соединения с Интернет в настройках программы (см. Главное меню \ Настройки \ Система \ Подключение к сети).
    В некоторых случаях может помочь увеличение времени ожидания (см. Главное меню \ Настройки \ Система \ Подключение к сети).


Командная строка
Командная строка
  • Возможно ли запускать несколько копий плеера?
  • Параметры командной строки
© Artem Izmaylov, 2006-%year%


Вопрос:
    Возможно ли запускать несколько копий плеера?

Ответ:
    Вы можете поставить две копии плеера в разные папки в портативном режиме. Затем, каждую из них запускать с ключом /DEBUG.


Использование
    AIMP.exe <команда> <параметр 1> <параметр 2> ...
    Примечание 1. Некоторые команды могут не иметь входящих параметров
    Примечание 2. Значение параметра следует заключать в двойные кавычки
Список поддерживаемых команд
  • /ADD_PLAY - Добавить объекты в плейлист и начать его воспроизведение.

    • Под объектом понимается - плейлист, папка или файл
    Входные параметры - пути к объектам

  • /BOOKMARK - Добавить файлы и/или папки в закладки.

    • Входные параметры - пути к файлам и/или папкам

  • /DIR - Добавить папку(и) в плейлист.

    • Начнется ли проигрывание добавленных файлов, зависит от выставленных настроек плеера
    Входные параметры - пути к папкам

  • /FILE - Добавить файл(ы) в плейлист.

    • Начнется ли проигрывание добавленных файлов, зависит от выставленных настроек плеера
    Входные параметры - пути к файлам

  • /INSERT - Добавить объекты в активный плейлист.

    • Начнется ли проигрывание добавленных файлов, зависит от выставленных настроек плеера
    Под объектом понимается - плейлист, папка или файл
    Входные параметры - пути к объектам

  • /QUEUE - Добавить объекты в активный плейлист и поставить их в очередь.

    • Под объектом понимается - плейлист, папка или файл
    Входные параметры - пути к объектам

  • /RESTORE - Восстановить плеер на передний план.

    • Входные параметры не используется

  • /SKIN - Установка обложек в AIMP. После установки будет открыто окно настроек на странице выбора обложки.

    • Входные параметры - пути к обложкам

  • /PLS - Открывает плейлисты в новых вкладках.

    • Начнется ли проигрывание плейлиста, зависит от выставленных настроек плеера
    Входные параметры - пути к плейлистам

  • /CDA - Создает новый плейлист со списком файлов с указанного носителя с последующим его воспроизведением.

    • Входной параметр - (!) единственный - буква диска

  • /PLAY - Начать воспроизведение.

    • Входные параметры не используется

  • /PLAYPAUSE - Приостановить/Продолжить воспроизведение.

    • Входные параметры не используется

  • /PAUSE - Приостановить воспроизведение.

    • Входные параметры не используется

  • /STOP - Остановить воспроизведение.

    • Входные параметры не используется

  • /NEXT - Следующий файл.

    • Входные параметры не используется

  • /PREV - Предыдущий файл.

    • Входные параметры не используется

  • /MUTE - Выключить / Включить звук.

    • Входные параметры не используется

  • /VOLUP - Прибавить громкость.

    • Величина изменений громкости задается в настройках - Настройки \ Плеер
    Входные параметры не используется

  • /VOLDWN - Убавить громкость.

    • Величина изменений громкости задается в настройках - Настройки \ Плеер
    Входные параметры не используется

  • /VOLUME - Устанавливает значение громкости

    • Входной параметр: значение громкости от 0 до 100 (%)

  • /EXIT - Выход из программы.

    • Входные параметры не используется

Список поддерживаемых команд для утилиты Elevator.exe
  • /REG=R1 - ассоциировать файлы с плеером.
  • /REG=R2 - сделать плеер программой по умолчанию.
  • /REG=U - отключить всю интеграцию плеера с Windows.


Мини-Плеер
Мини-Плеер
  • Как сделать мини-плеер поверх всех окон?
  • Как отключить мини-плеер?
  • Пропало основное окно плеера / окно мини-плеера
  • Мини-плеер проваливается под панель задач
© Artem Izmaylov, 2006-%year%


Вопрос:
    Как включить/отключить режим "поверх всех окон"?

Ответ:
    Это можно сделать с помощью контекстного меню:


Вопрос:
    Как отключить мини-плеер?

Ответ:
    Воспользуйтесь одним из вариантом:
    1) Правой кнопкой на значке в трее и снять галочку "Показывать мини-плеер".
    2) Пройдите в Главное меню \ Настройки \ Система \ Трей, снимите галочку с опции "Показывать мини-плеер".


Вопрос:
    Куда пропало основное окно плеера, плейлист или мини-плеер?

Ответ:
    а) Просто перезапустите плеер.
    б) Если не помог перезапуск: закройте AIMP, найдите файлы *.ini в папке Skins, что расположена в папке с профилем и удалите их.


Вопрос:
    Почему мини-плеер, даже в режиме поверх всех окон, проваливается под панель задач?

Ответ:
    Панель задач отображается также поверх всех окон и имеет более высокий приоритет перед другими программами.


Настройки (Резервное копирование / Перенос / Сброс)
Настройки (Резервное копирование / Перенос / Сброс)
  • Перемещение файлов без потери оценок
  • Пропали настройки после обновления программы
  • Расположение настроек программы
  • Резервная копия настроек программы
© Artem Izmaylov, 2006-%year%


Вопрос:
    После перемещения файлов пропали оценки треков. Как их вернуть?

Ответ:
    1. Чтобы перемещать файлы без потери оценок нужно воспользоваться соответствующей функцией в фонотеке (Контекстное меню файлов \ Отправить файлы \ Переместить в...)

    2. Для восстановления оценок и статистики есть специальная функция в фонотеке: (Главное меню фонотеки \ База данных \ Перемещенные файлы... либо Меню "разное" \ Перемещенные файлы...).
    Данная функция выводит список файлов, ссылки в БД на которые некорректны. Это может произойти, если файл был удален, перемещен в другую папку или переименован.

    После поиска, если файлы были физически удалены из папки, ссылки на такие записи можно смело удалять.
    Для удаления файлов выделите их и нажмите кнопку "Удалить выбранные".

    Если файлы были переименованы или перемещены в другую папку/на другой диск, вы можете воспользоваться функцией автопоиска, которая, основываясь на имени файла, попытается найти файлы, ссылки на которые некорректны.
    Для этого нажмите кнопку "Поиск" и в появившемся окне выберите папку, где находятся новые файлы

    Зачастую файлы переименовываются и перемещаются, в таких случаях "автопоиск" не поможет - возникает два пути:
    • 1. Удалить файлы с некорректными ссылками и добавить их в библиотеку заново - при этом вся статистика и оценки для этих файлов будут потеряны.
    • 2. Задать имя файла вручную - для этого достаточно кликнуть два раза левой кнопкой мыши по файлу в списке (или нажать справа кнопку с троеточием). При таком подходе статистика файлов будет сохранена.
      Для применения новых путей нажмите кнопку "Заменить отмеченные".


Вопрос:
    После очередного обновления программы сбились все мои настройки. Как их восстановить?

Ответ:
    При обновлении всегда сохраняется резервная копия предыдущей установки в папке \AIMP\!Backup. Оттуда и можно восстановить настройки.


Вопрос:
    Где программа хранит свои настройки?

Ответ:
    Откройте настройки и найдите внизу ссылку "Папка профиля". Она откроет в Проводнике папку с файлами настроек программы.


Вопрос:
    Как сделать резервную копию всех настроек программы?

Ответ:
    Вам будет достаточно сделать резервную копию папки профиля.


Обложки к альбомам
Обложки к альбомам
  • Откуда плеер берет обложку для песни?
  • Не работает радио / не скачиваются обложки альбомов
© Artem Izmaylov, 2006-%year%


Вопрос:
    Откуда плеер берет обложку для песни?

Ответ:
    Алгоритм поиска обложки для файла
    • Кэш изображения в локальной базе данных
    • Поиск обложки в тегах файла
    • Поиск обложки в папке, где лежит файл (порядок можно сменить: Главное меню \ Настройки \ Плеер \ Дополнительная информация \ Обложки альбомов):
      • Поиск изображения с таким же названием, как у файла
      • Поиск изображения, в имени которого есть "folder"
      • Поиск изображения, в имени которого есть "front"
      • Поиск изображения, в имени которого есть "cover"
      • Поиск изображения в подпапке Cover
      • Поиск изображения в подпапке Scan
      • Первое попавшееся изображение в папке
    • Поиск обложки в интернете

    Поддерживаемые форматы изображений
    • Загрузка из тега файла -
      JPG, PNG, BMP
    • Загрузка из папки с файлом -
      JPG, PNG, BMP, GIF, TIFF


Плейлист
Плейлист
  • Алгоритм подхвата CUE-Sheet
  • Где найти список шаблонов?
  • Двойной клик вызывает диалог "открыть папку"
  • Закрыл плейлист - как восстановить?
  • Как в плейлисте отключить вторую строку?
  • Как отключить отображение рейтинга вместо оценки в плейлисте?
  • Как растянуть окно плейлиста по ширине?
  • Неактивный пункт меню 'поставить после текущего'
  • Не могу добавить файлы / папки в плейлист
  • Один плейлист отличается от всех других
  • Отображение окна плейлиста
  • Плейлист не перескакивает к проигрываемому треку автоматически
  • Повтор плейлиста - как включить?
  • Пропали звездочки оценок из плейлиста
  • Смарт-плейлисты (синхронизация с источником)
  • Как отсортировать плейлист по оценке?
  • Файлы всегда открываются в default плейлисте при перетаскивании мышкой
© Artem Izmaylov, 2006-%year%


Вопрос:
    В каких случаях плеер автоматически подхватывает файл разметки?

Ответ:
    1. Файл разметки находится в одном из полей тега исходного аудио файла.
    2. Файл разметки имеет такое же имя, что и исходный аудио файл (без учета расширений), при этом файл разметки должен описывать только этот файл.

    Во всех остальных случаях необходимо добавить в плейлист непосредственно сам файл разметки.


Вопрос:
    Где найти список шаблонов для плейлиста / бегущей строки / переименования файлов / сортировки Файлов?

Ответ:
    Жмем правой кнопкой мыши по полю ввода - выскочит список всех доступных шаблонов.


Вопрос:
    Случайно закрыл не тот плейлист. Есть ли возможность восстановить его?

Ответ:
    Восстановить закрытые плейлисты можно с помощью менеджера плейлистов (ПКМ по вкладке плейлиста \ Управление плейлистами).


Вопрос:
    Как в плейлисте отключить вторую строку с информацией / звезды рейтинга?

Ответ:
    Все это и многое другое можно изменить открыв Главное меню \ Настройки \ Плейлист \ Внешний вид.
    Если нужно отключить вторую строку только для одного конкретного плейлиста, это можно сделать в его индивидуальных настройках.


Вопрос:
    Как отключить отображение рейтинга вместо оценки в плейлисте?

Ответ:
    Это можно сделать на вкладке Главное меню \ Настройки \ Плеер \ Фонотека, опция "Показывать рейтинг вместо оценки, если оценка для файла не задана".


Вопрос:
    Как растянуть окно плейлиста по ширине, чтобы поместилось больше вкладок?

Ответ:
    Убедитесь, что окно плейлиста отсоединено от главного окна.


Вопрос:
    Почему-то все время неактивный пункт меню "поставить после текущего". Что делать?

Ответ:
    Нужно снять галочку "Автоматически объединять одноименные группы" в настройках отображения плейлиста (Главное меню \ Настройки \ Плейлист \ Внешний вид) либо в индивидуальных настройках вашего плейлиста.


Вопрос:
    Не могу добавить файлы / папки путем перетаскивания их в плейлист. Подскажите, в чем может быть проблема?

Ответ:
    Убедитесь, что программа запущена от имени вашего пользовательского аккаунта, а не от имени администратора.


Вопрос:
    Вид одного или нескольких плейлистов отличается от остальных.

Ответ:
    Каждый плейлист, помимо общих настроек отображения (Главное меню \ Настройки \ Плейлист \ Внешний вид), имеет индивидуальные настройки отображения:


Вы можете сделать плейлист в виде отдельного окна или, наоборот, присоединить окно плейлиста к главному окну.
Делается это следующим образом:
  • Зажимаем левую кнопку мыши на списке закладок плейлиста (в любом свободном месте в окне плейлиста);
  • Тянем окно от главного окна (если хотим отсоединить плейлист) или на главное окно (если хотим присоединить плейлист);
  • Отпускаем левую кнопку мыши:

Плейлист может выступать в роли панели инструментов рабочего стола, для этого:
  • Зажимаем левую кнопку мыши на списке закладок плейлиста (в любом свободном месте в окне плейлиста);
  • Тянем окно к границам экрана;
  • Как только курсор достигнет края экрана, рамка окна плейлиста вытянется по высоте рабочего стола;
  • Отпускаем левую кнопку мыши - плейлист теперь приклеен к границе рабочего стола:

Когда программа становится неактивной, плейлист будет прятаться ("уезжать") из зоны видимости.
Чтобы выдвинуть плейлист - достаточно подвести указатель мыши к границе, к которой приклеен плейлист, появится маркер, символизирующий возможность показа плейлиста. Клик по этой иконке выдвинет плейлист в зону видимости.

Примечание: При перемещении файлов в плейлист с помощью Drag and Drop не нужно заранее выдвигать плейлист - достаточно навести мышь на маркер и плейлист выдвинется сам.


Вопрос:
    Плейлист не перескакивает (не фокусируется) на переключившийся трек. Как увидеть играющий трек?

Ответ:
    Автоматическая фокусировка работает только тогда, когда программа работает в фоне (указатель мыши находится не над окном программы).
    Чтобы быстро перейти к проигрываемому треку, воспользуйтесь командой "Показать текущий" в меню "Разное".


Вопрос:
    Пропали звездочки оценок из плейлиста

Ответ:
    Проверьте, включена ли соответствующая опция в настройках (см. Главное меню \ Настройки \ Плейлист \ Внешний вид).


Вопрос:
    Есть ли возможность автоматической синхронизации плейлиста AIMP с содержимым папки на компьютере?

Ответ:
    Ручная синхронизация:
    • Раздельное удаление и добавление файлов:
      • Удаление: Меню "Удаление файлов" -> "Удалить несуществующие файлы";
      • Добавление: "Меню "Разное" -> "Поиск новых файлов".
    • Синхронизация с прообразом
      • Шаг 1 (настройка прообраза): Клик ПКМ по вкладке плейлиста -> "Управление плейлистами" -> задать прообраз (папка);
      • Шаг 2 (синхронизация): Меню "Разное" -> "Перечитать данные из прообраза"
        При этом файлы выстраиваются в таком же порядке, как в прообразе.

    Автоматическая синхронизация:
      • Клик ПКМ по вкладке плейлиста -> "Управление плейлистами" -> задать прообраз (папка или фонотека), задать источники данных и дополнительные параметры (для папки отметить необходимые способы автоматической синхронизации: "при запуске", "при обнаружении изменений").

    Логические операции:
      • AND: выполнение нескольких условий одновременно.
        Пример: AND: Исполнитель=Ария, Оценка>=4: получим плейлист из треков Арии с оценками 4 и 5
      • OR: выполнение нескольких условий по очереди.
        Пример: OR: Исполнитель=Ария, Исполнитель=Кипелов: получим плейлист из треков Арии и Кипелова
      • NOT AND, NOT OR: инверсия операций AND, OR.
        Пример: NOT OR: Исполнитель=Ария, Исполнитель=Кипелов: получим плейлист из всех треков фонотеки кроме треков Арии и Кипелова


Вопрос:
    Как отсортировать плейлист по оценке?

Ответ:
    Этого можно достичь с помощью пользовательской сортировки на основе шаблонов (см. Главное меню \ Настройки \ Сортировка по шаблону).

    См. Меню "Сортировка файлов" -> "Сортировка по шаблону".


Вопрос:
    Я перетаскиваю мышью файл на главное окно AIMP, файл открывается в новом плейлисте "default". Но в настройках стоят другие параметры, как это исправить?

Ответ:
    Drag-and-drop на главное окно AIMP не настраивается: эта функция используется для быстрого прослушивания музыки. Для составления плейлиста - перетаскивайте файлы в плейлист (на панель вкладок плейлистов).


Проблемы / Ошибки
Проблемы / Ошибки
  • Высокая нагрузка на процессор
  • Ошибка 0xc0000005
  • Подвисает плеер в конце каждой песни при смене трека
© Artem Izmaylov, 2006-%year%


Вопрос:
    AIMP сильно грузит процессор. Что делать?

Ответ:
    Такое поведение наблюдается на старых компьютерах со слабой видео подсистемой. Как вариант, отключите "попиксельную полупрозрачность" (Главное меню \ Настройки \ Интерфейс).
    При этом, некоторые обложки могут отображаться некорректно.


Вопрос:
    Выскакивает ошибка 0xc0000005.

Ответ:
    Проблема обычно кроется в системе. Причина может быть в чем угодно, начиная от ошибок в реестре и заканчивая вирусами. Подробнее можно почитать здесь.


Скиндвижок
Скиндвижок
  • Высокая нагрузка на процессор
  • Как изменить значок в трее?
  • Нет эффекта размытия
  • Почему нет эффекта полупрозрачности у обложки?
© Artem Izmaylov, 2006-%year%


Вопрос:
    Как изменить значок в трее?

Ответ:
    Значок в трее можно изменить только на уровне скина.


Вопрос:
    Нет эффекта размытия под окном плеера, хотя соответствующая галка в настройках стоит.

Ответ:
    1. Обложка так же должна поддерживать размытие (такая возможность задается автором на уровне скина).
    2. Размытие возможно только на системах, поддерживающих Windows AERO: Windows 7 начиная с редакции Home Premium.


Вопрос:
    Почему нет эффекта полупрозрачности у обложки? Я точно знаю, что обложка имеет этот эффект.

Ответ:
    Убедитесь, что опция "Попиксельная полупрозрачность окон" включена (см. Настройки \ Интерфейс).
    (На слабых компьютерах может вызвать повышенную нагрузку на процессор).


Установщик
Установщик
  • Ошибка установщика: сannot open file
  • Параметры командной строки
  • Пропали настройки после обновления программы
© Artem Izmaylov, 2006-%year%


Вопрос:
    При установке новой версии, инсталлятор AIMP выдает ошибку "Cannot open file C:\Program Files (x86)\AIMP\%filename%. Отказано в доступе".

Ответ:
    1) Убедитесь, что у вас есть права на запись в указанную папку
    2) Убедитесь, что в данной папке нет файла с таким же именем, и он не занят какой-либо программой.
    (Узнать, какая программа блокирует файл, можно с помощью утилиты Unlocker).

    В некоторых случаях изменение/удаление файла может блокировать процесс cidaemon.exe, который отвечает за индексацию файлов для последующего быстрого поиска информации.
    В свойствах файла есть данная опция, снимающая с него индексацию, тем самым решая проблему (может потребоваться перезагрузка компьютера).

    Иногда при обновлении плеера возможно появление такой ошибки:

    Данная ошибка возникает в случае блокировки файла "aimp_menu32/64.dll" (зачастую проводником), при этом можно выбрать одно из трех действий:
    - "Abort" (Прервать) - установка будет отменена;
    - "Retry" (Повторить) - следует нажимать после того, как указанный файл был разблокирован вручную (например, с помощью утилиты Unlocker);
    - "Ignore" (Игнорировать) - пропускает заблокированный файл.


Использование
    aimp_setup.exe <команда 1> <команда 2> ...
Список поддерживаемых команд
  • /AUTO="Целевая папка"
    - запуск автоматического режима установки.

    • (AIMP будет установлен в папку по умолчанию, если "Целевая папка" не задана)

  • /PORTABLE
    - установка версии в портативном режиме, если он доступен.

    • (используется совместно с /AUTO, несовместима с /UPDATE)

  • /UPDATE
    - обновление текущей версии, если установленная версия не может быть обновлена, то установка просто прервется.

    • (используется совместно с /AUTO, несовместима с /PORTABLE и /SILENT)

  • /SILENT
    - не показывать GUI.

    • (используется совместно с /AUTO, несовместима с /UPDATE)

  • /RUN
    - запустить плеер после установки.

    • (используется совместно с /AUTO)


Фонотека
Фонотека
  • Как отключить отображение рейтинга вместо оценки в плейлисте?
  • Перемещение файлов без потери оценок
  • Резервная копия базы данных фонотеки
© Artem Izmaylov, 2006-%year%


Функциональность
Функциональность
  • Будильник не выводит компьютер из спящего режима
  • Возможно ли запускать несколько копий плеера?
  • Информационная лента вверху экрана
  • Какому из тегов AIMP отдает приоритет?
  • Контекстное меню проводника - отсутствует AIMP
  • Куда делся Audio Recorder?
  • Не работает скробблинг Last.fm
  • Параметры командной строки
  • Поверх всех окон - как выключить?
  • Сведение/затухание - где найти настройки
© Artem Izmaylov, 2006-%year%


Вопрос:
    Почему будильник не выводит компьютер из спящего режима?

Ответ:
    Убедитесь, что в настройках плана электропитания у вас разрешено пробуждение компьютера при срабатывании таймеров:


Вопрос:
    Какому из тегов AIMP отдает приоритет, ID3v1, ID3v2 или APEv2?

Ответ:
    AIMP отображает наиболее полные данные, собранные из всех доступных тегов.
    Приоритет отдается конкретному полю тега в случае выполнения следующих условий:
    1. Содержимое поля находится в кодировке UTF-8 или UTF-16.
    2. Содержимое поля большей длины.


Вопрос:
    AIMP отсутствует в контекстном меню проводника. Как его туда добавить?

Ответ:
    Включите опцию "Интеграция в контекстное меню проводника" (Главное меню \ Настройки \ Система)

    Если первый совет не помог, проделайте следующую последовательность действий:
    1. Снимите все галочки во вкладке Главное меню \ Настройки \ Система;
    2. Примените изменения и закройте программу;
    3. Перезагрузите компьютер;
    4. Из папки С:\Users\<UserName>\AppData\Roaming\AIMP\ удалите aimp_menu.ini;
    5. Поставьте галочки во вкладке Главное меню \ Настройки \ Система, что были до этого;
    6. Примените изменения.


Вопрос:
    Куда делся Audio Recorder?

Ответ:
    Audio Recorder больше не развивается.


Вопрос:
    Установил недавно очередное обновление и плеер стал сворачиваться вправо (приклеен к правой стороне экрана). Никаких настроек я не менял и мне абсолютно не нужна такая функция. Пытался найти в настройках, где можно выключить такое поведение АИМПа, но ничего не обнаружил.

Ответ:
    У Вас плеер прикреплен к краю экрана.

    Открепить его можно двумя способами:
    • Разверните плеер, схватите его мышью и перетащите в середину рабочего стола.
    • Через контекстное меню: