Добро пожаловать

Добро пожаловать в справочную систему по Расширенному Планировщику для Download Master

Расширенный Планировщик (Advanced Scheduler) это плагин для Download Master предназначенный для тех, кому не хватает возможностей стандартного расписания. Плагин позволяет создавать неограниченное число заданий и выполнять самые разнообразные задачи.

Типы заданий:

  • старт/остановка запланированных закачек;
  • старт/остановка всех закачек;
  • старт/остановка закачек из выбранных категорий;
  • изменение скорости закачки;
  • изменение количества одновременных закачек;
  • запуск любых программ с желаемыми параметрами;
  • установка/разрыв выбранного соединения, разрыв всех соединений;
  • выключение ПК, переход в спящий режим, переход в ждущий режим, выход из программы.

Задания выполняются:

  • однажды;
  • ежедневно;
  • по определенным дням недели;
  • по определенным дням месяца;
  • постоянно (через определенные промежутки времени);
  • при старте программы;
  • при установлении соединения;
  • при завершении всех закачек.

Получить более подробную информацию и закачать новые версии вы сможете на сайте программы: http://www.westbyte.com/dm

Copyright (c) 2006 WestByte
info@westbyte.com
http://www.westbyte.com/dm


Окно заданий

Список заданий и лог выполнения заданий.

Задания планировщика
Список заданий планировщика.

N - Состояние задания (включено/выключено) и порядковый номер задания;
Задание - Краткое описание задания;
Запуск - Когда выполняется задание;
Время следующего запуска - Время следующего выполнения задания;
Время последнего запуска - Время, когда задание было выполнено в последний раз.

Цветная разметка повышает наглядность списка:
Зеленым - выделены задания которые будут выполнены сегодня;
Оранжевым - выделены задания которые будут выполнены позднее;
Синим - выделены задания которые уже выполнены и не будут выполнятся в дальнейшем;
Серым - выделены оключенные задания;

Кнопки: Добавить, Изменить, Удалить, Вверх, Вниз - позволяют произвести соотвествующие операции над заданиями. Эти же действия вы можете выполнить из контекстного меню (кликнув правой кнопкой мыши на задании из списка). Кроме того, из контекстного меню можно выполнить принудительный старт задания - Выполнить.

Лог выполнения заданий
Список выполненных заданий планировщика.

Из контекстного меню вы можете копировать содержимое лога в буфер обмена и удалять содержимое лога целиком, или по частям.

Вызывать расширенный планировщик вместо стандартного из панели инструментов
Если установлен флажок, то из панели инструментов Download Master будет вызываться расширенный планировщик.


Задания

Добавление/изменение задания.

Что выполнять
Список действий, которые может выполнять планировщик.

Когда выполнять
Возможные периоды выполнения действий планировщика.

Подтверждение

Перед выполнением запросить подтверждения
Если установлен флажок, то Download Master будет запрашивать подверждение перед стартом запланированного задания.

Таймаут (сек.)
Время ожидания подтверждения.


История версий

Версия 0.3.1.19 - 20 Февраля 2006
Добавлена возможность управления количеством одновременных закачек.

Версия 0.2.1.15 - 9 Февраля 2006
Первая публичная версия плагина Расширенный Планировщик.


Лицензия

Условия использования плагина

Расширенный Планировщик (Advanced Scheduler) для Download Master является бесплатным ("freeware") и распространяется на условиях "как есть" ("as is"). Вы можете использовать плагин без всяких ограничений при условии информирования разработчиков об обнаруженных ошибках.

Разработчики непрерывно трудятся над улучшением плагина, стараясь сделать его более удобным и производительным. Это невозможно сделать без вашей помощи.

Разработчики не несут никакой ответственности за повреждения аппаратного или программного обеспечения вызванные использованием плагина.

Использование плагина или других частей дистрибутива для коммерческих целей, без согласия разработчиков, запрещено. Эта версия плагина может распространяться свободно и на любых носителях при соблюдении следующих условий:
- Дистрибутив должен включать только оригинальный архив, предоставленный компанией WestByte. Вы не имеете права изменять, удалять или добавлять файлы в оригинальный дистрибутив.
- Вы не имеете права взымать оплату за программу, за исключением разумной суммы за носитель данных, каналы связи и т.п.

Официальный сайт программы: http://www.westbyte.com/dm
E-mail: dm@westbyte.com

Для получения дополнительной информации о программе и
предложениях о сотрудничестве обращайтесь в компанию WestByte:
WWW: http://www.westbyte.com/
E-mail: info@westbyte.com

Copyright (c) 2006 WestByte
info@westbyte.com
http://www.westbyte.com/dm


Контакты

Контактная информация

Advanced Scheduler для Download Master
Copyright (c) 2006 WestByte

Download Master
Copyright (c) 2002-2006 WestByte

Все пользователи программы обеспечиваются технической поддержкой. Мы ответим на все ваши вопросы, выслушаем ваши пожелания и постараемся исправить все найденные ошибки.

Последнюю версию плагина, программы, и множество полезной информации вы найдете на официальном сайте программы: http://www.westbyte.com/dm/
E-mail: dm@westbyte.com

Сайт компании WestByte: http://www.westbyte.com
E-mail: info@westbyte.com

Люди создавшие Advanced Scheduler для Download Master:
Вячеслав Витер (slava@westbyte.com) - разработка проекта и программирование;
Руслан Волошин (ruslan@westbyte.com) - дизайн, справочная система.

Огромная благодарность всем людям, принимающим участие в тестировании программы, присылающим информацию о найденных ошибках и предложения по усовершенствованию программы.