Установка и администрирование SOLIDWORKS

В данном руководстве описываются установка, лицензирование, обновление и администрирование продуктов SOLIDWORKS для установки на отдельных компьютерах и массовой установки.

Индивидуальные установки | Внедрение установок в многопользовательской среде
Установка Установка на одном или нескольких компьютерах. | Установка Создание администрирующего образа, который внедряется на многих клиентских компьютерах.
Лицензии Активация на компьютере, онлайн-лицензирование или сетевое лицензирование. | Лицензии Активация на компьютере, онлайн-лицензирование или сетевое лицензирование.
Обновление Обновление индивидуальных компьютеров до новой версии. | Обновление Обновление нескольких компьютеров до нового выпуска посредством обновления администрирующего образа, используемого для установки на данных компьютерах.
Администрирование Изменение, восстановление и удаление установок, обновление до новых выпусков. | Администрирование Обновление администрирующих образов и клиентов и администрирование сетевых лицензий.

Менеджер установки SOLIDWORKS позволяет задать настройки для компонентов продуктов SOLIDWORKS, включая SOLIDWORKS, SOLIDWORKS Toolbox, PhotoView 360, SOLIDWORKS Electrical, SOLIDWORKS Manage, SOLIDWORKS PDM, SOLIDWORKS PCB, SOLIDWORKS Visualize и SOLIDWORKS SolidNetWork License Manager.

SolidNetWork License Manager поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.

SOLIDWORKS Admin Portal — это облачный ресурс и система управления сервисами, с помощью которой можно назначать сетевые лицензии и управлять ими. Назначение лицензий требуется только для онлайн-лицензирования. Для других типов лицензий назначение лицензий не является обязательным.

Содержание

  • Индивидуальная установка или Администрирующий образ

    Необходимо установить продукты SOLIDWORKS отдельно на каждый компьютер или следует создать администрирующий образ и внедрить установку на другие клиентские компьютеры, с помощью одной команды?

  • Проверка системы и требований к программному обеспечению

    Перед началом установки убедитесь, что система соответствует требованиям оборудования, операционной системы и продуктов Microsoft. Обратите внимание, что дополнения, например SOLIDWORKS Electrical, SOLIDWORKS Visualize и eDrawings, имеют дополнительные требования.

  • Скачивание установочного носителя с Портала клиентов

    Все установочные материалы доступны на Портале клиентов SOLIDWORKS.


Индивидуальная установка или Администрирующий образ

Необходимо установить продукты SOLIDWORKS отдельно на каждый компьютер или следует создать администрирующий образ и внедрить установку на другие клиентские компьютеры, с помощью одной команды?

Если Вы проводите установку на одном компьютере или администрируете десятки или сотни компьютеров, Ваш выбор очевиден. Для менее явных ситуаций рассмотрите приведенные сравнения.

Индивидуальная установка | Администрирующий образ
Пользователи могут администрировать свои установки SOLIDWORKS самостоятельно. | Системный администратор может настроить несколько установок с помощью Редактора параметров, указав параметры установки, такие как создание новой установки или обновление существующей, запуск установки в качестве административного пользователя, запуск внешних команд до или после установки, различные группы продуктов и т.д.
Компьютеры должны быть физически доступны для человека, проводящего установку. | Клиентские компьютеры могут быть удалены, если они доступны через сеть.
Пользователь может устанавливать разные версии, пакеты обновления и продукты на разных компьютерах, используя разные настройки. | С помощью Редактора параметров администрирующие образы могут сохранить последовательность в версиях, пакетах обновления, продуктах и настройках для нескольких установок.
На компьютере должен быть установлен доступ к сети или электронной почте. Требуется установить сетевое подключение или подключение электронной почты для активации SOLIDWORKS и загрузки файлов. Сетевой доступ также требуется при сборе лицензий с сервера сетевых лицензий.

Подключение к локальной сети необходимо для распространения программы; наличие носителей на клиентских компьютерах не требуется.

Клиенты можно обновить автоматически. Установка на всех клиентских компьютерах, проведенная с помощью одного администрирующего образа, распространяет единый пакет обновления на все компьютеры. Для поддержки нескольких версий пакетов обновления можно создать несколько администрирующих образов.

Лицензия может активироваться автоматически.

Администрирующий образ занимает дополнительное место на сервере; клиенты должны обладать таким же количеством свободного места, что и индивидуальные установки.

На уровень выше Установка и администрирование SOLIDWORKS
Проверка системы и требований к программному обеспечению
Скачивание установочного носителя с Портала клиентов


Проверка системы и требований к программному обеспечению

Перед началом установки убедитесь, что система соответствует требованиям оборудования, операционной системы и продуктов Microsoft. Обратите внимание, что дополнения, например SOLIDWORKS Electrical, SOLIDWORKS Visualize и eDrawings, имеют дополнительные требования.

Чтобы получить доступ к текущим системным требованиям, перейдите по ссылке http://solidworks.com/System_Requirements.

На уровень выше Установка и администрирование SOLIDWORKS
Индивидуальная установка или Администрирующий образ
Скачивание установочного носителя с Портала клиентов


Скачивание установочного носителя с Портала клиентов

Все установочные материалы доступны на Портале клиентов SOLIDWORKS.

Если вы не можете получить доступ к Порталу клиентов, обратитесь к своему реселлеру для получения DVD-дисков.

Чтобы скачать установочный носитель с Портала клиентов, выполните следующие действия.

  1. Выполните вход на Портал клиентов SOLIDWORKS в качестве клиента Subscription Service, используя свой адрес электронной почты и пароль или свой серийный номер SOLIDWORKS.
  2. В разделе Download (Скачать) нажмите Downloads and Updates (Загрузки и обновления).
  3. На странице скачивания в разделе Выбор версии выберите год.
  4. Выберите вкладку SOLIDWORKS для продуктов SOLIDWORKS.
  5. В области "Продукт" выберите пакет обновления.
    Для последнего основного выпуска выберите Продукты SOLIDWORKS версии 0.0.
  6. Нажмите Принять соглашение и продолжить на странице скачивания лицензионного соглашения SOLIDWORKS.
  7. Нажмите Скачать.
    Менеджер установки скачивает установочный пакет.
    Для выборочного скачивания установочных файлов следуйте подсказкам, чтобы выбрать метод ручного скачивания.
На уровень выше Установка и администрирование SOLIDWORKS
Индивидуальная установка или Администрирующий образ
Проверка системы и требований к программному обеспечению


Индивидуальные установки

Содержание

  • Установка на отдельных компьютерах

    Программу SOLIDWORKS можно установить на отдельном компьютере следующими способами.

  • Администрация индивидуальных установок

    Как правило, администрирование индивидуальных установок включает изменение, исправление, удаление и обновление установленных версий.


Установка на отдельных компьютерах

Программу SOLIDWORKS можно установить на отдельном компьютере следующими способами.

Менеджер установки SOLIDWORKS выполняет установку, адаптируя ее для приобретенных продуктов. Перед началом установки необходимо:

  • Необходимо иметь собственный серийный номер для SOLIDWORKS.
  • Убедитесь, что у Вас есть работающее подключение к Интернету. Для проверки объема обслуживания требуется установить подключение.

Менеджеру установки SOLIDWORKS необходимы различные компоненты Microsoft, в том числе установщик Microsoft Windows, Microsoft Visual Studio Tools для приложений, Visual Basic и платформа .NET Framework. Если на компьютере не установлены все необходимые компоненты Windows, Менеджер установки SOLIDWORKS автоматически выполнит их установку перед установкой продуктов SOLIDWORKS. Служба Bonjour для Windows также является обязательным компонентом.

Метод установки Сводка по процессу
Скачивание с Портала клиентов SOLIDWORKS
  1. Перейдите к Порталу клиентов SOLIDWORKS.
  2. Выполните вход в качестве Клиента Subscription Service, используя свой адрес электронной почты и пароль или свой серийный номер SOLIDWORKS.
  3. В поле Self Service (Самообслуживание) выберите Download Software and Updates (Загрузка программ и обновлений).
  4. В разделе Загрузка программ нажмите на версию SOLIDWORKS, которую необходимо установить.
Необходимо наличие рабочего подключения к Интернету, и вы должны быть клиентом Subscription Service и иметь права доступа для входа в клиентский портал.
Установка с помощью каталога загрузки на сервере В каталоге скачивания дважды нажмите setup.exe.

Каталог скачивания должен быть доступен с компьютера, на котором выполняется установка продуктов SOLIDWORKS, и должен содержать все установочные файлы SOLIDWORKS до начала процесса установки. Менеджер установки SOLIDWORKS позволяет искать недостающие файлы при наличии доступа в Интернет и права записи в каталог скачивания.

Установка с помощью носителя SOLIDWORKS
  • Приобретите DVD-диски у реселлера и вставьте их в дисковод компьютера.
Обновление текущей установки SOLIDWORKS с помощью параметра Проверить наличие обновлений. Выполните одну из следующих операций:
  • В SOLIDWORKS выберите Справка > Проверить наличие обновлений.
  • В ОС Windows нажмите Пуск > Все программы > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.
Необходимо наличие рабочего подключения к Интернету и полномочия администратора на компьютере.

В Менеджере установки SOLIDWORKS можно также выбрать параметр Скачать и предоставить общий доступ ко всем файлам, включая необходимое программное обеспечение. Эта функция полезна, если вы устанавливаете программное обеспечение на нескольких компьютерах и хотите скопировать его с помощью портативного или сетевого диска. Также полезно установить пакеты обновления, т.к. полная версия и пакет обновления содержатся в одной установке.

После завершения установки запустите программу SOLIDWORKS и активируйте лицензию.

Чтобы отобразить список установленных на компьютере продуктов, в главном меню SOLIDWORKS выберите Справка > Мои продукты. Флажки в диалоговом окне указывают, какими продуктами вы или ваша организация владеете на основе активации или сетевых лицензий. Также можно узнать больше о продуктах SOLIDWORKS, нажав на ссылку в верхней части каждой категории продукта.

Чтобы просмотреть, какие лицензии используются, в ОС Windows нажмите Пуск > SOLIDWORKS <версия > > Инструменты SOLIDWORKS > Клиент SolidNetWork License Manager > Использование лицензий.

На уровень выше Индивидуальные установки
Администрация индивидуальных установок
Советы по использованию SOLIDWORKS с ОС Microsoft Windows 8


Администрация индивидуальных установок

Как правило, администрирование индивидуальных установок включает изменение, исправление, удаление и обновление установленных версий.

Содержание

  • Изменение установки

    Вы можете изменить установку, чтобы установить еще не установленные продукты, или удалить продукты, если установлен полный набор установочных файлов во время предыдущей установки. Этот вариант не может использоваться, если обновление предыдущей установки выполнено с использованием пакета обновления.

  • Исправление установки

    При возникновении неполадок в установленном продукте SOLIDWORKS можно воспользоваться Менеджером установки SOLIDWORKS для исправления установки.

  • Откат индивидуальной установки к предыдущей версии пакета обновления

  • Удаление установки

    Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

  • Обновление до новой версии

    Выполнить обновление индивидуальной установки SOLIDWORKS до новой версии можно несколькими способами.

  • Правила сосуществования продуктов

    Правилами совместимости продуктов определяются способы установки новых продуктов и обновления существующих.

На уровень выше Индивидуальные установки
Установка на отдельных компьютерах


Изменение установки

Вы можете изменить установку, чтобы установить еще не установленные продукты, или удалить продукты, если установлен полный набор установочных файлов во время предыдущей установки. Этот вариант не может использоваться, если обновление предыдущей установки выполнено с использованием пакета обновления.

Если вы установили SOLIDWORKS и позднее приобрели добавление, можно изменить установку, чтобы включить в нее новое добавление. Добавление следует установить на каждом отдельном компьютере.

  1. Убедитесь, что не существует текущих сеансов SOLIDWORKS.
  2. В ОС Windows 7или более поздней версии нажмите Пуск > Панель управления >Программы и компоненты.
  3. Выберите версию SOLIDWORKS, которую требуется изменить, и нажмите кнопку Изменить.
  4. На экране Вас приветствует Менеджер установки SOLIDWORKS выберите Изменение индивидуальной установки (на данном компьютере).
  5. На экране Серийный номер проверьте, указаны ли соответствующие серийные номера.
  6. На странице выбора продуктов выберите продукты для установки или удаления.
    При изменении установки:
    • продукты не устанавливаются и не удаляются по умолчанию, даже если указан новый серийный номер. Необходимо изменить установку каждого продукта или компонента.
    • Для просмотра спроецированного действия определенного компонента щелкните его имя (не флажок). Планируемое действие по установке появится в поле сведений под списком продуктов.
    • Можно установить флажок рядом с компонентом продукта, чтобы изменить действие по установке для данного компонента. (Например, установка флажка при установке или удалении компонента означает, что отмеченный компонент необходимо установить или удалить, а снятие флажка означает, что компонент не следует устанавливать или удалять.)
    • При изменении действия по установке компонента, заданного в исходной спецификации, в списке рядом с этим компонентом отобразится звездочка (*).
    • Если компонент содержит необязательные для установки субкомпоненты, после компонента отобразится значок +. Для просмотра доступных субкомпонентов компонента щелкните на значок +.
    • Если компонент уже был развернут для просмотра субкомпонентов, после него отобразится значок -. Чтобы свернуть список субкомпонентов, щелкните на значок -.
  7. На экране Сводная информация нажмите кнопку Изменить сейчас.
  8. На экране Установка завершена нажмите на кнопку Готово.
На уровень выше Администрация индивидуальных установок
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Обновление до новой версии
Правила сосуществования продуктов


Исправление установки

При возникновении неполадок в установленном продукте SOLIDWORKS можно воспользоваться Менеджером установки SOLIDWORKS для исправления установки.

Для исправления установки потребуются все исходные файлы предыдущей установки, а также все установленные пакеты обновлений, которые должны находиться в том же расположении, куда они были установлены изначально.

Можно исправить индивидуальную установку. Администрирующий образ исправить нельзя; необходимо отменить установку и затем повторно установить администрирующий образ.
  1. Откройте панель управления Windows и выберите Программы > Программы и компоненты.
  2. Выберите версию SOLIDWORKS, которую требуется исправить, и нажмите кнопку Изменить.
  3. На экране Вас приветствует Менеджер установки SOLIDWORKS нажмите Восстановить установку.
  4. На экране Продукты для исправления выберите продукт, который требуется исправить.
  5. Отмените выбор всех остальных продуктов.
  6. Выберите Исправить.
На уровень выше Администрация индивидуальных установок
На уровень выше Ошибки установки/Отмена установки
Изменение установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Обновление до новой версии
Правила сосуществования продуктов
Восстановление после неудачной или отмененной установки
Обращение к реселлеру SOLIDWORKS


Откат индивидуальной установки к предыдущей версии пакета обновления

Чтобы выполнить откат индивидуальной установки к предыдущей версии пакета обновления в текущем семействе версий, удалите установленную на компьютере версию пакета обновления и переустановите более раннюю версию.
На уровень выше Администрация индивидуальных установок
Изменение установки
Исправление установки
Удаление установки
Обновление до новой версии
Правила сосуществования продуктов


Удаление установки

Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

  1. Убедитесь, что не существует текущих сеансов SOLIDWORKS.
  2. Если вы хотите перенести лицензию SOLIDWORKS на другой компьютер, деактивируйте лицензию на этом компьютере до удаления установки SOLIDWORKS.
    Чтобы узнать больше, см. раздел Перенос лицензии.
  3. В ОС Windows 7 или более поздней версии запустите Панель управления > Программы и компоненты.
  4. Выберите компонент продукта, который нужно удалить.
    В некоторых случаях можно обнаружить несколько компонентов пакета обновления SOLIDWORKS для существующей основной версии. Чтобы удалить основной выпуск SOLIDWORKS, удалите все элементы пакета обновления для данного основного выпуска.
  5. На экране Удалить:
    1. Выберите продукты для удаления. По умолчанию установлено значение "Все компоненты продуктов".
    2. Отмените выбор продуктов, которые вы не хотите удалять.
    3. Выберите для выполнения полную установку или настраиваемую пользователем. По умолчанию Менеджер установки SOLIDWORKS выполняет стандартную отмену установки и удаляет файлы и папки программ.
      1. Нажмите кнопку Изменить в разделе Дополнительные параметры.

        Откроется экран Дополнительные параметры с выбранным параметром «Файлы и папки программ»

      2. Выберите один или несколько параметров, чтобы выполнить настраиваемую пользователем отмену установки, или все параметры, чтобы выполнить полную отмену установки.
      3. Нажмите Назад в Сводку.
      4. На экране Сводка разверните Дополнительные параметры, чтобы отобразить удаляемые объекты и метод отмен установки.
    4. Выберите Удалить объект.
На уровень выше Администрация индивидуальных установок
На уровень выше Администрация множественных установок
Изменение установки
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Обновление до новой версии
Правила сосуществования продуктов
Обновление администрирующих образов до новой версии
Администрирование обновлений продуктов с помощью пакетов обновления
Перенос лицензии


Обновление до новой версии

Выполнить обновление индивидуальной установки SOLIDWORKS до новой версии можно несколькими способами.

Выполнять обновление до новой версии можно в следующих случаях.
  • При получении нового установочного носителя;
  • при получении уведомления о наличии обновлений во время запуска SOLIDWORKS.
  • Проверка наличия обновлений вручную
  • Запуск новой версии Менеджера установки SOLIDWORKS

При установке новой основной версии можно обновить установленную ранее версию или установить новую параллельно с существующей версией. При установке версии пакета обновления для установленной ранее основной версии эта версия обновляется автоматически.

На уровень выше Администрация индивидуальных установок
Изменение установки
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Правила сосуществования продуктов

Проверка наличия обновлений вручную

Если у вас есть полномочия администратора компьютера, можно выполнить проверку обновлений для установленной версии SOLIDWORKS одним из перечисленных ниже способов.

  • В SOLIDWORKS выберите Справка > Проверить наличие обновлений.
  • В ОС Microsoft Windows выберите Пуск > Все программы > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.

Предупреждения относительно обновления

Продукты, допускающие множественные установки, принадлежащие разным основным выпускам, не всегда поддерживают основные обновления или возможность обновления до следующего основного выпуска посредством одного действия.

В этом случае Менеджер установки SOLIDWORKS имитирует обновление: сначала устанавливается новая версия, а затем удаляется более ранняя. В настоящее время только основной продукт SOLIDWORKS поддерживают основные обновления.

Последствия таковы:
  • При обновлении основного продукта SOLIDWORKS до следующей основной версии происходит следующее.
    • Текущее месторасположение установки не изменяется.
    • Можно выполнить откат обновления при возникновении ошибки или при отмене процесса обновления во время его выполнения.
  • При обновлении других продуктов до следующего основного выпуска:
    • Каждый из продуктов сначала устанавливается в качестве нового продукта в новом месторасположении, а затем его исходная установка удаляется.
    • После запуска процесса обновления его нельзя откатить назад при возникновении ошибки или при отмене процесса обновления во время его выполнения.


Правила сосуществования продуктов

Правилами совместимости продуктов определяются способы установки новых продуктов и обновления существующих.

Правило | Примеры
Разрешается устанавливать несколько основных версий базовых продуктов SOLIDWORKS, исключение составляют три перечисленных ниже продукта. | На одном компьютере можно устанавливать SOLIDWORKS 2019 SP3.0 и SOLIDWORKS 2020 SP0.0.
Несколько пакетов обновления из одной основной версии базовых продуктов запрещены. | Версии SOLIDWORKS 2020 SP0.0 и 2020 SP1.0 не могут работать на одном компьютере. При установке SOLIDWORKS 2019 SP1.0 на компьютер с уже установленной версией SOLIDWORKS 2020 SP0.0 Менеджер установки SOLIDWORKS заменит версию SP0.0 на SP1.0.
Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • SolidNetWork License Manager
 Если установлена версия SOLIDWORKS 2020 SP0.0, SolidNetWork License Manager обновляется до версии 2020 SP0.0, даже если на данном компьютере остается более ранняя основная версия SOLIDWORKS.
Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • SOLIDWORKS Electrical
 Если создается новая установка SOLIDWORKS Electrical 2020 SP1.0, Менеджер установки SOLIDWORKS автоматически удалит более ранние версии SOLIDWORKS Electrical с компьютера. Создайте резервную копию среды SOLIDWORKS Electrical перед обновлением.
Перечисленные ниже продукты можно устанавливать на компьютере только в одной версии:
  • Клиент SOLIDWORKS PDM
  • Сервер SOLIDWORKS PDM

При установке SOLIDWORKS 2020 SP0.0 или SP1.0 необходимо также обновить сервер и клиент до версии SOLIDWORKS 2020 PDM.

При установке сервера SOLIDWORKS 2020 PDM клиент SOLIDWORKS PDM необходимо установить в процессе установки сервера PDM. Не устанавливайте клиент SOLIDWORKS PDM отдельно в процессе установки клиента.

На одной машине клиент SOLIDWORKS PDM должен иметь ту же рабочую версию и пакет обновления, что сервер SOLIDWORKS PDM.

Дополнительные сведения см. в разделе Установка сервера PDM с помощью раздела SLDIM.

Для каждой основной версии SOLIDWORKS встроенного продукта можно установить только одну версию. Однако версии встроенных продуктов с других основных выпусков SOLIDWORKS могут работать на одном компьютере. | Если SOLIDWORKS 2020 SP0.0 обновляется до версии 2020 SP1.0, SOLIDWORKS Composer 2020 SP0.0 будет автоматически обновлено до версии 2020 SP1.0. Тем не менее, SOLIDWORKS Composer 2019 SP4.0 может сосуществовать с версией SOLIDWORKS Composer 2020 SP0.0 или SOLIDWORKS Composer 2020 SP1.0.
На уровень выше Администрация индивидуальных установок
Изменение установки
Исправление установки
Откат индивидуальной установки к предыдущей версии пакета обновления
Удаление установки
Обновление до новой версии


Множественные установки

Содержание

  • Внедрение на нескольких клиентах

    Продукты SOLIDWORKS можно установить на нескольких клиентских компьютерах, создав для этого соответствующий администрирующий образ и внедрив его на клиентах.

  • Использование администрирующих образов

    Администрирующий образ позволяет настраивать установку продуктов SOLIDWORKS из одной сетевой папки.

  • Внедрение администрирующего образа на клиентах через электронную почту

    Когда будет создан общий каталог администрирующего образа, можно по электронной почте оповестить об этом клиентов.

  • Внедрение с использованием командной строки

    Можно автоматически внедрить администрирующий образ с использованием командной строки или пакетного файла (автоматическая установка).

  • Администрация множественных установок

    К административным задачам по созданию нескольких установок относятся обновление администрирующих образов до новых версий, применение пакетов обновления и удаление установок.


Внедрение на нескольких клиентах

Продукты SOLIDWORKS можно установить на нескольких клиентских компьютерах, создав для этого соответствующий администрирующий образ и внедрив его на клиентах.

Ниже дается описание процесса внедрения на нескольких клиентских компьютерах.
  1. Создайте администрирующий образ.
    • Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS
  2. Разверните администрирующий образ на клиентских компьютерах.
    • Внедрение администрирующего образа на клиентах через электронную почту
    • Установка администрирующего образа с использованием командной строки
  3. Примените лицензирование.
    • Администрирование индивидуальных лицензий
    • Администрирование лицензий с помощью SolidNetWork License Manager
На уровень выше Множественные установки
Использование администрирующих образов
Внедрение администрирующего образа на клиентах через электронную почту
Внедрение с использованием командной строки
Администрация множественных установок
Советы по использованию SOLIDWORKS с ОС Microsoft Windows 8


Использование администрирующих образов

Администрирующий образ позволяет настраивать установку продуктов SOLIDWORKS из одной сетевой папки.

Администрирующий образ можно установить с любого компьютера в сети, включая клиент.
  • Администрирующий образ должен находиться в папке общего использования.
  • При включении всех продуктов необходимый объем дискового пространства для создания администрирующего образа может составить 7 ГБ и больше.
  • Если обновить общее имя при обновлении администрирующего образа, клиент будет обновлен автоматически при следующем запуске приложения. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.
  • При развертывании администрирующего образа путь к файлу образа должен содержать меньше 58 символов.
  • Клиенты должны иметь полномочия администраторов на своих компьютерах. Если у клиента недостаточно прав, он может выполнить установку от имени другого пользователя. Этот возможность полезна, когда отдельные пользователи не имеют на компьютере прав административного доступа, что необходимо для установки продуктов SOLIDWORKS.

    См. Внедрение установок из Редактора параметров. Здесь также описан альтернативный метод установки образов, когда клиент не обладает достаточными правами.

  • Если ведение журнала Windows включено или используется функциональность статуса в редакторе параметров администрирующего образа, необходимо иметь права на чтение/запись данных в этой папке: {Каталог администрирующего образа}\x64\Logs.

Параметрами установки созданного администрирующего образа можно управлять при помощи Редактора параметров администрирующего образа, настраивая их для пользователей и групп, использующих данный образ для установки. Подробнее см. раздел Редактор параметров администрирующего образа.

Содержание

  • Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS

    Если Вы устанавливаете программу SOLIDWORKS на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

На уровень выше Множественные установки
Внедрение на нескольких клиентах
Внедрение администрирующего образа на клиентах через электронную почту
Внедрение с использованием командной строки
Администрация множественных установок
Обновление клиентов с помощью администрирующих образов
Редактор параметров администрирующего образа


Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS

Если Вы устанавливаете программу SOLIDWORKS на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

  1. Запустите Менеджер установки SOLIDWORKS. См. Инициация установки SOLIDWORKS.
  2. На экране Добро пожаловать выберите Администрирующий образ.
    На экране отображаются параметры создания администрирующего образа.
    Опция | Описание
    Создать новый образ с использованием параметров по умолчанию. | Создать образ при помощи параметров конфигурации, настроенных по умолчанию (иными словами, не используя текущие параметры, заданные для имеющегося администрирующего образа).
    Создать новый образ с использованием параметров и файлов существующего образа. | Создать образ, используя параметры конфигурации, настроенные для существующего администрирующего образа. Нажмите Обзор, чтобы указать каталог установки существующего администрирующего образа.
  3. Следуйте инструкциям на экране.

Содержание

  • Редактор параметров администрирующего образа

    С помощью Редактора параметров администрирующего образа можно настроить параметры установки администрирующего образа для отдельных компьютеров или для группы компьютеров.

На уровень выше Использование администрирующих образов
Начало установки SOLIDWORKS


Редактор параметров администрирующего образа

С помощью Редактора параметров администрирующего образа можно настроить параметры установки администрирующего образа для отдельных компьютеров или для группы компьютеров.

После создания администрирующего образа Менеджер установки SOLIDWORKS выдает запрос на запуск Редактора параметров. Можно также запустить Редактор параметров, дважды нажав sldAdminOptionEditor.exe в папке администрирующего образа.

Чтобы указать разные конфигурации установки для групп компьютеров или отдельных компьютеров, в редакторе параметров выберите компьютеры, указав любой из следующих параметров:
  • имя компьютера
  • IP-адрес
  • диапазону IP-адресов
Затем укажите параметры установки для этих компьютеров.
Все диалоговые окна, запрашивающие путь к файлу или папке, содержат возможность назначить выбранную папку переменной среды. Например, при выборе C:\Program Files\SOLIDWORKS Corp путь к файлу будет привязан к %ProgramFiles%\SOLIDWORKS Corp. Наиболее распространенными переменными являются %ProgramFiles% и %SystemDrive%. Тем не менее, не все пути можно преобразовать в переменные среды. Например, Z:\SOLIDWORKS Data нельзя привязать к переменной среды.

Содержание

  • Добавление и удаление групп и компьютеров

    В Редакторе параметров администрирующего образа можно указать различные конфигурации установки для групп компьютеров или отдельных компьютеров.

  • Просмотр и изменение значений параметров

    Редактор параметров администрирующего образа SOLIDWORKS позволяет просматривать и изменять настройки параметров для групп и компьютеров, указанных для образа.

  • Инструмент "Администратор параметров"

  • Внедрение установок из Редактора параметров

    Развертывание можно выполнять непосредственно из редактора параметров двумя способами – вручную или автоматически.

  • Выход из Редактора параметров

    Для выхода из Редактора параметров можно нажать кнопку «OK» или «Закрыть».

  • Создание ярлыка Редактора параметров на рабочем столе

    Можно создать ярлык Редактора параметров на рабочем столе Windows для определенного администрирующего образа внутри приложения.

На уровень выше Создание администрирующего образа с помощью Менеджера установки SOLIDWORKS


Добавление и удаление групп и компьютеров

В Редакторе параметров администрирующего образа можно указать различные конфигурации установки для групп компьютеров или отдельных компьютеров.

Например, может потребоваться настройка нескольких компьютеров, на которых планируется использовать определенный набор компонентов продукта, доступных в образе. А на другой группе компьютеров планируется использовать другой набор компонентов продукта. Даже в случае использования одного администрирующего образа групповые настройки Редактора параметров позволяют устанавливать на разных группах машин разные наборы компонентов продукта.

Чтобы добавить группу, выполните следующие действия.
  1. Нажмите правой кнопкой мыши Глобальные настройки, а затем выберите Добавить группу.
  2. Введите имя группы.

Чтобы добавить компьютеры, выполните следующие действия.
  1. Нажмите правой кнопкой мыши существующую группу или пункт Глобальные настройки, а затем выберите Добавить компьютер.
    Если нажать существующую группу правой кнопкой мыши, компьютеры будут добавлены в эту группу. В противном случае они будут добавлены на верхний уровень.
  2. Выполните одно из действий ниже.
    • Выберите По имени компьютера и ведите одно или несколько имен компьютеров. Имена нескольких компьютеров можно разделить с помощью разрыва строки, пробела, символа табуляции, запятой, точки, двоеточия или точки с запятой. Можно скопировать и вставить список имен компьютеров из существующего файла. Имена компьютеров не могут включать квалификаторы домена. Например, имя pluto.solidworks.com неверное.
    • Выберите По IP-адресу и введите IP-адрес компьютера.
    • Выберите По диапазону IP-адресов и введите начальный и конечный IP-адреса диапазона.
    • Нажмите Добавить несколько компьютеров, чтобы выбрать компьютеры в сети.

Чтобы переместить существующий компьютер в группу, выполните следующее действие.

Перетащите компьютер в группу.

Чтобы переместить компьютер из группы, выполните следующее действие.

Перетащите компьютер в раздел Глобальные настройки или в другую группу.

Чтобы удалить группу или компьютер, выполните следующие действия.

Нажмите правой кнопкой мыши группу или компьютер и выберите Удалить группу или Удалить компьютер.

При удалении группы удаляются все компьютеры, входящие в ее состав.

Чтобы удалить все группы и компьютеры, выполните следующие действия.

Нажмите правой кнопкой мыши Глобальные настройки, а затем выберите Удалить все.

На уровень выше Редактор параметров администрирующего образа
Просмотр и изменение значений параметров
Инструмент "Администратор параметров"
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе


Просмотр и изменение значений параметров

Редактор параметров администрирующего образа SOLIDWORKS позволяет просматривать и изменять настройки параметров для групп и компьютеров, указанных для образа.

  • При первом запуске Редактора параметров настройки параметров отображаются в режиме только для чтения. Значок "Редактировать" не затенен.

    При выборе параметра Глобальные настройки, группы или компьютера отобразится краткий перечень настроек параметра для данного элемента:

    Область | Отображаемые настройки параметров
    Глобальные настройки | Все настройки параметров, указанные для администрирующего образа
    Группа | Изменения настроек групп относительно глобальных настроек
    Машина | Изменения настроек компьютеров относительно группы
  • Для изменения настроек параметров щелкните значок «Редактировать». Значок становится затемненным, а на экране появится более подробный список настроек параметров.

    При выборе параметра Глобальные настройки, группы или компьютера пользователь может изменять настройки параметра для данного элемента. При изменении настройки параметра, отличной от унаследованной глобальной настройки или настроек группы, эта настройка параметра будет выделена.

    При повторном щелчке на значке «Редактировать» содержимое на экране снова будет отображаться в режиме только для чтения.

    Если в «Редакторе параметров» были внесены изменения, перед выходом отобразится запрос об их сохранении или отмене.

Содержание

  • Установка значений параметров для отдельных компьютеров и групп

    Задать параметры можно для всех компьютеров (Глобальные параметры), группы компьютеров или отдельного компьютера.

  • Настройка параметров администрирующего образа

    Редактор параметров позволяет указать настройки для отдельных клиентов или групп, включая серийные номера, параметры установки клиента, компонентов для установки и расположение Toolbox.

  • Наследование настроек глобальных и групповых параметров

    Настройки параметров для элемента Глобальные настройки или групп наследуются по элементам нижнего уровня.

  • Настройка параметров для каждого компьютера

    Также можно изменить параметры, которые применены к определенным компьютерам, щелкнув правой кнопкой мыши имя соответствующего компьютера.

На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Инструмент "Администратор параметров"
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе


Установка значений параметров для отдельных компьютеров и групп

Задать параметры можно для всех компьютеров (Глобальные параметры), группы компьютеров или отдельного компьютера.

  1. В Редакторе параметров нажмите объект, который необходимо изменить (например, Глобальные настройки, группа, компьютер).
  2. Справа нажмите значок редактирования.
    Значок редактирования потемнеет, а на экране появится более подробный список для настройки параметров.
  3. Измените настройки для параметров в левой части окна, выбирая необходимые значения справа.
    Изменения параметров, влияющие на Глобальные настройки или параметры группы, будут выделены.
  4. Нажмите OK или Закрыть, чтобы сохранить изменения.
    Опция | Описание
    OK | Изменения будут сохранены, а Редактор параметров будет закрыт.
    Закрыть | На экран будет выдан запрос на сохранение изменений, после чего Редактор параметров будет закрыт.
На уровень выше Просмотр и изменение значений параметров
Настройка параметров администрирующего образа
Наследование настроек глобальных и групповых параметров
Настройка параметров для каждого компьютера


Настройка параметров администрирующего образа

Редактор параметров позволяет указать настройки для отдельных клиентов или групп, включая серийные номера, параметры установки клиента, компонентов для установки и расположение Toolbox.

Серийные номера

Введите серийные номера для установки продуктов на клиентских компьютерах.
Поскольку существует множество способов приобретения продуктов SOLIDWORKS, некоторые серийные номера могут принадлежать двум или нескольким продуктам. Например, серийный номер SOLIDWORKS дает возможность установить SOLIDWORKS Simulation без ввода отдельного серийного номера SOLIDWORKS Simulation. Кроме того, для некоторых продуктов серийный номер не требуется. В случае возникновения вопросов, касающихся серийных номеров, обратитесь к своему реселлеру.
При управлении лицензиями с помощью лицензий SolidNetWork:
  • В первом поле для серийного номера введите серийный номер SolidNetWork.
  • В поле Порт сервера SNL@сервер введите имя сервера SolidNetWork License Manager и порт следующим образом: nnnnn@имя_сервера. В качестве разделителей между различными записями используйте точку с запятой.

Подробные сведения о лицензиях SolidNetWork License см. в разделе Установка и настройка лицензий SolidNetWork License.

Параметры установки на клиентском компьютере

Как вы хотите выполнить установку основных версий на клиентских компьютерах? Можно указать, каким образом клиентские установки будут взаимодействовать с уже существующей установкой основной версии:
  • Обновить существующий основной выпуск (если есть).

    Выберите этот параметр для замены предыдущего основного выпуска версии на новый.

  • Создать новый основной выпуск.

    Выберите этот вариант, чтобы сохранить предыдущий основной выпуск и создать новую установку для нового основного выпуска. Чтобы указать местоположение установки новой версии, нажмите кнопку Обзор.
Удалить установку последней предыдущей версии перед установкой новой основной версии? Можно указать, отменять ли установку существующей прежней основной версии:
  • Нет, не нужно сначала отменять установку.

    Выберите этот вариант, чтобы оставить установку предыдущей основной версии.

  • Да, выполните настроенную пользователем отмену установки.

    Выберите этот вариант, чтобы удалить следующие элементы: Файлы и папки данных, созданные во время предыдущей установки.

Применение настроек SOLIDWORKS При запуске программы можно указать файл настроек. Клиентские установки ссылаются на файл настроек. Файл настроек (*.sldsettings) должен быть сохранен в общем пути UNC, который виден для всех установок. Перед установкой SOLIDWORKS укажите путь к файлу *.sldsettings. Клиентские установки обнаруживают путь к файлу *.sldsettings во время установки.
Обеспечьте защиту файла *.sldsettings с помощью установки разрешений Windows на доступ к записи только для определенных пользователей.

Чтобы создать или изменить файл *.sldsettings, нажмите Запустить администратор настроек. Инструмент Администратор параметров SOLIDWORKS позволяет определить, какие параметры системы SOLIDWORKS необходимо применить и при необходимости заблокировать для конечных пользователей. Также можно определить способ и время применения параметров к индивидуальным установкам. Файл *.sldsettings можно изменить в любое время с помощью запуска инструмента администратора параметров и перезаписи существующего файла.

Можно использовать другие файлы *.sldsettings для разных компьютеров или групп.

Путь к *.sldsettings задается во время установки. После развертывания не следует переименовывать или перемещать файл *.sldsettings .

Для запуска инструмента администратора настроек необходимо иметь существующую установку SOLIDWORKS [текущая основная версия].
Как вы хотите активировать установки клиента? Можно указать, следует ли после запуска установки продукта автоматически выполнять активацию продукта или пользователь должен вручную выполнять активацию продукта после установки.
  • Активировать автоматически после завершения каждой установки клиента.

    Выбор этого параметра указывает, что активация продукта запускается автоматически с помощью файла активации продукта SOLIDWORKS. Выберите Обзор, чтобы найти существующий файл активации, или Создать, чтобы запустить активацию продукта SOLIDWORKS для создания нового файла активации.

  • Не активировать автоматически.

    Выбор этого параметра указывает на отсутствие автоматической активации продуктов. Клиент производит активации продукта после установки.

Административные настройки

Во время каждой установки следует создать журнал диагностики. | Установка клиента может создать журнал диагностики для устранения проблем с установкой. Создание такого журнала может замедлить установку клиента. Файл журнала хранится в каталоге Administrative image directory}\x64\Logs\<имя_компьютера>\Status.xml.
Выполнить установку как другой пользователь.

Установку клиента можно запустить от имени другого пользователя. Этот параметр полезен, если отдельные пользователи не имеют прав административного доступа на локальный компьютер, что необходимо для установки продуктов SOLIDWORKS.

Альтернативный метод развертывания и установки доступен только тогда, когда клиенты не имеют административных прав. См. Внедрение установок из Редактора параметров.
Программы для запуска до или после установки. | Можно указать, чтобы до установки клиента или после нее запускалась программа, указанная пользователем.
Вы хотите, чтобы клиенты участвовали в Программе отзывов клиентов SOLIDWORKS? | Можно указать, что компьютеры клиентов могут принимать участие в Программе отзывов клиентов SOLIDWORKS. Информация по быстродействию программы посылается корпорации SOLIDWORKS с целью улучшения продукта. Процесс является прозрачным и конфиденциальным. Дополнительные сведения см. на веб-сайте программы улучшения качества программного обеспечения.

Ограничения на параметры выполнения программ до и после установки

Эти параметры позволяют выполнять другие программы и сценарии установки на клиентских компьютерах до или после развертывания SOLIDWORKS, например, сценарий установки Microsoft Office.

При автоматическом развертывании на клиентских компьютерах Windows 10 есть ограничения на использование таких параметров. Сбой возникает в случае использования любого из этих вариантов для развертывания программы или сценария установки, которые отображают пользовательский интерфейс, например, сценарий, который открывает диалоговые окна. При автоматическом развертывании выполняющихся экземпляров SOLIDWORKS, программу SOLIDWORKS не удастся установить на целевых компьютерах. Это ограничение не возникает на клиентских компьютерах Windows 7.

Чтобы использовать параметры Запустить программу до установки и Запустить программу после установки, выберите только те программы, которые могут быть установлены в автоматическом режиме.

Программное обеспечение для установки

Можно указать, какие компоненты продукта SOLIDWORKS следует установить.
  • Установленный флажок рядом с компонентом продукта означает, что компонент устанавливается во время установки клиента.
  • Отсутствие флажка означает, что компонент не будет установлен.
  • Если компонент содержит необязательные для установки подкомпоненты, рядом с ним отображается значок +. Для просмотра доступных подкомпонентов компонента нажмите на значок +.
  • Если компонент уже был развернут для просмотра подкомпонентов, рядом с ним отобразится значок -. Чтобы свернуть список подкомпонентов, нажмите на значок -.
Параметр Языки ограничивает иностранные языки, устанавливаемые для продуктов SOLIDWORKS. Это не повлияет на установки других продуктов. Например, eDrawings® устанавливает все языки.

Параметры Toolbox

Можно указать поддерживаемые стандарты и местоположение Toolbox по умолчанию для установок клиентов.

Обычно к общей установке Toolbox , как правило в сети, имеют доступ несколько пользователей (например, указывается путь UNC, общая папка или общий сетевой диск).

Если в указанном месте расположен более ранний основной выпуск Toolbox, во время установки клиента версия Toolbox будет обновлена до нового основного выпуска. После этого файлы не будут распознаваться в предыдущих основных выпусках SOLIDWORKS.
Если некоторые клиенты продолжают использовать более раннюю версию SOLIDWORKS, необходимо указать другое сетевое расположение Toolbox для клиентов, обновляющихся до более новой версии.

Для получения более подробной информации об администрировании SOLIDWORKS Toolbox см. раздел Toolbox в Справке SolidWorks.

Установка программного обеспечения Toolbox без установки данных Toolbox

Если в вашей среде используется PDM или общая папка для Toolbox или мастера "Отверстие под крепеж", можно настроить установленные клиенты так, чтобы они не устанавливали и не обновляли данные Toolbox в этом расположении.

Это необходимо сделать в следующих случаях:
  • Если перед установкой программного обеспечения SOLIDWORKS не был создан локальный вид SOLIDWORKS PDM.
  • Если файлы в этом расположении используются и могут блокировать завершение установки SOLIDWORKS.
  • Если это расположение недоступно и может блокировать завершение установки SOLIDWORKS.

Если установленные клиенты настроены так, чтобы данные Toolbox не устанавливались, программа SOLIDWORKS и настройки ссылаются на расположение Toolbox или мастера "Отверстие под крепеж", но в дальнейшем необходимо установить данные в центральном расположении.

Чтобы установить программное обеспечение SOLIDWORKS без включения данных Toolbox/Отверстие под крепеж, выполните следующие действия.
  • При появлении запроса на установку/обновление файлов Toolbox для этого клиента выберите Нет, установить программное обеспечение Toolbox без включения файлов данных.

Как минимум один пользователь, как правило, администратор CAD, должен установить или обновить данные Toolbox или мастера "Отверстие под крепеж" в центральном расположении, иначе программа будет работать неправильно. Все пользователи в организации могут однократно установить программное обеспечение SOLIDWORKS вручную. Если Toolbox находится под управлением SOLIDWORKS PDM, выполните действия, описанные в разделе "Toolbox" в Руководстве администратора SOLIDWORKS PDM, чтобы установить или обновить данные Toolbox.

Параметры клиента SOLIDWORKS PDM

Можно выбрать следующие параметры для развертывания добавлений и клиентов SOLIDWORKS PDM:

  • Тип продукта PDM
  • Тип клиента PDM
  • Элементы

Дополнительные сведения о клиентах и добавлениях см. в разделе SOLIDWORKS PDM.

Параметры электрики

Можно указать следующие параметры для компонентов администрирования SOLIDWORKS Electrical:
  • Маршрут для данных
  • Имя компьютера сервера совместной работы и номер порта
  • Имя компьютера SQL Server и пароль

Дополнительные сведения об этих компонентах см. в разделе, посвященном SOLIDWORKS Electrical.

На уровень выше Просмотр и изменение значений параметров
Установка значений параметров для отдельных компьютеров и групп
Наследование настроек глобальных и групповых параметров
Настройка параметров для каждого компьютера
Установка и настройка лицензий SolidNetWork
Внедрение установок из Редактора параметров
SOLIDWORKS Electrical


Наследование настроек глобальных и групповых параметров

Настройки параметров для элемента Глобальные настройки или групп наследуются по элементам нижнего уровня.

Например:
  • Параметры, заданные в разделе Глобальные настройки, применяются ко всем группам и отдельным компьютерам.
  • Параметры, заданные для группы, применяются ко всем компьютерам, входящим в нее.

Наследуемые параметры и параметры по умолчанию можно заменить как для отдельных компьютеров, так и для целых групп. Если изменить наследуемый параметр или параметр по умолчанию, соответствующее значение выделяется.

Чтобы вернуть исходные унаследованные настройки параметра, нажмите правой кнопкой мыши группу или компьютер, а затем выберите Вернуть глобальные настройки (для группы или компьютера, не принадлежащего никакой группе) или Вернуться к настройкам группы (для компьютера, принадлежащего группе).
На уровень выше Просмотр и изменение значений параметров
Установка значений параметров для отдельных компьютеров и групп
Настройка параметров администрирующего образа
Настройка параметров для каждого компьютера


Настройка параметров для каждого компьютера

Также можно изменить параметры, которые применены к определенным компьютерам, щелкнув правой кнопкой мыши имя соответствующего компьютера.

В контекстном меню можно выполнять следующие задачи для каждого из компьютеров:
  • Удаление компьютера в редакторе
  • Возврат к глобальным параметрам
  • Добавление или редактирование примечаний
  • Редактирование параметров

Благодаря параметрам редактирования можно изменять все параметры для соответствующего компьютера, например параметры установки на клиентском компьютере и административные параметры.

На уровень выше Просмотр и изменение значений параметров
Установка значений параметров для отдельных компьютеров и групп
Настройка параметров администрирующего образа
Наследование настроек глобальных и групповых параметров


Инструмент "Администратор параметров"

Инструмент "Администратор параметров" можно использовать для настройки параметров системы, которые применяются при развертывании и обновлении программы SOLIDWORKS, а также для предотвращения изменения этих параметров пользователями. Этот инструмент заменяет помощника копирования настроек для развертывания параметров, даже если мастер все еще доступен для копирования настроек.

Существует три действия для использования инструмента "Администратор параметров":
  1. Создайте администрирующий образ, чтобы получить доступ к данному инструменту.
  2. Используйте администратор параметров для создания файла *.sldSettings, который содержит выбранные параметры SOLIDWORKS.
  3. Включите файл *.sldSettings в установки SOLIDWORKS.

Содержание

  • Доступ к инструменту "Администратор параметров"

    Для доступа к инструменту "Администратор параметров" необходимо сначала создать администрирующий образ.

  • Использование инструмента "Администратор параметров"

  • Применение и блокировка параметров

  • Завершение настройки параметров

  • Добавление файла .sldSettings в установки SOLIDWORKS

На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Внедрение установок из Редактора параметров
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе


Доступ к инструменту "Администратор параметров"

Для доступа к инструменту "Администратор параметров" необходимо сначала создать администрирующий образ.

Инструмент администратора параметров можно запустить из администрирующего образа.

Чтобы получить доступ к инструменту "Администратор параметров", выполните следующие действия.

  1. Запустите файл sldAdminOptionEditor.exe в папке администрирующего образа.
  2. В редакторе параметров администрирующего образа нажмите Изменить настройки.
  3. В разделе Параметры установки клиента выполните следующие действия:
    1. Нажмите Использовать экспорт файла параметров из администратора параметров SOLIDWORKS.
    2. Нажмите Запустить администратор параметров.
На уровень выше Инструмент "Администратор параметров"


Использование инструмента "Администратор параметров"

Чтобы использовать инструмент Администратор параметров, выполните указанные ниже действия.

  1. На вкладке приветствия выберите следующие параметры:
    • Набор параметров по умолчанию — запуск этой версии SOLIDWORKS.
    • Импорт параметров SOLIDWORKS 2020 с этого компьютера.
    • Перейти к существующему файлу sldreg.
    • Перейти к существующему файлу sldSetting.
    Файл *.sldreg создается с помощью мастера копирования настроек, а файл *.sldSettings создается с помощью инструмента "Администратор параметров".
  2. Щелкните Далее.
На уровень выше Инструмент "Администратор параметров"


Применение и блокировка параметров

На вкладке Параметры системы два столбца флажков позволяют выбрать параметры для применения, а также заблокировать примененные параметры, чтобы пользователи не могли их изменить.

При получении пользователем доступа к диалоговому окну Параметры системы в ПО SOLIDWORKS заблокированные параметры отображаются недоступными со значком блокировки [image]. Тем не менее, можно создать пароль, который позволяет пользователям разблокировать параметры. Когда пользователь наводит курсор на заблокированный параметр, отображается подсказка с именем и адресом эл. почты, чтобы пользователи могли обратиться к вам и запросить пароль.

Порядок применения и блокировки параметров

  1. На вкладке Параметры системы выполните указанные ниже действия.
    1. Для применения параметра выберите его и установите соответствующий флажок в столбце Применить.
    2. Для блокировки параметра выберите его и установите соответствующие флажки в обоих столбцах Применить и Заблокировать.
      При получении пользователями доступа к вкладке Параметры системы параметры отображаются со значком замка [image].
  2. В зависимости от параметра может потребоваться указать дополнительные параметры.
  3. Кроме того, для пользователей можно заблокировать закрытые сообщения, применив элементы управления для элемента Сообщения/Ошибки/Предупреждения.
    1. Нажмите Сообщения/Ошибки/Предупреждения.
    2. Установите флажок Применить и дополнительно установите флажок Заблокировать для сообщений, которыми хотите управлять.
    3. Установите для сообщения значение Показывать или Не показывать.

      При выборе значения Показывать сообщение удаляется из списка закрытых сообщений пользователя и показывается пользователю в соответствующее время. При выборе значения Не показывать сообщение автоматически добавляется в список закрытых сообщений пользователя и не отображается при работе пользователя с моделью.

      В данной таблице описано поведение в программе.
      Применить | Заблокировать | Показывать | Не показывать | Поведение
      X | X | Принудительное отображение сообщения.
      X | X | Отключает сообщение и добавляет сообщение в список закрытых сообщений.
      X | X | X | Принудительное отображение сообщения и отключение параметра Не показывать в окне сообщения.
      X | X | X | Отключает сообщение и запрещает пользователю включать его в меню Инструменты > Параметры > Сообщения/ошибки/предупреждения.
  4. На вкладке Параметры системы нажмите Далее.
На уровень выше Инструмент "Администратор параметров"


Завершение настройки параметров

Чтобы завершить настройку параметров, выполните указанные ниже действия.

  1. На вкладке Готово выберите вариант применения параметров системы:
    • при первом запуске программы пользователем;
    • каждый раз при запуске программы;
    • а также необходимость одновременного применения настроек.
  2. Можно выбрать Применение параметров блокировки, когда пользователи вне сети и Разрешение API перезаписывать заблокированные параметры.
  3. Для заблокированных системных параметров необходимо указать имя и адрес электронной почты. SOLIDWORKS отображает эту информацию в виде подсказки при наведении курсора на заблокированный параметр.
  4. Также можно разрешить пользователям перезаписывать заблокированные параметры. В данном случае необходимо указать Пароль, который можно предоставить пользователям.
  5. Нажмите Сохранить, чтобы создать файл .sldSettings для развертывания.
На уровень выше Инструмент "Администратор параметров"


Добавление файла .sldSettings в установки SOLIDWORKS

Чтобы добавить файл *.sldSettings в установки, выполните следующие действия.

  1. Дважды нажмите на файл sldAdminOptionEditor.exe в папке администрирующего образа.
  2. В редакторе параметров администрирующего образа нажмите Изменить настройки.
  3. В разделе Параметры установки клиента выполните следующие действия.
    1. Нажмите Использовать файл настроек, экспортированный из Помощника копирования настроек SOLIDWORKS.
    2. Нажмите Изменить путь и перейдите к файлу *.sldSettings.
    Можно создать и применить разные файлы *.sldSettings к разным группам или компьютерам.
  4. Выполните развертывание и установку ПО SOLIDWORKS.

После развертывания можно повторить шаг 2, чтобы изменить существующий файл *.sldSettings в любое время. Программа SOLIDWORKS считывает измененный файл *.sldSettings при следующем запуске.

На уровень выше Инструмент "Администратор параметров"


Внедрение установок из Редактора параметров

Развертывание можно выполнять непосредственно из редактора параметров двумя способами – вручную или автоматически.

  • На странице развертывания вручную в редакторе параметров можно передать пользователям сообщения электронной почты с инструкциями по установке. Этот метод используется, когда у пользователей имеются права локальных администраторов на их клиентских машинах.
  • На странице автоматического развертывания в редакторе параметров можно настроить автоматическую передачу задач установки на соответствующие компьютеры. Также поддерживается выборочное удаление компонентов. Этот способ применяется в том случае, если пользователям систем не предоставлены полномочия на администрирование, необходимые для установки программного обеспечения.

Независимо от выбранного способа необходимо изменить каталог установки администрирующего образа на общий каталог Windows для обеспечения доступа по сети (например, \\ПК\общий_каталог или скопируйте весь образ в локальный каталог на каждом компьютере, например, C:\SOLIDWORKS Admin\SOLIDWORKS 2020 SP0).

Содержание

  • Использование подключенного диска для развертывания администрирующего образа

    Для указания сетевого местоположения для каталога установки администрирующего образа рекомендуется использовать путь UNC (\\имя_компьютера\имя_совместно_используемого_ресурса ). Однако можно использовать подключенный диск в качестве местоположения для файла StartSWInstall.hta в администрирующем образе (например, U:\StartSWInstall.hta), если все клиенты, выполняющие установку, имеют на своих компьютерах одинаковое буквенное обозначение для диска, соответствующего общему каталогу администрирующего образа.

  • Использование процесса StartSWInstall.exe для развертывания администрирующего образа

  • Развертывание вручную

    Используйте этот метод, если у пользователей есть права, необходимые для установки на их системах.

  • Требования к автоматическому развертыванию

    При автоматическом развертывании задачи установки передаются на соответствующие компьютеры и выполняются в каждой системе средствами планировщика заданий Microsoft, не требуя вмешательства пользователя. Этот способ применяется, если пользователям не предоставлены права администратора, необходимые для установки программного обеспечения.

  • Автоматическое развертывание

  • Тестирование конфигурации для автоматического развертывания

    На вкладке Автоматическое развертывание в редакторе параметров администрирующего образа доступна функция тестирования.

На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Инструмент "Администратор параметров"
Выход из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе


Использование подключенного диска для развертывания администрирующего образа

Для указания сетевого местоположения для каталога установки администрирующего образа рекомендуется использовать путь UNC (\\имя_компьютера\имя_совместно_используемого_ресурса ). Однако можно использовать подключенный диск в качестве местоположения для файла StartSWInstall.hta в администрирующем образе (например, U:\StartSWInstall.hta), если все клиенты, выполняющие установку, имеют на своих компьютерах одинаковое буквенное обозначение для диска, соответствующего общему каталогу администрирующего образа.

Например, если в совместно используется диск U:, в электронном уведомлении будет содержаться следующая ссылка на файл file://U:\StartSWIOnstall.hta. Клиенты, получившие электронное сообщение, смогут успешно выполнить установку при условии, что диск U: соответствует пути UNC для администрирующего образа (\\имя_компьютера\имя_совместно_используемого_ресурса ).

На уровень выше Внедрение установок из Редактора параметров


Использование процесса StartSWInstall.exe для развертывания администрирующего образа

Можно установить или удалить администрирующий образ на клиентах, выполнив команду admin_image_install_dir\ StartSWInstall.exe. Это метод установки SOLIDWORKS использует параметры, компьютеры и группы, определенные в Редакторе параметров администрирующего образа.

Следующие переключатели можно добавить к команде StartSWInstall.exe:
/установить | Служит для установки администрирующего образа на компьютеры клиента.
/удалить Служит для удаления программного обеспечения с компьютеров клиента, с двумя дополнительными переключателями:

/removedata

Доступно только для удаления. Служит для удаления файлов данных и папок SOLIDWORKS.

/removeregistry

Доступно только для удаления. Служит для удаления записей реестра SOLIDWORKS.
/showui | Служит для отображения окна хода выполнения для Менеджер установки SOLIDWORKS. В противном случае Менеджер установки SOLIDWORKS скрыт от пользователя.
/сейчас | Служит для незамедлительного запуска установки или удаления. 5-минутное диалоговое окно предупреждения не отображается.

Рекомендуется использовать процесс StartSWInstall.exe вместо StartSWInstall.hta в тех случаях, когда необходимо продолжить установку без взаимодействия с пользователем, не используя при этом автоматическое развертывание в Редакторе параметров администрирующего образа.

На уровень выше Внедрение установок из Редактора параметров


Развертывание вручную

Используйте этот метод, если у пользователей есть права, необходимые для установки на их системах.

Развертывание установок вручную с помощью электронной почты:

  1. Выберите элемент Развертывание в Редакторе параметров.
    На экране отобразятся сведения о возможности и состоянии установки для каждого компьютера.
  2. Нажмите Отправить сообщение.
  3. Укажите сетевой путь к каталогу установки администрирующего образа.
    Как правило, путь к каталогу установки администрирующего образа изначально отображается как путь к файлу Windows (например, C:\SOLIDWORKS Admin\SOLIDWORKS 2020 SP0). В диалоговом окне отобразится сообщение Данный путь не является сетевым.
    1. Для указания местоположения в сети для каталога установки администрирующего образа нажмите кнопку Обзор.
    2. Укажите путь к компьютеру, на котором установлен администрирующий образ, а затем укажите совместно используемый каталог Windows, указанный в качестве каталога установки администрирующего образа.
      Не переходите в другие папки в общедоступном каталоге администрирующего образа (например, в подкаталоги 64bit).
    3. Нажмите кнопку ОК.
      В диалоговом окне отобразится сообщение Данный путь является сетевым.
    Для владельцев компьютеров будет создано сообщение электронной почты с указаниями по выполнению установки из администрирующего образа с указанием сетевого местоположения файла StartSWInstall.hta в администрирующем образе.
  4. Отправьте это электронное сообщение пользователям, ответственным за установку SOLIDWORKS.

Для установки SOLIDWORKS из администрирующего образа пользователь может дважды щелкнуть ссылку на сетевое расположение файла StartSWInstall.hta, которая содержится в сообщении электронной почты.

В Редакторе параметров Статус установки показывает:
Ожидается | Пользователь еще не начал установку на данном компьютере.
Успешно | Пользователь успешно завершил установку на данном компьютере.
Сбой | Пользователь запустил установку на данном компьютере, однако установку не удалось выполнить.

Прочие возможные статусные сообщения: "установка успешно завершена", "удаление успешно завершено", "выполняется установка", "выполняется удаление", "требуется перезагрузка", "сбой установки", "сбой удаления".

На уровень выше Внедрение установок из Редактора параметров


Требования к автоматическому развертыванию

При автоматическом развертывании задачи установки передаются на соответствующие компьютеры и выполняются в каждой системе средствами планировщика заданий Microsoft, не требуя вмешательства пользователя. Этот способ применяется, если пользователям не предоставлены права администратора, необходимые для установки программного обеспечения.

При передаче установки планировщик задач запускает Менеджер установки SOLIDWORKS, который работает под указанными администратором учетными данными. Планировщик задач работает под учетной записью LocalSystem компьютера. Эта учетная запись представлена в сети в виде принципа обеспечения безопасности компьютера. Принцип обеспечения безопасности компьютера должен иметь следующий доступ:
  • Доступ для чтения к папке администрирующего образа.
  • Доступ для чтения и записи в папку администрирующий образ\x64\logs.

В Active Directory при добавлении компьютера в группу Общей папки выберите Типы объектов и Компьютеры.

Кроме того, компьютер, обслуживающий администрирующий образ, и целевые клиентские компьютеры должны принадлежать одному домену Microsoft Active Directory.

На уровень выше Внедрение установок из Редактора параметров


Автоматическое развертывание

Для автоматического развертывания путем передачи задач установки в системы пользователей выполните следующие действия.

  1. В редакторе параметров перейдите на вкладку Автоматическое развертывание.
    На экране отобразятся сведения о возможности и состоянии установки для каждого компьютера.
  2. В столбце Развертывание выберите целевые клиентские компьютеры и группы.
    Перед запуском процесса развертывания необходимо выбрать в столбце Развертывание один или несколько компьютеров или групп.
  3. В разделе Время установки выберите Сейчас для безотлагательного развертывания или Позднее для планирования развертывания на конкретную дату и время.
  4. В окне Параметры клиента, выберите следующее.
    • Установка или обновление SOLIDWORKS 2020
    • Удаление SOLIDWORKS 2020
      При выборе удаления можно указать, следует ли удалять записи из реестра, а также файлы и папки данных наряду с файлами и данным программы.
  5. Выберите Перезагрузить компьютер автоматически, если вы хотите, чтобы один или несколько целевых компьютеров перезагружались (при необходимости) во время или после развертывания.
  6. Введите Учетные данные клиента одного или нескольких целевых компьютеров.
  7. Нажмите Развертывание для запуска процесса развертывания.
В Редакторе параметров в разделе Статус установки отображаются состояния:
Ожидается | На данном компьютере установка еще не завершена.
Успешно | На данном компьютере установка успешно не завершена.
Сбой | На данном компьютере произошел сбой установки.

Прочие возможные статусные сообщения: "установка успешно завершена", "удаление успешно завершено", "планирование", "подключение", "выполняется установка", "выполняется удаление", "требуется перезагрузка", "установка запланирована", "удаление запланировано", "сбой установки", "сбой удаления", "сбой подключения", "сбой планирования".

На уровень выше Внедрение установок из Редактора параметров


Тестирование конфигурации для автоматического развертывания

На вкладке Автоматическое развертывание в редакторе параметров администрирующего образа доступна функция тестирования.

Можно запустить пробный процесс установки, в котором будут участвовать системы, используемые для развертывания, например:
  • Подключение к целевому компьютеру.
  • Создание задачи установки на этом компьютере.
  • Выполнение задачи установки на этом компьютере.
  • Обновление состояния и журналов в администрирующем образе.
  • Обнаружение программ, которые должны быть запущены до или после установки.

В ходе тестирования проверяются пути к файлам и разрешения. После успешного завершения установки отображается соответствующее сообщение. Функция тестирования не устанавливает программное обеспечение и не вносит изменения в реестр на целевом компьютере. Если какая-либо из систем на одном из целевых компьютеров выходит из строя, функция тестирования показывает, в какой системе возникли проблемы.

Всплывающие подсказки содержат дополнительную информацию о сбоях. Результаты можно экспортировать в электронную таблицу .xml (или .csv). Эта таблица позволяет просматривать информацию о различных сбоях, и ее можно отправить другим специалистам службы поддержки.

Чтобы протестировать конфигурацию для автоматического развертывания, выполните следующие действия.

  1. С помощью Менеджера установки создайте Администрирующий образ.
  2. Откройте Редактор параметров администрирующего образа.

    Для этого выберите соответствующую функцию в менеджере установки, когда он завершить создание администрирующего образа, или дважды нажмите на файл sldAdminOptionEditor.exe в папке администрирующего образа.

  3. На вкладке Настройка добавьте один или несколько компьютеров.
  4. Нажмите Автоматическое развертывание:
    1. Введите Имя пользователя и Пароль администратора домена.
    2. Выберите один или несколько компьютеров для тестирования.
    3. Нажмите Проверить.
  5. В открывшемся окне "Проверка установки" нажмите Запуск проверки.
  6. Подождите несколько минут до завершения теста или нажмите Отменить проверку в любое время.
  7. Проверьте информацию и устраните проблемы конфигурации.
На уровень выше Внедрение установок из Редактора параметров


Выход из Редактора параметров

Для выхода из Редактора параметров можно нажать кнопку «OK» или «Закрыть».

Чтобы применить изменения и выйти из Редактора параметров, нажмите кнопку OK, Закрыть или кнопку закрытия приложения Windows.
  • Чтобы применить все изменения настроек параметров и выйти из Редактора параметров, нажмите кнопку OK.
  • Для выхода из Редактора параметров нажмите кнопку Закрыть.

    Если остались несохраненные изменения, появится запрос о необходимости сохранения изменений.

  • Нажмите кнопку закрытия приложений Windows (X). Если остались несохраненные изменения, появится запрос о необходимости сохранения изменений.
На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Инструмент "Администратор параметров"
Внедрение установок из Редактора параметров
Создание ярлыка Редактора параметров на рабочем столе


Создание ярлыка Редактора параметров на рабочем столе

Можно создать ярлык Редактора параметров на рабочем столе Windows для определенного администрирующего образа внутри приложения.

  1. Запустите Редактор параметров.
    Например, в Проводнике файлов перейдите к каталогу для установки администрирующего образа и дважды щелкните файл sldAdminOptionEditor.exe.
  2. Выберите Создать ярлык на Рабочем столе для данного Редактора параметров.
    На рабочем столе Windows отобразится ярлык Редактора параметров для администрирующего образа.
На уровень выше Редактор параметров администрирующего образа
Добавление и удаление групп и компьютеров
Просмотр и изменение значений параметров
Инструмент "Администратор параметров"
Внедрение установок из Редактора параметров
Выход из Редактора параметров


Внедрение администрирующего образа на клиентах через электронную почту

Когда будет создан общий каталог администрирующего образа, можно по электронной почте оповестить об этом клиентов.

Настройте каталог администрирующего образа так, чтобы к компьютеру, на котором хранится этот каталог, имели доступ все другие компьютеры (например, по пути UNC).

Всем клиентам можно отправить электронные сообщения со ссылкой на каталог каталог_установки_администрирующего_образа\StartSWInstall.hta. Клиенты могут перейти по этой ссылке и выбрать параметр Установить продукты SOLIDWORKS сейчас, чтобы начать установку с использованием администрирующего образа.

При обновлении администрирующего образа до новой версии SOLIDWORKS можно настроить его местоположение и общие свойства так, чтобы все клиенты, установленные ранее с помощью этого образа, были обновлены автоматически. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.
На уровень выше Множественные установки
Внедрение на нескольких клиентах
Использование администрирующих образов
Внедрение с использованием командной строки
Администрация множественных установок
Обновление клиентов с помощью администрирующих образов


Внедрение с использованием командной строки

Можно автоматически внедрить администрирующий образ с использованием командной строки или пакетного файла (автоматическая установка).

Развертывание административного образа с помощью командной строки для клиентов SOLIDWORKS PDM см. в руководстве по установке SOLIDWORKS PDM.

Содержание

  • Подготовка клиентов для установки командной строки из администрирующего образа

    После создания администрирующего образа и до оповещения клиентов необходимо установить компоненты Microsoft Windows, которые не могут быть установлены с помощью администрирующих образов, созданных с использованием командной строки или Microsoft Active Directory.

  • Установка администрирующего образа с использованием командной строки

    С помощью командной строки можно выполнить внедрение установок с использованием администрирующего образа.

  • Свойства командной строки

    К свойствам командной строки, описанным в данном разделе, относятся свойства элемента, глобальные свойства, свойства продукта и условные обозначения расположения, используемые в Windows.

  • Развертывание администрирующего образа с помощью Microsoft Active Directory

    Развертывание с помощью Microsoft Active Directory поддерживается при внедрении основных продуктов SOLIDWORKS на клиентах.

  • Установка требуемых компонентов Windows с помощью Microsoft Active Directory

    Чтобы подготовить существующий администрирующий образ, с помощью которого программа SOLIDWORKS будет установлена на клиентские компьютеры, используя Microsoft Windows Active Directory, выполните следующие действия.

На уровень выше Множественные установки
Внедрение на нескольких клиентах
Использование администрирующих образов
Внедрение администрирующего образа на клиентах через электронную почту
Администрация множественных установок


Подготовка клиентов для установки командной строки из администрирующего образа

После создания администрирующего образа и до оповещения клиентов необходимо установить компоненты Microsoft Windows, которые не могут быть установлены с помощью администрирующих образов, созданных с использованием командной строки или Microsoft Active Directory.

Установка данных компонентов Windows вручную требуется только в том случае, если установка выполняется из администрирующего образа с помощью командной строки или через Microsoft Active Directory. Если для создания и установки администрирующего образа использовался Менеджер установки SOLIDWORKS, это значит, что данные компоненты Windows были установлены автоматически.
Здесь представлен перечень файлов, которые требуется использовать в SOLIDWORKS при работе с компонентами Windows:
Набор средств для оценки производительности Windows: |
Распространяемый пакет Visual C++ 2008, 2010, 2012, 2013 и 2015 | Содержит компоненты времени выполнения для Microsoft Visual C++. Должны быть установлены версии 2008, 2010, 2012, 2013 и 2015.
Visual Basic для приложений 7.1 | Поддерживает макросы Visual Basic.
Инструменты Visual Studio Tools для приложений 2005 | Содержит набор инструментов, поддерживающих приложения Visual Studio 2005. Начиная с SOLIDWORKS 2013, установка Microsoft Visual Studio Tools для приложений (VSTA) необязательна. VSTA 2005 зависит от наличия на компьютере платформы Microsoft .NET Framework 3.5. Начиная с Windows 7 .NET Framework является компонентом операционной системы. Если необходимо установить .NET Framework 3.5, он доступен на дисках с Windows и в интернете. Если нет диска с Windows и доступа к Интернету или отсутствуют права на установку Microsoft .NET Framework 3.5 на компьютере, обратитесь за помощью к своему администратору.
Инструменты Visual Studio Tools для приложений 2015 | Дополнительно. Содержит набор инструментов, поддерживающих приложения Visual Studio 2015.
Удаленный отладчик Visual Studiо | Создает среду отладки для 64-разрядных операционных систем.
.NET Framework 4.6.2 | Содержит общие для языка программирования компоненты времени исполнения и компоненты .NET Framework, необходимые для работы приложений в .NET Framework 4.6.2.
Сервис Bonjour для Windows | Обеспечивает возможность обнаружения служб в локальной сети.
Распространяемый пакет Visual С++ и .NET Framework 4.6.2 требуются для всех продуктов SOLIDWORKS, не только для базового продукта SOLIDWORKS.

Эти компоненты должны быть включены в подкаталоги каталога администрирующего образа.

Следующие таблицы определяют требуемые для каждой из поддерживаемых операционных систем файлы.
Операционная система: Windows Server 2016, 64-разрядная версия и Windows Server 2019, 64-разрядная версия
Операционная система: Windows Server 2012 R2, 64-разрядная версия
В ОС Windows Server 2012 R2, 2016 и 2019 поддерживается установка сервера SOLIDWORKS PDM и менеджера лицензий SOLIDWORKS SolidNetWork.
Набор средств для оценки производительности Windows: | WPTx64-x86_en-us.msi
Распространяемый пакет Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2013: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2015: | vc_redist_x86.exe vc_redist_x64.exe Необходимо установить оба.
Инструменты Visual Studio Tools для приложений 2005: (необязательно). | vsta_aide.msi
Если установлена система VSTA 2005, требуется наличие .NET 3.5 Framework (dotnetfx35.exe). .NET Framework и Windows Desktop Search являются элементами операционной системы.
Инструменты Visual Studio Tools для приложений 2015 (дополнительно): | vsta_setup.exe
Удаленный отладчик Visual Studiо: | rdbgexp.msi
Visual Basic 7.1 | vba71_1033.msi Плюс дополнительный языковой пакет.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Сервис Bonjour для Windows: | bonjour64.msi
В ОС Windows Server 2012 R2 поддерживается установка сервера SOLIDWORKS PDM и менеджера лицензий SOLIDWORKS SolidNetWork.
Набор средств для оценки производительности Windows: | WPTx64-x86_en-us.msi
Распространяемый пакет Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2013: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2015: | vc_redist_x86.exe vc_redist_x64.exe Необходимо установить оба.
Инструменты Visual Studio Tools для приложений 2005: (необязательно). | vsta_aide.msi
Если установлена система VSTA 2005, требуется наличие .NET 3.5 Framework (dotnetfx35.exe). .NET Framework и Windows Desktop Search являются элементами операционной системы.
Инструменты Visual Studio Tools для приложений 2015 (дополнительно): | vsta_setup.exe
Удаленный отладчик Visual Studiо: | rdbgexp.msi
Visual Basic 7.1 | vba71_1033.msi Плюс дополнительный языковой пакет.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Сервис Bonjour для Windows: | bonjour64.msi
Операционная система: Windows 7, 64-разрядная
Набор средств для оценки производительности Windows: | WPTx64-x86_en-us.msi
Распространяемый пакет Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2013: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2015: | vc_redist_x86.exe vc_redist_x64.exe Необходимо установить оба.
Инструменты Visual Studio Tools для приложений: (необязательно). | vsta_aide.msi
Если установлена система VSTA 2005, требуется наличие .NET 3.5 Framework (dotnetfx35.exe). .NET Framework и Windows Desktop Search являются элементами операционной системы.
Инструменты Visual Studio Tools для приложений 2015: (необязательно) | vsta_setup.exe
Удаленный отладчик Visual Studiо: | rdbgexp.msi
Visual Basic 7.1 | vba71_1033.msi Плюс дополнительный языковой пакет.
.NET Framework 4.6.2: | NDP462-KB2901907-x86-x64-AllOS-ENU.exe
Сервис Bonjour для Windows: | bonjour64.msi
Операционная система: Windows 10, 64-разрядная
Набор средств для оценки производительности Windows: | WPTx64-x86_en-us.msi
Распространяемый пакет Visual C++ 2008: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2010: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2012: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2013: | vcredist_x86.exe vcredist_x64.exe Необходимо установить оба.
Распространяемый пакет Visual C++ 2015: | vc_redist_x86.exe vc_redist_x64.exe Необходимо установить оба.
Инструменты Visual Studio Tools для приложений 2005: (необязательно). | vsta_aide.msi
Если установлена система VSTA 2005, требуется наличие .NET 3.5 Framework (dotnetfx35.exe). .NET Framework и Windows Desktop Search являются элементами операционной системы.
Инструменты Visual Studio Tools для приложений 2015: (необязательно). | vsta_setup.exe
Удаленный отладчик Visual Studiо: | rdbgexp.msi
Visual Basic 7.1 | vba71_1033.msi Плюс дополнительный языковой пакет.
.NET Framework 4.6.2: | .Net 4.6.2 — часть операционной системы, которая соответствует данным требованиям.
Сервис Bonjour для Windows: | bonjour64.msi

Содержание

  • Установка необходимых компонентов Windows с использованием командной строки в 64-разрядных операционных системах

    Чтобы установить администрирующий образ с помощью командной строки в 64-разрядных версиях операционных систем Windows, выполните следующие действия для установки необходимых компонентов Windows.

На уровень выше Внедрение с использованием командной строки
Установка администрирующего образа с использованием командной строки
Свойства командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory
Установка требуемых компонентов Windows с помощью Microsoft Active Directory


Установка необходимых компонентов Windows с использованием командной строки в 64-разрядных операционных системах

Чтобы установить администрирующий образ с помощью командной строки в 64-разрядных версиях операционных систем Windows, выполните следующие действия для установки необходимых компонентов Windows.

Чтобы установить несколько компонентов за одну операцию, создайте пакетный файл с командами, описанными в следующих процедурах, и используйте его для установки компонентов на клиентские компьютеры.

  1. Убедитесь, что на целевом компьютере объем свободного дискового пространства составляет минимум 620 МБ и имеется верный каталог TEMP.
  2. Установите распространяемый пакет Visual C++ RELEASE:
    Установите пакет для RELEASE = 2008, 2010, 2012, 2013 и 2015.
    каталог_администрирующего_образа\Microsoft_C++_RELEASE_Redistributable_(x64)\vcredist_x64.exe /Q

    каталог_администрирующего_образа\Microsoft_C++_RELEASE_Redistributable\vcredist_x86.exe /Q

    Необходимо установить обе версии данного пакета: 32-разрядную и 64-разрядную.

    Например, для установки распространяемого пакета Visual C++ 2008 используйте:

    • administrative_image_directory\Microsoft_C++_2008_Redistributable_(x64)\vcredist_x64.exe /Q
    • administrative_image_directory\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /Q
  3. Установите Microsoft .NET Framework 4.6.2:
    каталог_администрирующего_образа\.Net_Framework_4.6.2\NDP462-KB3151800-x86-x64-AllOS-ENU.exe
  4. Установите инструменты Visual Studio для приложений 2015:
    каталог_администрирующего_образа\Microsoft_VSTA\vsta_setup.exe
  5. Установите Удаленный отладчик Visual Studio:
    каталог_администрирующего_образа\VSRemoteDebugger\install.exe /Q
  6. Установите Visual Basic 7.1
    каталог_администрирующего_образа\Microsoft_VBA\vba71.msi и каталог_администрирующего_образа\Microsoft_VBA\vba71_1033.msi требуются для всех языков.
    Только 64-разрядная версия этого пакета должна быть установлена.

    Кроме этого, установите следующий пакет для необходимого языка:

    vba71_1028.msi | китайский
    vba71_1031.msi | немецкий
    vba71_1036.msi | французский
    vba71_1040.msi | итальянский
    vba71_1041.msi | японский
    vba71_1042.msi | корейский
    vba71_1046.msi | португальский (Бразилия)
    vba71_2052.msi | китайский (упрощенный)
    vba71_3082.msi | испанский
    Для английского, чешского, польского, русского и турецкого языков дополнительные языковые пакеты не требуются.
    Начиная с версии SOLIDWORKS 2013 Service Pack 2.0, требуется предварительная установка дополнительных компонентов: Msiexec.exe /p vba71-kb27832-x64.msp
  7. Установите службу Bonjour для Windows:
    каталог_администрирующего_образа\Bonjour\Bonjour64.msi
На уровень выше Подготовка клиентов для установки командной строки из администрирующего образа


Установка администрирующего образа с использованием командной строки

С помощью командной строки можно выполнить внедрение установок с использованием администрирующего образа.

Чтобы провести автоматическую установку:

  1. Откройте окно «Командная строка» (в Windows выберите Пуск > Выполнить.
  2. Введите команду msiexec.exe с автоматическими ключами /i и /qb и укажите параметры для свойств, не являющихся свойствами по умолчанию.

    msiexec /i "64-bit_admin_image_path\SWFileUtilities\SOLIDWORKS File Utilities.msi" INSTALLDIR="C:\Program Files\ваша_папка /qb

Свойства командной строки для установки отдельных компонентов включают в себя:
  • Свойства элементов командной строки
  • Глобальные свойства командной строки
  • eDrawings Свойства командной строки
  • Свойства командной строки SOLIDWORKS Flow Simulation

Используйте следующие примеры в качестве шаблона для автоматической установки.

Клиент SOLIDWORKS

  • SOLIDWORKS основной продукт (на английском языке)
  • Дополнительное приложение Toolbox
  • Участие в Программе отзывов клиентов
  • Поддержка французского языка

SOLIDWORKS:

msiexec /i "64-bit_admin_image_path\SOLIDWORKS\SOLIDWORKS.Msi" INSTALLDIR="C:\Program Files\your_folder" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx xxxx xxxx" ENABLEPERFORMANCE=1 OFFICEOPTION=3 ADDLOCAL=SolidWorks, SolidWorksToolbox /qb

Установка компонента поддержки французского языка SOLIDWORKS должна быть проведена отдельно:

msiexec /i "путь_к_64-разрядному_администрирующему_образу\SOLIDWORKS French\french.msi" /qb

Не следует указывать аргументы командной строки вместе с командами установки компонента языковой поддержки SOLIDWORKS.

Клиент eDrawings

  • Журнал эффективности
  • Все элементы

msiexec /i "путь_к_администрирующему образу\eDrawings\eDrawings.msi" INSTALLDIR="C:\Program Files\ваша_папка" LOGPERFORMANCE=1 SNLSERVER=eDrawings_SNL_server TRANSFORMS=1040.mst ADDLOCAL=All /qb

SOLIDWORKS Electrical

Из-за технической сложности установки SOLIDWORKS Electrical с Microsoft SQL Server примеры командной строки для SOLIDWORKS Electrical были исключены из документации.

SOLIDWORKS PCB

msiexec /i "admin_image_path\SOLIDWORKS PCB.msi" ACTIVSERIALNUMBER="1234123412341234ABCDEFGH" INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PCB" /qb

SOLIDWORKS Visualize и Visualize Boost

Для SOLIDWORKS Visualize:

msiexec. /i "admin_image_path\SOLIDWORKS Visualize.msi" ACTIVSERIALNUMBER="1234123412341234ABCDEFGH" INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize" /qb

Для SOLIDWORKS Visualize Boost:

msiexec /i "admin_image_path\SOLIDWORKS Visualize Boost.msi" ACTVISERIALNUMBER="1234123412341234ABCDEFGH" INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Visualize Boost" /qb

На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Свойства командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory
Установка требуемых компонентов Windows с помощью Microsoft Active Directory


Свойства командной строки

К свойствам командной строки, описанным в данном разделе, относятся свойства элемента, глобальные свойства, свойства продукта и условные обозначения расположения, используемые в Windows.

Содержание

  • Свойства элементов командной строки

    Установка SOLIDWORKS поддерживает следующие свойства ADDLOCAL для развертывания с использованием командной строки.

  • Глобальные свойства командной строки

    Если не указано иное, каждое свойство определено либо для административной, либо для индивидуальной установки. Серийные номера можно передавать как в административную, так и в индивидуальную установку с помощью глобальных свойств.

  • eDrawings Свойства командной строки

    Данные свойства командной строки присущи только программе eDrawings ®.

  • Свойства командной строки SOLIDWORKS Composer/Composer Player

    Перечисленные здесь свойства командной строки относятся только к SOLIDWORKS Composer и SOLIDWORKS Composer Player.

  • Свойства командной строки SOLIDWORKS Flow Simulation

    Перечисленные здесь свойства командной строки присущи только SOLIDWORKS Flow Simulation.

  • Свойства командной строки SOLIDWORKS Inspection

    Эти свойства командной строки относятся только к только программе SOLIDWORKS Inspection.

  • Свойства командной строки SOLIDWORKS Visualize

    Эти свойства командной строки относятся только к программе SOLIDWORKS Visualize.

  • Месторасположение файла MSI для администрирующих образов

    Файлы .msi компонентов продуктов, позволяющие создавать администрирующие образы при помощи командной строки, хранятся в указанных каталогах на носителях SOLIDWORKS.

На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Установка администрирующего образа с использованием командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory
Установка требуемых компонентов Windows с помощью Microsoft Active Directory


Свойства элементов командной строки

Установка SOLIDWORKS поддерживает следующие свойства ADDLOCAL для развертывания с использованием командной строки.

  • CircuitWorks
  • CoreSolidWorksTaskScheduler
  • ExampleFiles
  • FeatureWorks
  • HelpFiles
  • Manuals
  • Motion
  • PhotoView
  • RealViewGraphicsdisplay
  • ScanTo3D
  • Simulation
  • SolidWorks
  • SolidWorksAnimator
  • SolidWorksCosting
  • SolidWorksDesignChecker
  • SolidWorksRoutedsystems
  • SolidWorksToolbox
  • SolidWorksUtilities
  • TolAnalyst
  • VSTA
При указании свойств для установки с использованием командной строки следует иметь в виду, что:
  • SOLIDWORKS не поддерживает установку продукта с использованием параметра SolidWorks не поддерживает установку продукта с использованием параметра .
  • Свойства зависят от регистра, не должны содержать пробелы или дефисы и должны быть разделены запятыми.

    Смешанные свойства SolidWorks должны быть указаны в свойствах ADDLOCAL для применения правильной установки.

На уровень выше Свойства командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Глобальные свойства командной строки

Если не указано иное, каждое свойство определено либо для административной, либо для индивидуальной установки. Серийные номера можно передавать как в административную, так и в индивидуальную установку с помощью глобальных свойств.

Свойство | Описание
ENABLEPERFORMANCE Указывает, должно ли приложение автоматически посылать данные по быстродействию корпорации SOLIDWORKS.

1

Отправлять данные об эффективности программы.

0

Не отправлять.
INSTALLDIR Папка установки SOLIDWORKS.

Только индивидуальные установки.
MBDSERIALNUMBER | Серийный номер для продукта с определением на основе модели SOLIDWORKS.
MOTIONSERIALNUMBER | Серийный номер для продукта SOLIDWORKS Motion
OFFICEOPTION Указывает пакет для установки:
0 | Клиент SOLIDWORKS
1 | SOLIDWORKS Office
2 | SOLIDWORKS Professional
3 | SOLIDWORKS Premium
REINSTALL Укажите Укажите , чтобы обновить все установленные компоненты.
Данное свойство требуется указывать только при обновлении версии пакета обновления в рамках одного и того же основного выпуска SOLIDWORKS (например, при обновлении установленного пакета обновления SOLIDWORKS 2020 версии 1 до версии 2).
REINSTALLMODE Параметры переустановки пакета установки Microsoft Installer.

Например, при обновлении установки, в случае замены одной версии пакета обновления на другую в рамках одного и того же выпуска SOLIDWORKS, требуется указать REINSTALLMODE=vomus.

Подробнее о параметрах REINSTALLMODE см. в документации по установщику Windows на сайте www.microsoft.com.

Данное свойство требуется указывать только при обновлении версии пакета обновления в рамках одного и того же основного выпуска SOLIDWORKS (например, при обновлении установленного пакета обновления SOLIDWORKS 2020 версии 1 до версии 2). Не следует указывать данное свойство при первой установке нового основного выпуска SOLIDWORKS.
SERVERLIST Список серверов SolidNetWork.
Список серверов SolidNetWork представляет собой разделенный список строк, каждая из которых ссылается на номер порта сервера и имеет следующий формат:
  • Система координат (разделенная запятыми) =xxxxx@имя_сервера1,yyyyy@имя_сервера2,zzzzz@имя_сервера3.
  • Не система координат (разделенная точками с запятой) =xxxxx@имя_сервера1;yyyyy@имя_сервера2;zzzzz@имя_сервера3.
X и Y являются однозначными числами. После последнего названия сервера в списке разделение не ставится.

Только индивидуальные установки.
SIMULATIONSERIALNUMBER | Серийный номер для продукта SOLIDWORKS Simulation
SOLIDWORKSSERIALNUMBER | Серийный номер продукта SOLIDWORKS, который включает все дополнения.
SWMIGRATE Указывает версию SOLIDWORKS для обновления так, как она будет отображаться в списке диалогового окна Выбор установки SOLIDWORKS. Например:

SWMIGRATE="SOLIDWORKS 2020 x64 Edition SP01"

Данное свойство указывается только при установке нового основного выпуска в систему, где уже установлен предыдущий основной выпуск SOLIDWORKS. Не следует указывать это свойство при замене одной версии пакета обновления на другую в рамках одного и того же основного выпуска SOLIDWORKS.
TOOLBOXFOLDER Папка установки файлов SOLIDWORKS Toolbox.

Только индивидуальные установки.

Например: TOOLBOXFOLDER = "C:\SOLIDWORKS Data"

Если в вашей среде используется PDM или общая папка для Toolbox или мастера "Отверстие под крепеж", можно настроить установленные клиенты так, чтобы они не устанавливали и не обновляли данные Toolbox в этом расположении с помощью свойства NOTTOOLBOXSETUP. Указать:

0 | Установка файлов Toolbox.
1 | Без установки файлов Toolbox.
TRANSFORMS Содержит зависящие от языка элементы в следующем формате:
TRANSFORMS номер.mst
  • Китайский (1028)
  • Китайский (упрощенный) (2052)
  • Чешский (1029)
  • Английский (1033)
  • Французский (1036)
  • Немецкий (1031)
  • Итальянский (1040)
  • Японский (1041)
  • Корейский (1042)
  • Польский (1045)
  • Португальский (Бразилия) (1046)
  • Русский (1049)
  • Испанский (1034)
  • Турецкий (1055)
UPGRADESWINSTALL
Укажите, следует ли обновлять существующую версию SOLIDWORKS до новейшей версии.
0 | Новая установка, не обновлять.
1 | Обновить

Только индивидуальные установки.

Данное свойство указывается только при установке нового основного выпуска в систему, где уже установлен предыдущий основной выпуск SOLIDWORKS. Не следует указывать это свойство при замене одной версии пакета обновления на другую в рамках одного и того же основного выпуска SOLIDWORKS.
На уровень выше Свойства командной строки
Свойства элементов командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


eDrawings Свойства командной строки

Данные свойства командной строки присущи только программе eDrawings ®.

Свойство | Описание
ADDLOCAL Указывает, какую часть приложения eDrawings требуется установить.
All является рекомендуемым параметром.
Синтаксис командной строки | Элемент
Все | Установка всех элементов. Приложение eDrawings осуществляет поиск установленных приложений опубликования SOLIDWORKS и AutoCAD, чтобы проверить установку.
CALS | Просмотр файлов CAL в eDrawings Viewer.
Inventor | Создайте файлы eDrawings из приложения Autodesk Inventor.
eDrawingsViewer | Просмотр файлов eDrawings и других файлов.
ProE | Просмотр файлов ProE в eDrawings Viewer.
DXFDWGTranslator | Просмотр файлов DXF/DWG в программе eDrawings Viewer.
Shortcuts | Установка ярлыка на Рабочем столе.
XML3D | Просмотр файлов 3DXML в eDrawings Viewer.
INSTALLDIR | Задание папки установки для eDrawings.
LOGPERFORMANCE Указывает, должна ли программа автоматически отправлять данные об эффективности программы по электронной почте в корпорацию SOLIDWORKS.
1 | Отправлять данные об эффективности программы
0 | Не отправлять
SNLSERVER Введите порт@имясервера для сервера лицензий SolidNetWork. Используйте точку с запятой для разделения нескольких комбинаций порт@имясервера .

Имя порта сервера для SNLSERVER требуется только для настройки сервера SOLIDWORKS SNL. список_портов@строки_сервера – это список текстовых строк, разделенных точкой с запятой, каждая из которых соответствует номеру порта сервера в формате:

xxxxx@имя_сервера1; yyyyy@имя_сервера2;

где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Composer/Composer Player

Перечисленные здесь свойства командной строки относятся только к SOLIDWORKS Composer и SOLIDWORKS Composer Player.

Для SOLIDWORKS Composer:

Свойство | Описание
ACTIVSERIALNUMBER | Серийный номер SOLIDWORKS Composer.
ACTIVSERIALNUMBERPLAYERPRO | Дополнительно. Серийный номер SOLIDWORKS Composer Player Pro.
ADDLOCAL При установке полноценного приложения не требуется указывать следующие элементы.
Требуется:
  • Лицензии
  • Eula
  • InterOps
  • LicenseSupportFiles
  • Подключаемые модули
  • SWComposerCommon
  • SWPlayer
Дополнительно:
  • Sync3Dvia
INSTALLDIR | Указывает папку для установки программного обеспечения SOLIDWORKS Composer.

Для SOLIDWORKS Composer Player:

Свойство | Описание
ACTIVSERIALNUMBERPLAYERPRO | Дополнительно. Серийный номер SOLIDWORKS Composer Player Pro.
INSTALLDIR | Указывает папку для установки программного обеспечения SOLIDWORKS Composer Player.
На компьютерах, на которых не установлена программа SOLIDWORKS, необходимо использовать SOLIDWORKS Translator для импорта файлов SOLIDWORKS в SOLIDWORKS Composer. Чтобы развернуть SOLIDWORKS Translator, необходимо использовать Менеджер установки SOLIDWORKS. Командную строку использовать нельзя.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Flow Simulation

Перечисленные здесь свойства командной строки присущи только SOLIDWORKS Flow Simulation.

Свойство | Описание
ACTIVSERIALNUMBER Отдельный серийный номер SOLIDWORKS Flow Simulation.

(индивидуальные установки и установки клиента с помощью администрирующего образа)
CWUPGRADEINSTALL Обновление существующей версии определенного программного обеспечения SOLIDWORKS Flow Simulation.
1 | Обновление
2 | Новая установка; установка в новый каталог

(индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR Задание установки определенного программного обеспечения SOLIDWORKS Flow Simulation.

(только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;& где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
SOLIDWORKSPATH Указывает папку, в которой установлена программа SOLIDWORKS.

(индивидуальные установки и установки клиента с помощью администрирующего образа)
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Inspection

Эти свойства командной строки относятся только к только программе SOLIDWORKS Inspection.

Свойство | Описание
ACTIVSERIALNUMBER | Серийный номер SOLIDWORKS Inspection. (индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR | Указывает папку для установки программного обеспечения SOLIDWORKS Inspection. (только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;& где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Visualize
Месторасположение файла MSI для администрирующих образов


Свойства командной строки SOLIDWORKS Visualize

Эти свойства командной строки относятся только к программе SOLIDWORKS Visualize.

Свойство | Описание
ACTIVSERIALNUMBER | Наличие серийного номера SOLIDWORKS Visualize. (индивидуальные установки и установки клиента с помощью администрирующего образа)
INSTALLDIR | Указывает папку для установки программного обеспечения SOLIDWORKS Visualize. (только индивидуальные установки)
SERVERLIST | Список строк, разделенных точкой с запятой, каждая из которых указывает на номер порта формата: xxxxx@имя_сервера1; yyyyy@имя_сервера2;& где x и y являются однозначными числами. После последнего названия сервера в списке точка с запятой не ставится.
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Месторасположение файла MSI для администрирующих образов


Месторасположение файла MSI для администрирующих образов

Файлы .msi компонентов продуктов, позволяющие создавать администрирующие образы при помощи командной строки, хранятся в указанных каталогах на носителях SOLIDWORKS.

SOLIDWORKS (основной продукт, англоязычная версия)

swwi\data\SOLIDWORKS.msi

SOLIDWORKS (версии компонентов для языков, отличных от английского)

Традиционный китайский | swwi\lang\chinese\chinese.msi
Китайский (упрощенный) | swwi\lang\chinese-simplified\chinese-simplified.msi
Чешский | swwi\lang\czech\czech.msi
французский | swwi\lang\french\french.msi
немецкий | swwi\lang\german\german.msi
итальянский | swwi\lang\italian\italian.msi
японский | swwi\lang\japanese\japanese.msi
корейский | swwi\lang\korean\korean.msi
Польский | swwi\lang\polish\polish.msi
Португальский (Бразилия) | swwi\lang\portuguese-brazilian\portuguese-brazilian.msi
русский | swwi\lang\russian\russian.msi
испанский | swwi\lang\spanish\spanish.msi
Turkish | swwi\lang\turkish\turkish.msi

DocManager APIs

swdocmgr\SOLIDWORKS Document Manager API.msi

eDrawings

eDrawings\eDrawings.msi

eDrawingsAPI SDK

eDrwAPISDK\eDrawings API SDK.msi

Средства построения теней eDrawings

eDrawingsShaders\eDrawings.msi

Flow Simulation

Flow Simulation\SOLIDWORKS Flow Simulation.msi

Отрисовка по сети в PhotoView 360

pvnetworkrender\pvnetrender.msi

Менеджер лицензии SolidNetWork

swlicmgr\SOLIDWORKS SolidNetWork License Manager.msi

Помощник активации SOLIDWORKS

swactwizard\Activation Wizard.msi

Комплект программ для разработчиков программных интерфейсов приложений SOLIDWORKS

apisdk\SOLIDWORKS API SDK.msi

SOLIDWORKS CAM

cam\SOLIDWORKS CAM.msi

SOLIDWORKS File Utilities

SWFileUtilities\SOLIDWORKS File Utilities.msi

SOLIDWORKS Composer

composer\SOLIDWORKS Composer.msi

SOLIDWORKS Inspection

Inspection\SOLIDWORKS Inspection.msi

SOLIDWORKS PCB

PCB\SOLIDWORKS PCB.msi

SOLIDWORKS PDM

SOLIDWORKS PDM Professional предоставляет API, который доступен только для клиента, но не в файле .msi. Дополнительные сведения см. в Руководстве по API в каталоге клиента SOLIDWORKS PDM Client install\API.

SOLIDWORKS Plastics

plastics\SOLIDWORKS Plastics.msi
На уровень выше Свойства командной строки
Свойства элементов командной строки
Глобальные свойства командной строки
eDrawings Свойства командной строки
Свойства командной строки SOLIDWORKS Composer/Composer Player
Свойства командной строки SOLIDWORKS Flow Simulation
Свойства командной строки SOLIDWORKS Inspection
Свойства командной строки SOLIDWORKS Visualize


Развертывание администрирующего образа с помощью Microsoft Active Directory

Развертывание с помощью Microsoft Active Directory поддерживается при внедрении основных продуктов SOLIDWORKS на клиентах.

Microsoft Active Directory – это служба каталогов для управления клиентами и серверами в сетевой среде. Упрощает управление, миграцию и развертывание.

Для получения сведений об установке SOLIDWORKS через Microsoft Active Directory обратитесь к реселлеру.

На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Установка администрирующего образа с использованием командной строки
Свойства командной строки
Установка требуемых компонентов Windows с помощью Microsoft Active Directory


Установка требуемых компонентов Windows с помощью Microsoft Active Directory

Чтобы подготовить существующий администрирующий образ, с помощью которого программа SOLIDWORKS будет установлена на клиентские компьютеры, используя Microsoft Windows Active Directory, выполните следующие действия.

  1. Извлеките все файлы для установки распространяемого пакета Visual C++ и установите их.
    1. Visual C++ 2008
      1. каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable\vcredist_x86.exe /x: {Целевой каталог}
      2. каталог_администрирующего_образа\Microsoft_C++_2008_Redistributable(64)\vcredist_x64.exe /x: {Целевой каталог}
      3. Создайте политику для установки распространяемых модулей Microsoft C++ 2008.
    2. Visual C++ 2010
      1. каталог_администрирующего_образа\Microsoft_C++_2010_Redistributable\vcredist_x86.exe /x:{Целевой_каталог}
      2. каталог_администрирующего_образа\Microsoft_C++_2010_Redistributable\vcredist_x64.exe /x:{Целевой_каталог}
      3. Создайте политику для установки распространяемых модулей Microsoft C++ 2010.
    3. Visual C++ 2012
      1. Установите каталог_администрирующего_образа\Microsoft_C++_2012_Redistributable\vcredist_x86.exe на тестовом компьютере.
      2. Скопируйте эти папки в сетевую папку (целевой каталог):
        1. C:\ProgramData\PackageCache\{BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030
        2. C:\ProgramData\PackageCache\{B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030
    4. Visual C++ 2013
      1. каталог_администрирующего_образа\Microsoft_C++_2013_Redistributable\vcredist_x86.exe /x: {Целевой каталог}
      2. каталог_администрирующего_образа\Microsoft_C++_2013_Redistributable_(64)\vcredist_x64.exe /x: {Целевой каталог}
      3. Создайте политику для установки распространяемых модулей Microsoft C++ 2013.
    5. Visual C++ 2015
      1. каталог_администрирующего_образа\Microsoft_C++_2015_Redistributable\vcredist_x86.exe /x: {Целевой каталог}
      2. каталог_администрирующего_образа\Microsoft_C++_2015_Redistributable_(64)\vcredist_x64.exe /x: {Целевой каталог}
      3. Создайте политику для установки распространяемых модулей Microsoft C++ 2015.

      1. Создайте политику для установки следующих файлов:
        В пути к файлу не должно быть пробелов.

        Целевой каталог\ {BD95A8CD-1D9F-35AD-981A-3E7925026EBB}v11.0.61030\packages\

        vcRuntimeMinimum_x86\vc_runtimeMinimum_x86.msi

        Целевой каталог\ {B175520C-86A2-35A7-8619-86DC379688B9}v11.0.61030\packages\

        vcRuntimeAdditional_x86\vc_runtimeAdditional_x86.msi

      2. Установите каталог_администрирующего_образа\Microsoft_ C++_2012_Redistributable_(64)\vcredist_x64.exe на тестовом компьютере.
      3. Скопируйте эти папки в сетевую папку (целевой каталог):
        1. C:\ProgramData\PackageCache\{CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030
        2. C:\ProgramData\PackageCache\{37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030
      4. Создайте политику для установки следующих файлов:
        В пути к файлу не должно быть пробелов.

        Целевой каталог\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Целевой каталог\ {CF2BEA3C-26EA-32F8-AA9B-331F7E34BA97}v11.0.61030\packages\

        vcRuntimeMinimum_amd64\vc_runtimeMinimum_x64.msi

        Целевой каталог\ {37B8F9C7-03FB-3253-8781-2517C99D7C00}v11.0.61030\packages\

        vcRuntimeAdditionalamd64\vc_runtimeAdditionalx64.msi

  2. Установите Microsoft .NET Framework 4.6.2.
    SOLIDWORKS рекомендует устанавливать .NET Framework 4.6.2 при помощи Windows Updates Services (WSUS) или схожей службы.
  3. Установите удаленный отладчик Visual Studio (только 64-разрядная версия, если на компьютере установлен .Net Framework 3.5), создав следующую политику:
    {каталог_удаленного_отладчика_Microsoft}\rdbgexp.MSI
    Для этой установки файлы преобразования не требуются.
  4. Выполните следующие действия:
    1. Обновите Visual Basic 7.1 для приложений с пакетом обновлений vba71-kb2783832-x64.
    2. После создания администрирующего образа запустите следующую команду:
      Msiexec /a {SOLIDWORKS Administrative image}/Microsoft_vba/vba71.msi /p {SOLIDWORKS Administrative image}/Microsoft_vba_ kb2783832/vba71-kb2783832-x64.msp
    3. Установите Visual Basic 7.1, создав следующую политику:
      {папка VBA}\vba71.MSI
      Для этой установки файлы преобразования не требуются.
  5. Установите языковой пакет Visual basic 7.1, создав следующую политику:
    {папка VBA}\vba71_nnnn.MSI
    Где nnnn определяет нужный язык:
    • 1028 = Китайский
    • 1031 = Немецкий
    • 1033 = Английский
    • 1036 = Французский
    • 1040 = Итальянский
    • 1041 = Японский
    • 1042 = Корейский
    • 1046 = Португальский
    • 2052 = Китайский - Китай
    • 3082 = Испанский
  6. Установите службу Bonjour Service создав следующую политику:
    {папка Bonjour}\Bonjour.MSI
    Для этой установки файлы преобразования не требуются.
На уровень выше Внедрение с использованием командной строки
Подготовка клиентов для установки командной строки из администрирующего образа
Установка администрирующего образа с использованием командной строки
Свойства командной строки
Развертывание администрирующего образа с помощью Microsoft Active Directory


Администрация множественных установок

К административным задачам по созданию нескольких установок относятся обновление администрирующих образов до новых версий, применение пакетов обновления и удаление установок.

Содержание

  • Обновление администрирующих образов до новой версии

    Для обновления клиентов, установки на которых были выполнены из администрирующего образа, сначала требуется обновить сам администрирующий образ, а затем настроить клиентов на обращение к новой копии этого образа.

  • Администрирование обновлений продуктов с помощью пакетов обновления

    Пакеты обновления могут включать обновления, касающиеся надежности системы, совместимости программ, безопасности и т.д.

  • Удаление установки

    Можно удалить установку на отдельном компьютере или в среде клиент/сервер.

На уровень выше Множественные установки
Внедрение на нескольких клиентах
Использование администрирующих образов
Внедрение администрирующего образа на клиентах через электронную почту
Внедрение с использованием командной строки


Обновление администрирующих образов до новой версии

Для обновления клиентов, установки на которых были выполнены из администрирующего образа, сначала требуется обновить сам администрирующий образ, а затем настроить клиентов на обращение к новой копии этого образа.

Запустите Менеджер установки SOLIDWORKS через Интернет, чтобы установились ссылки на верные файлы. Менеджер установки SOLIDWORKS самостоятельно переадресуется в соответствии с задачей. Обновление также можно запустить напрямую с веб-страницы загрузки SOLIDWORKS (http://www.solidworks.com/sw/support/downloads.htm).

После обновления администрирующего образа (что создает новую копию образа), можно обновить клиентов путем создания ссылки на новую копию администрирующего образа.

Если клиенты были связаны с предыдущей версией администрирующего образа через подключенный диск или общий каталог, то последние можно переопределить в соответствии с местоположением обновленной копии образа.

Содержание

  • Загрузка обновленных файлов установки для администрирующих образов

    С помощью Менеджера установки SOLIDWORKS можно определить, когда при обновлении администрирующего образа требуются обновленные файлы установки.

  • Обновление администрирующего образа

    Для обновления администрирующего образа Менеджер установки SOLIDWORKS создает новый каталог образа. Затем клиентам дается указание использовать новый каталог администрирующего образа, чтобы с его помощью выполнить обновление до этой версии продукта.

  • Обновление клиентов с помощью администрирующих образов

    Менеджер установки SOLIDWORKS позволяет автоматически обновлять клиентские компьютеры, установленные с помощью администрирующего образа.

На уровень выше Администрация множественных установок
Администрирование обновлений продуктов с помощью пакетов обновления
Удаление установки


Загрузка обновленных файлов установки для администрирующих образов

С помощью Менеджера установки SOLIDWORKS можно определить, когда при обновлении администрирующего образа требуются обновленные файлы установки.

  1. Запустите Менеджер установки SOLIDWORKS, вставив диск DVD в дисковод.
  2. На экране Добро пожаловать выберите Администрирующий образ.
  3. На экране Серийный номер введите серийный номер SOLIDWORKS.
    Менеджер установки SOLIDWORKS проверяет веб-сайт SOLIDWORKS на наличие лицензированных Вам продуктов и доступных пакетов обновлений.
  4. Если появляется окно Доступные более новые версии, выберите Да, загрузить и установить новую версию: Версия.
    Менеджер установки SOLIDWORKS запустит новый сеанс для установки более новой версии.
  5. При наличии проблемы с папкой загрузки может отобразиться сообщение Параметры загрузки. В этом случае для новых файлов установки выберите каталог по умолчанию или введите имя нового каталога.
    Если отобразится сообщение о том, что каталог не существует, выберите Да, чтобы его создать.
  6. На экране Загрузка завершена выберите Закрыть, чтобы закрыть текущую программу установки и запустить программу установки для новой версии.
На уровень выше Обновление администрирующих образов до новой версии
Обновление администрирующего образа
Обновление клиентов с помощью администрирующих образов


Обновление администрирующего образа

Для обновления администрирующего образа Менеджер установки SOLIDWORKS создает новый каталог образа. Затем клиентам дается указание использовать новый каталог администрирующего образа, чтобы с его помощью выполнить обновление до этой версии продукта.

Данный процесс подразумевает, что для администрирующего образа загружены обновленные файлы установки. Подробную информацию см. в разделе Загрузка обновленных файлов установки для администрирующего образа.

  1. Запустите Менеджер установки SOLIDWORKS. Подробную информацию см. в разделе Начало установки SOLIDWORKS.
  2. На экране Добро пожаловать выберите Администрирующий образ.
    На экране отображаются параметры создания администрирующего образа.
    Опция | Описание
    Создать новый образ с использованием параметров по умолчанию. | Создать образ при помощи параметров конфигурации, настроенных по умолчанию (иными словами, не используя текущие параметры, заданные для имеющегося администрирующего образа).
    Создать новый образ с использованием параметров и файлов существующего образа. | Создать образ, используя параметры конфигурации, настроенные для существующего администрирующего образа. Нажмите Обзор, чтобы указать каталог установки существующего администрирующего образа.
  3. На экране Серийный номер отметьте серийный номер.
  4. На экране Суммарная информация (Готов к созданию образа) отметьте, что параметры администрирующего образа верны.
    Для получения подробной информации об отдельном администрирующем образе и о параметрах установки нажмите кнопку ИЗМЕНИТЬ, чтобы перейти на страницу параметров, а затем выберите Справка.
  5. Чтобы создать новую версию администрирующего образа, нажмите кнопку Создать сейчас.

Теперь можно обновить клиенты до этой новой версии администрирующего образа. Для получения дополнительной информации см. раздел Обновление клиентов с помощью администрирующих образов.

На уровень выше Обновление администрирующих образов до новой версии
Загрузка обновленных файлов установки для администрирующих образов
Обновление клиентов с помощью администрирующих образов
Начало установки SOLIDWORKS


Обновление клиентов с помощью администрирующих образов

Менеджер установки SOLIDWORKS позволяет автоматически обновлять клиентские компьютеры, установленные с помощью администрирующего образа.

Обычно администрирующие образы располагаются в папках на сервере. Для поддержки автоматических обновлений клиентов администрирующий образ должен располагаться в папке общего использования.

После обновления администрирующего образа исходные и обновленные файлы будут сохранены в две разные папки. Чтобы воспользоваться обновленными файлами установки, отключите параметр общего использования для папки с исходным администрирующим образом и активируйте его для папки с обновленным образом.

При запуске программы SOLIDWORKS на клиентском компьютере, установленном с помощью исходного администрирующего образа, происходит автоматическое распознавание новой версии и обновление клиента.
Кроме того, когда SOLIDWORKS инициирует обновление, автоматически обновляются другие продукты, установленные с помощью администрирующего образа.
На уровень выше Обновление администрирующих образов до новой версии
Загрузка обновленных файлов установки для администрирующих образов
Обновление администрирующего образа

Отмена общего доступа для папки с исходным администрирующим образом

При обновлении администрирующего образа, доступ к которой осуществлялся из общей папки, необходимо отменить общий доступ для исходной папки.

  1. Перейдите в папку, где располагаются файлы исходного администрирующего образа.
  2. Нажмите правой кнопкой мыши папку и выберите Свойства.
  3. На вкладке Общие выберите параметр Отменить общий доступ к этой папке, затем нажмите кнопку ОК.

Теперь добавьте параметр общего доступа к обновленной папке администрирующего образа, как описано в Добавление параметра общего доступа к обновленной папке администрирующего образа.

Установка общего доступа для папки с обновленным администрирующим образом.

После создания папки с обновленным администрирующим образом и отключения общего доступа для папки с исходным администрирующим образом параметр общего доступа необходимо задать для вновь созданной папки. Это необходимо для повторной активации администрирующего образа.

  1. Перейдите в папку, где располагаются файлы обновленного администрирующего образа.
  2. Нажмите правой кнопкой мыши папку и выберите Свойства.
  3. На вкладке Совместное использование укажите параметры совместного использования, подходящие для Вашей организации или группы, и измените имя общего ресурса на имя, используемое в исходной папке администрирующего образа.
На компьютерах, установка на которых была выполнена из общей папки исходного администрирующего образа, при запуске программы SOLIDWORKS произойдет автоматическое обновление до новой версии.


Администрирование обновлений продуктов с помощью пакетов обновления

Пакеты обновления могут включать обновления, касающиеся надежности системы, совместимости программ, безопасности и т.д.

Обновления продуктов можно получать двумя способами.
  • Проверка наличия, скачивание и установка обновлений с помощью Менеджера установки SOLIDWORKS.

    Менеджер установки SOLIDWORKS можно запускать вручную или запрограммировать его на выполнение периодической проверки наличия обновлений.

  • Скачивание пакетов обновления вручную с веб-узла поддержки SOLIDWORKS.

    Пакеты обновления применяются как заплаты для существующей версии программного обеспечения. Например, SOLIDWORKS 2020 SP1.0 — это пакет обновления для SOLIDWORKS 2020 SP0.0. Эти пакеты обновления можно установить с помощью Менеджера установки SOLIDWORKS 2020. Установить их с помощью Менеджера установки SOLIDWORKS 2019 невозможно.

    Для получения более подробных инструкций по скачиванию и установке пакетов обновления, см. документацию по установке версии SOLIDWORKS, которую необходимо обновить.

Содержание

  • Откат пакетов обновления в администрирующем образе

    Администрирующий образ можно откатить до пакета обновления, установленного ранее. Если программное обеспечение SOLIDWORKS было установлено с помощью дисков, то для восстановления пакета обновления потребуются оригинальные диски. Необходимо, чтобы копия более ранней версии администрирующего образа была сохранена.

  • Применение пакетов обновления для клиентов, внедренных с помощью Microsoft Active Directory

    Если программное обеспечение SOLIDWORKS было установлено с помощью Microsoft Active Directory, с помощью этой программы можно также применить пакеты обновления к клиентам.

На уровень выше Администрация множественных установок
Обновление администрирующих образов до новой версии
Удаление установки


Откат пакетов обновления в администрирующем образе

Администрирующий образ можно откатить до пакета обновления, установленного ранее. Если программное обеспечение SOLIDWORKS было установлено с помощью дисков, то для восстановления пакета обновления потребуются оригинальные диски. Необходимо, чтобы копия более ранней версии администрирующего образа была сохранена.

Администрирующие образы, прошедшие обновления, невозможно откатить до предыдущей версии пакета обновления. Администрирующие образы, созданные любым способом без использования Менеджера установки SOLIDWORKS, невозможно откатить до предыдущей версии. Клиенты, установленные из таких администрирующих образов, должны удаляться и устанавливаться повторно с помощью администрирующего образа, созданного в предыдущей версии.
  1. Удалите папку, содержащую текущий администрирующий образ. Для этого откройте окно «Командная строка» и введите команду:
    rmdir /s/q путь_к_текущему_администрирующему_образу
  2. Переместите резервную копию администрирующего образа в папку, из которой был удален текущий администрирующий образ. Для этого откройте окно «Командная строка» и введите команду:
    move путь_к_резервной_копии_администрирующего_образа путь_к_текущему_администрирующему_образу
    После отката администрирующего образа откат на клиентских компьютерах будет выполнен автоматически при следующем запуске программы SOLIDWORKS.
На уровень выше Администрирование обновлений продуктов с помощью пакетов обновления
Применение пакетов обновления для клиентов, внедренных с помощью Microsoft Active Directory


Применение пакетов обновления для клиентов, внедренных с помощью Microsoft Active Directory

Если программное обеспечение SOLIDWORKS было установлено с помощью Microsoft Active Directory, с помощью этой программы можно также применить пакеты обновления к клиентам.

  1. Скопируйте администрирующий образ в новую папку с помощью следующей командной строки:
    xcopy путь_к_текущему_администрирующему_образу путь_к_резервной_копии_администрирующего_образа /s/i/v
  2. Обновите администрирующий образ с помощью Менеджера установки SOLIDWORKS.
  3. Создайте новый файл преобразования, чтобы указать обновление установки для программы SOLIDWORKS:
    1. Откройте окно «Командная строка».
    2. В папке, содержащей администрирующий образ, перетащите файл SWCreateMST.exe в окно «Запрос команды».
      Формат команды следующий:

      путь_к_администрирующему_образу\SWCreateMST.exe путь_к_файлу_MSI_администрирующего_образа список_свойств

      Командная строка должна включать все параметры, которые использовались для создания исходного файла преобразования, а также глобальные свойства Командная строка должна включать все параметры, которые использовались для создания исходного файла преобразования, а также глобальные свойства и UPGRADESWINSTALL.

      Например, если исходная команда выглядела следующим образом:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@ваш_сервер

      Обновленная команда должна выглядеть следующим образом:

      C:\admin\SWCreateMST.exe "c:\admin\SOLIDWORKS.msi" INSTALLDIR="C:\Program Files\ваша_папка" SOLIDWORKSSERIALNUMBER="xxxx xxxx xxxx xxxx" ADDLOCAL=SOLIDWORKS,Manuals OFFICEOPTION=0 SERVERLIST=25734@ваш_сервер UPGRADESWINSTALL=1 SWMIGRATE="SOLIDWORKS версия service_pack"

      В папке, содержащей администрирующий образ, будет создан файл преобразования SOLIDWORKS.mst.

  4. В окне Active Directory отредактируйте политику Published Apps (Опубликованные приложения) для группы или групп, чтобы можно было внедрить программное обеспечение SOLIDWORKS.
  5. В диалоговом окне Групповая политика раскройте Конфигурация компьютера и Конфигурация программ.
  6. Нажмите правой кнопкой мыши Установка программного обеспечения и выберите Создать > Пакет.
  7. Перейдите к администрирующему образу и нажмите Открыть.
  8. В диалоговом окне Deploy Software (Развертывание программы) выберите Advanced published or assigned (Дополнительные опубликованные или назначенные), затем нажмите OK.
  9. В диалоговом окне Свойства SOLIDWORKS на вкладке Изменения выполните следующие действия.
    1. Нажмите кнопку Добавить.
    2. Найдите файл .mst.
    3. Нажмите Открыть.
  10. Нажмите кнопку ОК.
На уровень выше Администрирование обновлений продуктов с помощью пакетов обновления
Откат пакетов обновления в администрирующем образе


SOLIDWORKS PDM и SOLIDWORKS Manage

SOLIDWORKS PDM представляет собой продукт для управления документацией на основе архитектуры "клиент-сервер", ранее известный как SOLIDWORKS Enterprise PDM. SOLIDWORKS PDM поставляется в двух типах:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

Для управления хранилищами файлов SOLIDWORKS PDM использует базу данных Microsoft SQL Server.

В этой таблице представлены определения доступных систем баз данных, серверных компонентов и параметров клиентов для каждого типа продукта.
 | PDM Standard | PDM Professional
Предназначение | Небольшие и средние сети офисов, в которых менее 20 одновременно работающих пользователей. | Крупные офисные сети, большое число параллельных пользователей
Ограничения | Меньшее из следующего: 1 сокет или 4 ядра, 1 ГБ ОЗУ, база данных размером 10 ГБ | Стандартные ограничения SQL: Меньшее из следующего: 4 сокета или 16 ядер, 128 ГБ ОЗУ, база данных размером 524 ПБ
Система управления базой данных | Microsoft SQL Server Express 2014 (поставляется и устанавливается в составе продукта SOLIDWORKS) | Microsoft SQL Server 2014 (отдельный компонент SOLIDWORKS) либо ранее установленные экземпляры Microsoft SQL Server 2014, 2012 или 2008 R2
Требуется SolidNetWork License Manager? | Да | Да
В комплект поставки входит сервер архивации и сервер базы данных? | Да | Да
В комплект поставки входит веб-сервер и веб-сервер2 SOLIDWORKS PDM? | Нет | Да
Типы клиентов | Собственный | Собственный, на основе браузера
Клиентские добавления для CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, интеграция Microsoft Office, Autodesk Inventor, AutoCAD
Клиентские добавления для Contributor | DraftSight | DraftSight, интеграция с Microsoft Office
Клиентские добавления для Viewer |  | Интеграция Microsoft Office

Версия SOLIDWORKS Manage Professional предоставляет набор расширенных инструментов управления данными для SOLIDWORKS PDM Professional. Она содержит возможности для расширенного управления версиями, проектом, процессом и объектами. Интерактивные информационные панели и отчеты помогают отслеживать элементы, действия и ход выполнения относительно проектов.

SOLIDWORKS Manage Professional имеет аналогичную SOLIDWORKS PDM Professional архитектуру. Она использует архитектуру клиент-сервер вместе с базой данных Microsoft SQL Server для управления данными объекта и проекта. Существует три службы для базы данных, файлового сервера и функций веб-сервера, которые поддерживают полные версии клиентов и клиентов веб-браузера. Три службы могут быть размещены на одном или на отдельных серверах. Пользователи с лицензиями SOLIDWORKS Manage Professional Editor могут использовать дополнение SOLIDWORKS Manage для доступа к управлению данными непосредственно из SOLIDWORKS.

Можно использовать менеджер установки SOLIDWORKS для установки сервера и клиента версии SOLIDWORKS Manage Professional.

Для получения инструкций по установке SOLIDWORKS Manage Professional см. Руководство по установке SOLIDWORKS PDM/SOLIDWORKS Manage.

Содержание

  • Список компонентов PDM Server

  • Описание различий между клиентами PDM

    Перед установкой программного обеспечения клиента необходимо определить требуемые клиенты в зависимости от среды PDM.

  • Перед установкой PDM Server

    Перед установкой серверных компонентов PDM необходимо учесть следующие требования:

  • Установка сервера PDM с помощью SLDIM

    При установке сервера PDM для продукта PDM Standard можно установить сервер архивации, сервер базы данных и клиент PDM CAD Editor на одном и том же компьютере. При этом нет необходимости выполнять установку клиента отдельно.

  • Установка клиента PDM с помощью SLDIM


Список компонентов PDM Server

В этой таблице представлены компоненты SOLIDWORKS PDM Server.

Сервер | Function | Установка
Microsoft SQL Server Express для PDM Standard | Управление данными в хранилищах SOLIDWORKS PDM. | Возможна установка с PDM Standard или использование ранее лицензированной и установленной версии.
Microsoft SQL Server для PDM Professional | Управление данными в хранилищах SOLIDWORKS PDM. | Поставляется отдельно с PDM Professional. Также можно использовать ранее лицензированную и установленную версию.
Менеджер лицензии SolidNetWork | Управление лицензиями SOLIDWORKS PDM. | Должен быть установлен перед созданием новых хранилищ. Может быть установлен с серверными компонентами SOLIDWORKS PDM при использовании SLDIM.
Сервер архивации | Управляет переносами файлов между клиентами и архивным хранилищем файлов; управление пользователями и их учетными данными. | Требуется. Устанавливается вместе с PDM Standard или Professional.
Сервер базы данных | Опрашивает базы данных PDM, проверяя наличие обновлений, управляет правилами импорта и экспорта данных, контролирует систему сообщений и планирует репликацию и холодное хранение. | Требуется. Устанавливается вместе с PDM Standard или Professional.
Веб-сервер и веб-сервер2 | Обеспечивает доступ к хранилищам файлов через Интернет посредством клиентов на основе браузера. | Дополнительно. Устанавливается только с PDM Professional.
Веб-сервер API | Пользователи EXALEAD OnePart могут использовать веб-сервер API для индексации и извлечения данных SOLIDWORKS PDM. | Дополнительно. Устанавливается только с PDM Professional.

Серверы архивации работают как службы в системной учетной записи компьютеров, на которых они установлены. На одном сервере архивации может размещаться несколько хранилищ файлов на одном компьютере.

При автономной установке сервер архивации, сервер базы данных, сервер лицензирования и веб-сервер API, а также базу данных SQL Express или SQL Server можно установить на одном компьютере.

В распределенной среде серверные компоненты можно разместить на разных компьютерах. Кроме того, можно установить несколько серверов архивации на разных компьютерах для размещения реплицированных копий одного и того же архива файлового хранилища. См. Руководство по репликации SOLIDWORKS PDM Professional.

На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Описание различий между клиентами PDM

Перед установкой программного обеспечения клиента необходимо определить требуемые клиенты в зависимости от среды PDM.

В этой таблице представлена обзорная информация по клиентам для SOLIDWORKS PDM Standard:
Тип клиента Standard | Описание
CAD Editor | Поддерживает работу с файлами SOLIDWORKS, DWG/DXF, Microsoft Word и Microsoft Excel. Все форматы файлов, которые обрабатывает плагин Microsoft Office, ведут себя в SOLIDWORKS PDM Standard одинаково, кроме предварительного просмотра.
Соавтор | Поддерживает работу с файлами SOLIDWORKS, DWG/DXF, Microsoft Word и Microsoft Excel.
Viewer | Обеспечивает доступ к файловым хранилищам в режиме "только чтение". Пользователь может перемещать файлы в рамках технологического процесса, но не может добавлять или изменять файлы (разрегистрировать, регистрировать, обновлять значения).
В этой таблице представлена обзорная информация по клиентам для SOLIDWORKS PDM Professional:
Тип клиента Professional | Описание
CAD Editor и веб-клиент | Поддерживает работу с файлами всех типов, включая файлы усовершенствованных форматов САПР для управления и просмотра, например SOLIDWORKS. Добавления CAD обеспечивают доступ к SOLIDWORKS PDM Professional из любого приложения CAD. Удаленные пользователи могут осуществлять поиск в хранилищах и работать с базовыми функциями через Интернет с помощью веб-клиента и клиента Web2.
Contributor и веб-клиент | Поддерживает работу с файлами всех типов, включая файлы САПР. Однако этот клиент не поддерживает добавления САПР. Удаленные пользователи могут осуществлять поиск в хранилищах и работать с базовыми функциями через Интернет с помощью веб-клиента и клиента Web2.
Viewer | Обеспечивает доступ к файловым хранилищам в режиме "только чтение". Пользователь может перемещать файлы в рамках технологического процесса, но не может добавлять или изменять файлы (разрегистрировать, регистрировать, обновлять значения) либо использовать добавления CAD.
На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Перед установкой PDM Server

Перед установкой серверных компонентов PDM необходимо учесть следующие требования:

  • Получите полные административные права на компьютерах, на которых планируется установить серверы и клиенты.
  • Убедитесь, что сервер базы данных имеет доступ к серверу архивации через порт TCP 3030 и к серверу SQL через порт TCP 1433.
  • Если будет использоваться существующая база данных SQL Server Express или SQL Server, получите имя базы данных SQL Server, идентификатор учетной записи и пароль администратора или владельца базы данных SQL Server с правом доступа к базе данных в режиме "чтение/запись". Работа с пользователем tew невозможна.
  • Если на компьютере уже установлен клиент PDM, удалите его. Чтобы использовать и сервер PDM, и клиент PDM на одном компьютере, можно установить обе программы на странице Серверы в Менеджере установки SOLIDWORKS.
На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Установка сервера PDM с помощью SLDIM

При установке сервера PDM для продукта PDM Standard можно установить сервер архивации, сервер базы данных и клиент PDM CAD Editor на одном и том же компьютере. При этом нет необходимости выполнять установку клиента отдельно.

При установке сервера PDM для продукта PDM Professional можно включить эти компоненты, а также веб-сервер и сервер Web2 и веб-сервер API.

Установка сервера PDM и его компонентов:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите Сервер и установите следующие флажки:
    • Установить компоненты SOLIDWORKS PDM Server на этом компьютере.
    • Установить SolidNetWork License Manager на этом компьютере.

      Если установлен компонент SolidNetWork License Manager, этот параметр не отображается.

  3. Если отображается страница Параметры SolidNetWork License Manager, введите серийный номер и укажите расположение, а затем нажмите Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Сводка для SOLIDWORKS PDM Server нажмите Изменить.
  6. На странице Параметры SOLIDWORKS PDM Server выполните следующие действия.
    1. В списке Выбрать сервер, выберите SOLIDWORKS PDM Standard или Professional.
    2. В разделе Расположение установки нажмите Обзор, чтобы указать путь к файлу.
    3. В разделе Выбрать элементы:
      1. Выберите Сервер архивации, Сервер базы данных и Клиент, чтобы установить эти компоненты на одном и том же компьютере. Если вы работаете в распределенной среде, можно установить сервер архивации и сервер базы данных с помощью Менеджера установки на другом компьютере.
        Если на компьютере уже установлен клиент PDM, необходимо отменить текущую установку и удалить ранее установленный клиент. Затем можно запустить SLDIM для одновременной установки сервера и клиента PDM.
      2. При установке PDM Professional можно также выбрать Веб-сервер, Сервер Web2 и Веб-сервер API.
        При установке веб-сервера API можно указать значение для номера порта HTTP от 0 до 65535. По умолчанию используется значение 65453.
    4. В разделе SQL Server можно установить новый экземпляр инструментов базы данных, поставляемый с сервером PDM (SQL Server Express для PDM Standard). Также можно указать имя базы данных, имя пользователя и пароль для существующего экземпляра.
      Полная версия SQL Server поставляется отдельно с PDM Professional.
    5. Нажмите Назад в Сводку.
  7. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.

    После завершения работы менеджера установки SOLIDWORKS запускается инструмент настройки сервера архивации. Настройте сервер архивации, следуя инструкциям мастера.

Информацию об установке, настройке и диагностике сервера архивации, сервера базы данных, веб-сервера и сервера Web2, а также баз данных SQL Server см. в соответствующих разделах Руководства по установке SOLIDWORKS PDM 2020.

Содержание

  • Изменение установки SOLIDWORKS PDM Server

На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


Изменение установки SOLIDWORKS PDM Server

Изменить установку SOLIDWORKS PDM Server и соответствующие компоненты можно в разделе Программы и компоненты на панели управления Windows. Нельзя изменить установку в Менеджере установки SOLIDWORKS (SLDIM), даже если он использовался для установки SOLIDWORKS PDM Server.

На уровень выше Установка сервера PDM с помощью SLDIM


Установка клиента PDM с помощью SLDIM

Основная версия клиента SOLIDWORKS PDM должна совпадать с основной версией сервера SOLIDWORKS PDM. При установке или обновлении клиента SOLIDWORKS PDM убедитесь, что версии совпадают.

Установка клиента PDM:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите параметр Индивидуальный.
  3. На странице Серийный номер нажмите кнопку Далее.
    Для клиентов SOLIDWORKS PDM не требуется отдельный серийный номер.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация в разделе "Продукты" выберите Изменить.
  6. На странице Выбор продуктов нажмите Выбрать другие пакеты или продукты.
  7. В диалоговом окне Выбрать предлагаемый пакет выберите версию SOLIDWORKS. Затем нажмите OK.
  8. На странице Выбор продуктов выберите Клиент SOLIDWORKS PDM. Затем выберите eDrawings, чтобы включить функцию предварительного просмотра PDM. При использовании SOLIDWORKS PDM Professional можно также выбрать Проводник объектов.
  9. На странице Сводка разверните узел Параметры SOLIDWORKS PDM и нажмите Изменить.
  10. На странице Параметры клиента SOLIDWORKS PDM выберите следующие значения и нажмите К странице "Суммарная информация":
    • Тип продукта PDM
    • Тип клиента PDM
    • Добавления
  11. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.
Для создания и развертывания образов клиентов PDM администраторы могут также использовать Редактор параметров администрирующего образа. Дополнительные сведения см. в разделе Использование административных образов в Руководстве по установке и администрированию SOLIDWORKS.
На уровень выше SOLIDWORKS PDM и SOLIDWORKS Manage


SOLIDWORKS Electrical

Менеджер установки SOLIDWORKS позволяет установить все компоненты SOLIDWORKS Electrical в автономном режиме или режиме клиент/сервер.

SOLIDWORKS Electrical использует несколько компонентов. Во время установки необходимо выбрать эти компоненты в соответствии с типом установки.
  • SOLIDWORKS Electrical Schematic — приложение 2D для создания и управления электрическими схемами.
  • SOLIDWORKS Electrical 3D — дополнение SOLIDWORKS для интеграции 2D-схем с 3D-моделями. Программа SOLIDWORKS Electrical 3D позволяет управлять компоновкой электрических устройств и прокладывать провода, кабели и жгуты проводов.
  • Данные — данные группируются по всем данным, необходимым для работы программного обеспечения. Эти данные являются графическими (файлы, представляющие обозначения, основные надписи...) или техническими (каталоги производителя, данные, связанные с символами...). Вы можете предоставить общий доступ к данным для всех пользователей.
  • Collaborative Server — утилита для управления процессом открытия и обновления электрических чертежей.
  • Приложение SOLIDWORKS Electrical требует использования базы данных Microsoft SQL Server. Можно создать новую базу данных или использовать существующую базу данных во время установки.

Тип установки

Все компоненты SOLIDWORKS Electrical можно установить на один и тот же компьютер. Это установка в виде отдельного приложения. Все программные данные такие, как чертежи объектов и отчеты, хранятся на одной рабочей станции.

Компоненты SOLIDWORKS Electrical также можно установить как приложения с архитектурой "клиент-сервер". Используйте этот тип установки, если необходимо сохранить данные на сетевом сервере. Установка клиент/сервер позволяет нескольким пользователям работать над одним проектом. Клиентские системы должны поддерживать сетевой доступ к серверу с правами на чтение и запись для создания проектов, библиотек и символов.

Информация

Независимо от типа установки (автономная или клиент/сервер), для установки SOLIDWORKS Electrical необходимо запустить сеанс Windows в режиме полных прав.

На компьютере можно установить только одну версию SOLIDWORKS Electrical. При установке SOLIDWORKS и выборе SOLIDWORKS Electrical в качестве одного из продуктов для установки программа установки удаляет старую версию SOLIDWORKS Electrical.

При запуске Менеджера установки SOLIDWORKS он автоматически определяет существующие версии SOLIDWORKS Electrical, установленные на рабочей станции или сервере.

Перед установкой новой версии следует создать резервную копию существующей среды SOLIDWORKS Electrical. В среде SOLIDWORKS Electrical Schematic выберите Файл > Архивировать среду или в SOLIDWORKS Electrical 3D выберите SOLIDWORKS Electrical > Инструменты > Архивировать среду.

Содержание

  • Требования к установке программы SOLIDWORKS Electrical

  • Автономная установка или установка клиента/сервера

    Установить SOLIDWORKS Electrical можно в двух режимах. В автономном режиме программное обеспечение устанавливается на рабочую станцию. В режиме клиент/сервер пользователи совместно используют данные.

  • Настройка сервера совместной работы

  • Настройка Microsoft SQL Server

  • Определение местоположения данных


Требования к установке программы SOLIDWORKS Electrical

Чтобы получить доступ к текущим системным требованиям, перейдите по ссылке http://solidworks.com/System_Requirements.

На уровень выше SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка сервера совместной работы
Настройка Microsoft SQL Server
Определение местоположения данных


Автономная установка или установка клиента/сервера

Установить SOLIDWORKS Electrical можно в двух режимах. В автономном режиме программное обеспечение устанавливается на рабочую станцию. В режиме клиент/сервер пользователи совместно используют данные.

SOLIDWORKS Electrical всегда должен подключаться к экземпляру SQL Server.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Настройка сервера совместной работы
Настройка Microsoft SQL Server
Определение местоположения данных

Установка в виде отдельного приложения

При первой установке НЕОБХОДИМО установить все компоненты на рабочую станцию.

  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  • Collaborative Server
  • Данные программного обеспечения
  1. На вкладке Сводка нажмите Изменить в разделе Выбор продукта и выберите все компоненты SOLIDWORKS Electrical.
  2. Если необходимо изменить параметры установки, на вкладке Сводка нажмите Изменить в разделе Параметры Electrical. Можно создать новый экземпляр SQL Server или использовать существующий. Дополнительные сведения см. в отдельных главах о Data и Microsoft SQL Server в данной документации. Также можно использовать параметры по умолчанию.
  3. Нажмите Установить, чтобы продолжить.
Если программа SOLIDWORKS Electrical уже установлена на рабочей станции, менеджер установки SOLIDWORKS автоматически находит ее и предлагает обновить. Установите все компоненты, не меняя Параметры Electrical.

Установка типа клиент/сервер

Установка типа клиент/сервер позволяет обмениваться данными между несколькими пользователями.

На сервере необходимо установить следующие компоненты:
  • Collaborative Server
  • Данные программного обеспечения
  • SQL Server
На клиентских устройствах необходимо установить следующие компоненты:
  • SOLIDWORKS Electrical Schematic
  • SOLIDWORKS Electrical 3D
  1. На сервере установите компоненты сервера.
  2. На вкладке приветствия Менеджера установки SOLIDWORKS нажмите Установить компонент сервера.
  3. Выберите параметр SOLIDWORKS Electrical.
  4. На вкладке Сводка можно изменять параметры установки. Дополнительные сведения см. в отдельных главах о Data и Microsoft SQL Server в данной документации. Также можно использовать параметры по умолчанию.
  5. Нажмите Установить, чтобы продолжить.
  6. На клиентских устройствах установите приложения.
  7. На вкладке приветствия Менеджера установки SOLIDWORKS нажмите Установить на этот компьютер.
  8. На вкладке Общие нажмите Изменить в разделе Выбор продукта и снимите флажок Сервер Electrical.
  9. На вкладке Сводка нажмите Изменить в разделе Параметры Electrical и измените настройки для подключения к серверу.
  10. Нажмите Установить, чтобы продолжить.
Если программа SOLIDWORKS Electrical уже установлена на рабочей станции или сервере, менеджер установки SOLIDWORKS автоматически находит ее и предлагает обновить ее. Чтобы обновить программное обеспечение, используйте тот же процесс, что и при первой установке.


Настройка сервера совместной работы

Чтобы запустить SOLIDWORKS Electrical, установите сервер совместной работы на ту же систему, в которой располагается база данных Microsoft SQL Server.

Collaborative Server — это служба Windows, которая должна быть всегда запущена и должна обеспечивать постоянную, бесперебойную, двустороннюю связь с клиентами посредством брандмауэров и средств поиска вирусов.

Чтобы настроить Collaborative Server в индивидуальном режиме или режиме сервера, укажите следующие параметры:
  • Имя компьютера (например, LOCALHOST или MyMachine) или его IP-адрес (например, 127.0.0.1 или 192.168.999.999).
  • Номер порта, (по умолчанию 26666).

Collaborative Server можно настроить во время установки или позже с помощью команды Инструменты > Настройки приложения.

В целях обеспечения бесперебойной двусторонней связи убедитесь, что номер порта 26666 доступен в соответствующей системе, на которую устанавливается Collaborative Server. В противном случае обратитесь к системному администратору, чтобы найти другой порт для SOLIDWORKS Electrical.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка Microsoft SQL Server
Определение местоположения данных


Настройка Microsoft SQL Server

Убедитесь, что экземпляр базы данных SQL Server доступен для любого типа установки SOLIDWORKS Electrical. Существующую базу данных SQL Server можно использовать даже при условии, что она уже установлена в системе или же установить новый экземпляр в рамках установки SOLIDWORKS Electrical.

При установке нового экземпляра SQL Server в рамках установки SOLIDWORKS предоставляется бесплатная версия приложения Microsoft SQL Server Express. Данная версия ограничивается 1 ЦПУ, 1 ГБ памяти и 10 ГБ данных. Ограничений по памяти и ЦПУ достаточно для поддержки 5 одновременно работающих пользователей.

При установке SQL Server Express Edition убедитесь, что программное и аппаратное обеспечение сервера соответствует требованиям, представленным на веб-сайте http://solidworks.com/System_Requirements.

Однако при одновременной работе на сервере 6 и более пользователей необходимо приобрести и установить полную версию SQL Server,а также использовать представленный рабочий процесс для установки приложения SOLIDWORKS Electrical с существующим экземпляром SQL Server.

Дополнительные сведения о SQL Server Express Edition см. в соответствующей документации к приложению Microsoft SQL Server.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка сервера совместной работы
Определение местоположения данных

Управление данными в SOLIDWORKS Electrical

Во многих программах используется отдельная база данных, в которой содержатся все программные данные. Однако в случае с SOLIDWORKS Electrical все обстоит по-другому. Каждому проекту в приложении SOLIDWORKS Electrical назначается уникальный идентификационный номер, при этом для каждого проекта существует связанная база данных, которую можно определить по уникальному идентификационному номеру. Например, если в окне Менеджера проектов SOLIDWORKS Electrical найти проект с идентификационным номером 112, связанной базе данных будет присвоено имя "tew_project_data_112".

При назначении уникальной базы данных каждому проекту существенным образом сокращается время обработки. Кроме того, в случае критической ошибки базы данных это коснется только одного проекта, при этом целостность большей части программной информации будет сохранена.

Однако некоторые компании вводят санкции, ограничивающие создание новых баз данных. Для запуска приложения SOLIDWORKS Electrical не действуют ограничения на создание новых баз данных пользователями. Обратитесь к администратору системы или базы данных, чтобы убедиться в отсутствии параметров конфигурации, препятствующих созданию новых баз данных.

Новые экземпляры SQL Server

Для установки нового экземпляра SQL Server необходимы полные административные права на сервер, а также клиентские системы. Кроме того, необходимо убедиться, что клиенты обладают правом на чтение и запись базы данных для последующего создания и изменения проектов, библиотек, символов и других данных проекта.

При установке нового экземпляра SQL Server выберите имя, отличное от имени по умолчанию.

Существующие экземпляры SQL Server

Чтобы установить новые базы данных SOLIDWORKS Electrical или подключиться к установке SOLIDWORKS Electrical на существующем экземпляре SQL Server, необходимо создать учетную запись пользователя с полными административными правами на использование базы данных SQL Server.

Для надлежащего функционирования приложения SOLIDWORKS Electrical необходимо активировать SQL Server для проверки подлинности в смешанном режиме. Благодаря проверке подлинности в смешанном режиме можно использовать учетные данные Windows или SQL Server.

Чтобы подключиться к существующей базе данных SQL Server, можно воспользоваться проверкой подлинности с помощью Windows или SQL Server. Введите имя пользователя и пароль для имени входа Windows или SQL Server с полными административными правами SQL Server.

Невозможно использовать пользователь "tew" для подключения к SQL Server с целью установки. Обратитесь к администратору SQL Server или системному администратору для получения имени входа с допустимыми учетными данными для SQL Server.

Базы данных SOLIDWORKS Electrical

После установки SOLIDWORKS Electrical программа установки создает следующие базы данных в экземпляре SQL Server.

  • TEW_APP_DATA
  • TEW_APP_MACRO
  • TEW_APP_PROJECT
  • TEW_CATALOG
  • TEW_CLASSIFICATION


Определение местоположения данных

Чтобы расположить данные, выберите каталог для хранения программных данных таких, как детали, шаблоны, двухмерные и трехмерные символы. Это место должно быть выделенным каталогом. Однако не может быть корневым каталогом или тем же каталогом, который используется для хранения данных SOLIDWORKS.

По умолчанию используется каталог C:\ProgramData\SOLIDWORKS Electrical.

В случае установки клиента/сервера необходимо предоставить общий доступ к каталогу данных.

Программа установки создает новую папку с именем Update в каталоге по умолчанию для хранения всех новых данных.

При первом запуске SOLIDWORKS Electrical программа автоматически объединяет данные, хранящиеся в папке Обновить, с существующими данными. В окне мастера Обновления данных выберите данные для добавления в приложение и базу данных SQL Server.

На уровень выше SOLIDWORKS Electrical
Требования к установке программы SOLIDWORKS Electrical
Автономная установка или установка клиента/сервера
Настройка сервера совместной работы
Настройка Microsoft SQL Server


SOLIDWORKS PCB

SOLIDWORKS® PCB (ранее PCBWorks) — это инструмент для проектирования печатных плат (PCB), который интегрируется с ПО для 3D-проектирования SOLIDWORKS. Этот компонент устанавливается отдельно с помощью мастера установки SOLIDWORKS.

Электротехники, использующие SOLIDWORKS PCB, могут вносить изменения в печатные схемы и сохранять эти изменения в общем хранилище. Инженеры-механики, работающие с ПО SOLIDWORKS, могут извлекать отредактированные печатные платы из хранилища, анализировать изменения, вносить дополнительные корректировки и загружать измененные проекты обратно в хранилище, где они будут доступны для электротехников.

Чтобы включить режим совместной работы, необходимо установить компонент SOLIDWORKS PCB Services, который управляет хранилищем на общем сервере. Этот компонент устанавливается с помощью мастера установки SOLIDWORKS вместе с установками сервера и не требует отдельной лицензии. Он включает в себя службы Microsoft Internet Information Services и базы данных, где хранятся синхронизируемые данные электротехников и инженеров-механиков.

В сетевой среде компонент SOLIDWORKS PCB Services Services, как правило, устанавливается на общем сервере, на котором не установлено ПО SOLIDWORKS. Также его можно установить на компьютере с другими компонентами SOLIDWORKS PCB. Компонент SOLIDWORKS PCB Services должен постоянно находиться в активном состоянии и поддерживать двустороннюю связь с клиентскими компьютерами, на которых установлен компонент SOLIDWORKS PCB и ПО SOLIDWORKS. Безопасность должна обеспечиваться посредством брандмауэров и антивирусных сканеров. Также необходима связь со всеми клиентскими компьютерами, где установлено ПО Altium Designer, которое требуется интегрировать с ПО SOLIDWORKS.
Рекомендуется устанавливать службы SOLIDWORKS PCB Services перед установкой SOLIDWORKS PCB.

Кроме того, на компьютерах с установленным ПО SOLIDWORKS необходимо включить еще один компонент — дополнение SOLIDWORKS PCB. Можно включить дополнение в меню Инструменты > Дополнения.

Электротехники, работающие с лицензированным ПО Altium Designer, также могут обмениваться проектами с пользователями ПО SOLIDWORKS для 3D-проектирования, используя общее хранилище. Для такого обмена пользователям необходимо установить SOLIDWORKS PCB Connector. Эта программа устанавливается на клиенте Altium Designer.

Содержание

  • Требования

  • Установка PCB Services с помощью SLDIM

  • Установка PCB с помощью SLDIM

  • Изменение пароля администратора по умолчанию для входа

  • Установка SOLIDWORKS PCB Viewer

    Приложение SOLIDWORKS PCB Viewer® можно скачать и установить с помощью Менеджера установки, что позволяет выполнить установку одновременно с SOLIDWORKS или другими продуктами SOLIDWORKS. Это бесплатное средство просмотра печатных плат доступно без лицензии.

  • Установка PCB Connector для Altium Designer

  • Действия после установки

  • Обновление PCB Services

  • Удаление PCB Services


Требования

Перед установкой убедитесь, что выполнены следующие требования:
  • серийный номер SOLIDWORKS PCB;
  • серийный номер SOLIDWORKS PCB Connector для всех клиентов Altium Designer, которые интегрируются с SOLIDWORKS.

Чтобы получить доступ к текущим системным требованиям, перейдите по ссылке http://solidworks.com/System_Requirements.

На уровень выше SOLIDWORKS PCB


Установка PCB Services с помощью SLDIM

Установка SOLIDWORKS PCB Services:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На экране Добро пожаловать выберите Серверные продукты.
  3. Затем выберите Установить SOLIDWORKS PCB Services на этом компьютере и нажмите Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На экране Сводка оставьте параметры SOLIDWORKS PCB Services, выбранные по умолчанию, или нажмите Изменить, чтобы задать следующие параметры:
    • Месторасположение установки
    • Папка базы данных
    • Папка файлов редакций
    • Номер порта

    Службы PCB Services включают в себя службы Microsoft Internet Information Services и базы данных, где хранятся синхронизируемые данные электротехников и инженеров-механиков.

    Номер порта по умолчанию — 9780.

  6. Примите условия лицензионного соглашения SOLIDWORKS и нажмите Установить сейчас.
На уровень выше SOLIDWORKS PCB


Установка PCB с помощью SLDIM

Установка SOLIDWORKS PCB:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите параметр Индивидуальный.
  3. Выполните следующие операции:
    1. Разверните Проектирование электрических схем.
    2. Выберите SOLIDWORKS PCB и введите серийный номер.
    3. Нажмите кнопку Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.
На уровень выше SOLIDWORKS PCB


Изменение пароля администратора по умолчанию для входа

SOLIDWORKS PCB Services предоставляют учетную запись администратора по умолчанию со следующими учетными данными:
  • admin для имени пользователя
  • admin для пароля
Для повышения безопасности настоятельно рекомендуется изменить данные для этой учетной записи.

Чтобы изменить учетные данные администратора по умолчанию для входа, выполните следующие действия.

  1. Откройте веб-браузер и в адресной строке введите имя и номер порта компьютера, используя следующую форму: http://server name:port number.

    Номер порта по умолчанию — 9780.

  2. На странице Вход в SOLIDWORKS PCB Services введите admin для имени пользователя и admin для пароля, затем нажмите кнопку Войти.
  3. В меню SOLIDWORKS PCB Services выберите Пользователи, затем выберите вкладку Пользователи.
  4. Нажмите ссылку, связанную с учетной записью администратора, или нажмите значок Редактировать пользователя [image].
  5. Измените информацию о пользователе, имени пользователя и пароль.
  6. Нажмите Сохранить.
На уровень выше SOLIDWORKS PCB


Установка SOLIDWORKS PCB Viewer

Приложение SOLIDWORKS PCB Viewer® можно скачать и установить с помощью Менеджера установки, что позволяет выполнить установку одновременно с SOLIDWORKS или другими продуктами SOLIDWORKS. Это бесплатное средство просмотра печатных плат доступно без лицензии.

Средство просмотра можно использовать для доступа, печати и поиска всех проектных файлов вашей команды, созданных в Altium Designer.

SOLIDWORKS PCB Viewer также можно добавить в администрирующий образ для развертывания.

SOLIDWORKS PCB Viewer невозможно установить на компьютере, на котором уже установлена программа SOLIDWORKS PCB.
На уровень выше SOLIDWORKS PCB


Установка PCB Connector для Altium Designer

Приложение Altium Designer представляет собой инструмент проектирования печатных плат (PCB). Пользователи с лицензированной установленной версией Altium Designer могут интегрировать ее в программу SOLIDWORKS при установке SOLIDWORKS PCB Connector.

Чтобы установить SOLIDWORKS PCB Connector на компьютере под управлением Altium Designer, выполните следующие действия.

  1. Войдите в учетную запись Altium, если вход в систему не выполнен автоматически.
  2. Запустите приложение Altium Designer, откройте файл DXP и нажмите кнопку Расширения и обновления.
  3. На странице Расширения и обновления нажмите вкладку Приобретено .
  4. Прокрутите экран до раздела Расширения программы. Затем на странице SOLIDWORKS PCB Connector нажмите на стрелку вниз в верхнем правом углу блока для скачивания и начала установки.

  5. В диалоговом окне Подтверждение нажмите Да для продолжения установки.
    Во избежание проблем с активацией и установкой продукта шаги 6 и 7 необходимо выполнить в указанном порядке.
  6. На странице Регистрация PCB Connector введите серийный номер SOLIDWORKS PCB Connector и нажмите Зарегистрировать.
  7. В диалоговом окне Подтверждение, отображенном приложением Altium Designer, нажмите Да для перезапуска системы и завершения процесса установки или нажмите Нет, чтобы завершить установку позднее.

Чтобы деактивировать лицензию SOLIDWORKS PCB Connector, в меню Справка выберите Лицензирование SOLIDWORKS PCB Connector > Деактивировать лицензии.

На уровень выше SOLIDWORKS PCB


Действия после установки

После установки ПО SOLIDWORKS PCB и его компонентов можно добавить учетные записи пользователей в SOLIDWORKS PCB Services, чтобы пользователи могли получать доступ к платам из хранилища.

К дополнительным задачам относятся вход в хранилище дополнения SOLIDWORKS PCB и удаление программы.

Содержание

  • Добавление пользователя в PCB Services

  • Вход в хранилище PCB

На уровень выше SOLIDWORKS PCB


Добавление пользователя в PCB Services

Добавление пользователя на веб-сайте SOLIDWORKS PCB Services:

  1. Откройте веб-браузер и введите в адресной строке имя сервера и номер порта, назначенные компоненту SOLIDWORKS PCB Services. Например: http://server name:port number.
  2. На странице Вход в SOLIDWORKS PCB Services введите имя администратора и пароль, затем нажмите Войти.
  3. В меню SOLIDWORKS PCB Services выберите Пользователи, затем выберите вкладку Пользователи.
  4. Нажмите кнопку Добавить пользователя и введите следующие данные:
    • Имя
    • Фамилия
    • Имя пользователя
    • Пароль
    • Адрес эл. почты
    • Телефон

    Кроме того, необходимо выбрать Роль пользователя и установить флажок Участник, чтобы включить пользователя в группу.

  5. Нажмите Сохранить.
Можно изменить информацию пользователя на вкладке Пользователи.
На уровень выше Действия после установки


Вход в хранилище PCB

В SOLIDWORKS для выбора новой платы или получения существующей платы через панель задач дополнения PCB необходимо войти в SOLIDWORKS PCB Services и получить доступ к хранилищу.

Вход в хранилище SOLIDWORKS PCB:

  1. Откройте Панель задач SOLIDWORKS и нажмите кнопку Дополнение SOLIDWORKS PCB [image].
  2. Нажмите Новая сборка платы или Получение платы из хранилища.
  3. Вход в SOLIDWORKS PCB Services:
    1. Укажите имя сервера и номер порта, присвоенные компоненту SOLIDWORKS PCB Services. Например, можно ввести следующие данные: http://server name:port number.
    2. Введите данные в полях Имя пользователя и Пароль и нажмите ОК.
На уровень выше Действия после установки


Обновление PCB Services

При обновлении SOLIDWORKS PCB Services до версии 2020 Менеджер установки SOLIDWORKS обновляет базу данных Firebird и автоматически переносит данные. Перед обновлением необходимо создать резервную копию базы данных.

Чтобы обновить SOLIDWORKS PCB Services, выполните указанные ниже действия.

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На экране Добро пожаловать выберите Серверные продукты.
  3. Выберите Обновить SOLIDWORKS PCB Services на этом компьютере и нажмите Далее.

    Отображается следующее сообщение: Для SOLIDWORKS PCB Services требуется обновить базу данных Firebird. Если продолжить, программное обеспечение Firebird и ваша база данных будут обновлены.

  4. Щелкните Далее.
  5. На странице Сводка примите настройки по умолчанию или нажмите Изменить, чтобы указать другие настройки.
  6. Примите условия лицензионного соглашения SOLIDWORKS и нажмите Установить сейчас.
На уровень выше SOLIDWORKS PCB


Удаление PCB Services

Чтобы удалить SOLIDWORKS PCB Services, выполните следующие действия.

  1. Нажмите Пуск > Все программы > SOLIDWORKS версия > SOLIDWORKS PCB Services > Удалить SOLIDWORKS PCB Services.
  2. При отображении запроса на удаление SOLIDWORKS PCB Services и компонентов выберите Да.
  3. При запросе на удаление всех данных SOLIDWORKS PCB Services нажмите Нет.
    Кнопку Нет следует нажать, если не нужно окончательно удалять все данные и файлы редакций.
На уровень выше SOLIDWORKS PCB


SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost

SOLIDWORKS® Visualize предоставляет пакет автономных инструментов, объединяющих расширенные возможности отрисовки с функциями и рабочими процессами визуального проектирования для создания высокореалистичных изображений моделей 3D CAD.

Продукты SOLIDWORKS Visualize доступны в двух версиях:
  • Стандарт
  • Professional

При активации подписки для каждой лицензии SOLIDWORKS 2020 Professional и Premium добавляется бесплатное рабочее место SOLIDWORKS Visualize Standard. Чтобы его активировать, требуется указать дополнительный серийный номер, который можно просмотреть, выполнив вход на портале клиентов SOLIDWORKS и нажав Мои продукты. Больше нельзя использовать серийный номер SOLIDWORKS Professional или Premium для активации бесплатного рабочего места SOLIDWORKS Visualize Standard.

SOLIDWORKS Visualize также поддерживает типы лицензирования SolidNetWork Licensing (SNL), включая плавающие лицензии и автономную активацию.

С помощью Менеджера установки SOLIDWORKS (SLDIM) выполните установку SOLIDWORKS Visualize как часть отдельной установки. Программу можно установить как автономное приложение, что является преимуществом при необходимости использования отдельных компьютеров для моделирования и отрисовки. Программа не использует лицензию SOLIDWORKS.

SOLIDWORKS Visualize Boost — это сервис, который позволяет передавать задания отрисовки с компьютера, на котором запущено приложение SOLIDWORKS Visualize Professional, на один или несколько компьютеров в сети. В результате готовые изображения становятся доступными быстрее, и во время отрисовки на компьютере можно выполнять другие задачи. Отрисовку изображений можно выполнить на одном компьютере или в кластере нескольких компьютеров под управлением Visualize Boost.

При активации подписки для каждого рабочего места SOLIDWORKS Visualize Professional 2020 добавляется бесплатное рабочее место SOLIDWORKS Visualize Boost.
Visualize Boost — это дополнительный продукт только для Visualize Professional. Visualize Boost не работает с Visualize Standard.

Visualize Boost можно установить на компьютере, отличном от того, на котором запущена программа SOLIDWORKS Visualize Professional. Visualize Boost можно также установить как часть индивидуальной установки в SLDIM.

Содержание

  • Предварительные условия и системные требования для SOLIDWORKS Visualize

  • Установка SOLIDWORKS Visualize с помощью SLDIM

  • Установка Visualize Boost с помощью SLDIM


Предварительные условия и системные требования для SOLIDWORKS Visualize

Перед установкой SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost необходимо выполнить следующие предварительные условия:
  • Наличие серийного номера SOLIDWORKS Visualize
  • Наличие серийного номера SOLIDWORKS Visualize Boost
Каждый компьютер, на котором запускаются SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost, должен соответствовать следующим требованиям:
  • Windows® 7 или Windows® 10 (64-разрядная версия)
  • Минимум: Двухъядерный процессор. Рекомендации: Четырехъядерный.
  • Минимум: 8 ГБ ОЗУ. Рекомендации: 16 ГБ.
  • Минимум: 2 ГБ свободного пространства на диске. Рекомендации: 5 ГБ.
  • Минимум: 2 ГБ или более ОЗУ графического процессора. Рекомендации: 4 ГБ.
  • Подключение HDR Light Studio: HDR Light Studio v5.3.3 или более поздней версии, кроме v5.4
  • 4 ГБ видеопамяти или выше для функции Denoiser
Для поддержки графического процессора NVIDIA Iray:
  • Графическая карта NVIDIA ®: NVIDIA Quadro®/NVIDIA GeForce®/Tesla™ как минимум с архитектурой NVIDIA Kepler™; конфигурация с двумя графическими процессорами как минимум с картами NVIDIA Maxwell™ для оптимальной работы
  • Поддержка драйверов NVIDIA CUDA® 10,1 или более поздних версий
    • Рекомендации: Драйвер NVIDIA версии 419.69 (или более поздней)
    • Для карт Turing с поддержкой RTX (Turing™ TU10x), версия драйвера 430.86 (или более поздняя)
Для поддержки графического процессора AMD ProRender:
  • Рекомендации: Платы для рабочих станций Radeon ™ или FirePro™.
Если подходящий графический процессор не найден, SOLIDWORKS Visualize по умолчанию будет обращаться к центральному процессору (ЦП) и не будет использовать установленные графические адаптеры для ускорения GPU. Кроме того, карты NVIDIA на базе архитектуры Fermi™ больше не поддерживают функцию ускорения GPU.

Дополнительные сведения о конкретных графических платах и драйверах см. в разделе Сертификация оборудования SOLIDWORKS.

На уровень выше SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost


Установка SOLIDWORKS Visualize с помощью SLDIM

Установка SOLIDWORKS Visualize:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите параметр Индивидуальный.
  3. Выполните следующие операции:
    1. На странице Серийный номер разверните пункт Visualization.
    2. Выберите SOLIDWORKS Visualize и введите серийный номер.
    3. Нажмите кнопку Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.

Дважды нажмите на ярлык SOLIDWORKS Visualize на рабочем столе для запуска приложения или в меню Windows Пуск выберите Все программы > SOLIDWORKS версия > SOLIDWORKS Visualize версия.

Содержание

  • Действия после установки

На уровень выше SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost


Действия после установки

После установки необходимо выполнить действия по настройке SOLIDWORKS Visualize.

Содержание

  • Создание папки содержания

  • Выбор режима отрисовки

  • Доступ к справке, учебным пособия, сведениям о системе и лицензировании

На уровень выше Установка SOLIDWORKS Visualize с помощью SLDIM


Создание папки содержания

При первом запуске программы SOLIDWORKS Visualize предлагает выбрать расположение для создания папки Content.

Папка Content включает в себя следующие подпапки, предназначенные для хранения ресурсов проекта:
Подпапки | Хранящиеся элементы
Камеры | Стандартные камеры и камеры, сохраненные пользователем
Окружающие среды | Изображения с расширенным динамическим диапазоном (HDR)
Палитры | Экспортированные файлы палитры
Изображения | Отрисовки и снимки
Внешние виды | Материалы Библиотеки внешних видов Содержание обновляется при добавлении в библиотеку новых внешних видов.
Модели | Файлы моделей По умолчанию SOLIDWORKS Visualize выполняет поиск по этой папке в первую очередь, когда используется команда Файл > Импорт для импорта модели.
Плиты | Стандартные двухмерные изображения, используемые в опорных плитах
Настройки проекта | Исходные файлы проекта в формате .SVP
Текстуры | Двухмерные текстуры, используемые во внешних видах
На уровень выше Действия после установки


Выбор режима отрисовки

В зависимости от характеристик системы различные режимы отрисовки могут давать разный результат. Протестируйте каждый режим отрисовки, чтобы выбрать наиболее подходящий.

Выбор режима отрисовки:

  1. Нажмите Инструменты > Параметры > Трехмерный вид.
  2. В разделе Устройства для отрисовки снимите флажок Авто.
  3. Выбор режима отрисовки:
    • CPU — если мощность ЦП значительно превышает мощность видеокарты.
    • GPU — при наличии мощной видеокарты, например nVidia с поддержкой CUDA и объемом памяти более 1 ГБ.
    • Гибридный — при наличии сбалансированной системы с достаточно мощной видеокартой nVidia и совместимым ЦП.

Для получения дополнительной информации см. Начало работы.

На уровень выше Действия после установки


Доступ к справке, учебным пособия, сведениям о системе и лицензировании

Через меню "Справка" можно получить доступ к документации, обновлениям программного обеспечения и средствам устранения неполадок.

Справка Visualize | Открывается онлайн-справка SOLIDWORKS Visualize.
Учебные пособия Visualize | Открывается портал MySolidWorks, где можно перейти на страницу с учебными пособиями по SOLIDWORKS Visualize.
Примечания к выпуску | Отображаются примечания к выпуску для текущей версии.
Новые возможности | Отображаются сведения о новых функциях продуктов SOLIDWORKS.
Горячие клавиши | Выводится список горячих клавиш.
Сведения о системе | Выполняется системная проверка на совместимость программного обеспечения SOLIDWORKS Visualize с аппаратным обеспечением компьютера. При необходимости отображается информация о требуемых обновлениях.
Активировать лицензию | (Лицензии, привязанные к узлу) Открывается мастер активации продуктов SOLIDWORKS, с помощью которого можно активировать продукт.
Деактивировать лицензию | (Лицензии, привязанные к узлу) Открывается мастер активация продуктов SOLIDWORKS, с помощью которого можно деактивировать продукт.
SolidNetWork License Manager | Открывается мастер активации продуктов SOLIDWORKS, с помощью которого можно деактивировать продукт.
О программе Visualize | Отображается номер версии и сведения о лицензировании текущей копии SOLIDWORKS Visualize.
На уровень выше Действия после установки


Установка Visualize Boost с помощью SLDIM

Установка Visualize Boost выполняется с помощью Менеджера установки SOLIDWORKS. Для этого требуется отдельный серийный номер.

Так как задача Visualize Boost — снизить нагрузку при отрисовке, необходимо установить Visualize Boost на компьютерах, отличных от тех, на которых используется SOLIDWORKS Visualize Professional. Установка Visualize Boost на компьютерах с несколькими ядрами ЦП и графическими процессорами (GPU) позволяет оптимизировать качество отрисовки.

Установка SOLIDWORKS Visualize Boost:

  1. Запустите Менеджер установки SOLIDWORKS.
  2. На странице приветствия выберите параметр Индивидуальный.
  3. Выполните следующие операции:
    1. На странице Серийный номер разверните пункт Visualization.
    2. Выберите SOLIDWORKS Visualize Boost и введите серийный номер.
    3. Нажмите кнопку Далее.
  4. Следуйте инструкциям в системных предупреждениях. Нажмите кнопку Далее.
  5. На странице Суммарная информация примите условия лицензионного соглашения SOLIDWORKS и выберите Установить сейчас.

Дважды нажмите на ярлык SOLIDWORKS Visualize Boost на рабочем столе, чтобы открыть интерфейс.

Содержание

  • Активация лицензии Visualize Boost

    Прежде чем использовать продукт для отрисовки, активируйте и настройте с помощью веб-интерфейса SOLIDWORKS Visualize Boost. Поддерживаемые браузеры: Chrome, Firefox и Internet Explorer.

  • Настройка Visualize Boost

На уровень выше SOLIDWORKS Visualize и SOLIDWORKS Visualize Boost


Активация лицензии Visualize Boost

Прежде чем использовать продукт для отрисовки, активируйте и настройте с помощью веб-интерфейса SOLIDWORKS Visualize Boost. Поддерживаемые браузеры: Chrome, Firefox и Internet Explorer.

После активации и настройки Visualize Boost на компьютере программа автоматически запускается при запуске системы и работает в фоновом режиме. Дополнительных действий не требуется.

Процесс активации лицензии SOLIDWORKS Visualize Boost:

  1. Выполните одно из действий ниже.
    1. На рабочем столе дважды нажмите на ярлык Visualize Boost.
    2. Откройте браузер и введите URL-адрес: http://localhost:8993/config.html.
  2. Введите адрес электронной почты и нажмите Разрешить использование лицензии.
На уровень выше Установка Visualize Boost с помощью SLDIM


Настройка Visualize Boost

Для большинства сетей достаточно настроек по умолчанию для конфигурирования компьютера для программы Visualize Boost, но если сетевая среда требует использования других параметров, выполните следующие действия для настройки компьютера вручную.

Чтобы настроить компьютер как часть кластера отрисовки в Visualize Boost, выполните следующие действия.

  1. Выполните одно из действий ниже.
    1. Если используется система SOLIDWORKS Visualize Boost, дважды нажмите на значок ярлыка Visualize Boost на рабочем столе или откройте браузер и введите URL-адрес: http://localhost:8993/config.html.
    2. Если вы работаете на другом компьютере, откройте браузер и введите URL-адрес: http://<IP-адрес>:8993/config.html или http://<Имя DNS>:8993/config.html.
  2. В раскрывающемся списке в верхнем правом углу экрана выберите Язык.
  3. Выберите вкладку Настройка, чтобы настроить параметры узла Visualize Boost.
  4. В поле Имя кластера укажите имя компьютера, например Очень быстрая отрисовка, Кластер презентации или Компьютеры на 4 этаже.

    Имя кластера отображается в SOLIDWORKS Visualize Professional как профиль кластера. Для отрисовки изображения пользователи, работающие в SOLIDWORKS Visualize Professional, выбирают профиль кластера в списке доступных кластеров Boost.

    Рекомендуется указать имя кластера для компьютера Visualize Boost вместо локального компьютера Visualize Professional, чтобы все пользователи Visualize имели доступ к тем же именам кластера в списке профилей Visualize Boost.
  5. Введите порт доступа к клиенту кластера.
    Это порт, который использует компьютер SOLIDWORKS Visualize для подключения к кластеру Boost. Порт доступа к клиенту кластера по умолчанию — 8998.
  6. В области Сетевой режим выберите параметр на основе сетевой среды.
    • Выберите Без сети, чтобы предотвратить возможность подключения данного компьютера к любому другому кластеру. Этот режим удобен при устранении неполадок с Visualize Boost.
    • Выберите Режим многоадресной рассылки UDP , если сеть поддерживает ее. Visualize Boost выполнит поиск в сети и сформирует кластер всех компьютеров с помощью режима многоадресной рассылки UDP в том же порте. Этот режим рекомендуется, если сеть поддерживает его.
    • Выберите Режим TCP с обнаружением (по умолчанию), если невозможно использовать режим многоадресной рассылки UDP. Visualize Boost выполнит поиск в сети и сформирует кластер всех компьютеров с помощью режима TCP с обнаружением в том же порте.
    • Выберите Режим TCP, если необходимо создать точный список всех компьютеров в кластере, так как другие режимы могут не найти все компьютеры для включения в список. Этот режим требует дополнительной настройки, и его не рекомендуется использовать, если доступны режимы многоадресной рассылки UDP или TCP с обнаружением.
  7. Если выбраны Режим многоадресной рассылки UDP или Режим TCP с обнаружением, введите адрес обнаружения кластера.
    Параметр должен включать IP-адрес и номер порта выше 1024. Номер порта по умолчанию различается для разных сетевых режимов:
    • 8994 для многоадресной рассылки UDP
    • 8995 для режима TCP с обнаружением
    • 8996 для TCP

    Эти порты используются для подключения компьютеров Visualize Boost друг к другу. Все компьютеры, настроенные с использованием одного адреса кластера обнаружения и находящиеся в одной локальной сети, сформируют кластер.

  8. При выборе режима TCP:
    • Введите порт доступа к кластеру. Это порт, который узлы Visualize Boost в кластере используют для обмена данными друг с другом. Порт по умолчанию для режима TCP — 8996.
    • Если этот компьютер будет «главным узлом» кластера (компьютер, который координирует работу кластера), используйте поле Список адресов кластера для указания IP-адресов других узлов в кластере. Каждый IP-адрес (например, 192.168.0.100:8996) должен включать порт доступа к кластеру, настроенный для всех узлов в кластере. Оставьте поле пустым, если данный компьютер не будет использоваться как главный узел.
  9. Нажмите Сохранить конфигурацию. Visualize Boost сохраняет новую конфигурацию, затем останавливает и перезапускает службу.
  10. Нажмите вкладку Статус. Если статус имеет значение Готово, на экране отобразятся подключенные компьютеры кластера и Сеансы (задания), назначенные кластеру.
На уровень выше Установка Visualize Boost с помощью SLDIM


SOLIDWORKS Admin Portal и сетевые лицензии

SOLIDWORKS Admin Portal — это облачный ресурс и система управления сервисами, с помощью которой можно назначать сетевые лицензии и управлять ими.

Admin Portal позволяет отслеживать сетевые лицензии SOLIDWORKS, добавлять участников в учетную запись, назначать участникам продукты и сервисы, а также создавать новых администраторов. Можно также удалять лицензии у пользователей, даже если они находятся в удаленном местоположении.

Сетевые лицензии позволяют вам SOLIDWORKS использовать одну лицензию SOLIDWORKS на всех ваших устройствах в любой точке без необходимости вручную активировать и деактивировать лицензии на каждом компьютере. Чтобы выполнить вход и использовать сетевые лицензии, необходим доступ в Интернет. После входа можно выбрать автономный режим и продолжить работу без подключения к сети.

Содержание

  • Доступ к Admin Portal

    Для доступа к порталу Admin Portal необходимо иметь идентификатор SOLIDWORKS и учетную запись MySolidWorks уровня Guest, Standard или Professional.

  • Задачи администратора

    Администраторы обычно отвечают за управление учетными записями пользователей и сетевыми лицензиями.

  • Использование продуктов SOLIDWORKS с сетевыми лицензиями

  • Доступ к панели администратора САПР

    При наличии договора об абонентских услугах SOLIDWORKS можно перейти к панели администратора SOLIDWORKS CAD Admin Dashboard из портала Admin Portal без повторного выполнения входа.


Доступ к Admin Portal

Для доступа к порталу Admin Portal необходимо иметь идентификатор SOLIDWORKS и учетную запись MySolidWorks уровня Guest, Standard или Professional.

Однако коммерческие заказчики с действующим идентификатором SOLIDWORKS ID могут выполнить вход на сайте MySolidWorks.com и перейти к порталу Admin Portal независимо от статуса подписки.

Для доступа на портал Admin Portal:

  1. Выполните вход на сайте MySolidWorks.com.
  2. Под именем профиля разверните список и нажмите Admin Portal.
На уровень выше SOLIDWORKS Admin Portal и сетевые лицензии
Задачи администратора
Использование продуктов SOLIDWORKS с сетевыми лицензиями
Доступ к панели администратора САПР


Задачи администратора

Администраторы обычно отвечают за управление учетными записями пользователей и сетевыми лицензиями.

По умолчанию программное обеспечение SOLIDWORKS настроено на использование активации на компьютере. Базовые действия для активации сетевых лицензий на портале Admin Portal:
  1. При наличии установленного ПО SOLIDWORKS на компьютере необходимо вручную деактивировать лицензию.
  2. Измените тип активации продукта с активации на компьютере на использование сетевых лицензий.
  3. Затем назначьте продукты и услуги участникам (пользователям).

Содержание

  • Создание учетной записи первого администратора

    Первый пользователь, создающий учетную запись на портале Admin Portal, может стать первым администратором при выполнении следующих условий:

  • Управление продуктами и сервисами

  • Управление участниками и лицензиями

  • Настройка продуктов для использования сетевых лицензий

    По умолчанию программное обеспечение SOLIDWORKS настроено на использование активации на компьютере. Если на вашем компьютере установлено ПО SOLIDWORKS, необходимо вручную деактивировать лицензию, а затем изменить тип активации на использование сетевых лицензий.

  • Повышение уровня пользователя до администратора

    Если для учетной записи существуют администраторы, на портале Admin Portal отображается их контактная информация. Пользователь может с ними связаться и запросить повышение уровня до администратора учетной записи.

  • Портал клиентов SOLIDWORKS для регистрации продуктов

    После назначения администратора для компании ни один пользователь не может регистрировать продукты этой компании на портале клиентов SOLIDWORKS.

На уровень выше SOLIDWORKS Admin Portal и сетевые лицензии
Доступ к Admin Portal
Использование продуктов SOLIDWORKS с сетевыми лицензиями
Доступ к панели администратора САПР


Создание учетной записи первого администратора

Первый пользователь, создающий учетную запись на портале Admin Portal, может стать первым администратором при выполнении следующих условий:

  • Учетная запись пользователя является основной учетной записью.
  • Учетная запись имеет активы.
  • Для учетной записи существует зарегистрированный продукт.

Если пользователь не связан с учетной записью или учетная запись не имеет активов, необходимо связаться с центром обслуживания клиентов SOLIDWORKS.

Чтобы назначить себя в качестве первого администратора, выполните следующие действия.

  1. Выполните вход в MySolidWorks.com, под именем профиля разверните список и нажмите Admin Portal.

    На странице приветствия отобразится информация о том, что администраторы отсутствуют.

  2. Необходимо ознакомиться и принять условия управления назначениями лицензий продуктов SOLIDWORKS.
  3. Нажмите Стать администратором.
На уровень выше Задачи администратора
Управление продуктами и сервисами
Управление участниками и лицензиями
Настройка продуктов для использования сетевых лицензий
Повышение уровня пользователя до администратора
Портал клиентов SOLIDWORKS для регистрации продуктов


Управление продуктами и сервисами

В Admin Portal отображаются вкладки Продукты и Сервисы. Используйте вкладку Продукты для назначения и активации продуктов. Используйте вкладку Сервисы для назначения участникам таких сервисов, как электронные учебные курсы и MySolidWorks Pro.

В отличие от продуктов передача сервисом невозможна. После назначения сервиса участнику невозможно отменить назначение сервиса этому участнику.

Использование вкладки Продукты не является обязательным для продуктов с активацией на компьютере, включая продукты с сетевой лицензией.

Можно перечислить имена участников и назначить им продукты, что позволит получить следующие преимущества.
  • Участники могут использовать функцию входа в мастере установки для установки назначенных им серийных номеров.
  • С назначением продуктов подписки участники получат доступ к интерактивным материалам подписки.

Однако перечислять имена участников и назначать им продукты для их активации на компьютере не требуется. Доступ к продуктам с активацией на компьютере предоставляется сервером лицензий или событиями активации вне зависимости от назначения продуктов в Admin Portal. В крупных организациях пользователи, вероятнее всего, не осуществляют управление всеми участниками и их продуктами.

Использование вкладки Продукты требуется для сетевых лицензий. Аналогичным образом перечисленным участникам должны быть назначены Сервисы.

На уровень выше Задачи администратора
Создание учетной записи первого администратора
Управление участниками и лицензиями
Настройка продуктов для использования сетевых лицензий
Повышение уровня пользователя до администратора
Портал клиентов SOLIDWORKS для регистрации продуктов


Управление участниками и лицензиями

Содержание

  • Добавление новых пользователей в учетную запись

    Администраторы могут приглашать новых пользователей присоединиться к учетной записи.

  • Удаление участников из учетных записей

    Перед удалением участника администратору необходимо удалить все продукты, назначенные для учетной записи этого участника.

  • Назначение продуктов участникам

    Администраторы могут назначить участника только для одного продукта каждого типа. Например, участнику может быть назначен только один продукт САПР и только один продукт Simulation.

  • Назначение участников продуктам

  • Назначение сервисов участникам

  • Удаление лицензий у участников

    Можно удалить продукты у участника.

  • Поиск участников и проверка прав пользователя и назначенных продуктов

    Admin Portal позволяет найти пользователя несколькими способами, а также предоставляет возможность отслеживать права пользователя и назначенные ему продукты.

  • Поиск продуктов и проверка пользователей, которым назначены эти продукты

    В Admin Portal найти продукты и отслеживать пользователей, которым назначены эти продукты, можно несколькими способами.

  • Удаление продуктов у внешних участников

    Внешние участники — это пользователи, не являющиеся сотрудниками вашей организации и зарегистрировавшие один из ваших продуктов. Admin Portal позволяет выявлять таких участников и удалить у них ваши продукты.

  • Использование меню параметров для запросов

    Меню в виде шестеренки содержит команды для создания и уточнения запросов.

На уровень выше Задачи администратора
Создание учетной записи первого администратора
Управление продуктами и сервисами
Настройка продуктов для использования сетевых лицензий
Повышение уровня пользователя до администратора
Портал клиентов SOLIDWORKS для регистрации продуктов


Добавление новых пользователей в учетную запись

Администраторы могут приглашать новых пользователей присоединиться к учетной записи.

Чтобы пригласить новых пользователей, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. Нажмите Пригласить участника.
  3. Введите адреса электронной почты участников, которых необходимо пригласить.
    Можно пригласить несколько пользователей при помощи ввода адресов электронной почты в поле, разделяя их точкой с запятой (;).
  4. Выберите пункт Участник или Администратор для определения уровня прав пользователей.
  5. При необходимости измените текст приглашения и нажмите Отправить приглашения.
На уровень выше Управление участниками и лицензиями
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Удаление участников из учетных записей

Перед удалением участника администратору необходимо удалить все продукты, назначенные для учетной записи этого участника.

Чтобы удалить участника из учетной записи, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. Выберите имя, нажав на строку в списке Участники.

    Используйте кнопки управления перемещением в нижней части для перехода в наборе записей. Для поиска участника можно также использовать панель Найти участников.

  3. На странице Сведения об участнике удалите все продукты из списка Назначенные продукты, нажав Удалить продукт.
  4. На странице Сведения об участнике выберите Удалить участника, а затем нажмите ОК для подтверждения.
На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Назначение продуктов участникам

Администраторы могут назначить участника только для одного продукта каждого типа. Например, участнику может быть назначен только один продукт САПР и только один продукт Simulation.

Участникам со статусом "На рассмотрении" невозможно назначить продукты.

Чтобы назначить продукт участнику, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. Выберите имя, нажав на строку в списке Участники.

    Используйте кнопки управления перемещением в нижней части списка для перехода в наборе записей. Для поиска участника можно также использовать панель Найти участников.

    На странице "Сведения об участнике" перечислены Назначенные продукты и Доступные продукты, которые еще не назначены.

  3. Выделите продукт в разделе Доступные продукты.

    Единовременно участнику можно назначить только один продукт. По умолчанию выбран первый элемент списка. Если продукт, который необходимо назначить, не является первым в списке, снимите флажок с первого элемента и выберите необходимый.

    Можно применить следующие фильтры для отображения:
    • продуктов с текущей подпиской или с подпиской с истекшим сроком действия;
    • продуктов, которые назначены или не назначены;
    • продуктов, которые активированы, не активированы или активированы для сетевых лицензий;
    • продуктов, которые относятся к одному или нескольким типам продуктов.
    Можно также выполнить фильтрацию по имени продукта или по серийному номеру.

    При выборе продукта отображается страница со сведениями о продукте. Чтобы вернуться на страницу "Сведения об участнике", нажмите в браузере Назад.

  4. Нажмите Назначить продукт.

    Admin Portal добавляет продукт в список назначенных продуктов участника.

    Назначить участников для продуктов можно также с помощью страницы "Сведения о продукте".
На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Назначение участников продуктам

Чтобы назначить участника продукту, выполните следующие действия.

  1. Нажмите на вкладку Продукты.

    На странице "Сведения о продукте" отображены доступные участники, которым еще не назначены продуктам.

  2. Выделите продукт в разделе Доступные продукты.
  3. Чтобы найти участника, можно применить фильтр по имени, фамилии, адресу электронной почты и типу продукта.
  4. Нажмите Назначить участника.

Назначить продукты участникам можно также в разделе Назначенные продукты на вкладке Участники.

На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Назначение сервисов участникам

Администраторы могут назначать сервисы участникам. Примерами таких сервисов являются MySolidWorks Professional и электронные учебные курсы. В отличие от продуктов передача сервисом невозможна. После назначения участнику сервиса будет невозможно удалить из использования этот сервис.

Чтобы назначить сервисы участникам, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. Выполните поиск участника на панели Найти участников или выберите имя пользователя в списке.
  3. На странице участника в разделе "Сведения об участнике" нажмите Сервисы.

    На вкладке Сервисы перечислены сервисы, назначенные этому участнику, и Доступные сервисы, которые еще не назначены.

  4. Выделите сервис в разделе Доступные продукты.

    Единовременно участнику можно назначить только один сервис. По умолчанию выбран первый элемент списка. Если сервис, который необходимо назначить, не является первым в списке, снимите флажок с первого элемента и выберите необходимый.

    Можно применить следующие фильтры для отображения:
    • сервисов с текущей подпиской или с подпиской с истекшим сроком действия;
    • сервисов, которые назначены или не назначены.
    Можно также выполнить фильтрацию по имени сервиса или по серийному номеру.

    При выборе сервиса отображается страница Сведения о сервисе. Нажмите в браузере Назад, чтобы вернуться на страницу Сведения об участнике.

  5. Нажмите Назначить сервис.

Admin Portal добавляет продукт в список сервисов участника.

На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Удаление лицензий у участников

Можно удалить продукты у участника.

Чтобы удалить продукт у участника, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. Выполните поиск участника на панели Найти участников или выберите имя в списке.

    На странице участника в разделе Назначенные продукты перечислены все продукты, назначенные выбранному участнику, а в разделе Доступные продукты — продукты, которые еще не назначены.

  3. Выберите продукт в разделе Назначенные продукты и нажмите Удалить продукт.
  4. Нажмите ОК для подтверждения.

    Admin Portal перемещает продукт в список доступных продуктов участника.

Если участник использует продукты в автономном режиме, восстановление и переназначение его лицензий станет возможно, когда участник отключит Автономный режим или по истечении 30 дней работы в автономном режиме.
На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Поиск участников и проверка прав пользователя и назначенных продуктов

Admin Portal позволяет найти пользователя несколькими способами, а также предоставляет возможность отслеживать права пользователя и назначенные ему продукты.

Чтобы найти участника и выполнить проверку прав пользователя и назначенных продуктов, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. На панели Найти участников можно применить фильтр по правам пользователя и назначенным продуктам:
    • Нажмите Администратор, Участник или На рассмотрении, чтобы искать только пользователей с указанным статусом.
    • Выберите один или несколько типов продукта, чтобы искать только пользователей, которым назначены выбранные продукты.
  3. Чтобы проверить права и назначенные определенному пользователю продукты, выберите имя в разделе Участники.

    На странице Сведения об участнике можно посмотреть уровень прав для определенного пользователя. На этой же странице указаны назначенные этому пользователю продукты и доступные для назначения продукты.

На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Поиск продуктов и проверка пользователей, которым назначены эти продукты

В Admin Portal найти продукты и отслеживать пользователей, которым назначены эти продукты, можно несколькими способами.

Для поиска продукта выполните следующие действия.

  1. Нажмите на вкладку Продукты.
  2. На панели "Найти участников" введите имя продукта.
  3. Можно применить следующие фильтры для отображения:
    • продуктов с текущей подпиской или с подпиской с истекшим сроком действия;
    • продуктов, которые назначены или не назначены;
    • продуктов, которые активированы или не активированы для сетевых лицензий;
    • продуктов, которые относятся к одному или нескольким типам продуктов.
    Можно также выполнить фильтрацию по серийному номеру.
  4. Нажмите кнопку Поиск.
  5. Для проверки пользователей, назначенных для продукта, выберите название продукта в разделе Продукты.
    На странице "Сведения о продукте" перечислены все участники, которым назначен этот продукт.
На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Удаление продуктов у внешних участников
Использование меню параметров для запросов


Удаление продуктов у внешних участников

Внешние участники — это пользователи, не являющиеся сотрудниками вашей организации и зарегистрировавшие один из ваших продуктов. Admin Portal позволяет выявлять таких участников и удалить у них ваши продукты.

Чтобы удалить продукты у внешних участников, выполните следующие действия.

  1. Нажмите на вкладку Продукты.
  2. На панели Найти продукты укажите имя продукта или критерии поиска.
  3. Нажмите кнопку Поиск.
  4. Выберите имя продукта.
    На странице "Сведения о продукте" перечислены все участники, которым назначен этот продукт.
  5. В списке Назначенные внешние участники выберите внешнего участника и нажмите Удалить участника.
На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Использование меню параметров для запросов


Использование меню параметров для запросов

Меню в виде шестеренки содержит команды для создания и уточнения запросов.

Команда | Горячая клавиша | Описание
Новый запрос | Alt + Q | Позволяет создать запрос путем ввода текста в одном или нескольких полях на странице "Участники", например "Имя", "Фамилия", "Права пользователя", "Адрес электронной почты" и "Назначенные продукты", а также на страницах продуктов, например "Название продукта", "Тип продукта", "Серийный номер", "Активированные", "Назначенные" и "Срок действия истекает".
Отправить запрос | Alt + Enter | Отправляет запрос.
Уточнить запрос | Alt + G | Позволяет изменить и добавить текст в поля запроса.
Отображаемые столбцы | Ctrl + Shift + K | Выбирает столбцы для отображения на страницах участников и продуктов.
Экспорт |  | Выполняет экспорт результатов запроса. Можно экспортировать все или только текущие строки в столбце, а также все или только видимые столбцы. Можно экспортировать результаты в разделенном символами табуляции текстовом файле, текстовом файле с разделителями-запятыми, файле HTML или текстовом файле с разделителем, определенным пользователем.
Дополнительная сортировка |  | Сортирует результаты запроса по трем столбам.
На уровень выше Управление участниками и лицензиями
Добавление новых пользователей в учетную запись
Удаление участников из учетных записей
Назначение продуктов участникам
Назначение участников продуктам
Назначение сервисов участникам
Удаление лицензий у участников
Поиск участников и проверка прав пользователя и назначенных продуктов
Поиск продуктов и проверка пользователей, которым назначены эти продукты
Удаление продуктов у внешних участников


Настройка продуктов для использования сетевых лицензий

По умолчанию программное обеспечение SOLIDWORKS настроено на использование активации на компьютере. Если на вашем компьютере установлено ПО SOLIDWORKS, необходимо вручную деактивировать лицензию, а затем изменить тип активации на использование сетевых лицензий.

На уровень выше Задачи администратора
Создание учетной записи первого администратора
Управление продуктами и сервисами
Управление участниками и лицензиями
Повышение уровня пользователя до администратора
Портал клиентов SOLIDWORKS для регистрации продуктов

Деактивация установленных лицензий в SOLIDWORKS

Перед использованием сетевой лицензии необходимо проверить, установлен ли этот продукт на компьютере. Если продукт уже установлен, необходимо деактивировать лицензию установленного продукта перед настройкой сетевой лицензии с помощью портала Admin Portal.

Чтобы деактивировать лицензию, выполните следующие действия.

  • В программе SOLIDWORKS выберите Справка > Лицензии > Деактивировать и следуйте инструкциям.
На одном и том же компьютере можно одновременно использовать и сетевые лицензии, и лицензии SolidNetWork. Например, на одном и том же компьютере может быть запущена программа SOLIDWORKS Premium 2020 с сетевой лицензией и программа SOLIDWORKS Simulation Premium 2020 с лицензией SolidNetWork.

Изменение типа активации на сетевые лицензии

Перед использованием сетевых лицензий с продуктом необходимо изменить тип активации с активации на компьютере на сетевые лицензии.

Тип активации можно изменить перед или после назначения участнику. Тип активации лицензии изменить невозможно, если она активирована или если продукт назначен нескольким участникам. Если лицензия активирована с помощью активации на компьютере, ее удаленная деактивация невозможна. Пользователю необходимо деактивировать лицензию на компьютере.

Чтобы изменить тип активации на сетевые лицензии, выполните следующие действия.

  1. Если продукт назначен участнику:
    1. Нажмите на вкладку Участники и выберите участника в списке.
    2. В разделе Назначенные продукты нажмите на продукт, который необходимо изменить.
    3. На странице сведений о продукте в разделе Тип активации нажмите Изменить на сетевые лицензии.
    4. Выберите Изменить для подтверждения или нажмите Отмена.
  2. Если продукт не назначен участнику:
    1. Нажмите на вкладку Продукты и выберите продукт в списке.

      Для поиска продукта можно использовать панель Найти продукты.

  3. На странице сведений о продукте в разделе Тип активации нажмите Изменить на сетевые лицензии.
  4. Выберите Изменить для подтверждения или нажмите Отмена.
  5. Назначьте продукт участнику.
При назначении сетевой лицензии участнику этот продукт может использоваться только этим участником. Тем не менее, назначение продукта с активацией на компьютере участнику предназначено только для возможности отслеживания. Любой пользователь, работающий за компьютером с активированным продуктом, может использовать данный продукт. В таком случае необходимо проверять, что человек, использующий этот компьютер, является участником, обладающим лицензией.


Повышение уровня пользователя до администратора

Если для учетной записи существуют администраторы, на портале Admin Portal отображается их контактная информация. Пользователь может с ними связаться и запросить повышение уровня до администратора учетной записи.

Администратор может повышать уровень других пользователей до администраторов учетной записи.

Чтобы повысить уровень пользователя до администратора, выполните следующие действия.

  1. Нажмите на вкладку Участники.
  2. В списке имен выберите пользователя.

    Если пользователя не удается найти, можно осуществить поиск через портал Admin Portal путем ввода критериев поиска на панели Найти участников.

  3. На панели "Сведения об участнике" в разделе Права пользователей нажмите Изменить уровень на "Администратор".
  4. Выберите Изменитьдля подтверждения или нажмите Отмена.
  5. Отображается сообщение электронной почты, приглашающее пользователя стать администратором. Нажмите Отправить.

При отправке приглашения права пользователя имеют статус На рассмотрении. После подтверждения поле "Права пользователя" изменяется на Администратор.

Можно понизить уровень администратора до пользователя, выбрав Изменить уровень на "Участник".
На уровень выше Задачи администратора
Создание учетной записи первого администратора
Управление продуктами и сервисами
Управление участниками и лицензиями
Настройка продуктов для использования сетевых лицензий
Портал клиентов SOLIDWORKS для регистрации продуктов


Портал клиентов SOLIDWORKS для регистрации продуктов

После назначения администратора для компании ни один пользователь не может регистрировать продукты этой компании на портале клиентов SOLIDWORKS.

Пользователь отклонил регистрацию, и указанным администраторам компании отправлено сообщение эл. почты с запросом контактной информации и серийным номером. Администратор может решить, следует ли запрашивающему лицу назначать продукт от своего имени.
При назначении продукта присваивается тот же статус, что и при регистрации продукта.

Если у запрашивающего лица уже есть учетная запись, можно назначить запрашиваемый продукт или его эквивалент от своего имени.

Если инициатор запроса еще не имеет учетной записи, администратор может пригласить запрашивающее лицо и завершить назначение позднее.

На уровень выше Задачи администратора
Создание учетной записи первого администратора
Управление продуктами и сервисами
Управление участниками и лицензиями
Настройка продуктов для использования сетевых лицензий
Повышение уровня пользователя до администратора


Использование продуктов SOLIDWORKS с сетевыми лицензиями

Сетевые лицензии позволяют вам использовать одну лицензию SOLIDWORKS на всех ваших устройствах в любой точке без необходимости вручную активировать и деактивировать лицензии на каждом компьютере.

Например, вы можете использовать продукт на рабочем ПК в офисе, затем отправиться домой и продолжить работу на домашнем компьютере. Не требуется вторая лицензия для использования продукта. Не требуется деактивация лицензии на рабочем ПК и ее активация на домашнем компьютере.

Чтобы выполнить вход и использовать сетевые лицензии, необходим доступ в Интернет. После выполнения входа можно выбрать автономный режим и продолжить работу без подключения к сети.

Можно также выполнить синхронизацию параметров SOLIDWORKS на компьютерах и получить доступ к веб-сайтам SOLIDWORKS, таким как MySolidWorks.com и Портал клиентов SOLIDWORKS, без повторного выполнения входа.

Содержание

  • Вход в программу SOLIDWORKS с сетевой лицензией

    После установки программы SOLIDWORKS с сетевой лицензией можно выполнить вход на любом компьютере. На другом компьютере не требуется повторно устанавливать программу.

  • Использование продукта SOLIDWORKS в автономном режиме

    При использовании продукта SOLIDWORKS с сетевой лицензией можно перейти в автономный режим, если отсутствует подключение к Интернету.

  • Переключение при использовании сетевых лицензий

    Сетевые лицензии позволяют использовать одну лицензию на всех компьютерах пользователя. Тем не менее, одновременное использование лицензии возможно только на одном компьютере.

  • Синхронизация настроек и параметров на нескольких компьютерах

    При использовании программного обеспечения SOLIDWORKS на нескольких компьютерах можно обновить настройки на любом из компьютеров и синхронизировать эти настройки на всех компьютерах, на которых запущена программа SOLIDWORKS 2018 и более поздней версии.

  • Уведомление в программе SOLIDWORKS об использовании сетевых лицензий

На уровень выше SOLIDWORKS Admin Portal и сетевые лицензии
Доступ к Admin Portal
Задачи администратора
Доступ к панели администратора САПР


Вход в программу SOLIDWORKS с сетевой лицензией

После установки программы SOLIDWORKS с сетевой лицензией можно выполнить вход на любом компьютере. На другом компьютере не требуется повторно устанавливать программу.

Чтобы выполнить вход в SOLIDWORKS с сетевой лицензией:

  1. Нажмите SOLIDWORKS [image] на рабочем столе.
  2. Введите идентификатор SOLIDWORKS и пароль и нажмите Вход.
    Идентификатор SOLIDWORKS может совпадать с вашим адресом электронной почты.

Если идентификатор SOLIDWORKS и пароль введены правильно, программа SOLIDWORKS запускается, и администратором SOLIDWORKS вам назначается лицензия для этой программы.

Можно закрыть и повторно запустить SOLIDWORKS на этом же компьютере. При этом пока не будет выполнен выход, повторный ввод учетных данных не потребуется.

На уровень выше Использование продуктов SOLIDWORKS с сетевыми лицензиями
Использование продукта SOLIDWORKS в автономном режиме
Переключение при использовании сетевых лицензий
Синхронизация настроек и параметров на нескольких компьютерах
Уведомление в программе SOLIDWORKS об использовании сетевых лицензий


Использование продукта SOLIDWORKS в автономном режиме

При использовании продукта SOLIDWORKS с сетевой лицензией можно перейти в автономный режим, если отсутствует подключение к Интернету.

Для работы в автономном режиме выполните следующие действия.

  • На панели заголовка SOLIDWORKS нажмите правой кнопкой мыши Вход [image] и выберите Изъять лицензию для автономного использования.

Продукт SOLIDWORKS можно использовать в течение 30 дней без подключения к веб-сайту SOLIDWORKS. По истечении 30 дней необходимо повторно нажать Изъять лицензию для автономного использования, чтобы продолжить работу в автономном режиме.

При использовании сетевой лицензии в автономном режиме на одном компьютере невозможно использовать эту же лицензию на другом устройстве.
На уровень выше Использование продуктов SOLIDWORKS с сетевыми лицензиями
Вход в программу SOLIDWORKS с сетевой лицензией
Переключение при использовании сетевых лицензий
Синхронизация настроек и параметров на нескольких компьютерах
Уведомление в программе SOLIDWORKS об использовании сетевых лицензий


Переключение при использовании сетевых лицензий

Сетевые лицензии позволяют использовать одну лицензию на всех компьютерах пользователя. Тем не менее, одновременное использование лицензии возможно только на одном компьютере.

Пользователь может запустить программу SOLIDWORKS на основном компьютере без выполнения выхода. При попытке выполнить вход на другом компьютере (например, домашнем) программа предлагает использовать лицензию основного компьютера.

Чтобы запустить программу SOLIDWORKS на другом компьютере, выполните следующие действия.

  1. При входе на другом компьютере программа SOLIDWORKS информирует пользователя о том, что продукт с сетевой лицензией уже используется на другом компьютере. Нажмите Да, чтобы продолжить.

    Продукт SOLIDWORKS запускается на дополнительном компьютере.

  2. При возвращении к работе на основном компьютере перед закрытием программы SOLIDWORKS отображается запрос на сохранение работы. Нажмите ОК для сохранения изменений модели.
На уровень выше Использование продуктов SOLIDWORKS с сетевыми лицензиями
Вход в программу SOLIDWORKS с сетевой лицензией
Использование продукта SOLIDWORKS в автономном режиме
Синхронизация настроек и параметров на нескольких компьютерах
Уведомление в программе SOLIDWORKS об использовании сетевых лицензий


Синхронизация настроек и параметров на нескольких компьютерах

При использовании программного обеспечения SOLIDWORKS на нескольких компьютерах можно обновить настройки на любом из компьютеров и синхронизировать эти настройки на всех компьютерах, на которых запущена программа SOLIDWORKS 2018 и более поздней версии.

Синхронизация настроек — это служба, которая может быть заблокирована в некоторых конфигурациях сети. Для доступа к сервису облачного хранилища убедитесь, что настройки брандмауэра и прокси-серверов разрешают установление связи с *.solidworks.com.

Чтобы синхронизировать настройки и параметры на нескольких компьютерах, выполните следующие действия.

  1. Войдите в программу SOLIDWORKS.
  2. В разделе Инструменты > Параметры нажмите Синхронизировать настройки.
  3. Выберите ручной или автоматический способ:
    • Синхронизировать сейчас.

      Загрузить настройки. Отправляет ваши настройки с текущего компьютера в облачную службу хранения данных. Настройки в облаке можно обновить в любое время, загрузив их еще раз.

      Скачать настройки. Скачивает настройки из облачной службы хранения данных и применяет их к текущему компьютеру.

    • Автоматическая синхронизация.

      Автоматически синхронизирует текущие компьютеры с облачной службой хранения данных. Выбранные настройки автоматически загружаются в облачные службы хранения данных по мере их обновления, а также скачиваются и применяются при запуске или входе в систему.

    Параметры синхронизации могут различаться на разных компьютерах. Например, можно указать один компьютер для автоматической синхронизации параметров системы и расположений файлов, но не пользовательских настроек. Для скачивания и загрузки всех типов настроек вручную можно указать другой компьютер.

    В процессе синхронизации нельзя перезаписать примененные или заблокированные настройки администратора.
  4. Нажмите ОК.
На уровень выше Использование продуктов SOLIDWORKS с сетевыми лицензиями
Вход в программу SOLIDWORKS с сетевой лицензией
Использование продукта SOLIDWORKS в автономном режиме
Переключение при использовании сетевых лицензий
Уведомление в программе SOLIDWORKS об использовании сетевых лицензий


Уведомление в программе SOLIDWORKS об использовании сетевых лицензий

В программе SOLIDWORKS существует два способа уведомления о переключении на использование сетевых лицензий:
  • При выполнении входа в программу SOLIDWORKS отображается сообщение, информирующее пользователя о том, что выполнен сброс введенного серийного номера для сетевой лицензии. Необходимо перезапустить продукт и выполнить вход.
  • Администратор может выбрать продукт для использования сетевых лицензий вместо серийного номера в редакторе параметров администрирующего образа. Каждый установленный таким образом продукт предлагает выполнить вход при запуске программы.
На уровень выше Использование продуктов SOLIDWORKS с сетевыми лицензиями
Вход в программу SOLIDWORKS с сетевой лицензией
Использование продукта SOLIDWORKS в автономном режиме
Переключение при использовании сетевых лицензий
Синхронизация настроек и параметров на нескольких компьютерах


Доступ к панели администратора САПР

При наличии договора об абонентских услугах SOLIDWORKS можно перейти к панели администратора SOLIDWORKS CAD Admin Dashboard из портала Admin Portal без повторного выполнения входа.

На панели SOLIDWORKS CAD Admin Dashboard можно выполнять такие задачи, как мониторинг производительности и статистики сеансов, а также просмотр сведений об устройствах сети, на которых запущено ПО SOLIDWORKS.

Для получения подробной информации см. раздел "Справка" на панели CAD Admin Dashboard.

На уровень выше SOLIDWORKS Admin Portal и сетевые лицензии
Доступ к Admin Portal
Задачи администратора
Использование продуктов SOLIDWORKS с сетевыми лицензиями


Администрирование лицензий

После установки можно активировать лицензии SOLIDWORKS одним из следующих способов: активировать отдельные компьютеры (активация на компьютере), установить и активировать плавающие сетевые лицензии на сервере (лицензирование SolidNetWork) или выполнить вход в приложения SOLIDWORKS (сетевые лицензии).

Как правило, для установки на отдельные компьютеры выполняется активация лицензий; однако программное обеспечение можно установить отдельно и затем управлять лицензиями с помощью SolidNetWork License Manager. С другой стороны, не смотря на то, что крупные пользователи обычно используют плавающие сетевые лицензии, можно внедрить установку с помощью администрирующего образа и затем активировать серийные номера с индивидуальных компьютеров.

Содержание

  • Администрирование индивидуальных лицензий

    Для активации на компьютере или онлайн-лицензирования можно настроить отдельную лицензию. В данном разделе представлена активация на компьютере. Для получения подробных сведений об онлайн-лицензировании см. портал администрирования.

  • Администрирование лицензий с помощью SolidNetWork License Manager

    SolidNetWork License Manager поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.


Администрирование индивидуальных лицензий

Для активации на компьютере или онлайн-лицензирования можно настроить отдельную лицензию. В данном разделе представлена активация на компьютере. Для получения подробных сведений об онлайн-лицензировании см. портал администрирования.

Как правило, администрирование индивидуальных лицензий заключается в активации и деактивации лицензий непосредственно в программе SOLIDWORKS.

Активация — это процесс лицензирования и регистрации продукта для использования автономных лицензий SOLIDWORKS (не SolidNetWork License). Как правило, если лицензия на продукт не активирована, SOLIDWORKS пытается активировать ее при запуске продукта.

Чтобы деактивировать индивидуальные лицензии, выберите Справка > Лицензии > Деактивировать в программе SOLIDWORKS.

На уровень выше Администрирование лицензий
Администрирование лицензий с помощью SolidNetWork License Manager

Активация лицензии

Прежде чем запустить продукт SOLIDWORKS на отдельном компьютере, необходимо активировать лицензию для данного компьютера.

Для активации необходим доступ в Интернет или к электронной почте. Для использования продуктов после активации подключение к Интернету не требуется. Если у вас нет доступа к электронной почте с компьютера, на котором используется этот продукт, можно сохранить файл активации и послать его с другого компьютера.

Данный процесс:
  • Активирует лицензии на все продукты SOLIDWORKS.
  • Позволяет переносить лицензионные права с одного компьютера на другой.
  • может выполняться немедленно (рекомендуется) или в течение 30 дней после установки;
  • Отменяет необходимость использования аппаратных ключей защиты. Однако если вы пользуетесь предыдущими версиями продуктов SOLIDWORKS, которые не используют процесс активации, вы должны использовать ключ аппаратной защиты.

Системные администраторы, имеющие дело с несколькими серийными номерами, могут использовать Редактор параметров администрирующего образа. Подробнее см. раздел Редактор параметров администрирующего образа.

Чтобы активировать лицензию:

  1. Запустите программу SOLIDWORKS.
  2. Запустите функцию Активация продукта SOLIDWORKS одним из перечисленных ниже способов.
    • Если лицензия для данного компьютера еще не активирована, при запуске программы SOLIDWORKS автоматически отображается окно Активация продукта SOLIDWORKS.
    • Если окно Активация продукта SOLIDWORKS не отображается автоматически, начните активацию, выбрав пункт меню Справка > Лицензии > Активировать.
  3. Щелкните список Продукт, чтобы указать продукт, лицензию для которого требуется активировать.
  4. Укажите метод активации через Интернет или вручную с использованием электронной почты.
  5. Укажите адрес своей электронной почты.
  6. Нажмите кнопку Далее.
    • Активация через Интернет: Активация выполняется автоматически.
    • Эл. почта: Нажмите Сохранить, чтобы создать файл запроса, затем отправьте его на адрес электронной почты activation@solidworks.com. Получив сообщение электронной почты с файлом ответа, извлеките файл из сообщения и нажмите Открыть, чтобы загрузить его.
      При необходимости можно завершить и повторно запустить процедуру активации, чтобы открыть файл ответа.
  7. Нажмите кнопку Готово.
Редактор параметров администрирующего образа

Перенос лицензии

Чтобы перенести лицензию на новый или обновленный компьютер, сначала деактивируйте ее на сервере лицензионных ключей Dassault Systèmes SolidWorks Corporation, а затем активируйте на другом компьютере.

Если не удалось деактивировать лицензию на сервере Dassault Systèmes SolidWorks Corporation (например, из-за сбоя жесткого диска), в большинстве случаев можно выполнить повторную активацию. Если это не так, обратитесь к вашему реселлеру за помощью.

Чтобы вернуть лицензию на сервер:

  1. В программе SOLIDWORKS выберите Справка > Лицензии > Деактивировать и следуйте инструкциям.
  2. Чтобы повторно активировать лицензию, перейдите на новый или обновленный компьютер и активируйте лицензию, выполнив ту же последовательность действий, что и для исходной активации. Подробнее см. раздел Активация лицензии.


Администрирование лицензий с помощью SolidNetWork License Manager

SolidNetWork License Manager поддерживает несколько лицензионных клиентов, распределяя лицензии для клиентов в сети. При этом благодаря использованию плавающих лицензий, число пользователей может превышать число лицензий.

На данном рисунке проиллюстрирован обычный процесс установки лицензии SolidNetWork License.

На данном рисунке отображается:
  • Установка и активация SolidNetwork License Manager выполняются только на компьютере, предназначенном для установки этого приложения.
  • На клиентских компьютерах специальное дополнительное программное обеспечение SolidNetWork не устанавливается.

    Если при установке указан серийный номер лицензии SolidNetWork License, Менеджер установки SOLIDWORKS идентифицирует этот компьютер как лицензионный клиент SolidNetWork. Менеджер установки SOLIDWORKS выводит запрос на имя компьютера с SolidNetWork License Manager и номер порта для подключения клиентского компьютера к данному компьютеру.

  • Менеджер лицензии и все лицензионные клиенты должны иметь возможность взаимодействия с протоколами TCP/IP (Transmission Control Protocol/Internet Protocol).

Содержание

  • Активация лицензии SolidNetWork License

    Прежде чем запустить SOLIDWORKS на отдельном компьютере, следует активировать лицензию SolidNetWork License на компьютере с SolidNetWork License Manager.

  • Перенос лицензии SolidNetWork License

    Чтобы перенести лицензию SolidNetWork License на новый или обновленный компьютер, сначала деактивируйте ее на сервере лицензионных ключей Dassault Systèmes SolidWorks Corporation, затем активируйте ее на другом компьютере.

  • Установка и настройка лицензий SolidNetWork

    Процедура настройки лицензии SolidNetWork License состоит из установки SolidNetWork License Manager на компьютер, предназначенный для установки этого приложения, и последующей установки программы SOLIDWORKS на клиентские компьютеры посредством ввода серийного номера лицензии SolidNetWork License.

  • Администрирование лицензии SolidNetWork

    В задачи администрирования входят запуск, обновление, удаление и управление лицензией, а также заимствование и возврат лицензий.

На уровень выше Администрирование лицензий
Администрирование индивидуальных лицензий


Активация лицензии SolidNetWork License

Прежде чем запустить SOLIDWORKS на отдельном компьютере, следует активировать лицензию SolidNetWork License на компьютере с SolidNetWork License Manager.

Для активации необходим доступ в Интернет или к электронной почте. После активации не требуется подключения к интернету для использования продуктов SolidWorks. Если у вас нет доступа к электронной почте с компьютера, на котором используется этот продукт, можно сохранить файл активации и послать его с другого компьютера.

Данный процесс:
  • Активирует SOLIDWORKS SolidNetWork License Manager с лицензиями SolidNetWork License для всех продуктов SOLIDWORKS.
  • позволяет переносить лицензионные права SolidNetWork с одного компьютера, на котором установлен SolidNetWork License Manager, на другой.
  • позволяет устанавливать и активировать лицензионные права SolidNetWork на одном компьютере с SolidNetWork License Manager;
  • должен быть выполнен до использования лицензий SolidNetWork License;
  • Отменяет необходимость использования аппаратных ключей защиты. При активации лицензии SolidNetWork License для данной версии программы SOLIDWORKS выполняется активация лицензий SolidNetWork License для предыдущих версий SOLIDWORKS. (Хранить аппаратный ключ больше не требуется.)

Чтобы активировать лицензию SolidNetWork License, выполните следующие действия.

  1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Если лицензия SolidNetWork License еще не активирована, появится запрос на активацию данной лицензии. Нажмите Да, чтобы активировать лицензию.
  3. В разделе Как вы хотите активировать? выберите Автоматически через Интернет (рекомендуется).
  4. В разделе Контактная информация укажите адрес электронной почты.
В диалоговом окне Активация/реактивация выполнена отобразятся активированные продукты.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Установка и настройка лицензий SolidNetWork
Администрирование лицензии SolidNetWork


Перенос лицензии SolidNetWork License

Чтобы перенести лицензию SolidNetWork License на новый или обновленный компьютер, сначала деактивируйте ее на сервере лицензионных ключей Dassault Systèmes SolidWorks Corporation, затем активируйте ее на другом компьютере.

Если не удалось деактивировать лицензию на сервере Dassault Systèmes SOLIDWORKS Corporation (например, из-за сбоя жесткого диска), во многих случаях можно выполнить повторную активацию. Если это не так, обратитесь к своему реселлеру за помощью.

Чтобы вернуть лицензию SolidNetWork License на сервер, выполните следующие действия.

  1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. В разделе Лицензионная информация выберите Изменить. Откроется мастер активации продуктов SOLIDWORKS.
  3. В разделе Что необходимо сделать? выберите Деактивировать лицензию на программное обеспечение и нажмите кнопку Далее.
  4. В разделе Как выполнить деактивацию? выберите Автоматически через Интернет (рекомендуется).
  5. В разделе Контактная информация укажите адрес электронной почты.
  6. Щелкните Далее. Будет выполнена деактивация лицензии.
На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Активация лицензии SolidNetWork License
Установка и настройка лицензий SolidNetWork
Администрирование лицензии SolidNetWork


Установка и настройка лицензий SolidNetWork

Процедура настройки лицензии SolidNetWork License состоит из установки SolidNetWork License Manager на компьютер, предназначенный для установки этого приложения, и последующей установки программы SOLIDWORKS на клиентские компьютеры посредством ввода серийного номера лицензии SolidNetWork License.

Содержание

  • Установка и активация Менеджера лицензий

    SolidNetWork License Manager поддерживает несколько лицензионных клиентов. Он распределяет лицензии для клиентов в сети.

  • Установка лицензионного клиента

    При установке программы SOLIDWORKS на клиентских компьютерах серийный номер лицензии SolidNetWork License указывает на то, что компьютер является клиентом SolidNetWork License.

  • Установка SolidNetWork License Manager перед установкой лицензионных клиентов

    Перед установкой лицензионных клиентов следует установить и настроить SolidNetWork License Manager хотя бы на одном компьютере.

  • Управление доступом к версиям SOLIDWORKS

    Можно ограничить доступ пользователей к отдельным версиям SOLIDWORKS в окружении SolidNetWork. Эта функция позволяет управлять версиями SOLIDWORKS, которыми пользуются отдельные сотрудники, проектные группы и подразделения организации.

  • Установка Менеджера лицензий для системы из трех компьютеров

    Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Если компьютер, управляющий лицензионным файлом, недоступен, один из двух других компьютеров его замещает.

  • Использование лицензий SolidNetWork License с брандмауэрами

    Если на компьютере используется брандмауэр, следует настроить порты для поддержки лицензий SolidNetWork License.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Активация лицензии SolidNetWork License
Перенос лицензии SolidNetWork License
Администрирование лицензии SolidNetWork


Установка и активация Менеджера лицензий

SolidNetWork License Manager поддерживает несколько лицензионных клиентов. Он распределяет лицензии для клиентов в сети.

При обновлении предыдущей версии SolidNetWork License Manager, использовавшей аппаратные ключи для активации лицензии, удалите аппаратный ключ перед установкой новой версии SolidNetWork License Manager.

  1. Запустите Менеджер установки SOLIDWORKS (в соответствии с описанием в разделе Начало установки SOLIDWORKS).
    1. В качестве типа установки выберите
      • Сервер
      • Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
    2. На странице Параметры SolidNetWork License Manager укажите серийный номер лицензии SolidNetWork License и каталог установки SolidNetWork License Manager.
    3. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SOLIDWORKS.
  2. Чтобы активировать лицензию SolidNetWork License:
    1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
    2. При запросе на активацию нажмите Да.
    3. На странице Сведения о сервере SolidNetWork License:
      • Если в вашей организации используется брандмауэр, выберите На этом сервере запущен брандмауэр.

        Подробнее см. раздел Использование лицензий SolidNetWork License с брандмауэрами.

      • Для параметра Номер порта (а также для параметра Номера порта демона поставщика, если используется брандмауэр) выберите значение по умолчанию или укажите номера портов, используемые в вашей компании.
        Номер порта должен представлять собой номер порта TCP/IP в диапазоне 1024-60000 и должен использоваться исключительно только в этом процессе. Обычно подходит значение по умолчанию (25734), и оно наверняка не будет совпадать ни с каким значением из используемых в процессах сервера FlexNet, запущенных на компьютере менеджера лицензии.
    4. На экране Активация продуктов SOLIDWORKS :
      • Выберите метод с использованием Интернета или электронной почты.
      • Укажите адрес своей электронной почты.
      • Для продолжения нажмите кнопку Далее.
        • Активация через Интернет: Активация выполняется автоматически.
        • Эл. почта: Нажмите кнопку Сохранить, чтобы создать файл запроса, а затем отправьте его на адрес электронной почты activation@solidworks.com. Получив сообщение электронной почты с файлом ответа, извлеките файл из сообщения и нажмите Открыть, чтобы загрузить его.
          Можно завершить и повторно запустить процедуру активации, чтобы открыть файл ответа.
  3. Нажмите Готово.
На уровень выше Установка и настройка лицензий SolidNetWork
Установка лицензионного клиента
Установка SolidNetWork License Manager перед установкой лицензионных клиентов
Управление доступом к версиям SOLIDWORKS
Установка Менеджера лицензий для системы из трех компьютеров
Использование лицензий SolidNetWork License с брандмауэрами
Начало установки SOLIDWORKS


Установка лицензионного клиента

При установке программы SOLIDWORKS на клиентских компьютерах серийный номер лицензии SolidNetWork License указывает на то, что компьютер является клиентом SolidNetWork License.

  1. Запустите Менеджер установки SOLIDWORKS (в соответствии с описанием в разделе Начало установки SOLIDWORKS).
  2. На странице приветствия выберите Индивидуальная установка (на этом компьютере), если это первая установка данной основной версии SOLIDWORKS на этом компьютере.
    Если выполняется обновление существующей версии и замена индивидуальной лицензии на лицензию SolidNetWork License, выберите Изменить существующую индивидуальную установку (на этом компьютере). Для получения дополнительной информации см. Переход с индивидуальных лицензий на лицензии SolidNetWork License.
  3. При запросе на ввод серийного номера укажите серийный номер лицензии SolidNetWork License.
  4. В диалоговом окне Добавление сервера введите адрес SolidNetWork License Manager в следующем формате:

    порт@имя_компьютера>

    Номер порта должен совпадать с номером порта компьютера, на котором установлен менеджер лицензий. По умолчанию используется 25734 (как описано в разделе Установка и активация Менеджера лицензий).

    Менеджер установки SOLIDWORKS попытается проверить, доступен ли компьютер с установленным SolidNetWork License Manager. Если Менеджер лицензий не еще установлен, проверка невозможна; однако установку лицензионного клиента по-прежнему можно продолжить.
  5. Завершите установку SOLIDWORKS, следуя инструкциям Менеджера установки SOLIDWORKS.
На уровень выше Установка и настройка лицензий SolidNetWork
Установка и активация Менеджера лицензий
Установка SolidNetWork License Manager перед установкой лицензионных клиентов
Управление доступом к версиям SOLIDWORKS
Установка Менеджера лицензий для системы из трех компьютеров
Использование лицензий SolidNetWork License с брандмауэрами
Начало установки SOLIDWORKS
Обновление индивидуальной лицензии до лицензии SolidNetWork


Установка SolidNetWork License Manager перед установкой лицензионных клиентов

Перед установкой лицензионных клиентов следует установить и настроить SolidNetWork License Manager хотя бы на одном компьютере.

При установке серийного номера лицензии SolidNetWork License Менеджер установки SOLIDWORKS выводит запрос на ввод имени компьютера, на котором установлен SolidNetWork License Manager, и номера порта, а затем пытается проверить эту информацию.

Если на указанном компьютере SolidNetWork License Manager не еще установлен, проверка информации невозможна. В данном случае ошибка проверки не указывает, предоставлена ли верная информация о Менеджере лицензий. Если же Менеджер лицензий установлен, ошибки проверки свидетельствуют о том, что предоставлена неверная информация о Менеджере лицензий.

На уровень выше Установка и настройка лицензий SolidNetWork
Установка и активация Менеджера лицензий
Установка лицензионного клиента
Управление доступом к версиям SOLIDWORKS
Установка Менеджера лицензий для системы из трех компьютеров
Использование лицензий SolidNetWork License с брандмауэрами


Управление доступом к версиям SOLIDWORKS

Можно ограничить доступ пользователей к отдельным версиям SOLIDWORKS в окружении SolidNetWork. Эта функция позволяет управлять версиями SOLIDWORKS, которыми пользуются отдельные сотрудники, проектные группы и подразделения организации.

Для управления доступом к версиям SOLIDWORKS с помощью файла параметров FlexNet:

  1. В каталоге установки Менеджера лицензий SolidNetWork создайте текстовый файл:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Для управления доступом к определенной версии SOLIDWORKS в файле лицензии добавьте следующий синтаксис SOLIDWORKS:
    :SWVERSION=xx где xx — версия продукта SOLIDWORKS, управление которым требуется осуществлять
  3. Для управления несколькими версиями SOLIDWORKS добавьте строку для каждой нужной версии.

    Поддерживаются не все параметры FlexNet. Поддерживаются следующие параметры фильтров версий:

    ВКЛЮЧИТЬ | Запускать указанную версию могут только пользователь или группа. Все другие пользователи не могут запускать эту версию.
    INCLUDE_BORROW | Заимствовать указанную версию могут только пользователь или группа. Все другие пользователи не могут заимствовать эту версию.
    EXCLUDE | Указанный пользователь или группа не могут запускать указанную версию SOLIDWORKS. Значение EXCLUDE перекрывает значение INCLUDE.
    EXCLUDE_BORROW | Указанный пользователь или группа не могут заимствовать указанную версию SOLIDWORKS. Значение EXCLUDE перекрывает значение INCLUDE.
    Примеры.
    1 | SWVERSION=27.0 относится к SOLIDWORKS 2020
    SWVERSION=26.0 относится к SOLIDWORKS 2019
    2 | INCLUDE solidworks:SWVERSION=27.0 USER jane
    INCLUDE_BORROW solidworks:SWVERSION=27.0 USER jane
    В результате размещения этих строк в файле параметров только пользователь jane может запускать SOLIDWORKS 2020. Другие пользователи не смогут запускать или заимствовать SOLIDWORKS 2020, но могут запускать или заимствовать другие версии SOLIDWORKS. Пользователь jane также может запускать и заимствовать другие версии SOLIWORKS.
    3 | GROUP chicago USER john robert eva
    EXCLUDE solidworks:SWVERSION=27.0 GROUP chicago
    EXCLUDE solidworks:SWVERSION=26.0 GROUP chicago
    EXCLUDE solidworks USER don
    Эти строки определяют ГРУППУ пользователей с именем chicago и запрещают этой группе доступ к версиям SOLIDWORKS 2020 и SOLIDWORKS 2019. Однако пользователи этой группы могут запускать другие версии SOLIDWORKS. Пользователь don не может запускать ни одну из версий SOLIDWORKS.
    4 | EXCLUDE swinspection_std:SWVERSION=27.0 HOST machine1
    Эта строка запрещает любому пользователю на компьютере machine1 запускать SOLIDWORKS Inspection 2020.

    Для получения дополнительной сведений о FlexNet см. Руководстве по администрированию лицензий FlexNet Publisher в каталоге установки SolidNetWork License Manager (\Docs\flexuser\licensingenduserguide.pdf).

На уровень выше Установка и настройка лицензий SolidNetWork
Установка и активация Менеджера лицензий
Установка лицензионного клиента
Установка SolidNetWork License Manager перед установкой лицензионных клиентов
Установка Менеджера лицензий для системы из трех компьютеров
Использование лицензий SolidNetWork License с брандмауэрами


Установка Менеджера лицензий для системы из трех компьютеров

Менеджеры лицензий для системы из трех компьютеров используют три компьютера для обеспечения дополнительной стабильности. Если компьютер, управляющий лицензионным файлом, недоступен, один из двух других компьютеров его замещает.

Требования к использованию Менеджеров лицензий для системы из трех компьютеров:
  • Менеджеры лицензий для системы из трех компьютеров следует устанавливать только на стабильно работающих компьютерах, которые не планируется часто отключать.
  • Три компьютера, на которых установлен Менеджер лицензий, должны быть установлены в одной подсети. Нельзя настраивать Менеджеры лицензий для системы из трех компьютеров с низкоскоростными или коммутируемыми линиями связи.
  • Системный администратор должен определять, когда работа компьютера, на котором установлен Менеджер лицензий, замедляется, и перезагружать его как можно скорее.
    Ситуация, когда работают два компьютера, на которых установлен Менеджер лицензий, сложнее, чем, когда работает только один компьютер, поскольку в данном случае присутствуют два уязвимых звена.

Содержание

  • Установка исходного Менеджера лицензий для системы из трех компьютеров

    Данная процедура описывает процесс установки SolidNetWork License Manager на первый компьютер системы из трех компьютеров.

  • Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров

    Для установки SolidNetWork License Manager на втором и третьем компьютерах в системе выполните следующие действия. Эта процедура практически идентична установке программного обеспечения на исходном компьютере, за исключением шагов 2(f) и 2(i).

На уровень выше Установка и настройка лицензий SolidNetWork
Установка и активация Менеджера лицензий
Установка лицензионного клиента
Установка SolidNetWork License Manager перед установкой лицензионных клиентов
Управление доступом к версиям SOLIDWORKS
Использование лицензий SolidNetWork License с брандмауэрами


Установка исходного Менеджера лицензий для системы из трех компьютеров

Данная процедура описывает процесс установки SolidNetWork License Manager на первый компьютер системы из трех компьютеров.

  1. С помощью Менеджера установки SOLIDWORKS установите SolidNetWork License Manager на первый компьютер системы, предназначенный для установки этого приложения.
    1. Запустите Менеджер установки SOLIDWORKS (в соответствии с описанием в разделе Начало установки SOLIDWORKS).
    2. В качестве типа установки выберите
      • Сервер
      • Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
    3. На странице Параметры SolidNetWork License Manager укажите серийный номер лицензии SolidNetWork License и каталог установки SolidNetWork License Manager.
    4. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SOLIDWORKS.
  2. С помощью SolidNetWork License Manager выполните настройку исходного компьютера с установленным менеджером лицензий для системы из трех компьютеров следующим образом.
    1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
    2. Нажмите Нет.
      Появится вкладка SolidNetWork License Manager "Администрирование сервера".
    3. В разделе Дополнительные параметры выберите пункт Параметры.
      Появится диалоговое окно Дополнительные параметры.
    4. В разделе "Режим сервера SolidNetWork License" выберите Использовать файл лицензии и нажмите кнопку ОК.
      Диалоговое окно Дополнительные параметры закроется.
    5. В разделе Лицензионная информация выберите Изменить.
      Появится мастер файла лицензий SolidNetWork License.
    6. В разделе Тип сервера выберите Сервер-тройка и нажмите кнопку Далее.
    7. На панели информации о сервере проверьте, что указаны правильные имя компьютера и номер порта для исходного компьютера с установленным Менеджером лицензий для системы из трех компьютеров и нажмите Далее.

      Убедитесь, что адрес сетевой интерфейсной карты (NIC) совпадает со сведениями в файле лицензии, полученном от SOLIDWORKS, и что номер порта для исходного компьютера с установленным менеджером лицензий указан верно. Адрес NIC также называется MAC-адресом (адрес управления доступом к среде передачи). Затем нажмите Далее.

      Чтобы найти адрес NIC, откройте окно командной строки и введите следующее:

      ipconfig /all

      Кроме того, если на компьютере используется брандмауэр, может потребоваться задать дополнительные требования. Для получения дополнительной информации см. Использование лицензий SolidNetWork License с брандмауэрами.

    8. На странице Информация о партнерском сервере-тройке введите имя компьютера и идентификатор хоста для двух других компьютеров системы.
      Это даст возможность клиентским компьютерам получить лицензию с двух других компьютеров, если Менеджер лицензий на одном компьютере системы недоступен.
    9. На странице Лицензии выберите Прочитать, чтобы перейти к файлу лицензии SolidNetWork License и открыть его.
      Лицензии отобразятся в окне мастера Файл лицензии SolidNetWork License. Для данного компьютера используется файл лицензии, который получен от реселлера или Центра обслуживания клиентов.
    10. Нажмите Готово.
    11. Нажмите кнопку ОК, чтобы закрыть окно мастера Файл лицензии SolidNetWork License, а затем нажмите Готово для выхода из SolidNetWork License Manager.
На уровень выше Установка Менеджера лицензий для системы из трех компьютеров
Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров
Начало установки SOLIDWORKS
Использование лицензий SolidNetWork License с брандмауэрами


Установка Менеджера лицензий на следующие два компьютера системы из трех компьютеров

Для установки SolidNetWork License Manager на втором и третьем компьютерах в системе выполните следующие действия. Эта процедура практически идентична установке программного обеспечения на исходном компьютере, за исключением шагов 2(f) и 2(i).

Предполагается, что хотя бы один Менеджер лицензий для системы из трех компьютеров установлен на другом компьютере системы.

  1. С помощью Менеджера установки SOLIDWORKS установите SolidNetWork License Manager на компьютер системы, предназначенный для установки данного приложения.
    1. Запустите Менеджер установки SOLIDWORKS (как описано в разделе Начало установки SOLIDWORKS).
    2. В качестве типа установки выберите
      • Сервер
      • Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
    3. На странице Параметры SolidNetWork License Manager укажите серийный номер лицензии SolidNetWork License и каталог установки SolidNetWork License Manager.
    4. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SOLIDWORKS.
  2. С помощью SolidNetWork License Manager выполните настройку компьютера, предназначенного для установки менеджера лицензий для системы из трех компьютеров, следующим образом.
    1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
      Поскольку на данном компьютере запуск SolidNetWork License Manager выполняется впервые, появится запрос на активацию.
    2. Нажмите Нет.
      Появится вкладка SolidNetWork License Manager "Администрирование сервера".
    3. В разделе Дополнительные параметры выберите пункт Параметры.
      Появится диалоговое окно Дополнительные параметры.
    4. В разделе "Режим сервера SolidNetWork License" выберите Использовать файл лицензии и нажмите кнопку ОК.
      Диалоговое окно Дополнительные параметры закроется.
    5. В разделе Лицензионная информация выберите Изменить.
      Появится мастер файла лицензий SolidNetWork License.
    6. В разделе Тип сервера выберите Сервер-тройка, Синхронизировать информацию сервера/лицензии и нажмите кнопку Далее.
    7. На панели информации о сервере проверьте, что указаны правильные имя компьютера и номер порта для компьютера с установленным Менеджером лицензий для системы из трех компьютеров и нажмите Далее.

      Убедитесь, что адрес сетевой интерфейсной карты (NIC) совпадает со сведениями в файле лицензии, полученном от SOLIDWORKS, и что номер порта для исходного компьютера с установленным менеджером лицензий указан верно. Адрес NIC также называется MAC-адресом (адрес управления доступом к среде передачи). Затем нажмите Далее.

      Чтобы найти адрес NIC, откройте окно командной строки и введите следующее:

      ipconfig /all

      Кроме того, если на компьютере используется брандмауэр, может потребоваться задать дополнительные требования. Для получения дополнительной информации см. Использование лицензий SolidNetWork License с брандмауэрами.

    8. На экране Информация о партнерском сервере-тройке введите имя компьютера и идентификатор хоста.
      Это даст возможность клиентским компьютерам получить лицензию с двух других компьютеров, если Менеджер лицензий на одном компьютере системы недоступен.
    9. На странице Лицензии выберите Прочитать, чтобы перейти к файлу лицензии SolidNetWork License и открыть его.
      Лицензии отобразятся в окне мастера Файл лицензии SolidNetWork License.
    Это файл лицензий создается первым компьютером, на который устанавливается менеджер лицензий. Как правило, лицензионный файл находится в папке \licenses\sw_d.lic. Например: C:\Program Files\SOLIDWORKS Corp\SolidNetWork License Manager\licenses\sw_d.lic .
    1. Нажмите Готово.
      Отобразится предупреждение мастера "Файл лицензии SolidNetWork License".
    2. Нажмите кнопку ОК, чтобы закрыть окно мастера Файл лицензии SolidNetWork License, а затем нажмите Готово для выхода из SolidNetWork License Manager.

Повторите процедуру для третьего компьютера.

На уровень выше Установка Менеджера лицензий для системы из трех компьютеров
Установка исходного Менеджера лицензий для системы из трех компьютеров


Использование лицензий SolidNetWork License с брандмауэрами

Если на компьютере используется брандмауэр, следует настроить порты для поддержки лицензий SolidNetWork License.

Следует добавить в список исключений брандмауэра два порта лицензий SolidNetWork License (например, входной порт SNL и выходной порт SNL). Для получения дополнительной информации о настройке этих портов обратитесь к системному администратору.

Если брандмауэр Windows используется в поддерживаемой операционной системе, следует изменить настройку портов на компьютере с SolidNetWork License Manager, и изменить файл лицензии SolidNetWork License для выдачи лицензий клиентским компьютерам.

Содержание

  • Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows

    Если используется брандмауэр Windows, следует изменить настройки портов на компьютере с SolidNetWork License Manager.

  • Изменение настроек SolidNetWork License Manager для брандмауэра Windows

    Если используется брандмауэр Windows, следует изменить файл лицензии SolidNetWork License, чтобы использовать порты брандмауэра для выдачи лицензий клиентским компьютерам.

На уровень выше Установка и настройка лицензий SolidNetWork
Установка и активация Менеджера лицензий
Установка лицензионного клиента
Установка SolidNetWork License Manager перед установкой лицензионных клиентов
Управление доступом к версиям SOLIDWORKS
Установка Менеджера лицензий для системы из трех компьютеров


Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows

Если используется брандмауэр Windows, следует изменить настройки портов на компьютере с SolidNetWork License Manager.

  1. В Windows откройте панель управления и дважды нажмите Центр безопасности.
  2. Выберите Брандмауэр Windows.
  3. На вкладке Исключения выберите Добавить порт.
  4. Введите имя (например, SNL-in-port) и номер порта (например, 25734), а затем нажмите ОК.
  5. Для изменения настроек второго порта снова выберите Добавить порт на вкладке Исключения и укажите имя и номер этого порта (например, SNL-out-port и 25735), а затем нажмите ОК. Запомните номер порта, так как необходимо указывать его при изменении файла лицензии SolidNetWork License.
  6. Закройте диалоговое окно Центр обеспечения безопасности Windows и Панель управления.
На уровень выше Использование лицензий SolidNetWork License с брандмауэрами
Изменение настроек SolidNetWork License Manager для брандмауэра Windows


Изменение настроек SolidNetWork License Manager для брандмауэра Windows

Если используется брандмауэр Windows, следует изменить файл лицензии SolidNetWork License, чтобы использовать порты брандмауэра для выдачи лицензий клиентским компьютерам.

  1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. На вкладке Администрация сервера в разделе Лицензионный сервер выберите Стоп. (При запросе на подтверждение нажмите Да, затем нажмите кнопку OK, чтобы выполнить остановку лицензионного сервера.)
  3. В разделе Лицензионная информация выберите Изменить.
  4. В разделе Тип сервера выберите тип организации серверов в сети (Один или Сервер-тройка) и нажмите кнопку Далее.
  5. В разделе Сведения о сервере:
    1. Выберите параметр На этом сервере используется брандмауэр.
    2. Номер порта и номер порта Vendor Daemon должны содержать номера портов, указанные для брандмауэра Windows (подробнее см. Изменение менеджера лицензий портов компьютера для брандмауэра Windows).
    3. Выберите Файл параметров и щелкните Обзор, чтобы найти файл. Щелкните Редактировать для изменения необходимых параметров.
      Файл параметров позволяет администратору лицензий управлять различными рабочими параметрами лицензирования FlexNet.

      Рекомендации: Расположение файла параметров — это каталог установки SolidNetWork License Manager (каталог_установки_SolidNetWork_License_Manager\Licenses \sw_d.opt). Данный файл должен находиться в том же каталоге, что и файл sw_d.lic.

      Дополнительную информацию о файле параметров см. в Руководстве по администрированию лицензий FlexNet Publisher в каталоге установки Менеджера лицензий SolidNetwork (\Docs\flexuser\licensingenduserguide.pdf).

    4. Нажмите кнопку Далее, затем нажмите Готово.
  6. На вкладке Администрация сервера в разделе Лицензионный сервер нажмите Пуск.
  7. Нажмите кнопку ОК, чтобы закрыть SolidNetWork License Manager.
На уровень выше Использование лицензий SolidNetWork License с брандмауэрами
Изменение портов компьютера с установленным Менеджером лицензий для брандмауэра Windows


Администрирование лицензии SolidNetWork

В задачи администрирования входят запуск, обновление, удаление и управление лицензией, а также заимствование и возврат лицензий.

Перед запуском или обновлением менеджера лицензий необходимо вернуть любую заимствованную лицензию.

Содержание

  • Запуск SolidNetWork License Manager

    SolidNetWork License Manager можно запустить в меню Пуск операционной системы Windows.

  • Обновление SolidNetWork License Manager

    Обновление основных версий SOLIDWORKS включает удаление устаревшей версии менеджера лицензий, установку новой версии и повторную активацию лицензии SolidNetWork License.

  • Удаление файлов лицензий SolidNetWork License

    Перед обновлением удалите устаревшие файлы лицензий SolidNetWork License, а также файлы лицензий, срок действия которых истек.

  • Заимствование и возврат лицензий SolidNetWork

    Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения. Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.

  • Контроль времени простоя лицензии

    С помощью SolidNetWork License Manager программа SOLIDWORKS может регистрировать время простоя. Таким образом, лицензии, которые не используются в течение определенного времени, возвращаются в пул свободных лицензий.

  • Установка временных лицензий

    Можно временно использовать "ЛЮБУЮ" временную лицензию, если исходная лицензия SolidNetWork License недоступна.

  • Обновление индивидуальной лицензии до лицензии SolidNetWork

    Можно выполнить обновление компьютера с индивидуальной лицензии SOLIDWORKS до лицензии SolidNetWork, указав серийный номер лицензии SolidNetWork в Менеджере установки SOLIDWORKS.

  • Использование лицензий SolidNetWork с приложениями

    С помощью SolidNetWork License Manager можно распространять лицензии на основные дополнения SOLIDWORKS.

  • Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License

    Пользователи лицензий SolidNetWork License могут управлять лицензиями SOLIDWORKS® Simulation в своем пуле лицензий, которые будут использоваться после добавления в SOLIDWORKS Simulation. Кроме того, можно обновить лицензию SOLIDWORKS Simulation, не выгружая дополнение, если требуется лицензия более высокого уровня для более сложных исследований.

  • Установка Менеджера лицензий и администрирующего образа на одном компьютере

    Можно настроить один сетевой компьютер в качестве менеджера лицензий, распределяющего лицензии SolidNetWork, и местоположения администрирующего образа, из которого пользователи смогут устанавливать программу SOLIDWORKS.

  • Система управления лицензиями FlexNet Publisher

    Лицензирование SolidNetWork основано на системе управления лицензиями FlexNet Publisher®.

На уровень выше Администрирование лицензий с помощью SolidNetWork License Manager
Активация лицензии SolidNetWork License
Перенос лицензии SolidNetWork License
Установка и настройка лицензий SolidNetWork


Запуск SolidNetWork License Manager

SolidNetWork License Manager можно запустить в меню Пуск операционной системы Windows.

Выполните следующую команду в Windows: Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager.
На уровень выше Администрирование лицензии SolidNetWork


Обновление SolidNetWork License Manager

Обновление основных версий SOLIDWORKS включает удаление устаревшей версии менеджера лицензий, установку новой версии и повторную активацию лицензии SolidNetWork License.

Менеджер лицензий для более новой версии программы также может выдавать лицензии для клиентских компьютеров, на которых установлена предыдущая версия программы.

  1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. На вкладке Использование лицензий проверьте, что на сетевых клиентских компьютерах не запущена программа SOLIDWORKS.
  3. Удалите устаревшую версию Менеджера лицензий. Дополнительные сведения см. в разделе Удаление SolidNetWork License Manager.
  4. Установите новую версию менеджера лицензий и активируйте лицензию SolidNetWork License на компьютере с установленным менеджером лицензий. Для получения дополнительной информации см. Установка и активация Менеджера лицензий.

При обновлении SolidNetWork License Manager на компьютере, на котором также используется приложение SOLIDWORKS, перед установкой новых пакетов обновления для приложения SOLIDWORKS на данный компьютер рекомендуется выполнить обновление менеджеров лицензий и клиентов SolidNetWork.

При обновлении Менеджера лицензий на компьютере, на котором установлены администрирующие образы, перед обновлением администрирующих образов выполните обновление Менеджера лицензий. Подробнее см. раздел Установка Менеджера лицензий и администрирующего образа на одном компьютере.

Содержание

  • Удаление SolidNetWork License Manager

    При обновлении SolidNetWork License Manager необходимо удалить устаревшую версию менеджера лицензий перед установкой новой версии.

На уровень выше Администрирование лицензии SolidNetWork


Удаление SolidNetWork License Manager

При обновлении SolidNetWork License Manager необходимо удалить устаревшую версию менеджера лицензий перед установкой новой версии.

  1. Запустите SolidNetwork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. Убедитесь, что ни на одном из подключенных к сети клиентских компьютеров не запущена программа SOLIDWORKS.
    На вкладке Использование лицензий отображаются клиенты, на которых запущена программа SOLIDWORKS.
  3. Если требуется перенести лицензию SolidNetWork License на другой компьютер, деактивируйте лицензию на этом компьютере до удаления SolidNetWork License Manager.
    Информацию о переносе лицензий SolidNetWork License см. в разделе Перенос лицензии SolidNetWork License.
  4. На вкладке Администрация сервера в разделе Лицензионный сервер выберите Стоп.
  5. Нажмите кнопку OK, чтобы выйти из Менеджера лицензий.
  6. В Windows выберите Панель управления > Установка и удаление программ.
  7. Выберите SOLIDWORKS SolidNetWork License Manager, нажмите Удалить и подтвердите удаление.
  8. В Проводнике файлов удалите папку SOLIDWORKS SolidNetWork License Manager.
    (Обычно эта папка находится в каталоге Program Files в каталоге установки SOLIDWORKS.)

Теперь можно установить новую версию Менеджера лицензий. Подробную информацию см. в разделе Установка и активация Менеджера лицензий.

Если компьютер с SolidNetWork License Manager обладает аппаратным ключом, извлеките аппаратный ключ перед установкой новой версии SolidNetWork License Manager.
На уровень выше Обновление SolidNetWork License Manager
Перенос лицензии SolidNetWork License
Установка и активация Менеджера лицензий


Удаление файлов лицензий SolidNetWork License

Перед обновлением удалите устаревшие файлы лицензий SolidNetWork License, а также файлы лицензий, срок действия которых истек.

  1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. На вкладке Администрация сервера в разделе Файл лицензии выберите Изменить, а затем нажмите Далее. Откроется страница Лицензии.
  3. На странице Лицензии выберите устаревший файл лицензии SolidNetWork License или файл лицензии с истекшим сроком действия и нажмите кнопку Удалить.
  4. Нажмите кнопку Готово, затем нажмите кнопку OK.
На уровень выше Администрирование лицензии SolidNetWork


Заимствование и возврат лицензий SolidNetWork

Пользователи могут заимствовать лицензии SolidNetWork для использования программного обеспечения SolidWorks из удаленного местоположения. Поскольку при заимствовании лицензия извлекается из пула свободных лицензий, чтобы она снова стала доступна, ее следует вернуть.

Заимствованные лицензии действительны только для текущего пользователя и компьютера, для которых они были получены; их нельзя переносить.

Лицензия предоставляется на период времени до 30 дней (или на срок, определенный системным администратором). На это время лицензия извлекается из пула свободных лицензий.

Заимствование и возврат лицензий не работают, если используется лицензия SOLIDWORKS.

Системный администратор может настроить процесс заимствования, чтобы:
  • определить пользователей или группы, которым разрешено заимствовать лицензии;
  • задать число лицензий, которые невозможно заимствовать.

Для получения дополнительных сведений см. каталог_установки_Менеджера_лицензий_SolidNetWork\Docs\flexuser\licensingenduserguide.pdf.

Содержание

  • Заимствование лицензий SolidNetWork License

  • Возврат заимствованной лицензии SolidNetWork License

    При заимствовании лицензия SolidNetWork License удаляется из пула доступных лицензий. Чтобы она снова стала доступна, ее следует вернуть.

На уровень выше Администрирование лицензии SolidNetWork


Заимствование лицензий SolidNetWork License

SolidNetWork License Manager следует запускать из меню Пуск. Для заимствования лицензий необходимо подключиться к SolidNetWork License Manager.

Эти шаги могут различаться в зависимости от конфигурации системы. Для получения дополнительных инструкций и параметров см. соответствующие документы Microsoft Windows.
  1. Запустите SolidNetWork License Manager на клиентском компьютере (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. На вкладке Заимствование лицензий:
    1. Выберите дату в поле Заимствовать до.
    2. Выберите продукты для заимствования, затем нажмите на Заимствовать и нажмите на Да для подтверждения.
    3. Нажмите Обновить. В столбце Срок истекает отображается дата, когда лицензии должны быть возвращены.
  3. Нажмите на кнопку OK.
На уровень выше Заимствование и возврат лицензий SolidNetWork
Возврат заимствованной лицензии SolidNetWork License


Возврат заимствованной лицензии SolidNetWork License

При заимствовании лицензия SolidNetWork License удаляется из пула доступных лицензий. Чтобы она снова стала доступна, ее следует вернуть.

  1. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  2. На вкладке Заимствование лицензий:
    1. Выберите продукты, лицензии на которые требуется вернуть, нажмите кнопку Вернуть, затем нажмите Да, чтобы подтвердить возврат.
    2. Нажмите Обновить. Столбец Дата истечения становится пустым, что свидетельствует о том, что лицензия возвращена.
  3. Нажмите на кнопку OK.
Лицензии, срок действия которых истек, возвращать необязательно. Лицензия возвращается в пул лицензий в SolidNetWork License Manager в полночь даты истечения срока действия. С этого момента приложения для удаленной системы запускаться не будут.
На уровень выше Заимствование и возврат лицензий SolidNetWork
Заимствование лицензий SolidNetWork License


Контроль времени простоя лицензии

С помощью SolidNetWork License Manager программа SOLIDWORKS может регистрировать время простоя. Таким образом, лицензии, которые не используются в течение определенного времени, возвращаются в пул свободных лицензий.

  1. В каталоге установки SolidNetWork License Manager создайте текстовый файл:
    SolidNetWork_License_Manager_install_dir\Licenses\sw_d.opt
  2. Добавьте следующую строчку в файл:
    TIMEOUTALL seconds

    где секунды – минимальное допустимое время, выраженное числом, большим или равным 900 (15 минут).

На уровень выше Администрирование лицензии SolidNetWork


Установка временных лицензий

Можно временно использовать "ЛЮБУЮ" временную лицензию, если исходная лицензия SolidNetWork License недоступна.

Устанавливая файл "ЛЮБОЙ" лицензии, пользователь подтверждает свое согласие на реализацию традиционной лицензии при получении лицензии SolidNetWork License от корпорации Dassault Systèmes SolidWorks Corporation. Требуется соблюдать лицензионные ограничения.

Для установки "ЛЮБОЙ" лицензии выполните следующие действия.

  1. Если вы являетесь существующим пользователем SolidNetWork, отмените установку SolidNetWork License Manager и удалите папку установки. Для получения дополнительной информации см. Удаление SolidNetWork License Manager.
  2. Запустите Менеджер установки SOLIDWORKS (как описано в разделе Начало установки SOLIDWORKS).
    1. В качестве типа установки выберите
      • Сервер
      • Установить SolidNetWork License Manager (распределение лицензий) на этом компьютере.
    2. На странице Параметры SolidNetWork License Manager укажите серийный номер лицензии SolidNetWork License и каталог установки SolidNetWork License Manager.
    3. На странице Сводка нажмите Установить, чтобы завершить работу Менеджера установки SOLIDWORKS.
  3. Запустите SolidNetWork License Manager (Пуск > Программы > SOLIDWORKS версия > SolidNetWork License Manager > SolidNetWork License Manager).
  4. При запросе на активацию нажмите Нет.
    Появится вкладка SolidNetWork License Manager "Администрирование сервера".
  5. В разделе Дополнительные параметры выберите пункт Параметры.
    Появится диалоговое окно Дополнительные параметры.
  6. В разделе "Режим сервера SolidNetWork License" выберите Использовать файл лицензии и нажмите кнопку ОК.
    Диалоговое окно Дополнительные параметры закроется.
  7. В разделе Лицензионная информация выберите Изменить.
    Появится мастер файла лицензий SolidNetWork License.
  8. В разделе Тип сервера выберите Один и нажмите кнопку Далее.
  9. Если отобразится сообщение
    Не удалось прочитать идентификатор ключа. Нажмите Отмена.
    Идентификатор "ЛЮБАЯ" отображается автоматически.
    Если на компьютере используется брандмауэр, необходимо задать дополнительные требования. Для получения дополнительной информации см. Использование лицензий SolidNetWork License с брандмауэрами.
  10. Продолжите установку.
На уровень выше Администрирование лицензии SolidNetWork


Обновление индивидуальной лицензии до лицензии SolidNetWork

Можно выполнить обновление компьютера с индивидуальной лицензии SOLIDWORKS до лицензии SolidNetWork, указав серийный номер лицензии SolidNetWork в Менеджере установки SOLIDWORKS.

Если программа SOLIDWORKS на компьютере не установлена, можно указать лицензию SolidNetWork, введя серийный номер лицензии SolidNetWork при установке с помощью Менеджера установки SOLIDWORKS.

Если программа SOLIDWORKS установлена и выполняется обновление индивидуальной лицензии до лицензии SolidNetWork, можно изменить установку для клиентского компьютера и при запуске Менеджера установки SOLIDWORKS вместо серийного номера индивидуальной лицензии указать серийный номер лицензии SolidNetWork. Для получения дополнительных сведений см. раздел Изменение установки.
Если программа SOLIDWORKS установлена с помощью администрирующего образа, параметр изменения будет недоступен. Внести изменения в административный образ можно с помощью редактора параметров администрирующего образа, затем удалить клиента и перезапустить установку.
На уровень выше Администрирование лицензии SolidNetWork
Изменение установки


Использование лицензий SolidNetWork с приложениями

С помощью SolidNetWork License Manager можно распространять лицензии на основные дополнения SOLIDWORKS.

  • Равное количество лицензий SOLIDWORKS и лицензий для добавлений SOLIDWORKS не требуется.
  • Чтобы получить лицензию на приложение, следует сначала получить лицензию на программу SOLIDWORKS.
  • Чтобы заимствовать лицензию на добавление, необходимо сначала заимствовать обе лицензии: лицензию на программу SOLIDWORKS и лицензию на продукт SOLIDWORKS, в который входит нужное добавление. Стандартная лицензия SOLIDWORKS одалживается по умолчанию, но для поддержки добавлений необходимо одолжить профессиональную лицензию или премиум-лицензию SOLIDWORKS.
  • Чтобы освободить лицензию на приложение:
    • В программе SOLIDWORKS выберите Инструменты > Приложения и освободите приложение.
    • Выйдите из программы SOLIDWORKS.
На уровень выше Администрирование лицензии SolidNetWork


Выбор лицензии SOLIDWORKS Simulation с помощью лицензии SolidNetWork License

Пользователи лицензий SolidNetWork License могут управлять лицензиями SOLIDWORKS® Simulation в своем пуле лицензий, которые будут использоваться после добавления в SOLIDWORKS Simulation. Кроме того, можно обновить лицензию SOLIDWORKS Simulation, не выгружая дополнение, если требуется лицензия более высокого уровня для более сложных исследований.

  1. Чтобы использовать специальную лицензию SOLIDWORKS Simulation, выполните следующие действия.
    1. В SOLIDWORKS выберите Инструменты > Дополнения. Затем в диалоговом окне Дополнение выберите SOLIDWORKS Simulation.
    2. В SOLIDWORKS Simulation (CommandManager) нажмите на стрелку вниз [image], чтобы отобразить список лицензий на сервере, который поддерживает Simulation.

    3. Выберите соответствующую лицензию SOLIDWORKS Simulation.
  2. Чтобы проверить или изменить текущую лицензию SOLIDWORKS Simulation, нажмите на стрелку вниз [image] в SOLIDWORKS Simulation (CommandManager).

    Используемая лицензия помечена флажком. Если доступны дополнительные типы лицензий, можно выполнить обновление.
    Понизить уровень лицензии SOLIDWORKS Simulation невозможно. Отключите дополнение SOLIDWORKS Simulation и добавьте лицензию на более низком уровне.
  3. Необязательно: Чтобы отключить дополнение, нажмите SOLIDWORKS Simulation (CommandManager) или отмените выбор в меню Инструменты > Дополнения.
В следующих случаях по-прежнему учитывается порядок лицензий:
  • При запуске SOLIDWORKS Simulation.
  • Если дополнение SOLIDWORKS Simulation добавлено в меню Инструменты > Дополнения.
  • Если дополнение SOLIDWORKS Simulation выбрано без указания лицензии в раскрывающемся списке.
На уровень выше Администрирование лицензии SolidNetWork


Установка Менеджера лицензий и администрирующего образа на одном компьютере

Можно настроить один сетевой компьютер в качестве менеджера лицензий, распределяющего лицензии SolidNetWork, и местоположения администрирующего образа, из которого пользователи смогут устанавливать программу SOLIDWORKS.

Клиентские компьютеры могут получить лицензии из Менеджера лицензий и затем установить программу SOLIDWORKS с компьютера, на котором он установлен.

Для выполнения этой настройки Менеджер лицензий и администрирующий образ должны быть установлены на одном компьютере. Сначала установите Менеджер лицензий, а затем создайте и разверните администрирующий образ.
Для получения дополнительной информации см.:
  • Установка и активация Менеджера лицензий
  • Внедрение на нескольких клиентах
На уровень выше Администрирование лицензии SolidNetWork


Система управления лицензиями FlexNet Publisher

Лицензирование SolidNetWork основано на системе управления лицензиями FlexNet Publisher®.

Дополнительную информацию о системе управления лицензиями FlexNet Publisher см. в Руководстве по администрированию лицензий FlexNet Publisher в каталоге установки Менеджера лицензий SolidNetwork (\Docs\flexuser\licensingenduserguide.pdf).

Для получения последней информации о системе управления лицензиями FlexNet Publisher обратитесь в Flexera® Software.

На уровень выше Администрирование лицензии SolidNetWork


Устранение неполадок

Ознакомление с этими темами поможет в выявлении и устранении проблем, связанных с установкой.

Содержание

  • Использование лицензий в сетевом окружении

  • Файлы журнала Менеджера установки SOLIDWORKS

    Файлы журнала Менеджера установки SOLIDWORKS помогают выявлять и устранять проблемы, связанные с установкой.

  • Папка загрузки Менеджера установки SOLIDWORKS

    Менеджер установки SOLIDWORKS может загрузить необходимые файлы установки в указанную Вами папку. Данная статья дает ответы на часто задаваемые вопросы о папке загрузки.

  • Устранение неполадок с лицензиями SolidNetWork License

    Если не удается установить SolidNetWork License Manager, возможны следующие причины.

  • Устранение неполадок, возникающих при обновлении программы

    Если во время обновления программы SOLIDWORKS до новой версии возникают проблемы, возможны следующие причины.

  • Проверка видеокарты при установке и обновлении

    После установки или обновления SOLIDWORKS следует запустить программу SOLIDWORKS Rx и убедиться, что на компьютере установлена поддерживаемая видеокарта и соответствующий драйвер.


Использование лицензий в сетевом окружении

Это диалоговое окно открывается, когда на сервере отсутствуют лицензии для продукта.

Щелкните стрелку в поле Продукт , чтобы отобразить все продукты, доступные для выбора. В их число входит программное обеспечение SOLIDWORKS и все приобретаемые приложения.

Число лицензий - это общее количество приобретенных лицензий.

Свободные лицензии - это количество лицензий, которые в настоящий момент не используются.

Поле Кто использует лицензии содержит информацию о каждом пользователе, который в настоящий момент использует лицензию.

На уровень выше Устранение неполадок
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарты при установке и обновлении


Файлы журнала Менеджера установки SOLIDWORKS

Файлы журнала Менеджера установки SOLIDWORKS помогают выявлять и устранять проблемы, связанные с установкой.

Эти файлы хранятся вместе с файлами журналов других приложений SOLIDWORKS.
  • Для Windows 7 или более поздней версии:

    C:\Users\имя_пользователя\AppData\Roaming\SOLIDWORKS\Installation Logs\установленная_версия

Чтобы просмотреть каталоги файлов журнала, необходимо настроить параметры папки Windows для отображения скрытых файлов и папок.

Если данные приложения находятся на диске, отличном от C:, настройте путь к каталогу соответствующим образом.

Этот каталог содержит файл SummaryIMLog_nnnnn_nnnnn_nnnn_nnnnn.txt , общий журнал работы Менеджера установки SOLIDWORKS.

Более подробная информация о журнале установки содержится в подкаталоге Другие журналы.

На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарты при установке и обновлении


Папка загрузки Менеджера установки SOLIDWORKS

Менеджер установки SOLIDWORKS может загрузить необходимые файлы установки в указанную Вами папку. Данная статья дает ответы на часто задаваемые вопросы о папке загрузки.

Вопрос Ответ
Как установить файлы в этой папке?

Запустите setup.exe. Возможно, Вам придется загрузить некоторые файлы, если Вы выберете установку ранее незагруженных объектов.

Не следует выполнять установку с помощью msiexec (см. ниже).
Можно установить файлы MSI вручную из этой папки, используя msiexec или какую-либо другую программу?

Нет. С помощью Менеджера установки нельзя загрузить некоторые файлы, которые потребуются при запуске msiexec.
Можно ли выбирать одну и ту же папку загрузки для каждой устанавливаемой мной версии?

Загруженные папки относятся к определенной версии. Начиная с выпуска SOLIDWORKS 2010, Менеджер установки SOLIDWORKS автоматически создает в указанной папке подпапку, относящуюся к соответствующей версии.

Некоторых продукты загружены мной вручную с веб-сайта корпорации Dassault Systèmes SOLIDWORKS. Можно ли установить это с помощью Менеджера установки?
Начиная с SW2009, загруженные вручную файлы можно использовать с помощью Менеджера установки SOLIDWORKS. Однако лучше запустить Менеджер установки SOLIDWORKS, выбрав вариант для загрузки файлов. В Менеджере установки SOLIDWORKS отображаются необходимые файлы на основе устанавливаемых продуктов с предоставлением ссылок для загрузки каждого файла. Этот вариант можно использовать, когда встроенная страница загрузки не работает (чаще всего по причине ограничений загрузки, установленных полномочным сервером).
Если Microsoft Internet Explorer запрашивает, требуется ли сохранить или запустить файлы во время загрузки или установки, всегда указывайте сохранение.
Могут ли загруженные мною файлы использоваться другими пользователями?

Да. Для этого загрузите файлы в общедоступный сетевой ресурс. Каждый клиент сможет запустить Менеджер установки SOLIDWORKS с этого ресурса для проведения локальной установки.

Дальнейшая загрузка не потребуется пока пользователь не выберет несколько элементов для установки, которые не были выбраны ранее во время первоначальной установки, или если компьютер, с которого выполняется загрузка файлов для установки, имеет набор требований, отличный от набора требований компьютера, на который выполняется загрузка файлов.

Если Вы загружаете файлы для других пользователей, но не устанавливаете их, выберите параметр Только загрузить при установке. Этот параметр позволяет выбирать продукты вне зависимости от того, какие из них пользователь может установить на своем компьютере. Однако этот вариант нельзя использовать для загрузки пакетов или создания администрирующих образов.
Как узнать, когда станет доступна новая версия продуктов SOLIDWORKS?
Вы будете извещены о наличии новых версий в следующих случаях:
  • Если выполняется проверка наличия обновлений ( Пуск > Все программы > Менеджера установки SOLIDWORKS > Проверить наличие обновлений)
  • при использовании Фонового загрузчика SOLIDWORKS;
  • При выборе неустановленной версии SOLIDWORKS в Windows Установка и удаление программ и нажмите Изменить
  • при запуске более ранней версии Менеджера установки (sldIM.exe) из папки загрузки.
В этих случаях можно выбрать загрузку более новой версии. Будут выполнены загрузка и запуск более новой версии Менеджера установки SOLIDWORKS, а не установочных файлов. После запуска более новой версии Менеджера установки SOLIDWORKS можно выбрать параметры установки. Менеджер установки SOLIDWORKS определит необходимые установочные файлы, которые не были загружены ранее, и предложит загрузить эти файлы.
Менеджер установки SOLIDWORKS не разрешает выбрать другой пакет обновления продукта для установки.

Каждая версия Менеджера установки SOLIDWORKS предназначена для установки только определенной версии продуктов SOLIDWORKS. Если вы хотите установить другой пакет обновления, вы должны запустить соответствующую версию Менеджер установки SOLIDWORKS. Процедуру поиска последней доступной версии см. в предыдущем пункте.
Менеджер установки SOLIDWORKS не позволяет выполнять загрузку файлов.

Если из-за ограничений полномочного сервера с помощью приложений нельзя загрузить файлы, Менеджер установки SOLIDWORKS не может выполнить загрузку файлов автоматически.

Файлы можно загрузить вручную и затем установить их с помощью Менеджера установки SOLIDWORKS. В Менеджере установки SOLIDWORKS выберите параметр для загрузки отдельных файлов (например, Провести загрузку вручную на странице Параметры загрузки). На основе выбранного продукта и системных требований веб-страница отображается в отдельном окне, содержащем ссылки для загрузки всех необходимых фалов вручную. Эти ссылки идентичны ссылкам, предоставленным на портале для клиентов SOLIDWORKS, но пользователю не требуется искать файлы.
Не все продукты SOLIDWORKS обновляются до последнего пакета обновлений. Почему функция «Проверить наличие обновлений» сообщает, что установлена последняя версия?

Параметр Проверить наличие обновлений сообщает об установке (или запуске) последней версии Менеджера установки SOLIDWORKS.

Если необходимо обновить все продукты до последних версий, в Добавление/удаление программ выберите последнюю установленную версию SOLIDWORKS и нажмите Изменить..

Можно ли скопировать DVD в папку загрузки?

Да, но установка может дать сбой, если Вы не скопируете все содержимое каждого DVD, выпущенного для соответствующей платформы. Менеджер установки SOLIDWORKS выполняет поиск файлов swdata*.id для определения версии. При отсутствии этих файлов Менеджер установки не сможет распознать скопированные пользователем установочные файлы и потребует загрузить их.
На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарты при установке и обновлении
Советы по использованию SOLIDWORKS с ОС Microsoft Windows 8


Устранение неполадок с лицензиями SolidNetWork License

Если не удается установить SolidNetWork License Manager, возможны следующие причины.

На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок, возникающих при обновлении программы
Проверка видеокарты при установке и обновлении

Доступ к файлам журнала лицензий SolidNetWork

При возникновении ошибки лицензии ее возможные причины см. в файле Каталог_установки_Менеджера_SNL\lmgrd.log.

Не удалось получить лицензию SOLIDWORKS. Не удалось связаться с лицензионным сервером.

Обычно эта проблема возникает в результате неправильной настройки портов.

  • Настройки портов компьютера с SolidNetWork License Manager и клиентского компьютера могут не совпадать.
  • Для различных версий SolidNetWork License Manager могут быть не заданы дополнительные настройки портов.
  • Убедитесь, что клиентский компьютер может точно решать проблемы и проводить маршруты к серверу, предоставляя имя сервера. Также убедитесь, что сервер может точно решать проблемы и проводить маршруты к клиентскому компьютеру, предоставляя его имя.
Для получения дополнительной информации о настройках портов для менеджеров лицензий и клиентов SolidNetWork см. Использование SolidNetWork License Manager с брандмауэрами.
Использование лицензий SolidNetWork License с брандмауэрами


Устранение неполадок, возникающих при обновлении программы

Если во время обновления программы SOLIDWORKS до новой версии возникают проблемы, возможны следующие причины.

На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Проверка видеокарты при установке и обновлении

Выполнение обновления из источника, который был перемещен

Во время установки SOLIDWORKS Менеджер установки SOLIDWORKS запоминает месторасположение источника установки (носитель, образ в сети и т.д.). При обновлении он ожидает, что источник будет находится в том же месторасположении.

Если источник был перемещен или удален, или носитель изменился, Менеджер установки SOLIDWORKS выводит сообщение об ошибке. Однако Вы можете продолжить процесс обновления путем перехода в другое месторасположение, если оно содержит те же файлы и структуру папок.


Проверка видеокарты при установке и обновлении

После установки или обновления SOLIDWORKS следует запустить программу SOLIDWORKS Rx и убедиться, что на компьютере установлена поддерживаемая видеокарта и соответствующий драйвер.

Проверка видеокарты и драйвера:

  1. После завершения установки и при отображении страницы с кнопкой Готово перейдите в раздел Проверка системы и нажмите Запустить диагностику системы.

    Запустится программа SOLIDWORKS Rx и начнет диагностику.

  2. SOLIDWORKS Rx проверяет, поддерживается ли текущая видеокарта и соответствующий драйвер. Если видеокарта поддерживается, а драйвер нет, отобразится статусное сообщение со ссылкой на поддерживаемый драйвер.

При каждом десятом запуске программы SOLIDWORKS будет отображаться сообщение Проверка системы с предложением провести повторную диагностику. Чтобы отключить уведомления, нажмите правой кнопкой мыши на значок SOLIDWORKS Resource Monitor [image] в области уведомлений Windows и выберите Закрыть графические уведомления.

Видеокарту и драйвер можно проверить в любое время. Для этого нажмите правой кнопкой мыши на значок SOLIDWORKS Resource Monitor в области уведомлений Windows. Через контекстное меню также можно выполнить следующие действия:
  • Открыть справку для SOLIDWORKS Resource Monitor
  • Запустить диагностику системы
  • Закрыть уведомления о подписке
  • Обновить драйвер видеокарты
На уровень выше Устранение неполадок
Использование лицензий в сетевом окружении
Файлы журнала Менеджера установки SOLIDWORKS
Папка загрузки Менеджера установки SOLIDWORKS
Устранение неполадок с лицензиями SolidNetWork License
Устранение неполадок, возникающих при обновлении программы


Справка Менеджера установки SOLIDWORKS

Менеджер установки SOLIDWORKS является отдельным приложением, которое устанавливает и обновляет продукты SOLIDWORKS.

Менеджер установки SOLIDWORKS является основным инструментом для скачивания, установки, изменения, обновления, восстановления и удаления программного обеспечения SOLIDWORKS.

Менеджер установки SOLIDWORKS можно запустить следующим образом:
  • С диска SOLIDWORKS DVD, из общей папки или папки загрузки (при установке новой версии)
  • Со страницы Установка и удаление программ панели управления (при изменении или удалении существующей версии)
  • При проверке в процессе запланированного или выполняемого вручную обновления (во время удаления, загрузки и установки новых версий)

Каждая версия SOLIDWORKS имеет собственную особую версию Менеджера установки SOLIDWORKS.

Содержание

  • SOLIDWORKS Фоновый загрузчик

    Фоновый загрузчик SOLIDWORKS автоматически скачивает файлы при помощи фоновых процессов (например, в случае обнаружения новой версии пакета обновления), благодаря чему пользователь во время скачивания может заниматься другими делами. По завершении скачивания пользователь может решить, выполнить ли установку немедленно, отложить установку или удалить скачанные файлы.

  • Определение параметров Менеджера установки

    Эти параметры включают настройки записи журнала, доступа в Интернет и языка, используемого в Менеджере установки.

  • Проверить результаты обновлений

    При проверке обновлений выполняется поиск последних версий SOLIDWORKS.

  • Месторасположение администрирующего образа

    Указывает месторасположение администрирующего образа.

  • Параметры загрузки

    Укажите сведения для выполнения загрузки, такие как местоположение загружаемых файлов, способ загрузки и необходимость установки этих файлов.

  • Параметры загрузки файлов Менеджера установки SOLIDWORKS

    Вы выбрали загрузить последнюю версию Менеджера установки SOLIDWORKS. На этом экране можно указать место и способ загрузки.

  • Загрузка файлов установки продукта

    Укажите, куда и каким образом загрузить отсутствующие файлы для указанного продукта.

  • Статус загрузки

    Менеджер установки SOLIDWORKS загружает, проверяет и извлекает все файлы во время процесса загрузки.

  • Результаты загрузки

    Здесь указывается состояние загрузки: успешное завершение, ошибка или отмена.

  • Ошибки установки/Отмена установки

    При установке обнаружена ошибка или она была отменена.

  • Установка завершена

    Менеджер установки SOLIDWORKS завершил свою работу.

  • Местоположение установки

  • Параметры обновления

    На компьютере установлена одна или несколько более ранних основных версий SOLIDWORKS. Можно создать новую установку, которая будет работать с более ранней версией, или можно выполнить обновление, которое удалит старую версию.

  • Ход выполнения установки

    Этот экран отображает ход выполнения установки.

  • Тип установки

    Можно указать операцию установки, которую необходимо выполнить. Например, создание новой установки, изменение или исправление существующей установки, создание администрирующего образа, установка продуктов для сервера администрирования или скачивание файлов для совместного использования и установки на другие компьютеры.

  • Установка и управление для нескольких компьютеров

    Менеджер установки SOLIDWORKS обеспечивает следующие инструменты для установки и управления несколькими компьютерами, на которых установлена программа SOLIDWORKS.

  • Загрузка вручную

    Вы выбрали загрузку файлов вручную (или загрузка вручную задана при последнем запуске Менеджера установки SOLIDWORKS).

  • Доступные более новые версии

    Менеджер установки обнаружил более новую версию продуктов SOLIDWORKS. Вы можете установить версию, содержащуюся на исходном DVD или в исходной загрузке, или можно загрузить и установить более новую версию.

  • Новые версии не доступны

    Новые версии не доступны для загрузки. Продолжите установку указанной версии.

  • Обнаружены процессы

    Менеджер установки SOLIDWORKS обнаружил на этом компьютер процессы, которые могут препятствовать установке.

  • Выбор продуктов

    Можно указать компоненты продукта для установки, изменения, скачивания и удаления.

  • Продукты для загрузки

    Выберите продукты SOLIDWORKS для загрузки в указанное месторасположение.

  • Продукты для исправления

    Если задан параметр Исправить эту установку, на экране отображаются те продукты SOLIDWORKS с номерами версий, которые можно исправить с помощью данной версии Менеджера установки SOLIDWORKS.

  • Серийные номера

    Серийные номера, имеющиеся на распределительной коробке, связывают ваш компьютер с приобретенными продуктами SOLIDWORKS.

  • Установка сервера

    При использовании этого параметра отобразится список устанавливаемых серверов с результатами установки.

  • SolidNetWork License Manager

    Укажите параметры установки сервера SolidNetWork License Manager.

  • Сводка

    В Менеджере установки SOLIDWORKS имеется вся информация, необходимая для выполнения операции установки.

  • Предупреждения проверки системы

    При проверке системы обнаружены ошибки, которые могут повлиять на дальнейший процесс установки. В большинстве случаев можно будет продолжить установку с помощью Менеджера установки SOLIDWORKS.

  • Параметры Отверстия под крепеж/Toolbox

    В случае установки SOLIDWORKS Toolbox в состав SOLIDWORKS будет включена стандартная библиотека типов отверстий и оборудования.

  • Установка продуктов

    Если выбрать Удалить или Отменить установку на панели управления, на экране отобразятся продукты SOLIDWORKS (с номерами версий), которые можно удалить с помощью данной версии Менеджера установки SOLIDWORKS. Можно выбрать вариант отмены установки: стандартная, по выбору и полная.

Советы по использованию SOLIDWORKS с ОС Microsoft Windows 8


SOLIDWORKS Фоновый загрузчик

Фоновый загрузчик SOLIDWORKS автоматически скачивает файлы при помощи фоновых процессов (например, в случае обнаружения новой версии пакета обновления), благодаря чему пользователь во время скачивания может заниматься другими делами. По завершении скачивания пользователь может решить, выполнить ли установку немедленно, отложить установку или удалить скачанные файлы.

Фоновый загрузчик SOLIDWORKS включается по умолчанию при установке SOLIDWORKS.

При запуске Менеджера установки SOLIDWORKS для выполнения установки или загрузки файлов работа Фонового загрузчика SOLIDWORKS приостанавливается. В частности, будет приостановлена загрузка любых файлов, запрещены запуск новых загрузок и изменение выбранной папки загрузки

Во время установки можно отключить фоновый загрузчик. На странице "Сводка" в разделе "Параметры скачивания" снимите флажок Использовать фоновый загрузчик для будущих пакетов обновления.

Если Фоновый загрузчик включен, его значок появляется в области уведомлений на панели задач Windows:

Нажмите на этот значок, чтобы выполнить следующие операции:
  • Помощь с Фоновым загрузчиком
  • Приостановка скачивания
  • Продолжить скачивание
  • Отмена скачивания
  • Параметры установки
  • Изменить расположение скачивания
  • Проверить наличие обновлений
  • Автоматически проверять наличие обновлений
  • Автоматически скачивать обновления
  • Отключить Фоновый загрузчик

Помощь с Фоновым загрузчиком

Открывает раздел справки по фоновому загрузчику в Руководстве по установке SOLIDWORKS.

Приостановка/Продолжение загрузки

Если скачивание выполняется в фоновом режиме, нажмите Приостановка скачивания, чтобы приостановить скачивание данного фала. Скачивание можно возобновить позднее, нажав Продолжить скачивание.

Отмена загрузки

Позволяет остановить выполняемую загрузку и удалить любые файлы, которые уже были загружены при помощи Фонового загрузчика.
Возобновить отмененную загрузку невозможно.

Параметры установки

По завершении скачивания можно выбрать следующие действия:
  • Установить сейчас: Скачанные файлы устанавливаются.
  • Напомнить потом: Скачанные файлы не устанавливаются, однако настраивается сообщение с напоминанием.
  • Удалить скачанные файлы: Скачанные файлы не устанавливаются, а удаляются. (Этот параметр полезен, если пользователь передумал устанавливать скачанные файлы).

Изменить месторасположение загрузки

Изменяет месторасположение файлов, загружаемых при помощи Фонового загрузчика.

Этот параметр недоступен, если загрузка выполняется или приостановлена.

Проверить наличие обновлений

Запускает средство Проверить наличие обновлений в Менеджере установки SOLIDWORKS.

Автоматически проверять наличие обновлений

Периодически запускает средство Проверить наличие обновлений, уведомляя пользователя о том, что обновления доступны для скачивания.

Автоматически загружать обновления

Периодически запускает средство Проверить наличие обновлений, скачивающее доступные обновления.

Отключение и повторное включение Фонового загрузчика SOLIDWORKS

Фоновый загрузчик можно отключить, нажав на значок и выбрав Отключить Фоновый загрузчик.

Чтобы снова включить Фоновый загрузчик, нажмите Пуск > Все программы > Менеджер установки SOLIDWORKS > Фоновый загрузчик SOLIDWORKS.

На уровень выше Справка Менеджера установки SOLIDWORKS


Определение параметров Менеджера установки

Эти параметры включают настройки записи журнала, доступа в Интернет и языка, используемого в Менеджере установки.

Чтобы определить параметры Менеджера установки перед установкой программного обеспечения, выполните следующие действия.

  1. В Менеджере установки нажмите правой кнопкой мыши на значок SOLIDWORKS в строке заголовка и выберите:
    Опция | Описание
    Уровень записи установки в журнал Установка уровня регистрации: Высокий, Средний или Низкий. Более высокие уровни собирают больше данных для поиска и устранения неисправностей, но могут замедлить установку. По умолчанию выбрано значение Низкая (самая быстрая), что обеспечивает наилучшую производительность и стабильность.

    При создании журналов установщика Windows эти журналы сохраняются в той же папке, что и другие журналы установки.

    Параметры Администрирующего образа | Выберите Использовать короткие имена файлов (формат 8.3) или Использовать полные имена папок и файлов.
    Сбор журналов установки | Определяет место хранения журналов установки. Менеджер установки хранит эти файлы в IM_Logs.zip.
    Отключить доступ к Интернету | Невозможно отключить доступ в Интернет, если выполняется установка с помощью сетевой лицензии.
    Язык | Установка языка, используемого для Менеджера установки. По умолчанию используется английский язык.
  2. Нажмите Закрыть.
На уровень выше Справка Менеджера установки SOLIDWORKS


Проверить результаты обновлений

При проверке обновлений выполняется поиск последних версий SOLIDWORKS.

Если у вас есть права администратора на компьютере, можно Проверить наличие обновлений вручную:
  • В ОС Windows выберите Пуск > Все программы > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.
  • В SOLIDWORKS выберите Справка > Проверить наличие обновлений.
Функция "Проверить наличие обновлений" недоступна на клиентах, установленных с помощью администрирующих образов.

Доступные более новые версии

Менеджер установки SOLIDWORKS обнаружил более новую версию продуктов SOLIDWORKS. Можно выполнить обновление до более новой версии, выбрав Менеджер установки SOLIDWORKS для этой версии.

С помощью этой более поздней версии можно загрузить файлы установки для продуктов, указанных в установке. Вы можете сделать загруженные файлы общими для других пользователей, которые используют для процесса установки Менеджер установки SOLIDWORKS.

Эти загружаемые файлы предназначены только для Менеджера установки SOLIDWORKS.
Доступны эти параметры:
  • Если доступны несколько версий, то вы сможете выбрать нужную вам версию в списке.
  • Для получения более подробной информации об этой версии выберите Отметить, чтобы просмотреть, что включено в это обновление.
При нажатии кнопки Далее загружается и запускается выбранная версия Менеджера установки SOLIDWORKS.

Нет доступных новых загрузок/Не удалось проверить наличие новых версий

Менеджер установки не нашел более позднюю версию продуктов SOLIDWORKS, потому что устанавливается последняя версия или потому что не удалось установить подключение к сайту SOLIDWORKS для проверки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Месторасположение администрирующего образа

Указывает месторасположение администрирующего образа.

При создании администрирующего образа используются следующие параметры.
Местоположение нового образа | Это местоположение каталога, в котором Менеджер установки SOLIDWORKS создаст новый образ. | Этот каталог не должен содержать существующий администрирующий образ. Администрирующий образ должен находиться в папке, которую можно совместно использовать для развертывания клиента.
Приблизительный объем свободного места на диске, необходимый для создания образа | Это дополнительное пространство, которое необходимо для администрирующего образа. | Проверьте наличие на диске установки необходимого для образа свободного пространства.
Создать образ из | Это местоположение папки, из которой выполняется установка продуктов SOLIDWORKS. Этот параметр появляется, если задан параметр Только установка. Для получения дополнительной информации см. Параметры загрузки.
На уровень выше Справка Менеджера установки SOLIDWORKS


Параметры загрузки

Укажите сведения для выполнения загрузки, такие как местоположение загружаемых файлов, способ загрузки и необходимость установки этих файлов.

Менеджер установки SOLIDWORKS поддерживает электронное распределение программного обеспечения (ESD). Если вы не производите установку с DVD-диска SOLIDWORKS, вы получите запрос на указание источника устанавливаемых вами продуктов SOLIDWORKS.

Для получения ответов на вопросы о папке скачивания см. Папка загрузки Менеджера установки SOLIDWORKS.

Что необходимо сделать?

Выберите один из следующих вариантов:

Загрузить и установить/загрузить и создать образ

По завершении загрузки Менеджер установки SOLIDWORKS запустит установку с использованием загруженных файлов.

Только загрузить. Файлы можно загрузить один раз, а затем использовать их на нескольких компьютерах.

Менеджер установки SOLIDWORKS не запустит установку после завершения скачивания.

Как правило, этот параметр необходимо указать, если файлы загружаются для создания установочного набора файлов, который будет использоваться на нескольких компьютерах.

Если задан этот параметр, отобразится запрос на выбор одного из двух наборов файлов для скачивания.
  • Файлы для ДАННОГО компьютера: Будут скачаны только те файлы, которые отсутствуют в установочном наборе файлов на данном компьютере.
    Объем скачанных данных будет меньше, поскольку в пакет будут включены только следующие файлы:
    • файлы продуктов, выбранных на странице "Выбор продуктов";
    • обязательные для установки на данном компьютере файлы, которые еще не были установлены.

    Однако при попытке установки загруженного установочного набора файлов на другом компьютере может оказаться, что некоторых файлов не хватает (поскольку установочный набор файлов на другом компьютере может отличаться от текущего). Эти загруженные файлы можно использовать для установки на другой компьютер, однако в ходе установки, возможно, потребуется загрузить дополнительные файлы, чтобы установить полный установочный набор файлов.

  • Файлы для использования на ЛЮБЫХ компьютерах: Будет скачан полный установочный набор файлов, который можно использовать для установки данной версии на любом компьютере.

    Объем загружаемого пакета будет больше, поскольку он содержит полный набор файлов, который можно использовать для установки данной версии продукта на любом компьютере.

    Если для загрузки определен ограниченный набор программных продуктов, при выборе этого параметра ограничение игнорируется и загружаются все программы данной версии.

    В пакет загрузки будут включены все файлы, необходимые для создания администрирующего образа, а не только те, которые требуются для индивидуальной установки.

Только установка/Только создание образа. У меня уже есть все необходимые для установки файлы.

Менеджер установки SOLIDWORKS не скачивает файлы, а использует файлы из выбранного каталога.

Нажмите кнопку Обзор, чтобы перейти в другой каталог. Например, можно перейти к установочному DVD-диску или папке скачивания, если там находятся все необходимые файлы.

Если вы получили сообщения об ошибке, в котором говорится о том, что папке не полная, и вы ожидали, что все файлы установки будут содержаться в указанном расположении, возможными объяснениями могут быть:
  • Вы выбрали компонент для установки, который не был ранее загружен или был выбран по умолчанию.
  • Файлы были загружены на компьютер с другими системными требованиями.
  • Вы ранее провели установку клиента и теперь создаете администрирующий образ, который требует большего набора файлов.

Можно перейти в папку, содержащую все файлы (например, на DVD-диске), или выбрать один из вариантов загрузки.

Куда скачать необходимые файлы?

Это местоположение папки загрузки.

В некоторых случаях этот параметр может отображаться, но быть неактивным. Например, если выбран параметр Только установка, Менеджер установки SOLIDWORKS выполнит установку скачанных файлов из каталога, указанного для этого параметра, отдельная папка скачивания использоваться не будет.

Независимо от того, выполняется ли загрузка файлов или они уже имеются на компьютере, все файлы должны быть в одной папке загрузки.

Приблизительный размер скачивания

Необходимый объем свободного пространства на диске зависит от того, какие компоненты выбраны для установки. При этом неважно, загружаются ли новые файлы или используются файлы из предыдущего сеанса.

Например, при восстановлении предыдущей загрузки Менеджер установки SOLIDWORKS обрабатывает только те файлы, которые еще не были загружены. Загрузка может занять меньше времени, чем было заявлено ранее.

Если загрузка файла выполнена в предыдущем сеансе, его размер не учитывается при приблизительной оценке. Поэтому приблизительный объем может быть выше реального размера пакета загрузки.

Как выполнять скачивание?

Возможны два варианта.

Провести загрузку вручную

В некоторых случаях прокси-сервер может запрещать автоматическую загрузку из Менеджера установки SOLIDWORKS.

При выборе этого параметра можно загрузить файлы с веб-страницы вручную, а затем продолжить операции установки в Менеджере установки SOLIDWORKS. Эта веб-страница настроена с помощью Менеджера установки SOLIDWORKS для загрузки только тех файлов, которые необходимы для выполнения установки.

Ускорьте загрузки с помощью добавочной полосы сетевого пропуска

Программа загрузки использует алгоритм для ускорения процесса загрузки с помощью использования добавочной полосы сетевого пропуска во время загрузки.

В некоторых случаях это может повлиять на быстродействие сети. Если при проведении загрузки возникли проблемы, этот параметр может не поддерживаться Вашим полномочным сервером. Попробуйте очистить этот параметр и провести загрузку снова. Для получения информации обратитесь к Вашему системному администратору.

Этот параметр применяется только при автоматической загрузке и не влияет на скорость при загрузке вручную.

Использование Фонового загрузчика SOLIDWORKS

Для выполнения данной операции загрузки или для загрузки дальнейших версий пакетов обновления по мере их доступности можно использовать Фоновый загрузчик SOLIDWORKS.

Фоновый загрузчик SOLIDWORKS позволяет автоматически обнаруживать и скачивать новые версии пакетов обновления в фоновом режиме. По завершению процесса пользователь уведомляется о том, что файлы скачаны и готовы к установке. Для получения дополнительной информации см. SOLIDWORKS Фоновый загрузчик.

На уровень выше Справка Менеджера установки SOLIDWORKS


Параметры загрузки файлов Менеджера установки SOLIDWORKS

Вы выбрали загрузить последнюю версию Менеджера установки SOLIDWORKS. На этом экране можно указать место и способ загрузки.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SOLIDWORKS.

Этот экран открывается только в случае проблем с папкой загрузки по умолчанию (например, при отсутствии доступа для записи или сетевого доступа). Как правило, для продолжения можно указать другую папку загрузки.

Каталог загрузки

Перейдите к месторасположению для файлов Менеджера установки SOLIDWORKS.

Будет показан размер пакета загрузки и требуемый объем свободного пространства. Необходимый объем включает дополнительный объем, необходимый для распаковки некоторых загрузок, и превышает объем самой загрузки.

Использовать акселерацию загрузки

Если Вы решите использовать этот параметр, программа загрузки использует алгоритм для ускорения загрузки.

При использовании функции акселерации загрузки увеличивается полоса пропускания, что может привести к нарушениям в работе сети. Посоветуйтесь с Вашим системным администратором до использования акселерации загрузки.

Если акселерация загрузки не поддерживается полномочным сервером, этот параметр будет автоматически отключен.

На уровень выше Справка Менеджера установки SOLIDWORKS


Загрузка файлов установки продукта

Укажите, куда и каким образом загрузить отсутствующие файлы для указанного продукта.

Менеджер установки SOLIDWORKS загружает, проверяет и извлекает все файлы во время процесса загрузки.

Если закрыть этот экран, невыполненные этапы последовательности установки будут отменены.

Для получения более подробной информации о последствиях отмены и инструкций для завершения прерванных установок см. Ошибки установки.

Каталог загрузки

Перейдите в месторасположение загруженных файлов.

Будут показаны размер пакета загрузки и требуемое пространство. Требуемый объем свободного пространства определяется с учетом места, необходимого для распаковки, и превышает фактический размер пакета загрузки.

Для получения ответов на вопросы о папке загрузке см. SOLIDWORKS менеджер установки папка загрузки.

Параметры загрузки

Ускорьте загрузки с помощью добавочной полосы сетевого пропуска

Программа загрузки использует алгоритм для ускорения процесса загрузки с помощью использования добавочной полосы сетевого пропуска во время загрузки.

В некоторых случаях это может повлиять на быстродействие сети. Если при проведении загрузки возникли проблемы, этот параметр может не поддерживаться Вашим полномочным сервером. Попробуйте очистить этот параметр и провести загрузку снова. Для получения информации обратитесь к Вашему системному администратору.
При использовании функции акселерации загрузки увеличивается полоса пропускания, что может привести к нарушениям в работе сети. Посоветуйтесь с Вашим системным администратором до использования акселерации загрузки.

Если акселерация загрузки не поддерживается прокси-сервером, этот параметр будет автоматически отключен.

На уровень выше Справка Менеджера установки SOLIDWORKS
Ошибки установки/Отмена установки
Папка загрузки Менеджера установки SOLIDWORKS


Статус загрузки

Менеджер установки SOLIDWORKS загружает, проверяет и извлекает все файлы во время процесса загрузки.

Чтобы отменить загрузку после ее запуска, выберите параметр Отмена.

При отмене или сбое загрузки на экране Отмена загрузки или Неполадка загрузки отображается список незагруженных файлов. Можно возобновить загрузку или закрыть приложение.

Для получения ответов на вопросы о папке загрузки см. Папка загрузки Менеджера установки SOLIDWORKS.
На уровень выше Справка Менеджера установки SOLIDWORKS


Результаты загрузки

Здесь указывается состояние загрузки: успешное завершение, ошибка или отмена.

Неполадка загрузки/Загрузка отменена

Если отображается сообщение Неполадка загрузки, Менеджер установки обнаружил проблемы, препятствующие загрузке.

Если отображается сообщение Загрузка отменена, процесс загрузки был отменен до завершения.

Чтобы продолжить:

Повторить/Возобновить автоматические загрузки | Чтобы возобновить автоматическую загрузку с того места, где она была отменена, выберите этот параметр и нажмите Повторить загрузку или Возобновить загрузку.
Загрузить отдельные файлы в веб-браузере | В некоторых случаях прокси-сервер может запрещать автоматическую загрузку из Менеджера установки SOLIDWORKS. | При выборе этого параметра можно загрузить файлы с веб-страницы вручную, а затем продолжить операции установки в Менеджере установки SOLIDWORKS. Эта веб-страница настроена с помощью Менеджера установки SOLIDWORKS для загрузки только тех файлов, которые необходимы для выполнения установки.

Загрузка завершена

Экран «Загрузка завершена» отображается при завершении загрузки, если выбран параметр Только загрузить.

Нажмите кнопку Готово, чтобы выйти из Менеджера установки SOLIDWORKS.

Не следует устанавливать эти продукты вручную. Для установки загруженных файлов всегда используйте Менеджер установки SOLIDWORKS.
На уровень выше Справка Менеджера установки SOLIDWORKS


Ошибки установки/Отмена установки

При установке обнаружена ошибка или она была отменена.

Если возникла ошибка или отмена:
  • Продукты, установленные до возникновения ошибки или отмены установки, остаются на компьютере.
  • Установка продуктов, устанавливаемых во время отмены установки, если возможно, откатывается так, чтобы не оставалось частично установленных продуктов.
  • Установка или отмена установки оставшихся продуктов выполняться не будет. Список отобразится в разделе Попытка не была сделана.

    Чтобы возобновить установку или отмену установки этих продуктов, щелкните предоставленную ссылку.

Менеджер установки SOLIDWORKS сначала выполнит установку всех обязательных компонентов, не установленных на компьютере, например .NET framework.

Содержание

  • Восстановление после неудачной или отмененной установки

    Если во время установки возникнет ошибка или отмена, с этого момента процесс установки можно восстановить, если запустить его повторно.

  • Исправление установки

    При возникновении неполадок в установленном продукте SOLIDWORKS можно воспользоваться Менеджером установки SOLIDWORKS для исправления установки.

  • Обращение к реселлеру SOLIDWORKS

    Если не удается провести изменение или исправление установки, обратитесь к реселлеру SOLIDWORKS, собрав информацию, отображаемую на этом экране. Возможно, вам потребуется предоставить сжатый фал, содержащий файлы журнала Менеджера установки SOLIDWORKS.

На уровень выше Справка Менеджера установки SOLIDWORKS


Восстановление после неудачной или отмененной установки

Если во время установки возникнет ошибка или отмена, с этого момента процесс установки можно восстановить, если запустить его повторно.

  1. Запишите сообщение об ошибке и код продукта для неудавшейся установки, как показано на экране Ошибки установки или Отмена установки.
    Если программа запрашивает исходный файл и вы не изменяете существующую установку SOLIDWORKS, возможно, установка или компьютер повреждены. Обратитесь к своему реселлеру SOLIDWORKS.
  2. Перезагрузите компьютер.
  3. Чтобы убедиться, что не запущены никакие продукты SOLIDWORKS, в Windows нажмите Ctr+Alt+Del и откройте диспетчер задач.
  4. Если на вкладке Процессы в разделе Имя образа отображается один из следующих процессов, выберите их и нажмите кнопку Завершить процесс.
    • SLDWORKS.exe
    • EModelViewer.exe
    • PDMworks.exe
    • pdmwVault.exe
    • SWViewer.exe
    • swlmwiz.exe
    • photoview360.exe
    • SWBoengine.exe
    • SWVBAServer.exe
    • Sldshellextserver.exe
  5. Если программа уже установлена, и Вы пытаетесь ее изменить или удалить, попробуйте исправить установку. Для получения дополнительных сведений см. раздел Исправление установки.
  6. В Windows 7 или более поздней версии выберите Пуск > Панель управления > Программы и компоненты.
  7. Выберите неисправную версию SOLIDWORKS.
    Если нет записи о версии SOLIDWORKS, которую вы пытаетесь установить, повторите процесс установки.
  8. Выполните одно из следующих действий:
    • Чтобы повторить попытку, нажмите кнопку Изменить и выберите все продукты, пропущенные во время установки или установка которых не удалась.

    • Чтобы опустить неудавшиеся установки, нажмите на кнопку Изменить и выберите все продукты, пропущенные во время установки. Удалите продукт, установка которого не удалась.

    • Чтобы отменить установку, нажмите на кнопку Удалить и выберите любые установленные продукты.
    При этом предыдущая версия обновляемых продуктов восстановлена не будет.
На уровень выше Ошибки установки/Отмена установки
Исправление установки
Обращение к реселлеру SOLIDWORKS


Обращение к реселлеру SOLIDWORKS

Если не удается провести изменение или исправление установки, обратитесь к реселлеру SOLIDWORKS, собрав информацию, отображаемую на этом экране. Возможно, вам потребуется предоставить сжатый фал, содержащий файлы журнала Менеджера установки SOLIDWORKS.

  1. Найдите файлы журнала. Для Windows 7 и новее:
    C:\Users\имя_пользователя\AppData\Roaming\SOLIDWORKS\Installation Logs\установленная_версия\.
    Если папку найти не удается, возможно, она скрыта. В Проводнике файлов выберите Инструменты > Параметры папки. На вкладке Вид в разделе Дополнительные настройки выберите Показать скрытые файлы и папки для скрытых файлов и папок.
  2. Выполните сжатие содержимого всей папки, включая и содержимое подпапок.
На уровень выше Ошибки установки/Отмена установки
Восстановление после неудачной или отмененной установки
Исправление установки


Установка завершена

Менеджер установки SOLIDWORKS завершил свою работу.

Может отображаться один или несколько этих параметров.

Новые возможности

Для индивидуальных установок при завершении процесса установки отображается документ, описывающий новые функциональности в SOLIDWORKS и его добавлениях.

Для установок с помощью администрирующего образа документ отображается на клиентских компьютерах при завершении ими установок.

Опрос

Поделитесь с нами Вашим мнением о процессе установки, заполнив короткий опрос.

SOLIDWORKS Программа отзывов клиентов

Информация по быстродействию программы посылается в Корпорацию SOLIDWORKS с целью улучшения продукта. Процесс является прозрачным и конфиденциальным. Выберите один из указанных ниже параметров:
  • Да, я хочу участвовать
  • Нет, спасибо
  • Напомнить потом
Дополнительную информацию см. в разделе веб-сайте программы улучшения качества программного обеспечения.

Создание администрирующего образа завершено

По завершению создания администрирующего образа можно нажать Настройка образа для настройки параметров образа с помощью Редактора параметров администрирующего образа.

Чтобы просмотреть инструкции по использованию Редактора параметров, нажмите Показать мне, как установить этот образ на компьютере клиента.

Подробную информацию о настройке администрирующего образа с помощью Редактора параметров см. в разделе Редактор параметров администрирующего образа.

Нажмите Настройка образа, чтобы запустить Редактор параметров и настроить параметры администрирующего образа.
Редактор параметров можно запустить и позже, дважды нажав файл sldAdminOptionEditor.exe, расположенный в каталоге установки администрирующего образа.

Содержание

  • Проверка наличия обновлений SOLIDWORKS

    Если у вас есть полномочия администратора компьютера, то проверку на наличие обновлений можно выполнять вручную с помощью Менеджера установки SOLIDWORKS. Можно также настроить автоматическую проверку обновлений.

  • Программа улучшения качества программного обеспечения SOLIDWORKS

    При установке SOLIDWORKS можно задать параметр отправки информации о производительности в корпорацию SOLIDWORKS, которая поможет улучшить продукт.

На уровень выше Справка Менеджера установки SOLIDWORKS
Редактор параметров администрирующего образа


Проверка наличия обновлений SOLIDWORKS

Если у вас есть полномочия администратора компьютера, то проверку на наличие обновлений можно выполнять вручную с помощью Менеджера установки SOLIDWORKS. Можно также настроить автоматическую проверку обновлений.

  1. Запустите Менеджер установки SOLIDWORKS, выполнив одно из следующих действий:

    • В приложении SOLIDWORKS нажмите Справка > Проверить наличие обновлений.

    • В Windows нажмите Пуск > Программы > Менеджер установки SOLIDWORKS I > Проверить наличие обновлений.

    В окне Менеджера установки SOLIDWORKS отобразятся сведения о том, доступны ли обновления.
  2. Если да, то выберите их загрузку или установку.
  3. Чтобы задать автоматические периодические проверки на наличие обновлений, по завершении обработки, выполняемой Менеджером установки SOLIDWORKS, выберите Проверять наличие обновлений каждые __ дней и задайте периодичность проверок.
На уровень выше Установка завершена
Программа улучшения качества программного обеспечения SOLIDWORKS


Программа улучшения качества программного обеспечения SOLIDWORKS

При установке SOLIDWORKS можно задать параметр отправки информации о производительности в корпорацию SOLIDWORKS, которая поможет улучшить продукт.

SOLIDWORKS использует информацию для нахождения тенденций использования продукта и его качества. Нашей целью является доставка продукта высочайшего качества, и журналы эффективности играют важную роль в этом процессе.

Процесс очень простой. Информация, содержащаяся в файлах журнала, является конфиденциальной. Эта информация не используется для иных целей, и никто не будет связываться с Вами по этому поводу.

Дополнительную информацию см. на веб-сайте Программы улучшения обслуживания клиентов.

На уровень выше Установка завершена
Проверка наличия обновлений SOLIDWORKS


Местоположение установки

В случае установки без создания администрирующего образа применимы следующие параметры.
Установить выбранные продукты в | Это расположение папки, в которую выполняется установка SOLIDWORKS. При обновлении или изменении установки все файлы необходимо устанавливать в существующую папку установки. В этом случае невозможно изменить расположение существующей установки SOLIDWORKS.
Приблизительный объем свободного пространства, необходимый для установки | Это дополнительное пространство, которое необходимо для продуктов, выбранных для установки или изменения. | Проверьте наличие на диске установки необходимого свободного пространства.
Установить из | Это расположение папки, из которой выполняется установка SOLIDWORKS. Этот параметр появляется, если задан параметр Только установка. Дополнительные сведения см. в разделе Параметры скачивания.
Перед изменением папки установки обратитесь к системному администратору SOLIDWORKS.

Местоположение администрирующего образа

При создании администрирующего образа используются следующие параметры.
Местоположение нового образа | Это расположение каталога, в котором Менеджер установки SOLIDWORKS создаст новый образ. | Этот каталог не должен содержать существующий администрирующий образ.
Приблизительный объем свободного места на диске, необходимый для создания образа | Это дополнительное пространство, которое необходимо для администрирующего образа. | Проверьте наличие на диске установки необходимого для образа свободного пространства.
Создать образ из | Это расположение папки, из которой выполняется установка продуктов SOLIDWORKS. Этот параметр появляется, если задан параметр Только установка. Дополнительные сведения см. в разделе Параметры скачивания.
Расположение существующего образа | При обновлении существующего администрирующего образа менеджер установки SOLIDWORKS создает новый образ с использованием параметров существующего образа. Существующий образ не изменяется. Этот параметр показывает расположение исходного образа, указанного на экране приветствия.

Отказ от использования путей с указанием версии

Если в расположении каталога установки указать номер версии (например, C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS 2019\), а затем обновить установку до версии SOLIDWORKS 2020 то каталог установки SOLIDWORKS 2020 будет иметь имя SOLIDWORKS 2019.

На уровень выше Справка Менеджера установки SOLIDWORKS
Параметры загрузки


Параметры обновления

На компьютере установлена одна или несколько более ранних основных версий SOLIDWORKS. Можно создать новую установку, которая будет работать с более ранней версией, или можно выполнить обновление, которое удалит старую версию.

Создайте новую установку SOLIDWORKS версия.

Если вы решите создать новую установку, можно выбрать, какие продукты SOLIDWORKS будут установлены.

Для каждого выбранного продукта будет создана новая установка этой основной версии. На компьютере остаются все более ранние основные версии, кроме SOLIDWORKS Electrical и клиента SOLIDWORKS PDM.

Если удалить продукт, новая версия не будет установлена.

Создание новой установки может быть полезным в том случае, если требуется доступ к более ранней версии SOLIDWORKS даже после установки более поздней версии. Например, те или иные файлы используются вами совместно с другими пользователями, у которых установлена более ранняя версия. При этом вы избегаете несовместимости версий, если работа с этими файлами выполняется на компьютере с более поздней версией программы.

Обновление SOLIDWORKS предыдущая_основная_версия до SOLIDWORKS 2020 текущая_основная_версия.

Если вы решите выполнить обновление, можно выбрать, какие продукты SOLIDWORKS будут обновлены. Для каждого выбранного продукта будет создана новая установка, а более старые версии удалены.

Если отменить выбор продукта, то новая версия не устанавливается, а на компьютере остаются более ранние версии.

Примечания о SOLIDWORKS Electrical и клиенте SOLIDWORKS PDM

На компьютере можно установить только одну версию SOLIDWORKS Electrical. Если создается новая установка SOLIDWORKS и SOLIDWORKS Electrical выбирается в качестве одного из продуктов для установки, то прежняя версия SOLIDWORKS Electrical будет удалена.

Перед установкой новой версии следует создать резервную копию существующей среды SOLIDWORKS Electrical. В среде SOLIDWORKS Electrical Schematic выберите Файл Архивировать среду или в SOLIDWORKS Electrical 3D выберите SOLIDWORKS Electrical > Инструменты > Архивировать среду.

Основная версия клиента SOLIDWORKS PDM должна совпадать с основной версией сервера SOLIDWORKS PDM. Если вы не планируете обновлять сервер SOLIDWORKS PDM, не выбирайте клиент SOLIDWORKS PDM для обновления.

Чтобы удалить продукт, используйте в Windows команду Установка и удаление программ. Дополнительные сведения см. в разделе Удаление установки.
На уровень выше Справка Менеджера установки SOLIDWORKS
Удаление установки


Ход выполнения установки

Этот экран отображает ход выполнения установки.

Чтобы отменить установку после ее начала, нажмите кнопку Отмена.

Для получения более подробной информации о последствиях отмены и инструкций для завершения прерванных установок см.Ошибки установки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Тип установки

Можно указать операцию установки, которую необходимо выполнить. Например, создание новой установки, изменение или исправление существующей установки, создание администрирующего образа, установка продуктов для сервера администрирования или скачивание файлов для совместного использования и установки на другие компьютеры.

Если на компьютере уже установлена последняя версия программы SOLIDWORKS, вам будут предоставлены параметры для ее изменения или исправления.

Индивидуальный

Устанавливает продукты SOLIDWORKS на данном компьютере.

Параметр появляется, только если данная версия не установлена на компьютере.

Изменение индивидуальной установки

Используя этот параметр, можно изменить существующую установку SOLIDWORKS на данном компьютере.

Параметр появляется, только если данная версия установлена на компьютере.
К изменениям относятся следующие действия:
  • добавление или удаление компонентов продукта SOLIDWORKS;
  • установка другого пакета SOLIDWORKS (например, SOLIDWORKS Professional, SOLIDWORKS Premium и др.);
  • изменение серийного номера SOLIDWORKS.
    Если вы уже указали серийный номер SOLIDWORKS при предварительной установке, Менеджер установки SOLIDWORKS не будет запрашивать его повторно. Чтобы изменить серийный номер, необходимо выбрать этот параметр.

Исправление индивидуальной установки

Этот параметр позволяет исправить существующую установку SOLIDWORKS на данном компьютере.

Параметр появляется, только если данная версия установлена на компьютере.
Исправление проверяет, что все файлы присутствуют и правильно зарегистрированы, и устраняет все обнаруженные ошибки. Созданные Вами данные не затрагиваются.
  • Чтобы исправить продукт, убедитесь, что он выбран.
  • Очистите все окна выбора для продуктов, которые не нуждаются в исправлении.
Можно исправить индивидуальную установку. Невозможно исправить установку с помощью администрирующего образа; необходимо выполнить установку повторно, используя администрирующий образ.

Администрирующий образ

Создание или обновление администрирующих образов для развертывания на нескольких компьютерах

Для получения сведений об установке SOLIDWORKS на нескольких клиентах с использованием администрирующих образов см. раздел Использование администрирующих образов.

При создании или обновлении администрирующих образов:
  • для настройки нового или обновленного образа можно использовать параметры установки существующего образа. Можно также использовать параметры установки SOLIDWORKS по умолчанию.
  • При обновлении существующего изображения:
    • Менеджер установки SOLIDWORKS создает новую копию изображения, даже если выполняется обновление. Исходный образ не изменяется.
    • Обновленный образ можно создать с использованием файлов существующего образа. При этом объем загружаемых данных будет меньше.
    Если образ, для которого можно применить пакет обновления, не указан, придется загрузить полный набор файлов.

Серверные продукты

К серверам SOLIDWORKS относятся SOLIDWORKS Electrical, SOLIDWORKS PDM и SolidNetWork License Manager.

Для SOLIDWORKS Electrical и SOLIDWORKS PDM можно установить средства клиента и сервера на один и тот же компьютер или на разные компьютеры.

Для получения подробной информации об установке этих серверов см. соответствующие разделы справки.

Скачивание и предоставление общего доступа ко всем файлам

Этот параметр позволяет загрузить файлы установки для выбранных продуктов SOLIDWORKS. При этом установка не выполняется.

Этот параметр не будет отображаться, если установка выполняется с DVD-диска.
Содержимое скачанных файлов совпадает с содержимым файлов на установочных DVD-дисках SOLIDWORKS. При выборе этого параметра скачивается полный набор файлов установки, независимо от того, что некоторые файлы могут быть уже установлены на компьютере. Затем можно скопировать файлы на портативное устройство или в сетевой каталог и использовать их для установки программного обеспечения SOLIDWORKS на другие компьютеры. Можно также использовать этот метод для установки сервера, с помощью которого пользователи смогут провести установки.
Данный способ отличается от создания администрирующего образа.
На уровень выше Справка Менеджера установки SOLIDWORKS
Использование администрирующих образов
SOLIDWORKS PDM
Администрирование лицензий с помощью SolidNetWork License Manager
SOLIDWORKS Electrical


Установка и управление для нескольких компьютеров

Менеджер установки SOLIDWORKS обеспечивает следующие инструменты для установки и управления несколькими компьютерами, на которых установлена программа SOLIDWORKS.

Администрирующие образы SOLIDWORKS

Если Вы устанавливаете программу SOLIDWORKS на нескольких компьютерах, можно создать администрирующий образ и затем распространить программу на другие компьютеры.

SOLIDWORKS PDM

SOLIDWORKS PDM Standard представляет собой продукт для управления документацией на основе той же архитектуры, что и SOLIDWORKS Enterprise PDM. Поставляется в двух версиях: Standard и Professional. Для управления хранилищами файлов SOLIDWORKS PDM использует базу данных Microsoft SQL Server.

SolidNetWork License Manager

SolidNetWork License Manager обеспечивает работу пользователей, даже если их количество превышает количество лицензий, путем передачи лицензий в использование. В то время, когда клиентская лицензия не используется, она становится доступна для другого пользователя SOLIDWORKS.

Кроме того, можно использовать SolidNetWork License Manager для распространения основных приложений SOLIDWORKS (например, FeatureWorks).

На уровень выше Справка Менеджера установки SOLIDWORKS


Загрузка вручную

Вы выбрали загрузку файлов вручную (или загрузка вручную задана при последнем запуске Менеджера установки SOLIDWORKS).

Щелкните ссылку, чтобы открыть автоматически созданную веб-страницу с полным списком файлов для загрузки.

Необходимо выполнить загрузку в папку, указанную на странице «Сводка». Невозможно начать установку, пока все файлы не будут загружены в эту папку.

По завершении выполнения загрузки вручную нажмите кнопку Далее, чтобы продолжить.

Если необходимо выполнить загрузку автоматически, можно указать другой параметр. Для этого необходимо вернуться на страницу «Сводка» и изменить параметры загрузки.

На уровень выше Справка Менеджера установки SOLIDWORKS


Доступные более новые версии

Менеджер установки обнаружил более новую версию продуктов SOLIDWORKS. Вы можете установить версию, содержащуюся на исходном DVD или в исходной загрузке, или можно загрузить и установить более новую версию.

Если установка выполняется через загрузку

Выберите один из следующих вариантов:
  • Продолжить установку версия.

    Выберите этот параметр для продолжения установки версии, содержащейся в исходном скачивании.

  • Скачать и установить новую версию: версия.

    Выберите этот параметр, чтобы скачать и установить новую версию. Если имеется несколько новых версий, можно выбрать версию для скачивания и установки.

Если установка выполняется с DVD

В разделе Хотите использовать более новую версию? выберите один из следующих параметров.
  • Нет, продолжить установку версии с данного DVD. Можно выполнить обновление позже.

    Выберите этот параметр для продолжения установки с помощью текущего Менеджера установки.

    После завершения установки можно проверить наличие и установить обновления с помощью Менеджера установки. Для проверки обновлений выберите Пуск > Менеджер установки SOLIDWORKS > Проверить наличие обновлений.
    Пункт Проверить наличие обновлений доступен, только если вы обладаете полномочиями администратора компьютера.

    Преимущество состоит в том, что объем скачиваемых данных будет меньше. Недостатки заключаются в том, что это двухэтапный процесс, и скачанные файлы принадлежат определенной версии (и не могут быть отправлены другим пользователям, которые используют другие версии).

  • Да, провести установку с использованием этого DVD, затем скачать и обновить до версия.

    Выберите этот параметр, чтобы скачать и запустить более позднюю версию Менеджера установки для установки продуктов SOLIDWORKS для этой версии.

    При наличии небольшого пакета обновления для версии DVD Менеджер установки сначала выполнит установку исходной версии с диска DVD, а затем установит пакет обновления. При этом объем скачиваемых данных будет меньше.

    Такие же результаты будут, если выбрать продолжение установки с DVD-диска, а затем позднее установить пакет обновления.

    Преимущество заключается в том, что эта процедура выполняется в один этап.

На уровень выше Справка Менеджера установки SOLIDWORKS


Новые версии не доступны

Новые версии не доступны для загрузки. Продолжите установку указанной версии.

Для продолжения установки нажмите кнопку Далее.

На уровень выше Справка Менеджера установки SOLIDWORKS


Обнаружены процессы

Менеджер установки SOLIDWORKS обнаружил на этом компьютер процессы, которые могут препятствовать установке.

  • Чтобы продолжить установку, выполните одно из следующих действий:
    • Завершите эти процессы (например, с помощью диспетчера задач Microsoft Windows), а затем нажмите кнопку Повторить.
    • Нажмите кнопку Игнорировать, чтобы продолжить, не завершая процессов.
  • Чтобы остановить установку, нажмите кнопку Отмена.
На уровень выше Справка Менеджера установки SOLIDWORKS


Выбор продуктов

Можно указать компоненты продукта для установки, изменения, скачивания и удаления.

В списке продуктов:
  • В списке продуктов перечислены все продукты пакета, указанного над этим списком.
  • Для просмотра спроецированного действия определенного компонента щелкните его имя (не флажок). Планируемое действие по установке появится в поле сведений под списком продуктов.
  • Можно установить флажок рядом с компонентом продукта, чтобы изменить действие по установке для данного компонента. (Например, установка флажка при установке или удалении компонента означает, что отмеченный компонент необходимо установить или удалить, а снятие флажка означает, что компонент не следует устанавливать или удалять.)
  • Если выполняется изменение установки, при изменении выбранного продукта слева от компонентов отобразится звездочка (*).
  • Если компонент содержит необязательные для установки подкомпоненты, рядом с ним отображается значок +. Для просмотра доступных подкомпонентов компонента нажмите на значок +.
  • Если компонент уже был развернут для просмотра подкомпонентов, рядом с ним отобразится значок -. Чтобы свернуть список подкомпонентов, нажмите на значок -.

Если применяется пакет обновления, невозможно выбрать функции SOLIDWORKS, отображающиеся под SOLIDWORKS (например, FeatureWorks). Это объясняется тем, что нельзя добавить или удалить элемент при выполнении данного типа обновления.

Действия Менеджера установки SOLIDWORKS определяются набором правил сосуществования продуктов. Дополнительные сведения см. в разделе Правила сосуществования продуктов.

Менеджер установки SOLIDWORKS по умолчанию выбирает следующие компоненты:
  • Если выполняется модернизация или обновление, Менеджер установки SOLIDWORKS выбирает продукты, установленные на компьютере в данный момент.
  • В противном случае Менеджер установки выбирает все продукты, на которые пользователь имеет право.
Чтобы сократить время установки и скачивания и необходимый объем свободного пространства на диске, разверните список компонентов продукта и снимите флажки для компонентов, которые вам не требуются.

Если Менеджеру установки SOLIDWORKS не удалось проверить, на какие продукты пользователь имеет право, можно нажать Выбрать другие пакеты или продукты, чтобы изменить список пакетов (например, SOLIDWORKS Professional или SOLIDWORKS Premium) для установки или изменения. Менеджер установки отображает все продукты SOLIDWORKS на носителе установки, которые совместимы с выбранным вами пакетом. Можно выбирать любые приобретенные продукты или продукты, на оценку которых пользователь имеет право.

Поиск SOLIDWORKS

Поиск в SOLIDWORKS — это мощный инструмент для выполнения текстового поиска в документах SOLIDWORKS и на веб-сайте 3D ContentCentral. Поиск отображает предварительный просмотр, расположение и имя файла.

После установки Поиск SOLIDWORKS индексирует документы SOLIDWORKS для убыстрения последующего поиска. По умолчанию индексируются только файлы SOLIDWORKS.

При установке Поиска SOLIDWORKS выполняется автоматическая установка Windows Desktop Search, если это приложение еще не установлено на компьютере пользователя.

Языковая поддержка

Разверните продукт SOLIDWORKS и компонент Языки, чтобы узнать, какие языки можно установить.

Параметр Языки ограничивает иностранные языки, устанавливаемые для продуктов SOLIDWORKS. Это не повлияет на установку других продуктов. Например, eDrawings® и SOLIDWORKS PDM устанавливают все поддерживаемые языки.

Требуемый объем свободного пространства

Менеджер установки SOLIDWORKS дает отчет об общем размере установки или общем размере загрузки в нижней части страницы.

  • Если вы выбрали параметр Только загрузить, отобразится размер пакета загрузки. Объем скачивания является общим объемом пространства на диске, необходимого для всех скачиваемых файлов (не включая дополнительное место, необходимое для распаковки файлов после завершения процесса скачивания). Это число является приблизительным.
    Общий размер скачивания включает все файлы, необходимые для установки. Если некоторые файлы уже были скачаны в текущую папку скачивания, они не будут скачиваться повторно. В результате фактический объем скачивания может быть меньше, чем указанный общий объем, или вам не придется скачивать файлы.
  • В противном случае отображается объем установки. Объем установки - это изменение в использовании дискового пространства, возникающее после завершения процесса установки. Из-за сжатия файлов эти показатели являются приблизительными.

    При обновлении или удалении существующей установки, объем установки может быть равен нулю.

    В это число не входит объем свободного пространства, необходимого для загрузки или извлечения файлов, если это требуется для установки.

    Если загрузка файлов необходима и все файлы загружаются на один диск, необходимый объем свободного пространства на диске может значительно превышать объем установки.

    Чтобы сократить объем загрузки или время установки для следующих модификаций, не удаляйте загруженные файлы после установки. Последующие обновления и заплаты обычно нуждаются в наличии полного набора файлов предыдущей установки.

На уровень выше Справка Менеджера установки SOLIDWORKS
Правила сосуществования продуктов


Продукты для загрузки

Выберите продукты SOLIDWORKS для загрузки в указанное месторасположение.

Доступные для загрузки продукты определяются введенным Вами серийным номером:

  • Действие, которое должно быть произведено над каждым из компонентов, отображается справа от объекта.
  • Если компонент содержит необязательные для установки субкомпоненты, после компонента отобразится значок +. Для просмотра доступных субкомпонентов компонента щелкните на значок +.
  • Если компонент уже был развернут для просмотра субкомпонентов, после него отобразится значок -. Чтобы свернуть список субкомпонентов, щелкните на значок -.
  • Установите флажок слева от каждого компонента, чтобы выбрать, каким образом он будет обработан Менеджером установки SOLIDWORKS.
Диспетчер установки SOLIDWORKS выполняет загрузку всех компонентов продуктов, на установку которых пользователь имеет право, если не указано иное. Чтобы уменьшить время загрузки и требование к количеству свободного места на диске, разверните список компонентов продукта и выберите "Не загружать" для компонентов, которые не нужны.

Если Менеджеру установки SOLIDWORKS не удалось проверить, на какие продукты пользователь имеет право, можно выбрать пакет SOLIDWORKS для установки. Менеджер установки указывает все продукты SOLIDWORKS, совместимые с выбранным вами пакетом.

Если Менеджеру установки SOLIDWORKS не удалось проверить, на какие продукты пользователь имеет право, можно нажать Выбрать другие пакеты или продукты, чтобы изменить список пакетов (например, SOLIDWORKS Professional или SOLIDWORKS Premium) для установки или изменения. Менеджер установки отображает все продукты SOLIDWORKS на носителе установки, которые совместимы с выбранным вами пакетом. Можно выбирать любые приобретенные продукты или продукты, на оценку которых пользователь имеет право.

Языковая поддержка

Параметр "Языки" ограничивает иностранные языки, устанавливаемые для продуктов SOLIDWORKS. Это не повлияет на установки других продуктов. Например, eDrawings® и SOLIDWORKS Explorer устанавливают все поддерживаемые языки.

Требуемый объем свободного пространства

В зависимости от выбранных Вами продуктов, отображается необходимый для загрузки объем свободного места. Объем загрузки является общим объемом пространства на диске, необходимого для всех загружаемых файлов (не включая дополнительное место, необходимое для распаковки файлов после завершения процесса загрузки). Это число является приблизительным.

Чтобы сократить объем загрузки или время установки следующих обновлений и пакетов, не удаляйте загруженные файлы после установки. Последующие обновления и заплаты обычно нуждаются в наличии полного набора файлов предыдущей установки.
На уровень выше Справка Менеджера установки SOLIDWORKS


Продукты для исправления

Если задан параметр Исправить эту установку, на экране отображаются те продукты SOLIDWORKS с номерами версий, которые можно исправить с помощью данной версии Менеджера установки SOLIDWORKS.

Исправление проверяет, что все файлы присутствуют и правильно зарегистрированы, и устраняет все обнаруженные ошибки. Созданные Вами данные не затрагиваются.
  • Чтобы исправить продукт, убедитесь, что он выбран.
  • Очистите все окна выбора для продуктов, которые не нуждаются в исправлении.

Чтобы начать исправление выбранных продуктов, нажмите кнопку Исправить.

Можно исправить индивидуальную установку. Невозможно исправить установку с помощью администрирующего образа; необходимо выполнить установку повторно, используя администрирующий образ.
На уровень выше Справка Менеджера установки SOLIDWORKS


Серийные номера

Серийные номера, имеющиеся на распределительной коробке, связывают ваш компьютер с приобретенными продуктами SOLIDWORKS.

Если продукты SOLIDWORKS уже установлены на компьютере, их серийные номера отображаются по умолчанию.
  • Введите ваш серийный номер SOLIDWORKS, если он еще не отображается.
  • Если серийные номера продуктов не включены в лицензию SOLIDWORKS, введите их в соответствующие поля.
  • Если администратор SOLIDWORKS назначил продукты на портале администрирования SOLIDWORKS, для автоматического заполнения назначенных серийных номеров можно использовать функцию входа в верхней части страницы.

Если имеется соединение с сетью Интернет, серийные номера соответствуют продуктам, которые вы можете использовать в процессе установки.

Поскольку существует множество способов приобретения продуктов SOLIDWORKS, некоторые серийные номера могут принадлежать двум или нескольким продуктам. Например, серийный номер SOLIDWORKS дает возможность установить SOLIDWORKS Simulation без ввода отдельного серийного номера SOLIDWORKS Simulation. Кроме того, для некоторых продуктов серийный номер не требуется. В случае возникновения вопросов, касающихся серийных номеров, обратитесь к своему реселлеру.

На уровень выше Справка Менеджера установки SOLIDWORKS


Установка сервера

При использовании этого параметра отобразится список устанавливаемых серверов с результатами установки.

Статус установки сервера

Установка серверов выполняется внешним приложением установки. Если окно приложения закрыто, для завершения установки необходимо перейти в него.

Нажмите кнопку Отмена, чтобы остановить установку серверов.

Установка сервера завершена

Внешнее приложение установки успешно завершило процесс установки.

Выберите Готово или Далее.
  • При установке других административных приложений (например, включенных в администрирующий образ SOLIDWORKS), эта процедура установки будет продолжена.
  • Если устанавливались только серверы, Менеджер установки SOLIDWORKS будет закрыт.

Отмена или ошибка установки сервера

В случае ошибки или отмены установки сервера после ее начала, отобразится список неустановленных серверов.

Выберите Закрыть или Далее.
  • Если задана установка других административных приложений, Менеджер установки SOLIDWORKS возобновит работу.
  • Если устанавливались только серверы, Менеджер установки SOLIDWORKS будет закрыт.
На уровень выше Справка Менеджера установки SOLIDWORKS


SolidNetWork License Manager

Укажите параметры установки сервера SolidNetWork License Manager.

Серийные номера

Укажите серийные номера лицензии SolidNetWork License. Можно указать несколько серийных номеров, через запятую.
Серийные номера SolidNetWork отличаются от серийных номеров SOLIDWORKS.

Расположение установки

Укажите местоположение установки SolidNetWork License Manager.

В случае обновления SolidNetWork License Manager его необходимо установить в папку существующей установки.

Дополнительная информация

Для получения детальной информации об установке, конфигурации и использовании SolidNetWork License Manager см. Администрирование лицензий с помощью SolidNetWork License Manager.

На уровень выше Справка Менеджера установки SOLIDWORKS
Администрирование лицензий с помощью SolidNetWork License Manager


Сводка

В Менеджере установки SOLIDWORKS имеется вся информация, необходимая для выполнения операции установки.

Чтобы продолжить, выполните следующие действия. | Нажмите кнопку действие Сейчас, чтобы начать операцию установки (например, Установить, Создать, Загрузить, Изменить).
Чтобы изменить параметры установки, выполните следующие действия. | Нажмите кнопку ИЗМЕНИТЬ [image] рядом с тем разделом, который требуется изменить (например, Продукты, Месторасположение установки, Параметры Toolbox).
Чтобы отменить установку, выполните следующие действия. | Нажмите Отмена, чтобы выйти из менеджера установки SOLIDWORKS без изменения компонентов установки.
Чтобы вернуться на предыдущую страницу, выполните следующее. | Нажмите Назад, чтобы вернуться на предыдущую страницу менеджера установки SOLIDWORKS.
Чтобы получить сведения об определенном наборе параметров установки (например, Продукты, Месторасположение установки, Параметры Toolbox и т. д.):
  1. Нажмите кнопку ИЗМЕНИТЬ [image] рядом с разделом, о котором требуется получить информацию.
  2. На открывшейся странице сведений выберите Справка, чтобы получить информацию об этих параметрах установки.
На уровень выше Справка Менеджера установки SOLIDWORKS


Предупреждения проверки системы

При проверке системы обнаружены ошибки, которые могут повлиять на дальнейший процесс установки. В большинстве случаев можно будет продолжить установку с помощью Менеджера установки SOLIDWORKS.

Далее приведен список предупреждений, которые могут появляться на данном этапе, а также рекомендации по продолжению установки.

Проблемы с проверкой серийного номера

Менеджеру установки не удалось проверить наличие новых версий, так как не удалось проверить серийный номер. Если серийный номер введен правильно и Интернет-соединение установлено, возможно, на нашем сервере возникли временные проблемы. Повторите попытку позже.

Проверка серийного номера: Менеджеру установки не удалось проверить ваш серийный номер для определения продуктов, на установку которых Вы имеете право. Вы сможете выбрать продукты для установки, но не сможете загрузить установочные файлы. Для проведения установки Вам понадобятся ранее загруженный набор файлов или исходные файлы на DVD.

Разрешение:
  • Проверьте подключение к Интернету. Для проверки серийного номера требуется успешное подключение к Интернету
  • Проверьте, правильно ли указан серийный номер продукта, который вы пытаетесь установить.
  • В некоторых случаях для успешной установки требуется наличие действующей подписки на абонентские услуги на момент выпуска версии. За дополнительной информацией обратитесь к своему реселлеру SOLIDWORKS.
  • В большинстве случаев Вы сможете продолжить установку, используя для этого файлы на DVD или ранее загруженный набор файлов.

Доступные более новые версии

Доступные более новые версии

Доступные новые версии

Более новая версия продукта доступна для загрузки.

Разрешение: Во время проверки наличия обновлений вам может быть предложено установить более новую версию, доступную для загрузки с веб-сайта SOLIDWORKS. Вы можете продолжить установку, используя ранее указанную версию, либо загрузить и установить вместо нее более позднюю версию.

Используется самая последняя версия

Эта новейшая доступная версия. Нажмите Далее, чтобы продолжить.

Нет доступных новых загрузок

Разрешение: Это сообщение может появиться во время проверки наличия обновлений при установке или изменении приложений. Это означает, что Вы устанавливаете (или уже установили) самую позднюю из имеющихся версий.

Проблемы с подключением к Интернету

Подключение к Интернету: Менеджер установки не может установить соединение с сервером SOLIDWORKS для определения продуктов, на установку которых вы имеете право. Вы сможете выбрать продукты для установки, но не сможете загрузить установочные файлы. Вам понадобятся исходные файлы на DVD или ранее загруженный набор файлов.

Не удалось проверить наличие новых версий

Менеджеру установки не удалось проверить наличие более новых версий, т.к. ему не удалось подсоединиться к серверу.

Разрешение:
  • Проверьте подключение к Интернету.
  • Вы сможете продолжить установку, используя для этого файлы на DVD или ранее загруженный набор файлов.

На уровень выше Справка Менеджера установки SOLIDWORKS


Параметры Отверстия под крепеж/Toolbox

В случае установки SOLIDWORKS Toolbox в состав SOLIDWORKS будет включена стандартная библиотека типов отверстий и оборудования.

Для получения дополнительной информации о настройке, обновлении и использовании SOLIDWORKS Toolbox в программе SOLIDWORKS выберите Справка > Справка по Toolbox.
Чтобы просмотреть справку, необходимо запустить приложение Toolbox, выбрав Инструменты > Дополнения.

Перед использованием SOLIDWORKS Toolbox убедитесь, что приложение настроено в соответствии с политикой компании или группы. Во многих случаях группа отвечает за настройку и обслуживание центрального компонента Toolbox. Узнайте у администратора SOLIDWORKS, каким образом следует задать настройки Toolbox во время установки программы SOLIDWORKS.

Выбранные параметры SOLIDWORKS Toolbox можно изменить и после установки. В SOLIDWORKS нажмите Инструменты > Параметры. На вкладке Параметры системы нажмите Отверстие под крепеж/Toolbox.

В следующих разделах описаны все параметры, которые могут появиться на экране при работе в любой из конфигураций. Фактический набор отображаемых параметров Toolbox зависит от того, какие конфигурации SOLIDWORKS и Toolbox ранее существовали на данном компьютере, а также от настроек Менеджера установки SOLIDWORKS, заданных на данный момент.

Создайте новую версию Toolbox новая-версия

Создание новой версии SOLIDWORKS Toolbox на данном компьютере.

При создании новой версии на экране "Выбор продуктов" разверните SOLIDWORKS > SOLIDWORKS Toolbox и выберите стандарты для поддержки Toolbox. По умолчанию выбираются все стандарты.

Любые компоненты Toolbox, уже существующие на данном компьютере, изменены не будут.

Создать ссылку или обновить существующий Toolbox

Использование существующего компонента Toolbox. Нажмите кнопку Обзор, чтобы указать местоположение Toolbox, которое требуется использовать для данной установки.

  • Если компонент Toolbox настроен для версии предыдущего основного выпуска SOLIDWORKS, он будет обновлен до этой версии. Любые настройки, выполненные для данного компонента Toolbox, будут сохранены в обновленном компоненте Toolbox.
    При обновлении Toolbox до новой основной версии SOLIDWORKS это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SOLIDWORKS.
  • Если компонент Toolbox настроен для данной версии SOLIDWORKS (например, указан Toolbox совместного пользования в сети, который уже обновлен), этот компонент уже не обновляется.
  • Если обновление Toolbox выполняется в среде SOLIDWORKS PDM, требуются дополнительные операции. Для получения дополнительной информации см. Примечания о настройке SOLIDWORKS Toolbox.

Этот параметр отображается во всех сценариях установки, за исключением создания администрирующего образа.

Обновить предыдущая версия Toolbox

Скопируйте компонент Toolbox, настроенный для версии предыдущего основного выпуска, в новую папку и обновите эту копию до данной версии.

Этот параметр отображается в том случае, если на компьютере установлена предыдущая версия основного выпуска SOLIDWORKS, однако вы не хотите обновлять установку до этого выпуска.
Цель использования данного параметра – обновление Toolbox для установленной предыдущей версии основного выпуска SOLIDWORKS, минуя компьютеры пользователей, использующих более раннюю версию Toolbox.

Если обновление Toolbox выполняется в среде SOLIDWORKS PDM, требуются дополнительные операции. Для получения дополнительной информации см. Примечания о настройке SOLIDWORKS Toolbox.

Обновить установленную версию Toolbox предыдущая-версия

Обновление Toolbox до более поздней версии.
При обновлении Toolbox до новой основной версии SOLIDWORKS это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SOLIDWORKS.

Этот параметр отображается в том случае, если предыдущая версия основного выпуска SOLIDWORKS обновляется до этой версии, а компонент Toolbox, настроенный для данного выпуска, найден на данном компьютере.

Если обновление Toolbox выполняется в среде SOLIDWORKS PDM, требуются дополнительные операции. Для получения дополнительной информации см. Примечания о настройке SOLIDWORKS Toolbox.

Использовать установленную версию Toolbox текущая-версия

Менеджер установки SOLIDWORKS обнаружил на компьютере компонент Toolbox, настроенный для данной версии основного выпуска SOLIDWORKS.

При выборе этого параметра в программе SOLIDWORKS будет использоваться данный компонент Toolbox. Обновление не выполняется.

Этот параметр отображается в том случае, если на компьютере установлена предыдущая версия основного выпуска SOLIDWORKS, однако компонент Toolbox настроен для данной версии. Это может иметь место в том случае, если Toolbox с общим доступом создан на компьютере, на котором все еще используется более ранняя версия SOLIDWORKS.

Укажите расположение Toolbox для клиентского компьютера

Указание сетевой папки или каталога в качестве месторасположения Toolbox по умолчанию, если клиенты устанавливаются из администрирующего образа.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SOLIDWORKS, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SOLIDWORKS.

Этот параметр отображается при создании нового администрирующего образа.

Обновить или использовать Toolbox, на который ссылается существующий образ на клиентском компьютере

Использование месторасположения Toolbox, указанного в обновляемом администрирующем образе.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SOLIDWORKS, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SOLIDWORKS.

Выберите другое расположение Toolbox для клиентского компьютера

Указание другого месторасположения Toolbox, отличного от указанного в обновляемом администрирующем образе.
Если в указанном местоположении содержится компонент Toolbox, настроенный для версии предыдущего основного выпуска SOLIDWORKS, то в момент установки клиента этот компонент Toolbox обновляется с помощью Менеджера установки SOLIDWORKS.

Содержание

  • Примечания о настройке SOLIDWORKS Toolbox

    SOLIDWORKS Toolbox — это мощный комплексный пакет программных средств. В этом разделе обобщаются некоторые понятия, необходимые для настройки Toolbox с помощью Менеджера установки SOLIDWORKS.

  • Формат UNC

    Формат Uniform (или Universal) Naming Convention (Единое соглашение об именовании) указывает, какой синтаксис имен файлов должен использоваться для описания общей папки с файлами.

На уровень выше Справка Менеджера установки SOLIDWORKS
Примечания о настройке SOLIDWORKS Toolbox


Примечания о настройке SOLIDWORKS Toolbox

SOLIDWORKS Toolbox — это мощный комплексный пакет программных средств. В этом разделе обобщаются некоторые понятия, необходимые для настройки Toolbox с помощью Менеджера установки SOLIDWORKS.

Дополнительная информация о SOLIDWORKS Toolbox

Для получения дополнительной информации о настройке, обновлении и использовании SOLIDWORKS Toolbox в программе SOLIDWORKS выберите Справка > Справка по Toolbox.
Чтобы просмотреть справку, необходимо запустить приложение Toolbox, выбрав Инструменты > Приложения.

Использование общего приложения Toolbox

При установке Toolbox данные Toolbox можно сохранить на локальном компьютере или в общей сетевой папке. Рекомендуется хранение данных Toolbox в сетевой папке. При использовании общей папки все пользователи SOLIDWORKS будут иметь доступ к одному набору данных крепежей.

При первой установке перейдите к новой общей папке, в которой требуется выполнить установку Toolbox.

Обновление существующего компонента Toolbox

При обновлении Toolbox до новой основной версии SOLIDWORKS это приложение не будет поддерживаться на компьютерах, на которых установлены более ранние версии SOLIDWORKS.

Если на других компьютерах сохраняется более ранняя основная версия и требуется приложение Toolbox для этой версии, необходимо сделать копию этого приложения и обновить ее. При установке новой версии SOLIDWORKS будет выполнено обновление копии Toolbox, а для более ранних установленных версий SOLIDWORKS будет использоваться предыдущая версия Toolbox.

Настройка доступа к Toolbox

После установки при открытии компонентов Toolbox SOLIDWORKS проверяет настройку Toolbox и предлагает варианты улучшения доступа и производительности.

Для доступа к общей сетевой установке Toolbox (рекомендуется) следует использовать путь UNC к серверу, на котором установлено это приложение. Дополнительные сведения см. в разделе Формат UNC.

Администратор может создать пароль для Toolbox и задать разрешения и настройки для всей рабочей группы. Ограничение доступа к конфигурации и задание стандартных настроек обеспечивает стабильность данных Toolbox.

Обновление Toolbox в среде SOLIDWORKS PDM

При обновлении программного обеспечения SOLIDWORKS элемент Toolbox также обновляется, если добавляются детали. Если корневая папка Toolbox находится в хранилище SOLIDWORKS PDM, перед обновлением SOLIDWORKS необходимо подготовить данную папку.

Чтобы выполнить обновление в первой системе, необходимо с помощью команды Получить последнюю версию загрузить файлы Toolbox в локальный кэш и отменить регистрацию файла базы данных Toolbox. В остальных обновляемых системах требуется только загрузить файлы Toolbox.

Перед обновлением:
  • Убедитесь в наличии полной недавней резервной копии базы данных и архива хранилища.
  • Проверьте, что у деталей Toolbox не отменена регистрация и они не используются в сборках, у которых отменена регистрация в данный момент.

Для обновления Toolbox выполните следующие действия.

  1. В Проводнике файлов войдите в хранилище в качестве пользователя с полными правами (на регистрацию и отмену регистрации, добавление, удаление).
  2. Нажмите правой кнопкой мыши папку Toolbox и выберите Получить последнюю версию, чтобы скопировать в локальный кэш все файлы Toolbox и базу данных Toolbox.
    Если вы используете удаленный сервер архивации, это может занять несколько минут.
  3. Отмените регистрацию файла базы данных Toolbox (SWBrowser.mdb) из \имя_папки_Toolbox\lang\выбранный_язык.
  4. Чтобы выполнить обновление, запустите менеджер установки SOLIDWORKS.
  5. На экране Суммарная информация убедитесь, что установка Параметры Toolbox находится в хранилище.

    Если это не так, выберите Изменить, Создать ссылку или обновить существующий Toolbox и перейдите в месторасположение Toolbox в хранилище.

  6. После завершения обновления в Проводнике файлов зарегистрируйте папку Toolbox для добавления новых или обновленных файлов в хранилище, чтобы другие пользователи могли работать с Toolbox.
  7. Для обновления до версии SOLIDWORKS 2012 или выше перейдите в папку Toolbox в хранилище и убедитесь в наличии следующих файлов и папок:
    • \Toolbox_folder_name\Updates
    • \Toolbox_folder_name\ToolboxStandards.xml
    • \Toolbox_folder_name\Browser\ToolboxFiles.index

      Если их нет, обратитесь к своему реселлеру.

  8. Обновите остальные компьютеры, которые используют интеграцию SOLIDWORKS PDM с Toolbox.
    1. С помощью Проводника файлов войдите в хранилище от имени пользователя, обладающего разрешением на чтение папки Toolbox.
    2. Правой кнопкой мыши щелкните папку Toolbox и выберите Получить последнюю версию, чтобы скопировать файлы Toolbox в локальный кэш.
    3. Чтобы выполнить обновление, запустите менеджер установки SOLIDWORKS.

      Программа установки обнаруживает, что средство Toolbox уже обновлено.

Дополнительные сведения о конфигурации Toolbox в SOLIDWORKS PDM см. в разделе Настройка Toolbox справки инструмента администрирования SOLIDWORKS PDM .

На уровень выше Параметры Отверстия под крепеж/Toolbox
Формат UNC


Формат UNC

Формат Uniform (или Universal) Naming Convention (Единое соглашение об именовании) указывает, какой синтаксис имен файлов должен использоваться для описания общей папки с файлами.

\\server\volume\path

Пример:

\\Disk_Server\SOLIDWORKS\AdminImage

На уровень выше Параметры Отверстия под крепеж/Toolbox
Примечания о настройке SOLIDWORKS Toolbox


Установка продуктов

Если выбрать Удалить или Отменить установку на панели управления, на экране отобразятся продукты SOLIDWORKS (с номерами версий), которые можно удалить с помощью данной версии Менеджера установки SOLIDWORKS. Можно выбрать вариант отмены установки: стандартная, по выбору и полная.

При стандартной отмене установки удаляются программные папки и файлы продукта SOLIDWORKS. Во время стандартной отмены установки по умолчанию выполняется удаление всех продуктов SOLIDWORKS выбранного выпуска.

При отмене установки по выбору удаляются один или несколько из следующих элементов: программные файлы и папки, разделы реестра и папки данных, такие как SOLIDWORKS Toolbox, а также файлы и папки из исходной папки загрузки.

При полной отмене установки удаляются каталоги установки, разделы реестра и папки данных.

Порядок отмены установки продукта
  1. На экране Отмена установки убедитесь, что выбран требуемый продукт.

    При удалении всех продуктов удаляется и менеджер установки SolidWorks.

  2. Отмените выбор продуктов, которые Вы не хотите удалять.

    В случае сохранения любого продукта Менеджер установки SOLIDWORKS не удаляется.

  3. Выберите для выполнения полную установку или настраиваемую пользователем.
    1. Нажмите кнопку Изменить в разделе Дополнительные параметры.

      Откроется экран Дополнительные параметры. Флажок "Файлы и папки программ" установлен.

    2. Выберите один или несколько параметров, чтобы выполнить отмену установки по выбору, или все параметры, чтобы выполнить полную отмену установки.
    3. Нажмите Назад в Сводку.
    4. На экране Сводка разверните Дополнительные параметры, чтобы отобразить удаляемые объекты и метод отмен установки.
  4. Выберите Удалить объект.
При нажатии кнопки Удалить объекты Менеджер установки SOLIDWORKS немедленно запустит процесс удаления продуктов.
На уровень выше Справка Менеджера установки SOLIDWORKS


Юридическая информация

© 1995-2019, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. Все права защищены.

Информация и программное обеспечение, описываемое в настоящем документе, могут изменяться без предварительного уведомления со стороны корпорации Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

Никакая часть настоящего документа ни в каких целях не может быть воспроизведена или переделана в какой бы то ни было форме и какими бы то ни было средствами, будь то электронными или механическими, без письменного разрешения DS SolidWorks.

Описываемое в настоящем документе программное обеспечение поставляется по лицензии и может использоваться только в соответствии с условиями и положениями данной лицензии. Все гарантии, предоставляемые DS SolidWorks, как на программное обеспечение, так и документацию, сформулированы в лицензионном соглашении, и никакие замечания в содержании данного документа, как явные, так и подразумеваемые, не могут рассматриваться или считаться поправкой указанных положений, в том числе гарантий, данного лицензионного соглашения.

Патенты

Программное обеспечение SOLIDWORKS® для трехмерного автоматизированного проектирования (CAD) в механике и машиностроении и/или Simulation защищено патентами США 6611725, 6844877, 6898560, 6906712, 7079990, 7477262, 7558705, 7571079, 7590497, 7643027, 7672822, 7688318, 7694238, 7853940, 8305376, 8581902, 8817028, 8910078, 9129083, 9153072, 9262863, 9465894, 9646412, 9870436, 10055083, 10073600, 10235493 и иностранными патентами (например, EP 1116190 B1 и JP 3517643).

Программное обеспечение eDrawings® защищено патентами США 7184044; 7502027 и патентом Канады 2318706.

Заявки на патенты США и иностранные патенты.

Товарные знаки и имена продуктов для продуктов и служб SOLIDWORKS

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings и логотип eDrawings являются зарегистрированными товарными знаками DS SolidWorks, а FeatureManager — товарным знаком, находящимся в совместном владении с DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360 и TolAnalyst являются товарными знаками DS SolidWorks.

FeatureWorks является зарегистрированным товарным знаком компании HCL Technologies Ltd.

SOLIDWORKS 2020, SOLIDWORKS Standard, SOLIDWORKS Professional, SOLIDWORKS Premium, SOLIDWORKS PDM Professional, SOLIDWORKS PDM Standard, SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, SOLIDWORKS Simulation Premium, SOLIDWORKS Flow Simulation, eDrawings Viewer, eDrawings Professional, SOLIDWORKS Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical Schematic Standard, SOLIDWORKS Electrical Schematic Professional, SOLIDWORKS Electrical 3D, SOLIDWORKS Electrical Professional, CircuitWorks, SOLIDWORKS Composer, SOLIDWORKS Inspection, SOLIDWORKS MBD, SOLIDWORKS PCB на платформе Altium, SOLIDWORKS PCB Connector на платформе Altium и SOLIDWORKS Visualize — названия продуктов DS SolidWorks.

Остальные торговые марки и названия продуктов являются товарными знаками или зарегистрированными товарными знаками, принадлежащими их владельцам.

КОММЕРЧЕСКОЕ ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ – ПРАВО СОБСТВЕННОСТИ

Программное Обеспечение является "коммерческим предметом", как определено в 48 C.F.R. 2.101 (OCT 1995), состоящим из коммерческого программного обеспечения и коммерческой документации, как определено в 48 C.F.R. 12.212 (SEPT 1995) и предоставляется Правительству США для (а) покупки гражданскими агентствами в соответствии с правилами, описанными в 48 C.F.R. 12.212; или (б) покупки отделами Министерства обороны США в соответствии с правилами, описанными в 48 C.F.R. 227.7202-1 (JUN 1995) и 227.7202-4 (JUN 1995)

При получении от любого агентства Правительства США запроса на предоставление Программного обеспечения с правами, отличными от вышеуказанных, необходимо направить описание такого требования компании DS SolidWorks, а компания DS SolidWorks в течение пяти (5) рабочих дней должна принять или отклонить этот запрос по собственному усмотрению. Подрядчик/Производитель: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Уведомления об авторских правах на продукты SOLIDWORKS Standard, Premium, Professional и Education

Отдельные части данного программного обеспечения © 1986-2018 Siemens Product Lifecycle Management Software Inc. Все права защищены.

Эта работа включает в себя следующее программное обеспечение, принадлежащее Siemens Industry Software Limited:

D-Cubed® 2D DCM © 2019. Siemens Industry Software Limited. Все права защищены.

D-Cubed® 3D DCM © 2019. Siemens Industry Software Limited. Все права защищены.

D-Cubed® PGM © 2019. Siemens Industry Software Limited. Все права защищены.

D-Cubed® CDM © 2019. Siemens Industry Software Limited. Все права защищены.

D-Cubed® AEM © 2019. Siemens Industry Software Limited. Все права защищены.

Отдельные части данного программного обеспечения © 1998-2019 HCL Technologies Ltd.

Отдельные части этого программного обеспечения используют PhysX™ компании NVIDIA, 2006-2010.

Отдельные части данного программного обеспечения © 2001-2019 Luxology, LLC. Все права защищены, патенты ожидаются.

Отдельные части данного программного обеспечения © 2007-2019 DriveWorks Ltd.

© Microsoft Corporation, 2012. Все права защищены.

Включает технологию Adobe® PDF Library.

Adobe Systems Inc. и ее лицензиары, 1984-2016. Все права защищены. Защищено патентами США 6563502; 6639593; 6754382; заявки на патенты рассматриваются.

Adobe, логотип Adobe, Acrobat, логотип Adobe PDF, Distiller и Reader являются зарегистрированными товарными знаками или товарными знаками Adobe Systems Inc. в США и других странах.

Подробнее об авторских правах DS SolidWorks см. в разделе Справка > О SOLIDWORKS.

Уведомления об авторских правах на продукты SOLIDWORKS Simulation

Отдельные части этого программного обеспечения © 2008 Solversoft Corporation.

PCGLSS © Computational Applications and System Integration, Inc., 1992—2017. Все права защищены.

Уведомления об авторских правах на продукт SOLIDWORKS PDM Professional

Outside In® Viewer Technology, © Oracle, 1992–2012 гг.

© Microsoft Corporation, 2012. Все права защищены.

Авторские права на продукты eDrawings

Отдельные части этого программного обеспечения © 2000-2014 Tech Soft 3D.

Частичное авторское право © 1995-1998 Jean-Loup Gailly and Mark Adler.

Отдельные части этого программного обеспечения © 1998-2001 3Dconnexion.

Отдельные части этого программного обеспечения © Open Design Alliance, 1998-2017. Все права защищены.

Программное обеспечение eDrawings® для Windows® частично основано на работах независимой группы JPEG.

Авторские права на части eDrawings® для iPad® принадлежат © Silicon Graphics Systems, Inc., 1996-1999 гг.

Авторские права на части eDrawings® для iPad® принадлежат © 2003 – 2005 Apple Computer Inc.

Уведомления об авторских правах на продукты SOLIDWORKS PCB

Отдельные части этого программного обеспечения © 2017-2018 Priware Limited.

Уведомления об авторских правах для продуктов SOLIDWORKS Visualize

NVIDIA GameWorks™ Technology предоставляется в рамках лицензии NVIDIA Corporation. Авторские права © 2002-2015 NVIDIA Corporation. Все права защищены.


Редактор параметров администрирующего образа

Улучшен редактор параметров администрирующего образа SOLIDWORKS.

  • Администраторы могут использовать новые параметры отмены установки для выполнения на клиентских компьютерах полной отмены установки или по выбору. Параметры отмены установки доступны в разделе Параметры установки на клиентском компьютере редактора параметров. Для просмотра данных параметров выберите Да, выполнить отмену установки по выбору, а затем — удаляемые объекты.
  • Администраторы также могут предварительно выбирать из списка стандарты SOLIDWORKS Toolbox.


SOLIDWORKS PDM

SOLIDWORKS PDM представляет собой продукт для управления документацией на основе архитектуры "клиент-сервер", ранее известный как SOLIDWORKS Enterprise PDM.

SOLIDWORKS PDM поставляется в двух типах:
  • SOLIDWORKS PDM Standard
  • SOLIDWORKS PDM Professional

Для управления хранилищами файлов SOLIDWORKS PDM использует базу данных Microsoft SQL Server.

В этой таблице представлены определения доступных систем баз данных, серверных компонентов и параметров клиентов для каждого типа продукта.
 | PDM Standard | PDM Professional
Предназначение | Небольшие и средние сети офисов, в которых менее 20 одновременно работающих пользователей. | Крупные офисные сети, большое число параллельных пользователей
Ограничения | Меньшее из следующего: 1 сокет или 4 ядра, 1 ГБ ОЗУ, база данных размером 10 ГБ | Стандартные ограничения SQL: Меньшее из следующего: 4 сокета или 16 ядер, 128 ГБ ОЗУ, база данных размером 524 ПБ
Система управления базой данных | Microsoft SQL Server Express 2014 Service Pack 3 или более поздняя версия (поставляется и устанавливается в составе продукта SOLIDWORKS) | Microsoft SQL Server 2014 Service Pack 3 или более поздняя версия (отдельный компонент, поставляемый с продуктом SOLIDWORKS), либо ранее установленные экземпляры Microsoft SQL Server 2014 Service Pack 3 или более поздние версии.
Требуется SolidNetWork License Manager? | Да | Да
В комплект поставки входит сервер архивации и сервер базы данных? | Да | Да
Включает веб-сервер SOLIDWORKS PDM, сервер Web2 и веб-сервер API? | Нет | Да
Типы клиентов | Собственный | Собственный, на основе браузера
Клиентские добавления для CAD Editor | SOLIDWORKS, DraftSight | SOLIDWORKS, DraftSight, интеграция Microsoft Office, Autodesk Inventor, AutoCAD
Клиентские добавления для Contributor | DraftSight | DraftSight, интеграция с Microsoft Office
Клиентские добавления для Viewer |  | Интеграция Microsoft Office


Советы по использованию SOLIDWORKS с ОС Microsoft Windows 8

Пользовательский интерфейс ОС Windows 8 (и более поздних версий) значительно отличается от более ранних версий ОС Windows. Изменились не только способы навигации. Кроме того, операционная система обновилась новыми методами доступа к ключевым командам.

В представленных здесь темах рассматриваются инструкции по получению доступа к трем основным функциям с помощью ОС Windows 8. Следуйте данным инструкциям при использовании ОС Windows 8 для установки SOLIDWORKS.
Эти шаги могут различаться в зависимости от конфигурации системы Windows. Для получения дополнительной информации, особенно о более поздних версиях системы, чем Windows 8, см. документацию Microsoft Windows.
Установка на отдельных компьютерах


Начало установки SOLIDWORKS

Установку SOLIDWORKS можно начать с загрузки DVD на локальный компьютер для получения доступа к общему каталогу установки или с загрузки с узла SOLIDWORKS.

Чтобы запустить установку SOLIDWORKS, выполните одно из следующих действий.

  • Чтобы установить на локальный компьютер с диска, вставьте диск в дисковод.
  • Чтобы выполнить установку из каталога загрузки, перейдите в этот каталог и дважды щелкните файл setup.exe.
  • Чтобы установить путем загрузки с узла SOLIDWORKS:
    1. Откройте веб-сайт SOLIDWORKS.
    2. Войдите в систему как Пользователь абонентских услуг, используя свой адрес электронной почты и пароль или серийный номер для SOLIDWORKS.
    3. В поле Self Service (Самообслуживание) выберите Download Software and Updates (Загрузка программ и обновлений).
    4. В разделе Загрузка программ (Windows, Mac, Linux) выберите для загрузки версию SOLIDWORKS и пакет обновлений.